(Risolto) Blocco directory amministrazione all'avvio

Prossima versione di Ubuntu in fase di sviluppo e test. Per i precedenti rilasci, consultare «Archivio del forum».

(Risolto) Blocco directory amministrazione all'avvio

Messaggioda brazov » giovedì 6 aprile 2017, 12:44

Ciao. Se io appena avviato il pc do il comando di aggiornamento, poi non riesco a fare upgrade. Risolvo a mano. E' un bug? Da segnalare?

Codice: Seleziona tutto
xx@xx-XPS-13-9350:~$ sudo apt-get update
[sudo] password di xx:
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Trovato:2 http://it.archive.ubuntu.com/ubuntu zesty InRelease
Trovato:3 http://security.ubuntu.com/ubuntu zesty-security InRelease                                   
Trovato:4 http://it.archive.ubuntu.com/ubuntu zesty-updates InRelease                                 
Trovato:5 http://it.archive.ubuntu.com/ubuntu zesty-backports InRelease       
Trovato:6 http://dl.google.com/linux/chrome/deb stable Release
Lettura elenco dei pacchetti... Fatto               
xx@xx-XPS-13-9350:~$ sudo apt-get upgrade
E: Impossibile impostare il blocco /var/lib/dpkg/lock - open (11: Risorsa temporaneamente non disponibile)
E: Impossibile acquisire il blocco sulla directory di amministrazione (/var/lib/dpkg/). Un altro processo potrebbe tenerla occupata.
xx@xx-XPS-13-9350:~$ sudo rm /var/cache/apt/archives/lock
xx@xx-XPS-13-9350:~$ sudo apt-get upgrade
Lettura elenco dei pacchetti... Fatto
Ultima modifica di brazov il lunedì 10 aprile 2017, 18:50, modificato 1 volta in totale.
Diffondere la filosofia Open Source
brazov
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 444
Iscrizione: maggio 2010
Desktop: ubuntu
Distribuzione: Ubuntu 17.04 x86_64
Sesso: Maschile

Re: Blocco directory amministrazione all'avvio

Messaggioda trekfan1 » giovedì 6 aprile 2017, 12:59

Aggiorna la distribuzione nel tuo profilo, cmq capita anche a me, evidentemente parte in automatico il check dei repo e, come ben sai, ci può essere un solo processo di update alla volta
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 15625
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Unity/Gnome Shell
Distribuzione: Ubuntu 17.04 e 17.10 (dev) 64 bit
Sesso: Maschile

Re: Blocco directory amministrazione all'avvio

Messaggioda brazov » giovedì 6 aprile 2017, 16:00

trekfan1 Immagine ha scritto:Aggiorna la distribuzione nel tuo profilo


Scusa non capisco cosa intendi.

EDIT: ah! il profilo. capito.
Ultima modifica di brazov il giovedì 6 aprile 2017, 18:00, modificato 1 volta in totale.
Diffondere la filosofia Open Source
brazov
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 444
Iscrizione: maggio 2010
Desktop: ubuntu
Distribuzione: Ubuntu 17.04 x86_64
Sesso: Maschile

Re: Blocco directory amministrazione all'avvio

Messaggioda et4beta » giovedì 6 aprile 2017, 17:19

Sono un po' di giorni che Zesty sta facendo questo "scherzetto", all'avvio non da la possibilità di acquisire il blocco. C'è evidentemente, come dice trekfan1, un processo già in atto, che sarà di certo inerente l'avvio e successivo al login, che non si è ancora concluso. Ma basta aspettare qualche secondo e torna tutto normale. Del resto è ancora in "sviluppo"! :D
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A(BIOS ver. 3402) - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb(4 x F4-3000C15-8GVR) - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - 1 SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - PSU XFX XTR 750W - / - Asus K55VD - i7 3610QM - RAM 8 Gb 1600MHz - Grafica ibrida Intel HD 4000/Nvidia 610M - SSD Samsung 850 Pro 512 Gb
Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
 
Messaggi: 7090
Iscrizione: gennaio 2008
Località: Ancona
Desktop: Unity/LXDE/MATE
Distribuzione: da 14.04 a 17.10-NO UEFI

Re: Blocco directory amministrazione all'avvio

Messaggioda brazov » venerdì 7 aprile 2017, 13:48

et4beta Immagine ha scritto:Sono un po' di giorni che Zesty sta facendo questo "scherzetto", all'avvio non da la possibilità di acquisire il blocco. C'è evidentemente, come dice trekfan1, un processo già in atto, che sarà di certo inerente l'avvio e successivo al login, che non si è ancora concluso. Ma basta aspettare qualche secondo e torna tutto normale. Del resto è ancora in "sviluppo"! :D


Dunque, oggi ho aspettato 10 minuti prima di dare i comandi e non ho avuto problemi. Quindi la vostra spiegazione è plausibile. Metto "risolto"?

Ciao
Diffondere la filosofia Open Source
brazov
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 444
Iscrizione: maggio 2010
Desktop: ubuntu
Distribuzione: Ubuntu 17.04 x86_64
Sesso: Maschile

Re: Blocco directory amministrazione all'avvio

Messaggioda et4beta » venerdì 7 aprile 2017, 14:08

Il "problema" da me dura alcuni secondi, non ho quantificato di preciso ma ritengo che non siano più di 30, penso proprio che si tratti di "problemi"(di poco conto) di sviluppo, che in breve risolveranno, spero.
Credo comunque che ci sia qualche processo di avvio, dopo il login, che rimanga in "stallo" e tenga occupato il blocco più del dovuto.
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A(BIOS ver. 3402) - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb(4 x F4-3000C15-8GVR) - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - 1 SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - PSU XFX XTR 750W - / - Asus K55VD - i7 3610QM - RAM 8 Gb 1600MHz - Grafica ibrida Intel HD 4000/Nvidia 610M - SSD Samsung 850 Pro 512 Gb
Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
 
Messaggi: 7090
Iscrizione: gennaio 2008
Località: Ancona
Desktop: Unity/LXDE/MATE
Distribuzione: da 14.04 a 17.10-NO UEFI

Re: Blocco directory amministrazione all'avvio

Messaggioda corradoventu » venerdì 7 aprile 2017, 17:18

Se guardi su /var/log/apt/history.log vedi che subito dopo l'avvio (a volte) parte unattended-upgrade che blocca la risorsa per qualche minuto. Stamattina ad esempio:
Codice: Seleziona tutto
Start-Date: 2017-04-07  06:40:28
Commandline: /usr/bin/unattended-upgrade
Install: libpoppler-qt5-1:amd64 (0.48.0-2ubuntu2, automatic), ubuntu-printing-app:amd64 (0.1+17.04.20170401-0ubuntu1, automatic), qtubuntu-print:amd64 (0.1+17.04.20170328-0ubuntu1, automatic)
........
1.22.0-0ubuntu2), libwebkit2gtk-4.0-37-gtk2:amd64 (2.16.0-1, 2.16.1-1), gir1.2-javascriptcoregtk-4.0:amd64 (2.16.0-1, 2.16.1-1), mesa-va-drivers:amd64 (17.0.2-1ubuntu2, 17.0.3-1ubuntu1)
End-Date: 2017-04-07  06:43:01
Con o senza religione, i buoni si comportano bene e i cattivi male, ma ci vuole la religione per far comportare male i buoni. (Steven Weinberg)
PC di casa: https://drive.google.com/folderview?id= ... sp=sharing
Avatar utente
corradoventu
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 743
Iscrizione: aprile 2008
Località: Montecompatri (RM) o Rezzoaglio (GE)
Desktop: unity -> gnome
Distribuzione: Ubuntu 16.04, 16.10, 17.04, 17.10
Sesso: Maschile

Re: Blocco directory amministrazione all'avvio

Messaggioda brazov » sabato 8 aprile 2017, 9:30

corradoventu Immagine ha scritto:Se guardi su /var/log/apt/history.log vedi che subito dopo l'avvio (a volte) parte unattended-upgrade che blocca la risorsa per qualche minuto. Stamattina ad esempio:
Codice: Seleziona tutto
Start-Date: 2017-04-07  06:40:28
Commandline: /usr/bin/unattended-upgrade
Install: libpoppler-qt5-1:amd64 (0.48.0-2ubuntu2, automatic), ubuntu-printing-app:amd64 (0.1+17.04.20170401-0ubuntu1, automatic), qtubuntu-print:amd64 (0.1+17.04.20170328-0ubuntu1, automatic)
........
1.22.0-0ubuntu2), libwebkit2gtk-4.0-37-gtk2:amd64 (2.16.0-1, 2.16.1-1), gir1.2-javascriptcoregtk-4.0:amd64 (2.16.0-1, 2.16.1-1), mesa-va-drivers:amd64 (17.0.2-1ubuntu2, 17.0.3-1ubuntu1)
End-Date: 2017-04-07  06:43:01


A me stamattina c'era il blocco ma in /var/log/apt/history.log nulla (solo i miei aggiornamenti di ieri). Comunque sì, è una roba proprio minima di un minuto o giù di lì. Non sono esperto delle sottigliezze nella definizione di un bug ma credo che siamo proprio al limite.
Diffondere la filosofia Open Source
brazov
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 444
Iscrizione: maggio 2010
Desktop: ubuntu
Distribuzione: Ubuntu 17.04 x86_64
Sesso: Maschile

Re: Blocco directory amministrazione all'avvio

Messaggioda corradoventu » sabato 8 aprile 2017, 9:36

Forse prima di unattended-upgrade va a vedere se ci sono update e occupa la risorsa?
Con o senza religione, i buoni si comportano bene e i cattivi male, ma ci vuole la religione per far comportare male i buoni. (Steven Weinberg)
PC di casa: https://drive.google.com/folderview?id= ... sp=sharing
Avatar utente
corradoventu
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 743
Iscrizione: aprile 2008
Località: Montecompatri (RM) o Rezzoaglio (GE)
Desktop: unity -> gnome
Distribuzione: Ubuntu 16.04, 16.10, 17.04, 17.10
Sesso: Maschile

Re: Blocco directory amministrazione all'avvio

Messaggioda et4beta » sabato 8 aprile 2017, 10:53

Da questa mattina qui nel mio Zesty il problema in questione è scomparso. Sono tre volte che riavvio, cronometro alla mano(volevo vedere i tempi), ma del blocco bloccato non c'è più traccia.
Forse dipende dagli aggiornamenti installati ieri, tra cui il kernel xxxx-19(ma non dipendeva da questo perché col -15 non ci faceva più ugualmente).
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A(BIOS ver. 3402) - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb(4 x F4-3000C15-8GVR) - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - 1 SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - PSU XFX XTR 750W - / - Asus K55VD - i7 3610QM - RAM 8 Gb 1600MHz - Grafica ibrida Intel HD 4000/Nvidia 610M - SSD Samsung 850 Pro 512 Gb
Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
 
Messaggi: 7090
Iscrizione: gennaio 2008
Località: Ancona
Desktop: Unity/LXDE/MATE
Distribuzione: da 14.04 a 17.10-NO UEFI

Re: Blocco directory amministrazione all'avvio

Messaggioda brazov » lunedì 10 aprile 2017, 18:49

Nessun problema più.
Diffondere la filosofia Open Source
brazov
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 444
Iscrizione: maggio 2010
Desktop: ubuntu
Distribuzione: Ubuntu 17.04 x86_64
Sesso: Maschile


Torna a Zesty Zapus 17.04

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite