SERVER 12 LTS e vari problemi!

Installazione, configurazione e uso di Ubuntu come server: web, ftp, mail, news, proxy, dns, ecc.

SERVER 12 LTS e vari problemi!

Messaggioda carmalao » martedì 15 maggio 2012, 20:42

Ciao a tutti.
Sono nuovo qui da voi, ma non del mondo linux.
Da anni uso opensuse (al lavoro) ed anche ubuntu (ambito casalingo multimediale).
Ho problemoni con la server 12 LTS 64bit appena installata.
Passo a descrivervi il server usato: HP PROLIANT MICROSERVER N40L con 2GB di ram, 1 hd SEAGATE 250gb per sistema operativo, 1 hd WESTERN DIGITAL 2gb per file multimediale in NTFS.
Ho installato la 12 LTS da stick usb ed è tutto filato liscio, poi ho aggiornato con apt-get update, ho installato samba sempre con apt-get configurandolo secondo quanto avevo fatto nella 10 LTS, ho installato a mano minidlna e configurato come avevo sulla 10 LTS.
Il risultato è che:
- samba non va
- minidlna non si avvia in automatico (non mi ci sono ancora messo però)
- facendo il comando HALT il server stoppa i vari servizi ma NON SI SPEGNE
- NON SI AGGIORNA E NON MI INSTALLA NULLA con apt-get, mi da errori di risoluzione dei repository
So che sono varie problematiche, ma se qualcuno avesse suggerimenti..... passo alla 10 LTS?
GRAZIE
carmalao Non specificato
Prode Principiante
 
Messaggi: 39
Iscrizione: maggio 2012
Distribuzione: server 12 64bit, desktop 10 LT
Desktop: --

Re: SERVER 12 LTS e vari problemi!

Messaggioda bingel » martedì 15 maggio 2012, 21:06

Mi chiedo per quale ragione tu abbia installato da penna usb. Uno dei vantaggi dell'installazione da CD, secondo me è che prima di masterizzare si può controllare l'MD5 della ISO scaricata e al termine della masterizzazione (da fare alla velocità più bassa possibile) verificare che questa sia avvenuta correttamente. Tramite installazione da USB invece non si può avere la certezza che il contenuto della chiavetta sia integro.

Mi chiedo poi se la chiavetta è avviabile perché in tal caso potresti innanzitutto verificare se avviando da chiavetta le cose funzionano o meno. Suppongo tuttavia si tratti di una versione server o minimale pertanto suppongo che non sia affatto avviabile quindi io mi procurerei una versione desktop e proverei ad avviare in modalità live e vedere se invece in tal modo le cose funzionano o meno.

Dici che hai installato quindi aggiornato e poi installato e configurato vario software. Poi qualche riga più sotto dici che non riesci più ad aggiornare. Questo significa che le operazioni fatte hanno provocato i problemi.

Per spegnere dovresti usare il comando
Codice: Seleziona tutto
poweroff
al posto del comando
Codice: Seleziona tutto
halt
oppure il comando
Codice: Seleziona tutto
shutdown -P now
Avatar utente
bingel Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3374
Iscrizione: aprile 2006

Re: SERVER 12 LTS e vari problemi!

Messaggioda carmalao » martedì 15 maggio 2012, 21:21

Il server non ha lettore cd/dvd, quindi sono andato per la via più semplice.
Anche il precedente server, ora spento e messo di lato, non aveva il lettore e ho installato la 10 LTS sempre con usb.
Proverò ad installare una 10 LTS, tanto si sta pochi minuti ed anche la configurazione di quello che mi serve è veloce.
Per i comandi elencati per lo spegnimento, avevo già usato positivamente lo shutdown -h now. Con la 10 usavo halt (come su tutte le distro che ho in uso).
Ho provato ora il poweroff e funziona bene.
Vado a scaricare una 10 64bit.
carmalao Non specificato
Prode Principiante
 
Messaggi: 39
Iscrizione: maggio 2012
Distribuzione: server 12 64bit, desktop 10 LT
Desktop: --

Re: SERVER 12 LTS e vari problemi!

Messaggioda carmalao » martedì 15 maggio 2012, 21:35

per scrupolo ho controllato il md5 della iso 12LTS scaricata: corisponde.
carmalao Non specificato
Prode Principiante
 
Messaggi: 39
Iscrizione: maggio 2012
Distribuzione: server 12 64bit, desktop 10 LT
Desktop: --

Re: SERVER 12 LTS e vari problemi!

Messaggioda bingel » martedì 15 maggio 2012, 21:51

Ho scrito

Codice: Seleziona tutto
shutdown -P now


e non

Codice: Seleziona tutto
shutdown -h now
Avatar utente
bingel Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3374
Iscrizione: aprile 2006

Re: SERVER 12 LTS e vari problemi!

Messaggioda carmalao » martedì 15 maggio 2012, 22:00

Dopo proverò con -P, scusa.
Per ora ho risolto parte del problema, quello dell'aggiornamento: ho modificato a mano il resolv.conf perché mi sono accorto che il problema era dettato dalla non risoluzione.
Ho messo:
nameserver 192.168.1.1
nameserver 8.8.8.8
nameserver 8.8.4.4

gli ultimi due sono di google.
Ho la rete in IP statico.
CIAOz
carmalao Non specificato
Prode Principiante
 
Messaggi: 39
Iscrizione: maggio 2012
Distribuzione: server 12 64bit, desktop 10 LT
Desktop: --

Re: SERVER 12 LTS e vari problemi!

Messaggioda bingel » martedì 15 maggio 2012, 22:04

Immaginavo che potesse essere qualcosa del genere tuttavia vorrei capire perché in un primo momento ti ha fatto gli aggiornamenti e poi ad un certo punto non ti andava più su internet.

Tu devi aver omesso di riportare qualche passaggio che hai fatto e che evidentemente ti è sfuggito.
Avatar utente
bingel Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3374
Iscrizione: aprile 2006

Re: SERVER 12 LTS e vari problemi!

Messaggioda bingel » martedì 15 maggio 2012, 22:06

carmalao ha scritto:Dopo proverò con -P, scusa.


Di nulla, il tono non voleva essere imperativo ma solo sintetico :)
Avatar utente
bingel Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3374
Iscrizione: aprile 2006

Re: SERVER 12 LTS e vari problemi!

Messaggioda carmalao » martedì 15 maggio 2012, 22:57

bingel ha scritto:Immaginavo che potesse essere qualcosa del genere tuttavia vorrei capire perché in un primo momento ti ha fatto gli aggiornamenti e poi ad un certo punto non ti andava più su internet.

Tu devi aver omesso di riportare qualche passaggio che hai fatto e che evidentemente ti è sfuggito.



Dopo il riavvio, il file resolv.conf è stato - ovviamente - riscritto visto che è dinamicamente generato.
E quindi ora di nuovo non va.
Da qualche parte avevo visto un comando per renderlo non scrivibile.....
Comunque sia, non ricordo tutti i passaggi che ho compiuto ma di massima sono quelli sintetizzati all'inizio:
- installazione con aggiornamento
- samba con configurazione
- minidlna a mano (ora lo ho fatto anche con apt)
.... ho messo mano anche a fstab per il mount automatico del sdb ma non credo influisca.
carmalao Non specificato
Prode Principiante
 
Messaggi: 39
Iscrizione: maggio 2012
Distribuzione: server 12 64bit, desktop 10 LT
Desktop: --

Re: SERVER 12 LTS e vari problemi!

Messaggioda carmalao » martedì 15 maggio 2012, 23:17

Ok per resolv, ho imparato che in /etc/resolv/ c'è una sottodir dove un file di nome base può essere modificato ed al riavvio il resolv.conf viene configurato in baso alla modifica.
Ora il resolv.conf funziona bene.

Shutdown -P now funziona alla grande.
carmalao Non specificato
Prode Principiante
 
Messaggi: 39
Iscrizione: maggio 2012
Distribuzione: server 12 64bit, desktop 10 LT
Desktop: --

Re: SERVER 12 LTS e vari problemi!

Messaggioda bingel » martedì 15 maggio 2012, 23:25

La domanda è questa: avendo messo a posto il resolv.conf quali problemi ti restano da risolvere?

Il comando per rendere immodificabile il resolv.conf è questo:

Codice: Seleziona tutto
sudo chattr +i /etc/resolv.conf


ma mi pare di capire che hai risolto in altro modo anche migliore.

C'è un discorso da fare: se il router è impostato per assegnare indirizzi dinamici tramite dhcp è possibile che tu abbia modificato qualcosa nella configurazione della scheda di rete se il resolv.conf non viene più scritto correttamente.
Oppure è possibile che i programmi installati abbiano modificato questi qualcosa.
Avatar utente
bingel Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3374
Iscrizione: aprile 2006

Re: SERVER 12 LTS e vari problemi!

Messaggioda carmalao » martedì 15 maggio 2012, 23:42

Il resolv.conf è apposto, provato e riprovato a riavviare.
Anche secondo me, installando qualcosa questo qualcosa è intervenuto sulla conf di rete........ boh.
Eppure mi par di aver fatto tutte le mosse come sulla 10...
Ora ho problemi con minidlna, ma andrò a letto. Domani sera rimetterò le mani (anche perché DEVE funzionare, altrimenti mia moglie mi spara se non potremo vedere un telefilm!!!!!!!!) e poi ci sarà samba da far risorgere.
Ora, nel frattempo, ho fatto un apt-get upgrade per i linux headers ecc. ecc.
carmalao Non specificato
Prode Principiante
 
Messaggi: 39
Iscrizione: maggio 2012
Distribuzione: server 12 64bit, desktop 10 LT
Desktop: --

Re: SERVER 12 LTS e vari problemi!

Messaggioda carmalao » martedì 15 maggio 2012, 23:52

Per minidlna ho risolto "a mano", copiando il .conf in etc dal tar della versione 1.0.24 installata (con apt-get).
Ho buttato via il db ed ora lo sta ricreando da zero, nei log per ora è tutto ok.
Non so però dove trovare il comando per il init.d.......... mi puoi dare una mano tu?
Anche a renderlo autoavviante, grazie.
carmalao Non specificato
Prode Principiante
 
Messaggi: 39
Iscrizione: maggio 2012
Distribuzione: server 12 64bit, desktop 10 LT
Desktop: --

Re: SERVER 12 LTS e vari problemi!

Messaggioda bingel » mercoledì 16 maggio 2012, 10:46

Non conosco minidlna. In ogni caso sarebbe meglio utilizzare Upstart piuttosto che il vecchio SystemV.
Posso provare ad aiutarti uagualmente ma stasera e solo se conosci il comando per avviare minidlna manualmente.

Per aggiornare è bene usare il seguente comando:

Codice: Seleziona tutto
sudo apt-get dist-upgrade


piuttosto che

Codice: Seleziona tutto
sudo apt-get upgrade


E ovviamente dovrà essere seguito preceduto dal comando:

Codice: Seleziona tutto
sudo apt-get update
Ultima modifica di bingel il mercoledì 16 maggio 2012, 11:49, modificato 1 volta in totale.
Avatar utente
bingel Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3374
Iscrizione: aprile 2006

Re: SERVER 12 LTS e vari problemi!

Messaggioda carmalao » mercoledì 16 maggio 2012, 11:41

Grazie per l'aiuto e le dritte.
Io uso root direttamente, e questa sera darò i comandi da te descritti.
Per l'avvio manuale di minidlna, con poca fantasia si usa "minidlna" oppure /usr/sbin/minidlna.
CIAOz
carmalao Non specificato
Prode Principiante
 
Messaggi: 39
Iscrizione: maggio 2012
Distribuzione: server 12 64bit, desktop 10 LT
Desktop: --

Re: SERVER 12 LTS e vari problemi!

Messaggioda carmalao » mercoledì 16 maggio 2012, 20:47

sto reinstallando la 12 lts server, solo ora ho letto di fare apt-get update PRIMA di apt-get dist-upgrade...... cavolo!
vabbé
per ora va tutto ok tranne halt (ma già lo sapevamo di usare poweroff o simile)
ora passo a configurare la rete in statico, poi vado a vedere del resolv.conf ed eventualmente lo configuro, poi passo a scaricare minidlna con apt-get
samba lo ho installato con la distro, poi vedrò di configurarlo
ciaoz
carmalao Non specificato
Prode Principiante
 
Messaggi: 39
Iscrizione: maggio 2012
Distribuzione: server 12 64bit, desktop 10 LT
Desktop: --

Re: SERVER 12 LTS e vari problemi!

Messaggioda carmalao » mercoledì 16 maggio 2012, 20:53

come previsto, passando in statico BISOGNA mettere mano al resolv.conf attraverso il /etc/resolvconf/resolv.conf.d/base
carmalao Non specificato
Prode Principiante
 
Messaggi: 39
Iscrizione: maggio 2012
Distribuzione: server 12 64bit, desktop 10 LT
Desktop: --

Re: SERVER 12 LTS e vari problemi!

Messaggioda bingel » mercoledì 16 maggio 2012, 21:17

Per eseguire minidlna all'avvio crea un file denominato minidlna.conf nella dir /etc/init e ricopiaci dentro quanto segue:

Codice: Seleziona tutto
description     "Start minidlna server"
author          "carmalao <carmalao@carmalao.net>"

start on startup
stop on runlevel [06]

respawn

script
/usr/sbin/minidlna
end script


dopodichè, se non li ha già, attribuiscigli i seguenti permessi:

Codice: Seleziona tutto
sudo chmod 644 minidlna.conf


A questo punto al successivo riavvio del sistema, minidlna si dovrebbe avviare automaticamente.
Avatar utente
bingel Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3374
Iscrizione: aprile 2006

Re: SERVER 12 LTS e vari problemi!

Messaggioda carmalao » mercoledì 16 maggio 2012, 21:23

impostato samba come da vecchie specifiche: non va
installato minidlna ed impostato, va ma non parte in automatico il servizio all'avvio del server
passo ad installare ethtool per il WOL
carmalao Non specificato
Prode Principiante
 
Messaggi: 39
Iscrizione: maggio 2012
Distribuzione: server 12 64bit, desktop 10 LT
Desktop: --

Re: SERVER 12 LTS e vari problemi!

Messaggioda carmalao » mercoledì 16 maggio 2012, 21:25

bingel ha scritto:Per eseguire minidlna all'avvio crea un file denominato minidlna.conf nella dir /etc/init e ricopiaci dentro quanto segue:

Codice: Seleziona tutto
description     "Start minidlna server"
author          "carmalao <carmalao@carmalao.net>"

start on startup
stop on runlevel [06]

respawn

script
/usr/sbin/minidlna
end script


dopodichè, se non li ha già, attribuiscigli i seguenti permessi:

Codice: Seleziona tutto
sudo chmod 644 minidlna.conf


A questo punto al successivo riavvio del sistema, minidlna si dovrebbe avviare automaticamente.



Ciao!
Scusa, ma in etc ho già un minidlna.conf messo dalla installazione con dentro i parametri di funzionamento....
In /etc/init.d c'è invece il minidlna per l'avvio.... non dovrebbe essere questo ad essere avviato automaticamente?
carmalao Non specificato
Prode Principiante
 
Messaggi: 39
Iscrizione: maggio 2012
Distribuzione: server 12 64bit, desktop 10 LT
Desktop: --

Successiva

Torna a Ubuntu su server

Chi c’è in linea

Visualizzano questa sezione: GREGORIO, neodago e 7 ospiti