...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Installazione, configurazione e uso di Ubuntu come server: web, ftp, mail, news, proxy, dns, ecc.

...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda batello » giovedì 5 giugno 2008, 11:10

Salve a tutti.
ogni volta che provo a fare sudo apt-get upgrade, l'operazione termina con il seguente messaggio:

E: Sub-process /usr/bin/dpkg returned an error code (1)


Ho visto che il problema è già stato postato in precedenza ma nessuno ha trovato una vera soluzione e, alla fine, il topic si conclude a metà.
Vi sarei molto grato, se potessi avere una mano.

Grazie
batello Maschile
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 505
Iscrizione: giugno 2008

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda pieddu » giovedì 5 giugno 2008, 12:41

quale pacchetto genera l'errore?
Va bene la fine, ma la causa?
pieddu Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 13376
Iscrizione: novembre 2006
Località: Foligno

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda Volans » giovedì 5 giugno 2008, 13:51

Prima fai:
Codice: Seleziona tutto
sudo apt-get update

e poi incolla qui con il tag CODE l'output di:
Codice: Seleziona tutto
sudo apt-get upgrade
Volans
Prima di scrivere leggi le Guide, poi vedi se c'è un HowTo nel Wiki e fai una ricerca nel Forum!
Avatar utente
Volans Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4915
Iscrizione: dicembre 2005

[Risolto] Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda batello » giovedì 5 giugno 2008, 23:59

Non so quale fosse la causa del mio problema ma, mi succedeva varie volte, anche quando facevo
sudo apt-get upgrade...
Alla fine, preso dalla disperazione, ho reinstallato ubuntu.
Ora va che è una meraviglia e ho anche installato compiz con gli effetti 3d
batello Maschile
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 505
Iscrizione: giugno 2008

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda sparazza » domenica 22 giugno 2008, 17:10

Per chiunque legga, avendo trovato la soluzione(anche se drastica) la linko qui:
http://paterna.nl/2007/06/25/e-sub-proc ... or-code-1/

Saluti
Sparazza
Avatar utente
sparazza Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1116
Iscrizione: febbraio 2007
Distribuzione: Ubuntu Precise

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda [lost]-Divilinux » domenica 22 giugno 2008, 17:11

se puoi postare tutto l'output per favore..la risposta e' semplicissima e ben lontana dall'essere drastica
il link che ti ha passato sparazza contiene la giusta soluzione comunque...
questione di seedings...
Avatar utente
[lost]-Divilinux Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3774
Iscrizione: giugno 2008
Località: Ipioca - Maceio - Alagoas - Brasil

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda polletty » giovedì 17 luglio 2008, 10:10

ciao a tutti... a me da lo stesso errore facendo l'aggiornamento
di openssl-blacklist, con apt-get update no, upgrade non so, ma non voglio cambiare versione!!!!
attualmente uso la 7.04. .. qualche suggerimento ?
polletty Non specificato
Prode Principiante
 
Messaggi: 95
Iscrizione: novembre 2007

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda polletty » giovedì 17 luglio 2008, 10:22

anzi scusate .. mi sono spiegata male, se provo a fare gli aggiornamenti , non da terminale,
mi da questo errore: E: /var/cache/apt/archives/openssl-blacklist_0.3.3+0.4-0ubuntu0.7.04.2_all.deb: lettura incompleta in buffer_copy (dpkg-deb backend su `./usr/share/openssl-blacklist/blacklist.RSA-2048')

se da terminale faccio sudo apt-get install openssl-blacklist , mi da l'errore oggetto del topic...
polletty Non specificato
Prode Principiante
 
Messaggi: 95
Iscrizione: novembre 2007

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda Gioenjoy » mercoledì 10 settembre 2008, 9:50

Prova così da terminale e facci sapere:

cd /var/cache/apt/archives/

poi dai questi comandi

dpkg --force-all -i nomepacchetto.deb *(nel tuo caso sarebbe dpkg --force-all -i openssl-blacklist_0.3.3+0.4-0ubuntu0.7.04.2_all.deb)
apt-get -f install
apt-get dist-upgrade
aptitude -f install
Gioenjoy Non specificato
Prode Principiante
 
Messaggi: 1
Iscrizione: maggio 2008

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda madamada » lunedì 11 maggio 2009, 23:14

Anche io ho un problema simile con tutti i pachetti in istallazione via synaptic.

riporto il codice ottenuto dopo il comando sudo apt-get update:

Codice: Seleziona tutto
Hit http://it.archive.ubuntu.com jaunty Release.gpg
Hit http://archive.canonical.com jaunty Release.gpg                           
Ign http://archive.canonical.com jaunty/partner Translation-it                
Hit http://security.ubuntu.com jaunty-security Release.gpg                    
Ign http://security.ubuntu.com jaunty-security/main Translation-it            
Ign http://security.ubuntu.com jaunty-security/restricted Translation-it      
Hit http://it.archive.ubuntu.com jaunty/main Translation-it                   
Hit http://archive.canonical.com jaunty Release                               
Ign http://security.ubuntu.com jaunty-security/universe Translation-it        
Ign http://security.ubuntu.com jaunty-security/multiverse Translation-it      
Hit http://security.ubuntu.com jaunty-security Release                        
Ign http://archive.canonical.com jaunty/partner Packages                      
Hit http://security.ubuntu.com jaunty-security/main Packages                  
Hit http://it.archive.ubuntu.com jaunty/restricted Translation-it
Ign http://archive.canonical.com jaunty/partner Sources                       
Hit http://security.ubuntu.com jaunty-security/restricted Packages            
Hit http://security.ubuntu.com jaunty-security/main Sources                   
Hit http://security.ubuntu.com jaunty-security/restricted Sources             
Hit http://archive.canonical.com jaunty/partner Packages                      
Hit http://security.ubuntu.com jaunty-security/universe Packages              
Hit http://security.ubuntu.com jaunty-security/universe Sources
Hit http://security.ubuntu.com jaunty-security/multiverse Packages
Hit http://security.ubuntu.com jaunty-security/multiverse Sources
Hit http://it.archive.ubuntu.com jaunty/universe Translation-it
Hit http://archive.canonical.com jaunty/partner Sources                       
Hit http://it.archive.ubuntu.com jaunty/multiverse Translation-it             
Hit http://it.archive.ubuntu.com jaunty-updates Release.gpg       
Ign http://it.archive.ubuntu.com jaunty-updates/main Translation-it
Ign http://it.archive.ubuntu.com jaunty-updates/restricted Translation-it
Ign http://it.archive.ubuntu.com jaunty-updates/universe Translation-it
Ign http://it.archive.ubuntu.com jaunty-updates/multiverse Translation-it
Hit http://it.archive.ubuntu.com jaunty Release                   
Hit http://it.archive.ubuntu.com jaunty-updates Release                       
Hit http://it.archive.ubuntu.com jaunty/main Packages                         
Hit http://it.archive.ubuntu.com jaunty/restricted Packages       
Hit http://it.archive.ubuntu.com jaunty/main Sources              
Hit http://it.archive.ubuntu.com jaunty/restricted Sources        
Hit http://it.archive.ubuntu.com jaunty/universe Packages         
Hit http://it.archive.ubuntu.com jaunty/universe Sources          
Hit http://it.archive.ubuntu.com jaunty/multiverse Packages       
Hit http://it.archive.ubuntu.com jaunty/multiverse Sources        
Hit http://it.archive.ubuntu.com jaunty-updates/main Packages     
Hit http://it.archive.ubuntu.com jaunty-updates/restricted Packages
Hit http://it.archive.ubuntu.com jaunty-updates/main Sources      
Hit http://it.archive.ubuntu.com jaunty-updates/restricted Sources
Hit http://it.archive.ubuntu.com jaunty-updates/universe Packages 
Hit http://it.archive.ubuntu.com jaunty-updates/universe Sources  
Hit http://it.archive.ubuntu.com jaunty-updates/multiverse Packages
Hit http://it.archive.ubuntu.com jaunty-updates/multiverse Sources
E: Impossibile ottenere il lock /var/lib/dpkg/lock - open (11 Risorsa temporaneamente non disponibile)
E: Impossibile bloccare la directory di amministrazione (/var/lib/dpkg/), potrebbe essere usata da un altro processo.


inoltre l'output di sudo apt-get upgrade:

Codice: Seleziona tutto
sudo: unable to resolve host danilo-laptop
E: Impossibile ottenere il lock /var/lib/dpkg/lock - open (11 Risorsa temporaneamente non disponibile)
E: Impossibile bloccare la directory di amministrazione (/var/lib/dpkg/), potrebbe essere usata da un altro processo.


cosa fare?
madamada Non specificato
Prode Principiante
 
Messaggi: 77
Iscrizione: maggio 2009

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda badìl » lunedì 11 maggio 2009, 23:21

Cominciamo dal problema del sudo. Posta
Codice: Seleziona tutto
cat /etc/hosts
e
Codice: Seleziona tutto
cat /etc/hostname
Avatar utente
badìl Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14806
Iscrizione: agosto 2007

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda madamada » lunedì 11 maggio 2009, 23:25

output di cat /etc/hosts:

Codice: Seleziona tutto
127.0.0.1 localhost
127.0.1.1 danilo-laptop.mshome.net

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts


output di cat /etc/hostname:

Codice: Seleziona tutto
danilo@danilo-laptop:~$ cat /etc/hostname
danilo-laptop
madamada Non specificato
Prode Principiante
 
Messaggi: 77
Iscrizione: maggio 2009

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda badìl » lunedì 11 maggio 2009, 23:28

Ora digita
Codice: Seleziona tutto
gksu /etc/hosts
e modifica questa riga da così
127.0.1.1 danilo-laptop.mshome.net

a così
Codice: Seleziona tutto
127.0.1.1 danilo-laptop

Salva e chiudi.

Per questo problema invece
E: Impossibile ottenere il lock /var/lib/dpkg/lock - open (11 Risorsa temporaneamente non disponibile)
E: Impossibile bloccare la directory di amministrazione (/var/lib/dpkg/), potrebbe essere usata da un altro processo.

Assicurati di non avere altri gestori di pacchetti aperti quando esegui il comando.
Avatar utente
badìl Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14806
Iscrizione: agosto 2007

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda madamada » lunedì 11 maggio 2009, 23:31

perdonami ma il comando gksu /etc/hosts non mi consente di far nulla: guarda un po'

Codice: Seleziona tutto
gksu /etc/hosts
danilo@danilo-laptop:~$
madamada Non specificato
Prode Principiante
 
Messaggi: 77
Iscrizione: maggio 2009

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda badìl » lunedì 11 maggio 2009, 23:35

madamada ha scritto:perdonami ma il comando gksu /etc/hosts non mi consente di far nulla: guarda un po'

Codice: Seleziona tutto
gksu /etc/hosts
danilo@danilo-laptop:~$



Sì scusa!!! Ho sbagliato io (ho dimenticato un pezzo...)  :-[
Codice: Seleziona tutto
gksu gedit /etc/hosts
Avatar utente
badìl Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14806
Iscrizione: agosto 2007

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda madamada » lunedì 11 maggio 2009, 23:41

Fatto! ora sembra che synaptic non dia più quel tipo di errore 1. E' illusione ottica o il problema è risolto?
madamada Non specificato
Prode Principiante
 
Messaggi: 77
Iscrizione: maggio 2009

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda badìl » lunedì 11 maggio 2009, 23:45

Non so se fosse collegato visto che con synaptic si usa gksu (che come abbiamo constatato funzionava anche prima)...  :-\
Avatar utente
badìl Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14806
Iscrizione: agosto 2007

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda Elettra84 » sabato 23 maggio 2009, 15:39

Ho un problema simile, ma purtroppo non riesco a risolverlo nè con apt-get nè con la modifica del file .pstrm.
Sto cercando di installare snort su ubuntu 9 e il risultato è il seguente:
Codice: Seleziona tutto
root@elettra-desktop:~# apt-get -f install
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso      
Lettura informazioni sullo stato... Fatto       
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
1 non completamente installati o rimossi.
Dopo quest'operazione, verranno occupati 0B di spazio su disco.
Configuro snort-mysql (2.7.0-22ubuntu1) ...
 * Stopping Network Intrusion Detection System  snort                            * No running snort instance found
 * Starting Network Intrusion Detection System  snort                            * /etc/snort/db-pending-config file found
 * Snort will not start as its database is not yet configured.
 * Please configure the database as described in
 * /usr/share/doc/snort-{pgsql,mysql}/README-database.Debian
 * and remove /etc/snort/db-pending-config
invoke-rc.d: initscript snort, action "start" failed.
dpkg: errore processando snort-mysql (--configure):
 il sottoprocesso post-installation script ha restituito un codice di errore 6
Sono occorsi degli errori processando:
 snort-mysql
E: Sub-process /usr/bin/dpkg returned an error code (1)


Non so davvero dove sbattere la testa.... :'(
Elettra84 Non specificato
Prode Principiante
 
Messaggi: 3
Iscrizione: maggio 2009

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda pieddu » domenica 24 maggio 2009, 0:50

Prova a seguire il suggerimento....
Codice: Seleziona tutto
 * Please configure the database as described in
 * /usr/share/doc/snort-{pgsql,mysql}/README-database.Debian
 * and remove /etc/snort/db-pending-config
pieddu Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 13376
Iscrizione: novembre 2006
Località: Foligno

Re: ...ancora E: Sub-process /usr/bin/dpkg returned an error code (1)

Messaggioda 'Leonardo' » mercoledì 4 novembre 2009, 9:41

pieddu ha scritto:quale pacchetto genera l'errore?
Va bene la fine, ma la causa?


Scusa, visto che sei collegato, potresti aiutarmi?

Ho lo stesso messaggio di errore, ma non riesco proprio ad eliminarlo.

Grazie
'Leonardo' Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 501
Iscrizione: giugno 2008

Successiva

Torna a Ubuntu su server

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 3 ospiti