Server ftp con proFTPd inaccessibile dall'esterno

Installazione, configurazione e uso di Ubuntu come server: web, ftp, mail, news, proxy, dns, ecc.

Server ftp con proFTPd inaccessibile dall'esterno

Messaggioda kabeira » martedì 17 aprile 2012, 23:11

Salve,
sto cercando di creare sulla mia macchina un server ftp.
Il mio obiettivo è rendere visibile tramite ftp una cartella specifica del mio computer.
Ho seguito molte guide e mi sono appoggiata anche alla documentazione originale del progetto ma non capisco ancora dove sbaglio.

Vi posto il file proftpd.conf
Codice: Seleziona tutto
#
# /etc/proftpd/proftpd.conf -- This is a basic ProFTPD configuration file.
# To really apply changes reload proftpd after modifications.
#

# Includes DSO modules
Include /etc/proftpd/modules.conf

# Set off to disable IPv6 support which is annoying on IPv4 only boxes.
UseIPv6            off
# If set on you can experience a longer connection delay in many cases.
IdentLookups         off

ServerName         "server FTP"
ServerIdent         on "Benvenuta!"
ServerType         standalone
DeferWelcome         off

MultilineRFC2228      on
DefaultServer         on
ShowSymlinks         on

TimeoutNoTransfer      600
TimeoutStalled         600
TimeoutIdle         1200

DisplayLogin                    welcome.msg
DisplayChdir                  .message true
ListOptions                   "-l"

DenyFilter         \*.*/

# Use this to jail all users in their homes
<Global>
RootLogin         off
DefaultRoot         /home/mioutente/Documenti/prova
</Global>

# Users require a valid shell listed in /etc/shells to login.
# Use this directive to release that constrain.
RequireValidShell      on

# Port 21 is the standard FTP port.
Port            21
AllowForeignAddress      on
AllowStoreRestart      on
AllowRetrieveRestart      on
IdentLookups         off
UseReverseDNS         off

# In some cases you have to specify passive ports range to by-pass
# firewall limitations. Ephemeral ports can be used for that, but
# feel free to use a more narrow range.
PassivePorts                  5900 5903

# If your host was NATted, this option is useful in order to
# allow passive tranfers to work. You have to use your public
# address and opening the passive ports used on your firewall as well.
MasqueradeAddress      prova.homepc.it

# This is useful for masquerading address with dynamic IPs:
# refresh any configured MasqueradeAddress directives every 8 hours
<IfModule mod_dynmasq.c>
DynMasqRefresh 3600
</IfModule>

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances         30

# Set the user and group that the server normally runs at.
User            root
Group            ftp

# Umask 022 is a good standard umask to prevent new files and dirs
# (second parm) from being group and world writable.
Umask            022
# Normally, we want files to be overwriteable.
<Directory />
AllowOverwrite         on
</Directory>

# Uncomment this if you are using NIS or LDAP via NSS to retrieve passwords:
PersistentPasswd      off
AuthPAM            off

# This is required to use both PAM-based authentication and local passwords
AuthOrder         mod_auth_pam.c* mod_auth_unix.c

# Be warned: use of this directive impacts CPU average load!
# Uncomment this if you like to see progress and transfer rate with ftpwho
# in downloads. That is not needed for uploads rates.
#
# UseSendFile         off

TransferLog /var/log/proftpd/xferlog
SystemLog   /var/log/proftpd/proftpd.log

<IfModule mod_quotatab.c>
QuotaEngine off
</IfModule>

<IfModule mod_ratio.c>
Ratios off
</IfModule>


# Delay engine reduces impact of the so-called Timing Attack described in
# http://security.lss.hr/index.php?page=details&ID=LSS-2004-10-02
# It is on by default.
<IfModule mod_delay.c>
DelayEngine      off
</IfModule>

<IfModule mod_ctrls.c>
ControlsEngine        off
ControlsMaxClients    2
ControlsLog           /var/log/proftpd/controls.log
ControlsInterval      5
ControlsSocket        /var/run/proftpd/proftpd.sock
</IfModule>

<IfModule mod_ctrls_admin.c>
AdminControlsEngine off
</IfModule>

#
# Alternative authentication frameworks
#
#Include /etc/proftpd/ldap.conf
#Include /etc/proftpd/sql.conf

#
# This is used for FTPS connections
#
#Include /etc/proftpd/tls.conf

#
# Useful to keep VirtualHost/VirtualRoot directives separated
#
#Include /etc/proftpd/virtuals.con

# A basic anonymous configuration, no upload directories.

<Anonymous /home/mioutente/Documenti/prova>
User            ftp
Group            nogroup
# We want clients to be able to login with "anonymous" as well as "ftp"
UserAlias         anonymous ftp
# Cosmetic changes, all files belongs to ftp user
DirFakeUser   on ftp
DirFakeGroup on ftp

RequireValidShell      off

# Limit the maximum number of anonymous logins
MaxClients         10

# We want 'welcome.msg' displayed at login, and '.message' displayed
# in each newly chdired directory.
DisplayLogin         welcome.msg
DisplayChdir      .message
 
# Limit WRITE everywhere in the anonymous chroot
<Directory *>
  <Limit WRITE>
    DenyAll
  </Limit>
</Directory>
 
# Uncomment this if you're brave.
# <Directory incoming>
#   # Umask 022 is a good standard umask to prevent new files and dirs
#   # (second parm) from being group and world writable.
#   Umask            022  022
#            <Limit READ WRITE>
#            DenyAll
#            </Limit>
#            <Limit STOR>
#            AllowAll
#            </Limit>
# </Directory>
</Anonymous>


Questo è il file ddclient.conf (mi sono appoggiata a www.dyndns.it avendo un ip dinamico)
Codice: Seleziona tutto
# Configuration file for ddclient generated by debconf
#
# /etc/ddclient.conf

protocol=dyndns2
use=web, web=checkip.dyndns.it
server=dyndns.it
login=mioutente
password='pass'
prova.homepc.it


Se cerco di accedere tramite ftp dal mio pc a ftp://mioipinterno tutto nella norma
Se però cerco di accedere al mio ip pubblico oppure a prova.homepc.it l'esito (da terminale) è

Codice: Seleziona tutto
331 Enter PASS command
Password:
530 User prova cannot log in.


Credo che il problema sia nelle autenticazioni ma non riesco a capire come e dove andare a modificare il file di configurazione del server ftp.
Ringrazio in anticipo chi vorrà darmi qualche dritta.

Alessia
kabeira Non specificato
Prode Principiante
 
Messaggi: 17
Iscrizione: luglio 2009

Re: Server ftp con proFTPd inaccessibile dall'esterno

Messaggioda $nake » martedì 17 aprile 2012, 23:28

kabeira ha scritto:Salve,
sto cercando di creare sulla mia macchina un server ftp.
Il mio obiettivo è rendere visibile tramite ftp una cartella specifica del mio computer.
Ho seguito molte guide e mi sono appoggiata anche alla documentazione originale del progetto ma non capisco ancora dove sbaglio.

Vi posto il file proftpd.conf
Codice: Seleziona tutto
#
# /etc/proftpd/proftpd.conf -- This is a basic ProFTPD configuration file.
# To really apply changes reload proftpd after modifications.
#

# Includes DSO modules
Include /etc/proftpd/modules.conf

# Set off to disable IPv6 support which is annoying on IPv4 only boxes.
UseIPv6            off
# If set on you can experience a longer connection delay in many cases.
IdentLookups         off

ServerName         "server FTP"
ServerIdent         on "Benvenuta!"
ServerType         standalone
DeferWelcome         off

MultilineRFC2228      on
DefaultServer         on
ShowSymlinks         on

TimeoutNoTransfer      600
TimeoutStalled         600
TimeoutIdle         1200

DisplayLogin                    welcome.msg
DisplayChdir                  .message true
ListOptions                   "-l"

DenyFilter         \*.*/

# Use this to jail all users in their homes
<Global>
RootLogin         off
DefaultRoot         /home/mioutente/Documenti/prova
</Global>

# Users require a valid shell listed in /etc/shells to login.
# Use this directive to release that constrain.
RequireValidShell      on

# Port 21 is the standard FTP port.
Port            21
AllowForeignAddress      on
AllowStoreRestart      on
AllowRetrieveRestart      on
IdentLookups         off
UseReverseDNS         off

# In some cases you have to specify passive ports range to by-pass
# firewall limitations. Ephemeral ports can be used for that, but
# feel free to use a more narrow range.
PassivePorts                  5900 5903

# If your host was NATted, this option is useful in order to
# allow passive tranfers to work. You have to use your public
# address and opening the passive ports used on your firewall as well.
MasqueradeAddress      prova.homepc.it

# This is useful for masquerading address with dynamic IPs:
# refresh any configured MasqueradeAddress directives every 8 hours
<IfModule mod_dynmasq.c>
DynMasqRefresh 3600
</IfModule>

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances         30

# Set the user and group that the server normally runs at.
User            root
Group            ftp

# Umask 022 is a good standard umask to prevent new files and dirs
# (second parm) from being group and world writable.
Umask            022
# Normally, we want files to be overwriteable.
<Directory />
AllowOverwrite         on
</Directory>

# Uncomment this if you are using NIS or LDAP via NSS to retrieve passwords:
PersistentPasswd      off
AuthPAM            off

# This is required to use both PAM-based authentication and local passwords
AuthOrder         mod_auth_pam.c* mod_auth_unix.c

# Be warned: use of this directive impacts CPU average load!
# Uncomment this if you like to see progress and transfer rate with ftpwho
# in downloads. That is not needed for uploads rates.
#
# UseSendFile         off

TransferLog /var/log/proftpd/xferlog
SystemLog   /var/log/proftpd/proftpd.log

<IfModule mod_quotatab.c>
QuotaEngine off
</IfModule>

<IfModule mod_ratio.c>
Ratios off
</IfModule>


# Delay engine reduces impact of the so-called Timing Attack described in
# http://security.lss.hr/index.php?page=details&ID=LSS-2004-10-02
# It is on by default.
<IfModule mod_delay.c>
DelayEngine      off
</IfModule>

<IfModule mod_ctrls.c>
ControlsEngine        off
ControlsMaxClients    2
ControlsLog           /var/log/proftpd/controls.log
ControlsInterval      5
ControlsSocket        /var/run/proftpd/proftpd.sock
</IfModule>

<IfModule mod_ctrls_admin.c>
AdminControlsEngine off
</IfModule>

#
# Alternative authentication frameworks
#
#Include /etc/proftpd/ldap.conf
#Include /etc/proftpd/sql.conf

#
# This is used for FTPS connections
#
#Include /etc/proftpd/tls.conf

#
# Useful to keep VirtualHost/VirtualRoot directives separated
#
#Include /etc/proftpd/virtuals.con

# A basic anonymous configuration, no upload directories.

<Anonymous /home/mioutente/Documenti/prova>
User            ftp
Group            nogroup
# We want clients to be able to login with "anonymous" as well as "ftp"
UserAlias         anonymous ftp
# Cosmetic changes, all files belongs to ftp user
DirFakeUser   on ftp
DirFakeGroup on ftp

RequireValidShell      off

# Limit the maximum number of anonymous logins
MaxClients         10

# We want 'welcome.msg' displayed at login, and '.message' displayed
# in each newly chdired directory.
DisplayLogin         welcome.msg
DisplayChdir      .message
 
# Limit WRITE everywhere in the anonymous chroot
<Directory *>
  <Limit WRITE>
    DenyAll
  </Limit>
</Directory>
 
# Uncomment this if you're brave.
# <Directory incoming>
#   # Umask 022 is a good standard umask to prevent new files and dirs
#   # (second parm) from being group and world writable.
#   Umask            022  022
#            <Limit READ WRITE>
#            DenyAll
#            </Limit>
#            <Limit STOR>
#            AllowAll
#            </Limit>
# </Directory>
</Anonymous>


Questo è il file ddclient.conf (mi sono appoggiata a www.dyndns.it avendo un ip dinamico)
Codice: Seleziona tutto
# Configuration file for ddclient generated by debconf
#
# /etc/ddclient.conf

protocol=dyndns2
use=web, web=checkip.dyndns.it
server=dyndns.it
login=mioutente
password='pass'
prova.homepc.it


Se cerco di accedere tramite ftp dal mio pc a ftp://mioipinterno tutto nella norma
Se però cerco di accedere al mio ip pubblico oppure a prova.homepc.it l'esito (da terminale) è

Codice: Seleziona tutto
331 Enter PASS command
Password:
530 User prova cannot log in.


Credo che il problema sia nelle autenticazioni ma non riesco a capire come e dove andare a modificare il file di configurazione del server ftp.
Ringrazio in anticipo chi vorrà darmi qualche dritta.

Alessia

Hai aperto le porte nel router per una connessione entrante?
Se insisti e persisiti raggiungi e conquisti!|||Non tutto il male viene per nuocere!|||Due cose sono infinite: l'universo e la stupidità umana, ma riguardo l'universo ho ancora dei dubbi...(Albert Einstein )|||Umuntu ngumuntu ngabantu, "io sono ciò che sono in virtù di ciò che tutti siamo".
Avatar utente
$nake Maschile
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2073
Iscrizione: febbraio 2012
Località: Italia
Distribuzione: Ubuntu 14.04 LTS x86_64
Desktop: Ubuntu "3D"

Re: Server ftp con proFTPd inaccessibile dall'esterno

Messaggioda kabeira » martedì 17 aprile 2012, 23:37

Avevo giusto dimenticato del router. E' un vecchio router perchè attendo la sostituzione del mio.
Queste sono le uniche impostazioni che ho trovato sulle porte.
Allegati
Schermata.png
kabeira Non specificato
Prode Principiante
 
Messaggi: 17
Iscrizione: luglio 2009

Re: Server ftp con proFTPd inaccessibile dall'esterno

Messaggioda $nake » mercoledì 18 aprile 2012, 0:05

kabeira ha scritto:Avevo giusto dimenticato del router. E' un vecchio router perchè attendo la sostituzione del mio.
Queste sono le uniche impostazioni che ho trovato sulle porte.


Sotto al numero 4 prova a mettere negli ("start port"23in tutte e due in start e stop)dove dice ipaddress metti l'ip della tua lan locale.
Fino adesso non ha funzionato semplicemente per le porte chiuse nel router,se vuoi che funzioni,in attesa del sostituto dei moddarlo come ti ho detto.Se ben ricordo come sopra detto la porta e la 23.
Riguardo alle altre porte aperte,nel caso non lo sapessi,sono una (probabile per qualche server di gioco)ed è la 5900,l'altra in genere serve come server per la posta.Ma non sapendo cosa sono o chi le ha aperte ti consiglierei vivamente di chiuderle,perchè potrebbero essere utilizzate per molto altro!
Se insisti e persisiti raggiungi e conquisti!|||Non tutto il male viene per nuocere!|||Due cose sono infinite: l'universo e la stupidità umana, ma riguardo l'universo ho ancora dei dubbi...(Albert Einstein )|||Umuntu ngumuntu ngabantu, "io sono ciò che sono in virtù di ciò che tutti siamo".
Avatar utente
$nake Maschile
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2073
Iscrizione: febbraio 2012
Località: Italia
Distribuzione: Ubuntu 14.04 LTS x86_64
Desktop: Ubuntu "3D"

Re: Server ftp con proFTPd inaccessibile dall'esterno

Messaggioda kabeira » mercoledì 18 aprile 2012, 0:38

Ti ringrazio per la risposta. ^_^

Ho cancellato i due settaggi precedenti ed ho inserito la porta 21 sul mio ip (se era questo che intendevi con
l'ip della tua lan locale


Ho ricontrollato il documento e indica la port 21. Hai scritto 23 per errore o devo aprire la 23?

Nel file delle configurazioni c'è scritto
Codice: Seleziona tutto
PassivePorts                  5900 5903

per questo avevo aperto quelle porte sul router, assieme alle porte dalla 20 alla 25.
Avevo male interpretato l'uso delle porte passive quindi.

Per il momento non sembra esser cambiato molto. Provo a riavviare il router ed il pc e ricontrollo.
kabeira Non specificato
Prode Principiante
 
Messaggi: 17
Iscrizione: luglio 2009

Re: Server ftp con proFTPd inaccessibile dall'esterno

Messaggioda $nake » mercoledì 18 aprile 2012, 0:45

kabeira ha scritto:Ti ringrazio per la risposta. ^_^

Ho cancellato i due settaggi precedenti ed ho inserito la porta 21 sul mio ip (se era questo che intendevi con
l'ip della tua lan locale


Ho ricontrollato il documento e indica la port 21. Hai scritto 23 per errore o devo aprire la 23?

Nel file delle configurazioni c'è scritto
Codice: Seleziona tutto
PassivePorts                  5900 5903

per questo avevo aperto quelle porte sul router, assieme alle porte dalla 20 alla 25.
Avevo male interpretato l'uso delle porte passive quindi.

Per il momento non sembra esser cambiato molto. Provo a riavviare il router ed il pc e ricontrollo.

Prova ad aprire la 21 se non dovesse ancora andare la 23.In ogni caso se ben ricordo è la 21.
Se insisti e persisiti raggiungi e conquisti!|||Non tutto il male viene per nuocere!|||Due cose sono infinite: l'universo e la stupidità umana, ma riguardo l'universo ho ancora dei dubbi...(Albert Einstein )|||Umuntu ngumuntu ngabantu, "io sono ciò che sono in virtù di ciò che tutti siamo".
Avatar utente
$nake Maschile
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2073
Iscrizione: febbraio 2012
Località: Italia
Distribuzione: Ubuntu 14.04 LTS x86_64
Desktop: Ubuntu "3D"

Re: Server ftp con proFTPd inaccessibile dall'esterno

Messaggioda kabeira » mercoledì 18 aprile 2012, 1:05

Ho provato entrambe le soluzioni (21 e 23), ma nulla :(
Sembra che non riconosca gli utenti...ma solo fuori dala rete.
Se da un altro pc nella lan vado su ftp://mioiplan mi fa vedere le cartelle senz nemmeno chiedere la pass. Se vado su ftp://prova.homepc..it o ftp://mioipesterno chiede l'autenticazione ma non fa entrare.
idem se faccio il tutto dal mio pc.
kabeira Non specificato
Prode Principiante
 
Messaggi: 17
Iscrizione: luglio 2009

Re: Server ftp con proFTPd inaccessibile dall'esterno

Messaggioda $nake » mercoledì 18 aprile 2012, 1:26

kabeira ha scritto:Ho provato entrambe le soluzioni (21 e 23), ma nulla :(
Sembra che non riconosca gli utenti...ma solo fuori dala rete.
Se da un altro pc nella lan vado su ftp://mioiplan mi fa vedere le cartelle senz nemmeno chiedere la pass. Se vado su ftp://prova.homepc..it o ftp://mioipesterno chiede l'autenticazione ma non fa entrare.
idem se faccio il tutto dal mio pc.

Ma hai provato a fare accedere un amico con un altro ip?Se non hai a chi chiedere prova sotto rete tor...
Se insisti e persisiti raggiungi e conquisti!|||Non tutto il male viene per nuocere!|||Due cose sono infinite: l'universo e la stupidità umana, ma riguardo l'universo ho ancora dei dubbi...(Albert Einstein )|||Umuntu ngumuntu ngabantu, "io sono ciò che sono in virtù di ciò che tutti siamo".
Avatar utente
$nake Maschile
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2073
Iscrizione: febbraio 2012
Località: Italia
Distribuzione: Ubuntu 14.04 LTS x86_64
Desktop: Ubuntu "3D"

Re: Server ftp con proFTPd inaccessibile dall'esterno

Messaggioda W@BLO » venerdì 20 aprile 2012, 17:47

Ciao
i router/modem Zyxel sono accessibili tramite ftp per caricare i nuovi firmware, può essere che sia attivo e ti chieda il login per accedere al modem e non al ftp, disattiva il controllo del firewall tramite ftp.

W@BLO
W@BLO Non specificato
Prode Principiante
 
Messaggi: 25
Iscrizione: dicembre 2009

Re: Server ftp con proFTPd inaccessibile dall'esterno

Messaggioda kabeira » sabato 21 aprile 2012, 13:30

Mi spiace non aver più risposto ai messaggi, ma sto avendo problemi col pc su cui stavo facendo il server. Una volta risolti, tornerò ad aggiornare la discussione. Grazie per le risposte date finora. :)
kabeira Non specificato
Prode Principiante
 
Messaggi: 17
Iscrizione: luglio 2009


Torna a Ubuntu su server

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 5 ospiti