executing grub-install /dev/mapper failed [NON RISOLTO]

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.

executing grub-install /dev/mapper failed [NON RISOLTO]

Messaggioda cancellic » martedì 11 settembre 2012, 22:41

ho un desktop con due hard disk. ho voluto reinstallare windows 7, cosi su uno ho installata windows 7 tramite cd avevo in dotazione quando ho acquistato il pc, sull 'altro hard disk vorrei installare ubuntu. tutta funziona bene tranne che alla fine quando mi appare la scritta executing grub-install /dev/mapper failed. cosa posso fare?
Ultima modifica di cancellic il venerdì 14 settembre 2012, 22:48, modificato 5 volte in totale.
cancellic Non specificato
Prode Principiante
 
Messaggi: 182
Iscrizione: febbraio 2008

Re: executing grub-install /dev/mapper failed

Messaggioda Carlin0 » martedì 11 settembre 2012, 22:45

Ciao , posta da live cd il risultato di
Codice: Seleziona tutto
sudo fdisk -l
Carlin0 Maschile
Rampante Reduce
Rampante Reduce
 
Messaggi: 7453
Iscrizione: novembre 2009
Località: Augusta Taurinorum
Distribuzione: Debian Squeeze
Desktop: Gnome 2.30.2

Re: executing grub-install /dev/mapper failed [NON RISOLTO]

Messaggioda cancellic » mercoledì 12 settembre 2012, 0:02

se da terminale scrivo sudo fdisk -l
mi ritorna

fdisk: unable to seek on /dev/sda: Invalid argument

cosa posso fare ora ?grazie
cancellic Non specificato
Prode Principiante
 
Messaggi: 182
Iscrizione: febbraio 2008

Re: executing grub-install /dev/mapper failed [NON RISOLTO]

Messaggioda dxgiusti » mercoledì 12 settembre 2012, 0:45

se riesci ad entrare in ubu, lancia gparted e fai due fotografie dei due hd.
quando hai installato ubu ti ricordi su quale disco hai messo il boot?
dxgiusti Maschile
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2497
Iscrizione: novembre 2007
Località: Lodi
Distribuzione: ubuntu 14.04
Desktop: unity

Re: executing grub-install /dev/mapper failed [NON RISOLTO]

Messaggioda cancellic » mercoledì 12 settembre 2012, 9:18

allego le schermate di gparted, spero qualcuno possa risolvere il mio problema
ho provato ad installare FEDORA e tutto funziona anche il bootloader che nel caso dell'installazione di fedora funziona senza creare problemi.
se non ho capito male gli hard disk sono bios raid, comunque il computer è un dell studio XPS 8100
spero di essere stato chiaro
grazie
Allegati
Screenshot from 2012-09-12 15_59_49.png
schermata gparted
Screenshot from 2012-09-12 15_59_35.png
schermata gparted
cancellic Non specificato
Prode Principiante
 
Messaggi: 182
Iscrizione: febbraio 2008

Re: executing grub-install /dev/mapper failed [NON RISOLTO ]

Messaggioda dxgiusti » mercoledì 12 settembre 2012, 13:05

Entra nel bios e imposta di partire con l'hd dove hai installato Ubuntu.
Poi apri il Terminale e dopo il digita: sudo update-grub e dai invio, ti chiede la password, digitala anche se sembra che non la scrive e dai invio.
Al termina riavvia e dovresti poter scegliere quale sistema avviare.
dxgiusti Maschile
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2497
Iscrizione: novembre 2007
Località: Lodi
Distribuzione: ubuntu 14.04
Desktop: unity

Re: executing grub-install /dev/mapper failed [NON RISOLTO ]

Messaggioda cancellic » mercoledì 12 settembre 2012, 13:11

imposto di partire con hd su cui ho installato ubuntu. dopo l'avvio mi appare una schermata tutta nera, con il cursore che lampeggia in alto a sinistra. ma ora non riesco nemmeno a scrivere, quindi tanto meno riesco ad aprire un terminale. devo fare queste operazioni usando il live CD? grazie mille della gentilezza
cancellic Non specificato
Prode Principiante
 
Messaggi: 182
Iscrizione: febbraio 2008

Re: executing grub-install /dev/mapper failed [NON RISOLTO ]

Messaggioda dxgiusti » mercoledì 12 settembre 2012, 13:38

quando sei con schermo nero e puntino lampeggiante guarda questo.
dxgiusti Maschile
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2497
Iscrizione: novembre 2007
Località: Lodi
Distribuzione: ubuntu 14.04
Desktop: unity

Re: executing grub-install /dev/mapper failed [NON RISOLTO ]

Messaggioda cancellic » mercoledì 12 settembre 2012, 14:30

ma il live cd si avvia e lo leggo
il problema è che lo schermo nero appare se decido, senza live cd, di far avviare il computer dal hd su è installato ubuntu
cancellic Non specificato
Prode Principiante
 
Messaggi: 182
Iscrizione: febbraio 2008

Re: executing grub-install /dev/mapper failed [NON RISOLTO]

Messaggioda dxgiusti » mercoledì 12 settembre 2012, 15:20

vedi questo.
dxgiusti Maschile
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2497
Iscrizione: novembre 2007
Località: Lodi
Distribuzione: ubuntu 14.04
Desktop: unity

Re: executing grub-install /dev/mapper failed [NON RISOLTO]

Messaggioda cancellic » giovedì 13 settembre 2012, 8:42

io ringrazio veramente tutti quanti, ma penso che il problema sia nel grub utilizzato nella versione in questa distribuzione 12. primo perche nella versione precedente funzionava benissimo e in secondo luogo perche fedora funziona senza problemi.
quindi purtroppo penso che la soluzione piu logica sia in questo momento passare a fedora.
ringrazio veraemtne tutti
cancellic Non specificato
Prode Principiante
 
Messaggi: 182
Iscrizione: febbraio 2008

Re: executing grub-install /dev/mapper failed [NON RISOLTO]

Messaggioda Mdfalcubo » giovedì 13 settembre 2012, 9:04

Tolgo il non risolto, non serve.
"Il genere umano è stimolante, è la gente che non sopporto,, (Linus - Peanuts)
L'unico modo per non commettere errori è non fare nulla.
Avatar utente
Mdfalcubo Maschile
Moderatore Globale
Moderatore Globale
 
Messaggi: 15093
Iscrizione: dicembre 2008

Re: executing grub-install /dev/mapper failed [NON RISOLTO]

Messaggioda streetcross » giovedì 13 settembre 2012, 13:58

cancellic » oggi, 9:42 ha scritto:io ringrazio veramente tutti quanti, ma penso che il problema sia nel grub utilizzato nella versione in questa distribuzione 12. primo perche nella versione precedente funzionava benissimo e in secondo luogo perche fedora funziona senza problemi.
quindi purtroppo penso che la soluzione piu logica sia in questo momento passare a fedora.
ringrazio veraemtne tutti

o cambiare grub (è come scegliere se cambiar la gomma bucata o la macchina :D )
Ubuntu user #22995 Linux user #474679 Stacy can't you see, you're just not the girl for me, I know it might be wrong, but I'm in love with Stacy's Mom. ﺕ In molti credono di essere degli alternativi. In realtà la maggior parte di loro lascia la strada principale per seguire la seconda strada più battuta; in pochi si creano il proprio sentiero.
Avatar utente
streetcross Non specificato
Accecante Asceta
Accecante Asceta
 
Messaggi: 24942
Iscrizione: febbraio 2008

Re: executing grub-install /dev/mapper failed

Messaggioda cancellic » venerdì 14 settembre 2012, 0:46

ho provato a usare boot repair e lascio qui di seguito quanto e' il report

Boot successfully repaired.

Please write on a paper the following URL:
http://paste.ubuntu.com/1203740/

In case you still experience boot problem, indicate this URL to:
boot.repair@gmail.com or to your favorite support forum.

You can now reboot your computer.
Please do not forget to make your BIOS boot on mapper/isw_dddighfbed_ARRAY0 (1933GB) disk!

The boot files of [Ubuntu 12.04.1 LTS] are far from the start of the disk. Your BIOS may not detect them. You may want to retry after creating a /boot partition (EXT4, >200MB, start of the disk). This can be performed via tools such as gParted. Then select this partition via the [Separate /boot partition:] option of [Boot Repair]. (https://help.ubuntu.com/community/BootPartition)

purtroppo anche se ora vedo la schermata che mi permette di scegliere fra avviare windows o linux , ma una volta selezionato questo ultimo appare la schermata iniziale di ubuntu e non va piu via, cosa fare?
cancellic Non specificato
Prode Principiante
 
Messaggi: 182
Iscrizione: febbraio 2008

Re: executing grub-install /dev/mapper failed

Messaggioda McLoy81 » venerdì 14 settembre 2012, 8:34

Hai provato ad entrare in modalità ripristino?
Asus P5QL-E , Core2Quad  Q6600 @3,00 GHz +  Asus Artic Square cooler, 4 GB Ram Kingston with cooler , ZOTAC Nvidia GeForce Gtx 460 AMP edition ( 1024Mb gddr5-256Bit) , Coolermaster Elite with AC Ryan mirror window , UBUNTU 12.04 LTS 64 bit
Avatar utente
McLoy81 Non specificato
Prode Principiante
 
Messaggi: 98
Iscrizione: aprile 2010
Località: Trieste
Distribuzione: ubuntu 12.04 LTS 64bit
Desktop: UNITY,ma rimpiango gnome2

Re: executing grub-install /dev/mapper failed

Messaggioda streetcross » venerdì 14 settembre 2012, 10:16

Per capire il problema (driver video?) sarebbe anche utile che editassi la riga di ubuntu togliendo le opzioni quiet,splash in modo da bootare in modalità testuale e vedere dove si blocca e che errore da
Ubuntu user #22995 Linux user #474679 Stacy can't you see, you're just not the girl for me, I know it might be wrong, but I'm in love with Stacy's Mom. ﺕ In molti credono di essere degli alternativi. In realtà la maggior parte di loro lascia la strada principale per seguire la seconda strada più battuta; in pochi si creano il proprio sentiero.
Avatar utente
streetcross Non specificato
Accecante Asceta
Accecante Asceta
 
Messaggi: 24942
Iscrizione: febbraio 2008

Re: executing grub-install /dev/mapper failed

Messaggioda cancellic » venerdì 14 settembre 2012, 22:47

si blocca alla scritta

starting CUPS printing spooler/server
cancellic Non specificato
Prode Principiante
 
Messaggi: 182
Iscrizione: febbraio 2008

Re: executing grub-install /dev/mapper failed [NON RISOLTO]

Messaggioda streetcross » venerdì 14 settembre 2012, 23:03

forse pacchetti danneggiati: http://ubuntuforums.org/showthread.php?t=1972259 e si spiegherebbe anche tutto il resto degli errori, magari un download fallato o una masterizzazione troppo veloce.

in alternativa potrebbe sempre essere per i driver video dato che a taluni si blocca comunque a quel punto e allora dovresti avviare con l'opzione xforcevesa al posto di quiet,splash e vedere se si avvia
Ubuntu user #22995 Linux user #474679 Stacy can't you see, you're just not the girl for me, I know it might be wrong, but I'm in love with Stacy's Mom. ﺕ In molti credono di essere degli alternativi. In realtà la maggior parte di loro lascia la strada principale per seguire la seconda strada più battuta; in pochi si creano il proprio sentiero.
Avatar utente
streetcross Non specificato
Accecante Asceta
Accecante Asceta
 
Messaggi: 24942
Iscrizione: febbraio 2008

Re: executing grub-install /dev/mapper failed [NON RISOLTO]

Messaggioda cancellic » sabato 15 settembre 2012, 9:14

ho provato a installare ubuntu su laptop DELL , stessa marca del laptop e tutto funziona. come mai in un caso funziona e nell'altro va in crash con la scritta appunto di executing grub-install dev/mapper failed?
cancellic Non specificato
Prode Principiante
 
Messaggi: 182
Iscrizione: febbraio 2008

Re: executing grub-install /dev/mapper failed [NON RISOLTO]

Messaggioda streetcross » sabato 15 settembre 2012, 19:20

Non è che "stessa marca" "stessa cosa" ;) anzi stessa merca per modo dire dato l'hw poi è di altre ditte.
senza considerare possibili danni ad hd o cavetto
Ubuntu user #22995 Linux user #474679 Stacy can't you see, you're just not the girl for me, I know it might be wrong, but I'm in love with Stacy's Mom. ﺕ In molti credono di essere degli alternativi. In realtà la maggior parte di loro lascia la strada principale per seguire la seconda strada più battuta; in pochi si creano il proprio sentiero.
Avatar utente
streetcross Non specificato
Accecante Asceta
Accecante Asceta
 
Messaggi: 24942
Iscrizione: febbraio 2008


Torna a Installazione e aggiornamento del sistema operativo

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 6 ospiti