[Risolto] Problema Lingua ubuntu

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.

[Risolto] Problema Lingua ubuntu

Messaggioda JackThunderX » martedì 8 maggio 2012, 18:11

Salve a tutti sono passato a ubuntu 12.04 e non ho avuto alcun problema fino a oggi, infatti oggi una volta completati gli aggiornamenti l'OS è passato all'inglese allora ho effettuato la stessa procedura che avevo precedentemente eseguito per portarlo all'italiano ma niente... sapete darmi una mano??
Grazie per la visione :D
Ultima modifica di JackThunderX il venerdì 11 maggio 2012, 12:13, modificato 1 volta in totale.
Siate pazienti con me uso ubuntu da poco :D
Unity non mi piace! meglio Gnome 3!! :D
JackThunderX Non specificato
Prode Principiante
 
Messaggi: 56
Iscrizione: gennaio 2012
Distribuzione: Ubuntu 12.04 LTS i686
Desktop: gnome 3

Re: Problema Lingua ubuntu

Messaggioda ^alessio^ » martedì 8 maggio 2012, 18:24

Ciao,apri un terminale e digita
Codice: Seleziona tutto
sudo apt-get install language-pack-it language-pack-it-base language-pack-gnome-it language-pack-gnome-it-base language-support-it
e dopo riavvia il pc,se al riavvio è ancora in inglese,non saprei come aiutarti :mad:
 
^alessio^ Non specificato
Rampante Reduce
Rampante Reduce
 
Messaggi: 5371
Iscrizione: maggio 2008
Località: como

Re: Problema Lingua ubuntu

Messaggioda JackThunderX » martedì 8 maggio 2012, 19:12

no, niente è rimasto in inglese... il fatto è che la lingua è già installata, ma non me la imposta come predefinita
Siate pazienti con me uso ubuntu da poco :D
Unity non mi piace! meglio Gnome 3!! :D
JackThunderX Non specificato
Prode Principiante
 
Messaggi: 56
Iscrizione: gennaio 2012
Distribuzione: Ubuntu 12.04 LTS i686
Desktop: gnome 3

Re: Problema Lingua ubuntu

Messaggioda ^alessio^ » martedì 8 maggio 2012, 19:25

posta
Codice: Seleziona tutto
cat /etc/default/locale
 
^alessio^ Non specificato
Rampante Reduce
Rampante Reduce
 
Messaggi: 5371
Iscrizione: maggio 2008
Località: como

Re: Problema Lingua ubuntu

Messaggioda JackThunderX » martedì 8 maggio 2012, 19:30

ecco il risultato:

Codice: Seleziona tutto
LANG="en_US.UTF-8"
LANGUAGE="en"
LC_NUMERIC="it_IT.UTF-8"
LC_TIME="it_IT.UTF-8"
LC_MONETARY="it_IT.UTF-8"
LC_PAPER="it_IT.UTF-8"
LC_IDENTIFICATION="it_IT.UTF-8"
LC_NAME="it_IT.UTF-8"
LC_ADDRESS="it_IT.UTF-8"
LC_TELEPHONE="it_IT.UTF-8"
LC_MEASUREMENT="it_IT.UTF-8"
Siate pazienti con me uso ubuntu da poco :D
Unity non mi piace! meglio Gnome 3!! :D
JackThunderX Non specificato
Prode Principiante
 
Messaggi: 56
Iscrizione: gennaio 2012
Distribuzione: Ubuntu 12.04 LTS i686
Desktop: gnome 3

Re: Problema Lingua ubuntu

Messaggioda ^alessio^ » martedì 8 maggio 2012, 19:33

aprilo con gedit
Codice: Seleziona tutto
sudo gedit /etc/default/locale
cancellane il contenuto e copia e incollaci questo dentro
Codice: Seleziona tutto
LANG="it_IT.UTF-8"
salva chiudi e riavvia il pc.
 
^alessio^ Non specificato
Rampante Reduce
Rampante Reduce
 
Messaggi: 5371
Iscrizione: maggio 2008
Località: como

Re: Problema Lingua ubuntu

Messaggioda JackThunderX » martedì 8 maggio 2012, 19:58

non ho avuto nessun miglioramento è sempre in inglese... comunque c'è un'altra cosa che non capisco, perchè se io ho ubuntu 12.04 ogni tanto mi da un errore dove mi dice che linux mint ha avuto un errore interno? e questo potrebbe influenzare sulla lingua del sistema?
Siate pazienti con me uso ubuntu da poco :D
Unity non mi piace! meglio Gnome 3!! :D
JackThunderX Non specificato
Prode Principiante
 
Messaggi: 56
Iscrizione: gennaio 2012
Distribuzione: Ubuntu 12.04 LTS i686
Desktop: gnome 3

Re: Problema Lingua ubuntu

Messaggioda ^alessio^ » martedì 8 maggio 2012, 20:09

posta
Codice: Seleziona tutto
cat /etc/lsb-release
 
^alessio^ Non specificato
Rampante Reduce
Rampante Reduce
 
Messaggi: 5371
Iscrizione: maggio 2008
Località: como

Re: Problema Lingua ubuntu

Messaggioda JackThunderX » martedì 8 maggio 2012, 20:50

DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=12
DISTRIB_CODENAME=lisa
DISTRIB_DESCRIPTION="Linux Mint 12 LXDE"
Siate pazienti con me uso ubuntu da poco :D
Unity non mi piace! meglio Gnome 3!! :D
JackThunderX Non specificato
Prode Principiante
 
Messaggi: 56
Iscrizione: gennaio 2012
Distribuzione: Ubuntu 12.04 LTS i686
Desktop: gnome 3

Re: Problema Lingua ubuntu

Messaggioda ^alessio^ » martedì 8 maggio 2012, 20:55

da quello che hai postato si evince che hai Mint,e Mint non si installa a tua insaputa :D posta
Codice: Seleziona tutto
cat /etc/apt/sources.list
 
^alessio^ Non specificato
Rampante Reduce
Rampante Reduce
 
Messaggi: 5371
Iscrizione: maggio 2008
Località: como

Re: Problema Lingua ubuntu

Messaggioda JackThunderX » martedì 8 maggio 2012, 21:04

Codice: Seleziona tutto
# deb cdrom:[Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012)]/ oneiric main restricted
deb-src http://archive.ubuntu.com/ubuntu precise main restricted #Added by software-properties

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://it.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://it.archive.ubuntu.com/ubuntu/ precise restricted main multiverse universe #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.
deb http://it.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://it.archive.ubuntu.com/ubuntu/ precise-updates restricted main multiverse universe #Added by software-properties

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://it.archive.ubuntu.com/ubuntu/ precise universe
deb http://it.archive.ubuntu.com/ubuntu/ precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://it.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://it.archive.ubuntu.com/ubuntu/ precise-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://it.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://it.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse #Added by software-properties

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security restricted main multiverse universe #Added by software-properties
deb http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main
# deb http://ubuntu.beryl-project.org feisty main
# deb-src http://ubuntu.beryl-project.org feisty main
deb http://packages.linuxmint.com/ lisa main upstream import




questa cosa è molto strana perché io ho installato ubuntu e me ne da conferma sia all'avvio che al logout
Siate pazienti con me uso ubuntu da poco :D
Unity non mi piace! meglio Gnome 3!! :D
JackThunderX Non specificato
Prode Principiante
 
Messaggi: 56
Iscrizione: gennaio 2012
Distribuzione: Ubuntu 12.04 LTS i686
Desktop: gnome 3

Re: Problema Lingua ubuntu

Messaggioda ^alessio^ » martedì 8 maggio 2012, 21:13

si ma hai un repo di Mint
Codice: Seleziona tutto
deb http://packages.linuxmint.com/ lisa main upstream import
toglilo,dopo apri un terminale e digita
Codice: Seleziona tutto
sudo gedit /etc/lsb-release
cancella il contenuto e copia e incollaci questo
Codice: Seleziona tutto
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04 LTS"
dopo aggiorna il sistema con
Codice: Seleziona tutto
sudo apt-get update && sudo apt-get upgrade
e quando hai finito riavvia.
 
^alessio^ Non specificato
Rampante Reduce
Rampante Reduce
 
Messaggi: 5371
Iscrizione: maggio 2008
Località: como

Re: Problema Lingua ubuntu

Messaggioda JackThunderX » martedì 8 maggio 2012, 21:19

ehm non so come fare a rimuovere la sorgente xD (non mi funziona il gestore sorgenti) mi puoi dire il processo da terminale?? :D grazie
Siate pazienti con me uso ubuntu da poco :D
Unity non mi piace! meglio Gnome 3!! :D
JackThunderX Non specificato
Prode Principiante
 
Messaggi: 56
Iscrizione: gennaio 2012
Distribuzione: Ubuntu 12.04 LTS i686
Desktop: gnome 3

Re: Problema Lingua ubuntu

Messaggioda daigo » martedì 8 maggio 2012, 21:40

prova così dai
Codice: Seleziona tutto
sudo gedit /etc/apt/sources.list
nel file di testo che ti apre raggiungi questa
Codice: Seleziona tutto
deb http://packages.linuxmint.com/ lisa main upstream import
e modificala mettendo davanti il cancelletto #
salva il file ,chiudi e dai
Codice: Seleziona tutto
sudo apt-get update
Ricerca Avanzata
Quando si chiede supporto postare sempre lsb_release -ds && echo $DESKTOP_SESSION && uname -m
Avatar utente
daigo Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 13836
Iscrizione: maggio 2011

Re: Problema Lingua ubuntu

Messaggioda JackThunderX » martedì 8 maggio 2012, 22:58

niente rimane che ho linux mint come release -.-
Siate pazienti con me uso ubuntu da poco :D
Unity non mi piace! meglio Gnome 3!! :D
JackThunderX Non specificato
Prode Principiante
 
Messaggi: 56
Iscrizione: gennaio 2012
Distribuzione: Ubuntu 12.04 LTS i686
Desktop: gnome 3

Re: Problema Lingua ubuntu

Messaggioda ^alessio^ » martedì 8 maggio 2012, 23:17

prova a rimuovere l'inglese
Codice: Seleziona tutto
sudo apt-get remove language-pack-en language-pack-en-base language-pack-gnome-en language-pack-gnome-en-base language-support-en
dopo riavvia e vediamo..........
 
^alessio^ Non specificato
Rampante Reduce
Rampante Reduce
 
Messaggi: 5371
Iscrizione: maggio 2008
Località: como

Re: Problema Lingua ubuntu

Messaggioda JackThunderX » martedì 8 maggio 2012, 23:23

mi scrive E: Unable to locate package language-support-en
Siate pazienti con me uso ubuntu da poco :D
Unity non mi piace! meglio Gnome 3!! :D
JackThunderX Non specificato
Prode Principiante
 
Messaggi: 56
Iscrizione: gennaio 2012
Distribuzione: Ubuntu 12.04 LTS i686
Desktop: gnome 3

Re: Problema Lingua ubuntu

Messaggioda ^alessio^ » martedì 8 maggio 2012, 23:26

ma gli altri li rimuove?prova a dare il comando non inserendo
Codice: Seleziona tutto
language-support-en
 
^alessio^ Non specificato
Rampante Reduce
Rampante Reduce
 
Messaggi: 5371
Iscrizione: maggio 2008
Località: como

Re: Problema Lingua ubuntu

Messaggioda JackThunderX » martedì 8 maggio 2012, 23:34

Codice: Seleziona tutto
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package language-pack-en is not installed, so not removed
Package language-pack-en-base is not installed, so not removed
Package language-pack-gnome-en is not installed, so not removed
Package language-pack-gnome-en-base is not installed, so not removed
The following packages were automatically installed and are no longer required:
  qbittorrent-nox mint-artwork-mate x11proto-xext-dev libmatecomponent mate-icon-theme libatk1.0-dev libmateweather python-mate mintmenu mate-conf-editor
  mate-common x11proto-xinerama-dev libpango1.0-dev mate-doc-utils mint-translations mint-backgrounds-lisa gtk2-engines-aurora mate-terminal libxi-dev
  mate-media mate-backgrounds mate-file-manager python-mate-desktop libmatepanelapplet mate-vfs caja libgail-dev mintsystem libxml-parser-perl mate-mime-data
  mate-panel-common gtk2-engines-candido mint-artwork-common x11proto-composite-dev intltool mate-menus mate-polkit mate-notification-daemon cowsay
  libmatedesktop fortunes-husse libxcursor-dev mint-x-icons mate-desktop x11proto-randr-dev x11proto-damage-dev gir1.2-mate-menus libgtk2.0-dev libxext-dev
  mint-info-lxde libxdamage-dev mate-settings-daemon mate-utils libart-2.0-dev x11proto-fixes-dev mate-control-center libcaja-extension libmatekeyring
  libxcomposite-dev mint-common libxrandr-dev libmateui libmatekbd mate-keyring mint-artwork-gnome libxft-dev mint-z-theme python-corba libmate
  libmatecomponentui python-mate-menu libxfixes-dev mintdesktop libxinerama-dev libgdk-pixbuf2.0-dev mint-x-theme libmatecanvas
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


questo è il risultato
Siate pazienti con me uso ubuntu da poco :D
Unity non mi piace! meglio Gnome 3!! :D
JackThunderX Non specificato
Prode Principiante
 
Messaggi: 56
Iscrizione: gennaio 2012
Distribuzione: Ubuntu 12.04 LTS i686
Desktop: gnome 3

Re: Problema Lingua ubuntu

Messaggioda ^alessio^ » martedì 8 maggio 2012, 23:38

dai
Codice: Seleziona tutto
sudo apt-get autoremove
e speriamo bene.........
 
^alessio^ Non specificato
Rampante Reduce
Rampante Reduce
 
Messaggi: 5371
Iscrizione: maggio 2008
Località: como

Successiva

Torna a Installazione e aggiornamento del sistema operativo

Chi c’è in linea

Visualizzano questa sezione: Google Feedfetcher, Mdfalcubo e 9 ospiti