Impossibile aggiornare a causa di pacchetti bloccati

Configurazione e uso delle applicazioni del desktop manager alla base di Kubuntu.

Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda MasterDavid » domenica 11 marzo 2012, 15:57

Salve,
è da ormai tre settimane che mi risulta impossibile aggiornare kubuntu (11.10), a causa di errori nelle dipendenze e pacchetti bloccati.

Precisamente:
Codice: Seleziona tutto
sudo apt-get update
[sudo] password for masterdavid:
Sorry, try again.
[sudo] password for masterdavid:
Ign http://dl.google.com stable InRelease
Scaricamento di:1 http://dl.google.com stable Release.gpg [198 B]                                                                                                                             
Ign http://it.archive.ubuntu.com oneiric InRelease                                                                                                                                            
Scaricamento di:2 http://dl.google.com stable Release [1351 B]                                                                                                                                
Ign http://extras.ubuntu.com oneiric InRelease                                                                                                                                         
Ign http://security.ubuntu.com oneiric-security InRelease                                                                                              
Ign http://deb.opera.com stable InRelease                                                                                     
Ign http://it.archive.ubuntu.com oneiric-updates InRelease                                                                    
Ign http://ppa.launchpad.net oneiric InRelease                                                                                
Scaricamento di:3 http://extras.ubuntu.com oneiric Release.gpg [72 B]                                                                                       
Trovato http://security.ubuntu.com oneiric-security Release.gpg                                                                                             
Ign http://it.archive.ubuntu.com oneiric-backports InRelease                                                                   
Trovato http://deb.opera.com stable Release.gpg                                                                                                                                       
Scaricamento di:4 http://dl.google.com stable/main amd64 Packages [1265 B]                                                                                                            
Trovato http://ppa.launchpad.net oneiric Release.gpg                                                                                                                                    
Trovato http://extras.ubuntu.com oneiric Release                                                                                                                               
Trovato http://security.ubuntu.com oneiric-security Release                                                                                                                    
Trovato http://it.archive.ubuntu.com oneiric Release.gpg                                                                                                                    
Scaricamento di:5 http://dl.google.com stable/main i386 Packages [1255 B]                                                                                 
Trovato http://deb.opera.com stable Release                                                                                                                                      
Ign http://dl.google.com stable/main TranslationIndex                                                                                                      
Trovato http://ppa.launchpad.net oneiric Release                                                                                                           
Scaricamento di:6 http://it.archive.ubuntu.com oneiric-updates Release.gpg [198 B]                                                
Trovato http://extras.ubuntu.com oneiric/main Sources                                                                                                    
Trovato http://security.ubuntu.com oneiric-security/main Sources                                                                                                                   
Trovato http://extras.ubuntu.com oneiric/main amd64 Packages                                                                   
Trovato http://extras.ubuntu.com oneiric/main i386 Packages                                                                                             
Trovato http://deb.opera.com stable/non-free amd64 Packages                                                                                             
Trovato http://ppa.launchpad.net oneiric/main Sources                                                                                                   
Trovato http://security.ubuntu.com oneiric-security/restricted Sources                                                         
Trovato http://security.ubuntu.com oneiric-security/universe Sources                                                           
Trovato http://security.ubuntu.com oneiric-security/multiverse Sources                                                         
Trovato http://security.ubuntu.com oneiric-security/main amd64 Packages                                                        
Trovato http://security.ubuntu.com oneiric-security/restricted amd64 Packages                                                  
Ign http://extras.ubuntu.com oneiric/main TranslationIndex                                                                                              
Trovato http://deb.opera.com stable/non-free i386 Packages                                                                                              
Ign http://deb.opera.com stable/non-free TranslationIndex                                                                                                                                      
Trovato http://ppa.launchpad.net oneiric/main amd64 Packages                                                                                                                                   
Trovato http://ppa.launchpad.net oneiric/main i386 Packages                                                                                                                                    
Ign http://ppa.launchpad.net oneiric/main TranslationIndex                                                                                                                                     
Trovato http://security.ubuntu.com oneiric-security/universe amd64 Packages                                                                             
Trovato http://security.ubuntu.com oneiric-security/multiverse amd64 Packages                                                                           
Trovato http://security.ubuntu.com oneiric-security/main i386 Packages                                                                                  
Trovato http://security.ubuntu.com oneiric-security/restricted i386 Packages                                                                            
Trovato http://security.ubuntu.com oneiric-security/universe i386 Packages                                                                              
Trovato http://security.ubuntu.com oneiric-security/multiverse i386 Packages                                                                            
Trovato http://security.ubuntu.com oneiric-security/main TranslationIndex                                                      
Trovato http://security.ubuntu.com oneiric-security/multiverse TranslationIndex                                                                         
Trovato http://security.ubuntu.com oneiric-security/restricted TranslationIndex                                                                         
Trovato http://security.ubuntu.com oneiric-security/universe TranslationIndex                                                                           
Trovato http://it.archive.ubuntu.com oneiric-backports Release.gpg                                                                                      
Ign http://dl.google.com stable/main Translation-it_IT                                                                              
Ign http://dl.google.com stable/main Translation-it                                                                                                                                   
Trovato http://security.ubuntu.com oneiric-security/main Translation-en                                                                                                               
Trovato http://security.ubuntu.com oneiric-security/multiverse Translation-en                                                                           
Ign http://dl.google.com stable/main Translation-en                                                                                                     
Trovato http://security.ubuntu.com oneiric-security/restricted Translation-en                                                                           
Trovato http://security.ubuntu.com oneiric-security/universe Translation-en                                                    
Ign http://extras.ubuntu.com oneiric/main Translation-it_IT                                           
Ign http://extras.ubuntu.com oneiric/main Translation-it                                              
Ign http://ppa.launchpad.net oneiric/main Translation-it_IT                                           
Ign http://deb.opera.com stable/non-free Translation-it_IT                                            
Ign http://extras.ubuntu.com oneiric/main Translation-en                                              
Ign http://ppa.launchpad.net oneiric/main Translation-it                                              
Ign http://deb.opera.com stable/non-free Translation-it                      
Ign http://ppa.launchpad.net oneiric/main Translation-en                     
Ign http://deb.opera.com stable/non-free Translation-en                      
Trovato http://it.archive.ubuntu.com oneiric Release
Scaricamento di:7 http://it.archive.ubuntu.com oneiric-updates Release [40,8 kB]
Trovato http://it.archive.ubuntu.com oneiric-backports Release                    
Trovato http://it.archive.ubuntu.com oneiric/main Sources                       
Trovato http://it.archive.ubuntu.com oneiric/restricted Sources
Trovato http://it.archive.ubuntu.com oneiric/universe Sources
Trovato http://it.archive.ubuntu.com oneiric/multiverse Sources
Trovato http://it.archive.ubuntu.com oneiric/main amd64 Packages
Trovato http://it.archive.ubuntu.com oneiric/restricted amd64 Packages
Trovato http://it.archive.ubuntu.com oneiric/universe amd64 Packages
Trovato http://it.archive.ubuntu.com oneiric/multiverse amd64 Packages
Trovato http://it.archive.ubuntu.com oneiric/main i386 Packages
Trovato http://it.archive.ubuntu.com oneiric/restricted i386 Packages
Trovato http://it.archive.ubuntu.com oneiric/universe i386 Packages
Trovato http://it.archive.ubuntu.com oneiric/multiverse i386 Packages
Trovato http://it.archive.ubuntu.com oneiric/main TranslationIndex
Trovato http://it.archive.ubuntu.com oneiric/multiverse TranslationIndex
Trovato http://it.archive.ubuntu.com oneiric/restricted TranslationIndex
Trovato http://it.archive.ubuntu.com oneiric/universe TranslationIndex
Scaricamento di:8 http://it.archive.ubuntu.com oneiric-updates/main Sources [129 kB]
Scaricamento di:9 http://it.archive.ubuntu.com oneiric-updates/restricted Sources [1337 B]
Scaricamento di:10 http://it.archive.ubuntu.com oneiric-updates/universe Sources [46,5 kB]
Scaricamento di:11 http://it.archive.ubuntu.com oneiric-updates/multiverse Sources [3648 B]
Scaricamento di:12 http://it.archive.ubuntu.com oneiric-updates/main amd64 Packages [297 kB]
Scaricamento di:13 http://it.archive.ubuntu.com oneiric-updates/restricted amd64 Packages [2982 B]                                                                                            
Scaricamento di:14 http://it.archive.ubuntu.com oneiric-updates/universe amd64 Packages [102 kB]                                                                                              
Scaricamento di:15 http://it.archive.ubuntu.com oneiric-updates/multiverse amd64 Packages [6202 B]                                                                                            
Scaricamento di:16 http://it.archive.ubuntu.com oneiric-updates/main i386 Packages [296 kB]                                                                                                   
Scaricamento di:17 http://it.archive.ubuntu.com oneiric-updates/restricted i386 Packages [2968 B]                                                                                             
Scaricamento di:18 http://it.archive.ubuntu.com oneiric-updates/universe i386 Packages [102 kB]                                                                                               
Scaricamento di:19 http://it.archive.ubuntu.com oneiric-updates/multiverse i386 Packages [6359 B]                                                                                             
Scaricamento di:20 http://it.archive.ubuntu.com oneiric-updates/main TranslationIndex [74 B]                                                                                                  
Scaricamento di:21 http://it.archive.ubuntu.com oneiric-updates/multiverse TranslationIndex [72 B]                                                                                            
Scaricamento di:22 http://it.archive.ubuntu.com oneiric-updates/restricted TranslationIndex [71 B]                                                                                            
Scaricamento di:23 http://it.archive.ubuntu.com oneiric-updates/universe TranslationIndex [73 B]                                                                                              
Trovato http://it.archive.ubuntu.com oneiric-backports/main Sources                                                                                                                           
Trovato http://it.archive.ubuntu.com oneiric-backports/restricted Sources                                                                                                                     
Trovato http://it.archive.ubuntu.com oneiric-backports/universe Sources                                                                                                                       
Trovato http://it.archive.ubuntu.com oneiric-backports/multiverse Sources                                                                                                                     
Trovato http://it.archive.ubuntu.com oneiric-backports/main amd64 Packages                                                                                                                    
Trovato http://it.archive.ubuntu.com oneiric-backports/restricted amd64 Packages                                                                                                              
Trovato http://it.archive.ubuntu.com oneiric-backports/universe amd64 Packages                                                                                                                
Trovato http://it.archive.ubuntu.com oneiric-backports/multiverse amd64 Packages                                                                                                              
Trovato http://it.archive.ubuntu.com oneiric-backports/main i386 Packages                                                                                                                     
Trovato http://it.archive.ubuntu.com oneiric-backports/restricted i386 Packages                                                                                                               
Trovato http://it.archive.ubuntu.com oneiric-backports/universe i386 Packages                                                                                                                 
Trovato http://it.archive.ubuntu.com oneiric-backports/multiverse i386 Packages                                                                                                               
Trovato http://it.archive.ubuntu.com oneiric-backports/main TranslationIndex                                                                                                                  
Trovato http://it.archive.ubuntu.com oneiric-backports/multiverse TranslationIndex                                                                                                            
Trovato http://it.archive.ubuntu.com oneiric-backports/restricted TranslationIndex                                                                                                            
Trovato http://it.archive.ubuntu.com oneiric-backports/universe TranslationIndex                                                                                                              
Trovato http://it.archive.ubuntu.com oneiric/main Translation-it                                                                                                                              
Trovato http://it.archive.ubuntu.com oneiric/main Translation-en                                                                                                                              
Trovato http://it.archive.ubuntu.com oneiric/multiverse Translation-it                                                                                                                        
Trovato http://it.archive.ubuntu.com oneiric/multiverse Translation-en                                                                                                                        
Trovato http://it.archive.ubuntu.com oneiric/restricted Translation-it                                                                                                                        
Trovato http://it.archive.ubuntu.com oneiric/restricted Translation-en                                                                                                                        
Trovato http://it.archive.ubuntu.com oneiric/universe Translation-it                                                                                                                          
Trovato http://it.archive.ubuntu.com oneiric/universe Translation-en                                                                                                                          
Trovato http://it.archive.ubuntu.com oneiric-updates/main Translation-en                                                                                                                      
Trovato http://it.archive.ubuntu.com oneiric-updates/multiverse Translation-en                                                                                                                
Trovato http://it.archive.ubuntu.com oneiric-updates/restricted Translation-en                                                                                                                
Trovato http://it.archive.ubuntu.com oneiric-updates/universe Translation-en                                                                                                                  
Trovato http://it.archive.ubuntu.com oneiric-backports/main Translation-en                                                                                                                    
Trovato http://it.archive.ubuntu.com oneiric-backports/multiverse Translation-en                                                                                                              
Trovato http://it.archive.ubuntu.com oneiric-backports/restricted Translation-en                                                                                                              
Trovato http://it.archive.ubuntu.com oneiric-backports/universe Translation-en                                                                                                                
Recuperati 1041 kB in 15s (67,0 kB/s)                                                                                                                                                         
Lettura elenco dei pacchetti... Fatto


E fin qui tutto ok, poi:
Codice: Seleziona tutto
sudo apt-get upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 cpp-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 g++-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 gcc-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 gcc-4.6-base : Rompe: gcc-4.6-base:i386 (!= 4.6.2-15) ma la versione 4.6.1-9ubuntu3 è installata
 gcc-4.6-base:i386 : Rompe: gcc-4.6-base (!= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 kdelibs5-plugins : Rompe: kdevelop (< 4:4.2) ma la versione 4:4.0.1-1 è installata
 kdevelop : Dipende: kdevplatform1-libs (>= 1.0.1) ma non è installabile
            Dipende: libqt4-webkit (>= 4:4.5.3) ma non è installato
            Dipende: libsublime1 (>= 1.0.1) ma non è installabile
            Dipende: kdevelop-data (>= 4:4.0.1-1) ma non è installato
            Dipende: lcov ma non è installato
 kdevelop-dev : Dipende: kdelibs5-dev ma non è installato
                Dipende: kdevplatform-dev ma non è installato
 libgcc1 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libgfortran3 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libgomp1 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libquadmath0 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libstdc++6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libstdc++6-4.6-dev : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
E: Dipendenze non trovate. Riprovare usando -f.


Allora provo con sudo apt-get dist-upgrade, ma niente:
Codice: Seleziona tutto
cpp-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 g++-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 gcc-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 gcc-4.6-base : Rompe: gcc-4.6-base:i386 (!= 4.6.2-15) ma la versione 4.6.1-9ubuntu3 è installata
 gcc-4.6-base:i386 : Rompe: gcc-4.6-base (!= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 kdelibs5-plugins : Rompe: kdevelop (< 4:4.2) ma la versione 4:4.0.1-1 è installata
 kdevelop : Dipende: kdevplatform1-libs (>= 1.0.1) ma non è installabile
            Dipende: libqt4-webkit (>= 4:4.5.3) ma non è installato
            Dipende: libsublime1 (>= 1.0.1) ma non è installabile
            Dipende: kdevelop-data (>= 4:4.0.1-1) ma non è installato
            Dipende: lcov ma non è installato
 kdevelop-dev : Dipende: kdelibs5-dev ma non è installato
                Dipende: kdevplatform-dev ma non è installato
 libgcc1 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libgfortran3 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libgomp1 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libquadmath0 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libstdc++6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libstdc++6-4.6-dev : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
E: Dipendenze non trovate. Riprovare usando -f.


Nemmeno con sudo apt-get -f install cambia qualcosa:
Codice: Seleziona tutto
sudo apt-get -f install
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... non riuscita.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 cpp-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 g++-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 gcc-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 gcc-4.6-base : Rompe: gcc-4.6-base:i386 (!= 4.6.2-15) ma la versione 4.6.1-9ubuntu3 è installata
 gcc-4.6-base:i386 : Rompe: gcc-4.6-base (!= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 kdelibs5-plugins : Rompe: kdevelop (< 4:4.2) ma la versione 4:4.0.1-1 è installata
 kdevelop : Dipende: kdevplatform1-libs (>= 1.0.1) ma non è installabile
            Dipende: libqt4-webkit (>= 4:4.5.3) ma non è installato
            Dipende: libsublime1 (>= 1.0.1) ma non è installabile
            Dipende: kdevelop-data (>= 4:4.0.1-1) ma non è installato
            Dipende: lcov ma non è installato
 kdevelop-dev : Dipende: kdelibs5-dev ma non è installato
                Dipende: kdevplatform-dev ma non è installato
 libgcc1 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libgfortran3 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libgomp1 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libquadmath0 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libstdc++6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libstdc++6-4.6-dev : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
E: Errore, pkgProblemResolver::Resolve ha generato delle interruzioni. Questo potrebbe essere causato da pacchetti bloccati.
E: Impossibile correggere le dipendenze


Non so più cosa fare, ho anche provato direttamente con muon, a cercare i pacchetti danneggiati e tentare di rimuoverli, ma mi fa rimuovere circa 6 giga di pacchetti, tra cui firefox, vlc, e altri che sinceramente non so cosa c'entrano con il mio problema...

Grazie mille per l'aiuto.
MasterDavid Non specificato
Prode Principiante
 
Messaggi: 57
Iscrizione: aprile 2010

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda Carlin0 » domenica 11 marzo 2012, 16:02

Posta
Codice: Seleziona tutto
cat /etc/apt/sources.list
ls /etc/apt/sources.list.d/
Carlin0 Maschile
Rampante Reduce
Rampante Reduce
 
Messaggi: 7453
Iscrizione: novembre 2009
Località: Augusta Taurinorum
Distribuzione: Debian Squeeze
Desktop: Gnome 2.30.2

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda MasterDavid » domenica 11 marzo 2012, 16:11

Allora:

Codice: Seleziona tutto
cat /etc/apt/sources.list
# deb cdrom:[Kubuntu 11.10 _Oneiric Ocelot_ - Release amd64 (20111012)]/ dists/oneiric/main/binary-i386/

# deb cdrom:[Kubuntu 11.10 _Oneiric Ocelot_ - Release amd64 (20111012)]/ dists/oneiric/restricted/binary-i386/
# deb cdrom:[Kubuntu 11.10 _Oneiric Ocelot_ - Release amd64 (20111012)]/ oneiric main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://it.archive.ubuntu.com/ubuntu/ oneiric main restricted
deb-src http://it.archive.ubuntu.com/ubuntu/ oneiric main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://it.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted
deb-src http://it.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://it.archive.ubuntu.com/ubuntu/ oneiric universe
deb-src http://it.archive.ubuntu.com/ubuntu/ oneiric universe
deb http://it.archive.ubuntu.com/ubuntu/ oneiric-updates universe
deb-src http://it.archive.ubuntu.com/ubuntu/ oneiric-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://it.archive.ubuntu.com/ubuntu/ oneiric multiverse
deb-src http://it.archive.ubuntu.com/ubuntu/ oneiric multiverse
deb http://it.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse
deb-src http://it.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://it.archive.ubuntu.com/ubuntu/ oneiric-backports main restricted universe multiverse
deb-src http://it.archive.ubuntu.com/ubuntu/ oneiric-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu oneiric-security main restricted
deb-src http://security.ubuntu.com/ubuntu oneiric-security main restricted
deb http://security.ubuntu.com/ubuntu oneiric-security universe
deb-src http://security.ubuntu.com/ubuntu oneiric-security universe
deb http://security.ubuntu.com/ubuntu oneiric-security multiverse
deb-src http://security.ubuntu.com/ubuntu oneiric-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu oneiric partner
# deb-src http://archive.canonical.com/ubuntu oneiric partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu oneiric main
deb-src http://extras.ubuntu.com/ubuntu oneiric main


e

Codice: Seleziona tutto
ls /etc/apt/sources.list.d/
google-chrome.list  kubuntu-ppa-ppa-oneiric.list  kubuntu-ppa-ppa-oneiric.list.save  opera.list
MasterDavid Non specificato
Prode Principiante
 
Messaggi: 57
Iscrizione: aprile 2010

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda Carlin0 » domenica 11 marzo 2012, 16:13

Hai provato a disabilitare i ppa che hai aggiunto ?
Carlin0 Maschile
Rampante Reduce
Rampante Reduce
 
Messaggi: 7453
Iscrizione: novembre 2009
Località: Augusta Taurinorum
Distribuzione: Debian Squeeze
Desktop: Gnome 2.30.2

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda MasterDavid » domenica 11 marzo 2012, 16:14

Sinceramente no, ora provo...
MasterDavid Non specificato
Prode Principiante
 
Messaggi: 57
Iscrizione: aprile 2010

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda MasterDavid » domenica 11 marzo 2012, 16:19

Non è cambiato niente, sempre lo stesso messaggio quando cerco di aggiornare...
Cmq ora che mi ricordo è da tempo che non aggiungevo dei ppa, sicuramente il pc funzionava anche con tutti i ppa abilitati...
MasterDavid Non specificato
Prode Principiante
 
Messaggi: 57
Iscrizione: aprile 2010

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda MasterDavid » domenica 11 marzo 2012, 17:57

Nessuna altra soluzione?

Ciò che mi preoccupa di più è che tra un mese quando ci sarà l'aggiornamento alla 12.04 risulterà tutto bloccato...
Se la 11.10 fosse una LTS non mi preoccuperei però a questo punto non vorrei essere costretto a formattare...

Possibile che neanche cercando i pacchetti bloccati su muon o synaptic non cambi niente o proponga modifiche assurde come rimuovere pacchetti di ogni genere (oltre ai danneggiati) per un totale di 6 giga di pacchetti che dovrei rimuovere?
Proprio non capisco perchè dovrei riumovere tutti quei pacchetti...
Ultima modifica di MasterDavid il domenica 11 marzo 2012, 18:01, modificato 1 volta in totale.
MasterDavid Non specificato
Prode Principiante
 
Messaggi: 57
Iscrizione: aprile 2010

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda TequilaMex » lunedì 12 marzo 2012, 12:46

2 suggerimenti:
- abilita i proposed e gli unsupported;
oppure
- fai l'avanzamento di versione.

ma il rischio è a spese tue  :P
Avatar utente
TequilaMex Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4511
Iscrizione: dicembre 2006

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda MasterDavid » lunedì 12 marzo 2012, 22:05

La prima soluzione mi sento di scartarla in quanto ho provato una volta ad abilitare gli unsupported ed è andato in crash l'intero sistema.
Non ho capito la seconda, cosa intendi dire quando parli di avanzamento di versione?
MasterDavid Non specificato
Prode Principiante
 
Messaggi: 57
Iscrizione: aprile 2010

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda Diabolik62 » lunedì 12 marzo 2012, 22:11

prova cosi
Codice: Seleziona tutto
sudo rm /var/lib/dpkg/status

Codice: Seleziona tutto
sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status

Codice: Seleziona tutto
sudo rm -rf /var/lib/apt/lists/*

Codice: Seleziona tutto
sudo dpkg --configure -a

Codice: Seleziona tutto
sudo apt-get update

Codice: Seleziona tutto
sudo apt.get upgrade

Codice: Seleziona tutto
sudo apt-get install -f

non sono sicuro che funzioni, ma prova.
posta le risposte
Avatar utente
Diabolik62 Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15208
Iscrizione: dicembre 2009
Distribuzione: windows8.1 fedora20 heisenbug mate

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda MasterDavid » lunedì 12 marzo 2012, 22:34

dunque al quarto passaggio:
Codice: Seleziona tutto
sudo dpkg --configure -a
dpkg: errore nell'elaborare gcc-4.6-base (--configure):
 gcc-4.6-base:amd64 4.6.2-15 non può essere configurato perché gcc-4.6-base:i386 ha una versione diversa (4.6.1-9ubuntu3)
dpkg: errore nell'elaborare gcc-4.6-base:i386 (--configure):
 gcc-4.6-base:i386 4.6.1-9ubuntu3 non può essere configurato perché gcc-4.6-base:amd64 ha una versione diversa (4.6.2-15)
Si sono verificati degli errori nell'elaborazione:
 gcc-4.6-base
 gcc-4.6-base:i386


al quinto:
Codice: Seleziona tutto
sudo apt-get update
Ign http://it.archive.ubuntu.com oneiric InRelease
Ign http://security.ubuntu.com oneiric-security InRelease                                                                   
Ign http://ppa.launchpad.net oneiric InRelease                                                                              
Ign http://deb.opera.com stable InRelease                                                                                   
Ign http://it.archive.ubuntu.com oneiric-updates InRelease                                                                  
Scaricamento di:1 http://security.ubuntu.com oneiric-security Release.gpg [198 B]                                           
Scaricamento di:2 http://ppa.launchpad.net oneiric Release.gpg [316 B]                                                      
Scaricamento di:3 http://security.ubuntu.com oneiric-security Release [40,8 kB]                                             
Scaricamento di:4 http://deb.opera.com stable Release.gpg [189 B]                                                           
Ign http://it.archive.ubuntu.com oneiric-backports InRelease                                                                
Scaricamento di:5 http://ppa.launchpad.net oneiric Release [9741 B]                                                         
Scaricamento di:6 http://it.archive.ubuntu.com oneiric Release.gpg [198 B]                                                  
Scaricamento di:7 http://deb.opera.com stable Release [633 B]                                                               
Scaricamento di:8 http://it.archive.ubuntu.com oneiric-updates Release.gpg [198 B]                                          
Scaricamento di:9 http://ppa.launchpad.net oneiric/main Sources [27,5 kB]                                                   
Scaricamento di:10 http://deb.opera.com stable/non-free amd64 Packages [843 B]                                              
Scaricamento di:11 http://it.archive.ubuntu.com oneiric-backports Release.gpg [198 B]                                       
Scaricamento di:12 http://security.ubuntu.com oneiric-security/main Sources [34,1 kB]                                       
Scaricamento di:13 http://it.archive.ubuntu.com oneiric Release [40,8 kB]                                                   
Scaricamento di:14 http://deb.opera.com stable/non-free i386 Packages [845 B]                                               
Ign http://deb.opera.com stable/non-free TranslationIndex                                                                   
Scaricamento di:15 http://ppa.launchpad.net oneiric/main amd64 Packages [74,4 kB]                                           
Scaricamento di:16 http://security.ubuntu.com oneiric-security/restricted Sources [14 B]                                    
Scaricamento di:17 http://security.ubuntu.com oneiric-security/universe Sources [12,2 kB]                                   
Scaricamento di:18 http://security.ubuntu.com oneiric-security/multiverse Sources [1654 B]                                  
Scaricamento di:19 http://security.ubuntu.com oneiric-security/main amd64 Packages [89,8 kB]                                
Scaricamento di:20 http://it.archive.ubuntu.com oneiric-updates Release [40,8 kB]                                           
Scaricamento di:21 http://ppa.launchpad.net oneiric/main i386 Packages [74,5 kB]                                            
Scaricamento di:22 http://security.ubuntu.com oneiric-security/restricted amd64 Packages [14 B]                             
Scaricamento di:23 http://security.ubuntu.com oneiric-security/universe amd64 Packages [30,4 kB]                            
Scaricamento di:24 http://security.ubuntu.com oneiric-security/multiverse amd64 Packages [3194 B]                           
Ign http://ppa.launchpad.net oneiric/main TranslationIndex                                                                  
Scaricamento di:25 http://security.ubuntu.com oneiric-security/main i386 Packages [90,0 kB]                                 
Scaricamento di:26 http://it.archive.ubuntu.com oneiric-backports Release [40,8 kB]                                         
Scaricamento di:27 http://it.archive.ubuntu.com oneiric/main Sources [877 kB]                                               
Scaricamento di:28 http://security.ubuntu.com oneiric-security/restricted i386 Packages [14 B]                              
Scaricamento di:29 http://security.ubuntu.com oneiric-security/universe i386 Packages [30,4 kB]                             
Ign http://ppa.launchpad.net oneiric/main Translation-it_IT                                                                 
Scaricamento di:30 http://security.ubuntu.com oneiric-security/multiverse i386 Packages [3362 B]                            
Scaricamento di:31 http://security.ubuntu.com oneiric-security/main TranslationIndex [73 B]                                 
Scaricamento di:32 http://security.ubuntu.com oneiric-security/multiverse TranslationIndex [72 B]                           
Scaricamento di:33 http://security.ubuntu.com oneiric-security/restricted TranslationIndex [70 B]                           
Scaricamento di:34 http://security.ubuntu.com oneiric-security/universe TranslationIndex [73 B]                             
Ign http://deb.opera.com stable/non-free Translation-it_IT                                                                  
Ign http://ppa.launchpad.net oneiric/main Translation-it                                                                    
Ign http://ppa.launchpad.net oneiric/main Translation-en                                                                    
Ign http://deb.opera.com stable/non-free Translation-it                                                                     
Scaricamento di:35 http://security.ubuntu.com oneiric-security/main Translation-en [50,4 kB]                                
Ign http://deb.opera.com stable/non-free Translation-en                                                                     
Scaricamento di:36 http://security.ubuntu.com oneiric-security/multiverse Translation-en [1494 B]                           
Scaricamento di:37 http://security.ubuntu.com oneiric-security/restricted Translation-en [14 B]                             
Scaricamento di:38 http://security.ubuntu.com oneiric-security/universe Translation-en [21,4 kB]                            
Scaricamento di:39 http://it.archive.ubuntu.com oneiric/restricted Sources [5351 B]                                         
Scaricamento di:40 http://it.archive.ubuntu.com oneiric/universe Sources [4677 kB]                                  
Ign http://dl.google.com stable InRelease                                                                                   
Scaricamento di:41 http://dl.google.com stable Release.gpg [198 B]                                         
Scaricamento di:42 http://dl.google.com stable Release [1351 B]                   
Ign http://extras.ubuntu.com oneiric InRelease                                       
Scaricamento di:43 http://dl.google.com stable/main amd64 Packages [1269 B]        
Scaricamento di:44 http://extras.ubuntu.com oneiric Release.gpg [72 B]                
Scaricamento di:45 http://extras.ubuntu.com oneiric Release [9759 B]               
Scaricamento di:46 http://dl.google.com stable/main i386 Packages [1256 B]               
Ign http://dl.google.com stable/main TranslationIndex                                                      
Scaricamento di:47 http://extras.ubuntu.com oneiric/main Sources [1662 B]          
Scaricamento di:48 http://extras.ubuntu.com oneiric/main amd64 Packages [2477 B]         
Scaricamento di:49 http://extras.ubuntu.com oneiric/main i386 Packages [2477 B]                            
Ign http://extras.ubuntu.com oneiric/main TranslationIndex                                                        
Ign http://dl.google.com stable/main Translation-it_IT                                                     
Ign http://dl.google.com stable/main Translation-it                                
Ign http://dl.google.com stable/main Translation-en                                
Ign http://extras.ubuntu.com oneiric/main Translation-it_IT                        
Ign http://extras.ubuntu.com oneiric/main Translation-it                                                                    
Ign http://extras.ubuntu.com oneiric/main Translation-en                                                                    
Scaricamento di:50 http://it.archive.ubuntu.com oneiric/multiverse Sources [149 kB]                                         
Scaricamento di:51 http://it.archive.ubuntu.com oneiric/main amd64 Packages [1226 kB]                                       
Scaricamento di:52 http://it.archive.ubuntu.com oneiric/restricted amd64 Packages [8261 B]                                  
Scaricamento di:53 http://it.archive.ubuntu.com oneiric/universe amd64 Packages [4460 kB]                                   
Scaricamento di:54 http://it.archive.ubuntu.com oneiric/multiverse amd64 Packages [117 kB]                                  
Scaricamento di:55 http://it.archive.ubuntu.com oneiric/main i386 Packages [1226 kB]                                        
Scaricamento di:56 http://it.archive.ubuntu.com oneiric/restricted i386 Packages [8216 B]                                   
Scaricamento di:57 http://it.archive.ubuntu.com oneiric/universe i386 Packages [4468 kB]                                    
Scaricamento di:58 http://it.archive.ubuntu.com oneiric/multiverse i386 Packages [119 kB]                                   
Scaricamento di:59 http://it.archive.ubuntu.com oneiric/main TranslationIndex [3289 B]                                      
Scaricamento di:60 http://it.archive.ubuntu.com oneiric/multiverse TranslationIndex [2265 B]                                
Scaricamento di:61 http://it.archive.ubuntu.com oneiric/restricted TranslationIndex [2263 B]                                
Scaricamento di:62 http://it.archive.ubuntu.com oneiric/universe TranslationIndex [2640 B]                                  
Scaricamento di:63 http://it.archive.ubuntu.com oneiric-updates/main Sources [130 kB]                                       
Scaricamento di:64 http://it.archive.ubuntu.com oneiric-updates/restricted Sources [1337 B]                                 
Scaricamento di:65 http://it.archive.ubuntu.com oneiric-updates/universe Sources [46,8 kB]                                  
Scaricamento di:66 http://it.archive.ubuntu.com oneiric-updates/multiverse Sources [3648 B]                                 
Scaricamento di:67 http://it.archive.ubuntu.com oneiric-updates/main amd64 Packages [298 kB]                                
Scaricamento di:68 http://it.archive.ubuntu.com oneiric-updates/restricted amd64 Packages [2982 B]                          
Scaricamento di:69 http://it.archive.ubuntu.com oneiric-updates/universe amd64 Packages [102 kB]                            
Scaricamento di:70 http://it.archive.ubuntu.com oneiric-updates/multiverse amd64 Packages [6202 B]                          
Scaricamento di:71 http://it.archive.ubuntu.com oneiric-updates/main i386 Packages [298 kB]                                 
Scaricamento di:72 http://it.archive.ubuntu.com oneiric-updates/restricted i386 Packages [2968 B]                           
Scaricamento di:73 http://it.archive.ubuntu.com oneiric-updates/universe i386 Packages [103 kB]                             
Scaricamento di:74 http://it.archive.ubuntu.com oneiric-updates/multiverse i386 Packages [6359 B]                           
Scaricamento di:75 http://it.archive.ubuntu.com oneiric-updates/main TranslationIndex [74 B]                                
Scaricamento di:76 http://it.archive.ubuntu.com oneiric-updates/multiverse TranslationIndex [72 B]                          
Scaricamento di:77 http://it.archive.ubuntu.com oneiric-updates/restricted TranslationIndex [71 B]                          
Scaricamento di:78 http://it.archive.ubuntu.com oneiric-updates/universe TranslationIndex [73 B]                            
Scaricamento di:79 http://it.archive.ubuntu.com oneiric-backports/main Sources [2742 B]                                     
Scaricamento di:80 http://it.archive.ubuntu.com oneiric-backports/restricted Sources [14 B]                                 
Scaricamento di:81 http://it.archive.ubuntu.com oneiric-backports/universe Sources [6957 B]                                 
Scaricamento di:82 http://it.archive.ubuntu.com oneiric-backports/multiverse Sources [14 B]                                 
Scaricamento di:83 http://it.archive.ubuntu.com oneiric-backports/main amd64 Packages [3288 B]                              
Scaricamento di:84 http://it.archive.ubuntu.com oneiric-backports/restricted amd64 Packages [14 B]                          
Scaricamento di:85 http://it.archive.ubuntu.com oneiric-backports/universe amd64 Packages [8360 B]                          
Scaricamento di:86 http://it.archive.ubuntu.com oneiric-backports/multiverse amd64 Packages [14 B]                          
Scaricamento di:87 http://it.archive.ubuntu.com oneiric-backports/main i386 Packages [3296 B]                               
Scaricamento di:88 http://it.archive.ubuntu.com oneiric-backports/restricted i386 Packages [14 B]                           
Scaricamento di:89 http://it.archive.ubuntu.com oneiric-backports/universe i386 Packages [8363 B]                           
Scaricamento di:90 http://it.archive.ubuntu.com oneiric-backports/multiverse i386 Packages [14 B]                           
Scaricamento di:91 http://it.archive.ubuntu.com oneiric-backports/main TranslationIndex [72 B]                              
Scaricamento di:92 http://it.archive.ubuntu.com oneiric-backports/multiverse TranslationIndex [70 B]                        
Scaricamento di:93 http://it.archive.ubuntu.com oneiric-backports/restricted TranslationIndex [70 B]                        
Scaricamento di:94 http://it.archive.ubuntu.com oneiric-backports/universe TranslationIndex [72 B]                          
Scaricamento di:95 http://it.archive.ubuntu.com oneiric/main Translation-it [554 kB]                                        
Scaricamento di:96 http://it.archive.ubuntu.com oneiric/main Translation-en [701 kB]                                        
Scaricamento di:97 http://it.archive.ubuntu.com oneiric/multiverse Translation-it [22,8 kB]                                 
Scaricamento di:98 http://it.archive.ubuntu.com oneiric/multiverse Translation-en [92,6 kB]                                 
Scaricamento di:99 http://it.archive.ubuntu.com oneiric/restricted Translation-it [2254 B]                                  
Scaricamento di:100 http://it.archive.ubuntu.com oneiric/restricted Translation-en [2229 B]                                 
Scaricamento di:101 http://it.archive.ubuntu.com oneiric/universe Translation-it [1672 kB]                                  
Scaricamento di:102 http://it.archive.ubuntu.com oneiric/universe Translation-en [3165 kB]                                  
Scaricamento di:103 http://it.archive.ubuntu.com oneiric-updates/main Translation-en [140 kB]                               
Scaricamento di:104 http://it.archive.ubuntu.com oneiric-updates/multiverse Translation-en [3524 B]                         
Scaricamento di:105 http://it.archive.ubuntu.com oneiric-updates/restricted Translation-en [508 B]                          
Scaricamento di:106 http://it.archive.ubuntu.com oneiric-updates/universe Translation-en [61,8 kB]                          
Scaricamento di:107 http://it.archive.ubuntu.com oneiric-backports/main Translation-en [2292 B]                             
Scaricamento di:108 http://it.archive.ubuntu.com oneiric-backports/multiverse Translation-en [14 B]                         
Scaricamento di:109 http://it.archive.ubuntu.com oneiric-backports/restricted Translation-en [14 B]                         
Scaricamento di:110 http://it.archive.ubuntu.com oneiric-backports/universe Translation-en [6707 B]                         
Recuperati 25,6 MB in 1min 34s (271 kB/s)                                                                                   
Lettura elenco dei pacchetti... Fatto


al sesto:
Codice: Seleziona tutto
sudo apt-get upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 cpp-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 g++-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 gcc-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 gcc-4.6-base : Rompe: gcc-4.6-base:i386 (!= 4.6.2-15) ma la versione 4.6.1-9ubuntu3 è installata
 gcc-4.6-base:i386 : Rompe: gcc-4.6-base (!= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 kdelibs5-plugins : Rompe: kdevelop (< 4:4.2) ma la versione 4:4.0.1-1 è installata
 kdevelop : Dipende: kdevplatform1-libs (>= 1.0.1) ma non è installabile
            Dipende: libqt4-webkit (>= 4:4.5.3) ma non è installato
            Dipende: libsublime1 (>= 1.0.1) ma non è installabile
            Dipende: kdevelop-data (>= 4:4.0.1-1) ma non è installato
            Dipende: lcov ma non è installato
 kdevelop-dev : Dipende: kdelibs5-dev ma non è installato
                Dipende: kdevplatform-dev ma non è installato
 libgcc1 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libgfortran3 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libgomp1 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libquadmath0 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libstdc++6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libstdc++6-4.6-dev : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
E: Dipendenze non trovate. Riprovare usando -f.


e infine al sesto:
Codice: Seleziona tutto
sudo apt-get -f install
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... non riuscita.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 cpp-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 g++-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 gcc-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 gcc-4.6-base : Rompe: gcc-4.6-base:i386 (!= 4.6.2-15) ma la versione 4.6.1-9ubuntu3 è installata
 gcc-4.6-base:i386 : Rompe: gcc-4.6-base (!= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 kdelibs5-plugins : Rompe: kdevelop (< 4:4.2) ma la versione 4:4.0.1-1 è installata
 kdevelop : Dipende: kdevplatform1-libs (>= 1.0.1) ma non è installabile
            Dipende: libqt4-webkit (>= 4:4.5.3) ma non è installato
            Dipende: libsublime1 (>= 1.0.1) ma non è installabile
            Dipende: kdevelop-data (>= 4:4.0.1-1) ma non è installato
            Dipende: lcov ma non è installato
 kdevelop-dev : Dipende: kdelibs5-dev ma non è installato
                Dipende: kdevplatform-dev ma non è installato
 libgcc1 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libgfortran3 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libgomp1 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libquadmath0 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libstdc++6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libstdc++6-4.6-dev : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
E: Errore, pkgProblemResolver::Resolve ha generato delle interruzioni. Questo potrebbe essere causato da pacchetti bloccati.
E: Impossibile correggere le dipendenze


Purtroppo non è cambiato nulla...
MasterDavid Non specificato
Prode Principiante
 
Messaggi: 57
Iscrizione: aprile 2010

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda Diabolik62 » lunedì 12 marzo 2012, 22:37

sudo apt-get clean
sudo apt-get autoremove
sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
Avatar utente
Diabolik62 Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15208
Iscrizione: dicembre 2009
Distribuzione: windows8.1 fedora20 heisenbug mate

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda MasterDavid » lunedì 12 marzo 2012, 22:42

Ti ringrazio sentitamente dell'aiuto diabolik62, ma sono al punto di partenza; ho sempre lo stesso errore dei pacchetti bloccati... Non so che cosa abbia combinato per fare un blocco simile...
MasterDavid Non specificato
Prode Principiante
 
Messaggi: 57
Iscrizione: aprile 2010

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda Diabolik62 » lunedì 12 marzo 2012, 22:46

posta le risposte lo stesso del terminale se ti va
Avatar utente
Diabolik62 Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15208
Iscrizione: dicembre 2009
Distribuzione: windows8.1 fedora20 heisenbug mate

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda MasterDavid » lunedì 12 marzo 2012, 22:49

ecco:
Codice: Seleziona tutto
sudo apt-get clean
masterdavid@Netbook-Davide:~$ sudo apt-get autoremove
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 cpp-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 g++-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 gcc-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 gcc-4.6-base : Rompe: gcc-4.6-base:i386 (!= 4.6.2-15) ma la versione 4.6.1-9ubuntu3 è installata
 gcc-4.6-base:i386 : Rompe: gcc-4.6-base (!= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 kdelibs5-plugins : Rompe: kdevelop (< 4:4.2) ma la versione 4:4.0.1-1 è installata
 kdevelop : Dipende: kdevplatform1-libs (>= 1.0.1) ma non è installabile
            Dipende: libqt4-webkit (>= 4:4.5.3) ma non è installato
            Dipende: libsublime1 (>= 1.0.1) ma non è installabile
            Dipende: kdevelop-data (>= 4:4.0.1-1) ma non è installato
            Dipende: lcov ma non è installato
 kdevelop-dev : Dipende: kdelibs5-dev ma non è installato
                Dipende: kdevplatform-dev ma non è installato
 libgcc1 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libgfortran3 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libgomp1 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libquadmath0 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libstdc++6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libstdc++6-4.6-dev : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
E: Dipendenze non trovate. Riprovare usando -f.
masterdavid@Netbook-Davide:~$ sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
Ign http://dl.google.com stable InRelease
Scaricamento di:1 http://dl.google.com stable Release.gpg [198 B]                                                           
Ign http://it.archive.ubuntu.com oneiric InRelease                                                                          
Scaricamento di:2 http://dl.google.com stable Release [1351 B]                                                              
Ign http://security.ubuntu.com oneiric-security InRelease                                                                   
Ign http://extras.ubuntu.com oneiric InRelease                                                                              
Ign http://ppa.launchpad.net oneiric InRelease                                                                              
Ign http://it.archive.ubuntu.com oneiric-updates InRelease                                                                  
Scaricamento di:3 http://dl.google.com stable/main amd64 Packages [1269 B]                                                  
Trovato http://security.ubuntu.com oneiric-security Release.gpg                                                             
Trovato http://ppa.launchpad.net oneiric Release.gpg                                                                        
Trovato http://extras.ubuntu.com oneiric Release.gpg                                                                        
Ign http://it.archive.ubuntu.com oneiric-backports InRelease                                                                
Ign http://deb.opera.com stable InRelease                                                                                   
Scaricamento di:4 http://dl.google.com stable/main i386 Packages [1256 B]                                                   
Ign http://dl.google.com stable/main TranslationIndex                                                                       
Trovato http://security.ubuntu.com oneiric-security Release                                                                 
Trovato http://extras.ubuntu.com oneiric Release                                                                            
Trovato http://ppa.launchpad.net oneiric Release                                                                            
Trovato http://it.archive.ubuntu.com oneiric Release.gpg                                                                    
Trovato http://deb.opera.com stable Release.gpg                                                                             
Trovato http://security.ubuntu.com oneiric-security/main Sources                                                            
Trovato http://it.archive.ubuntu.com oneiric-updates Release.gpg                                                            
Trovato http://extras.ubuntu.com oneiric/main Sources                                                                       
Trovato http://ppa.launchpad.net oneiric/main Sources                                                                       
Trovato http://deb.opera.com stable Release                                                                                 
Trovato http://security.ubuntu.com oneiric-security/restricted Sources                                                      
Trovato http://security.ubuntu.com oneiric-security/universe Sources                                                        
Trovato http://security.ubuntu.com oneiric-security/multiverse Sources                                                      
Trovato http://security.ubuntu.com oneiric-security/main amd64 Packages                                                     
Trovato http://security.ubuntu.com oneiric-security/restricted amd64 Packages                                               
Trovato http://extras.ubuntu.com oneiric/main amd64 Packages                                                                
Trovato http://extras.ubuntu.com oneiric/main i386 Packages                                                                 
Trovato http://ppa.launchpad.net oneiric/main amd64 Packages                                                                
Trovato http://ppa.launchpad.net oneiric/main i386 Packages                                                                 
Ign http://ppa.launchpad.net oneiric/main TranslationIndex                                                                  
Trovato http://it.archive.ubuntu.com oneiric-backports Release.gpg                                                          
Trovato http://security.ubuntu.com oneiric-security/universe amd64 Packages                                                 
Trovato http://security.ubuntu.com oneiric-security/multiverse amd64 Packages                                               
Trovato http://security.ubuntu.com oneiric-security/main i386 Packages                                                      
Trovato http://security.ubuntu.com oneiric-security/restricted i386 Packages                                                
Trovato http://security.ubuntu.com oneiric-security/universe i386 Packages                                                  
Trovato http://deb.opera.com stable/non-free amd64 Packages                                                                 
Ign http://extras.ubuntu.com oneiric/main TranslationIndex                                                                  
Ign http://dl.google.com stable/main Translation-it_IT                                                                      
Ign http://dl.google.com stable/main Translation-it                                                                         
Trovato http://it.archive.ubuntu.com oneiric Release                                                                        
Trovato http://security.ubuntu.com oneiric-security/multiverse i386 Packages                                                
Trovato http://security.ubuntu.com oneiric-security/main TranslationIndex                                                   
Trovato http://security.ubuntu.com oneiric-security/multiverse TranslationIndex                                             
Trovato http://security.ubuntu.com oneiric-security/restricted TranslationIndex                                             
Trovato http://security.ubuntu.com oneiric-security/universe TranslationIndex                                               
Ign http://dl.google.com stable/main Translation-en                                                                         
Trovato http://deb.opera.com stable/non-free i386 Packages                                                                  
Ign http://deb.opera.com stable/non-free TranslationIndex                                                                   
Trovato http://it.archive.ubuntu.com oneiric-updates Release                                                                
Trovato http://security.ubuntu.com oneiric-security/main Translation-en                                                     
Trovato http://it.archive.ubuntu.com oneiric-backports Release                                                              
Trovato http://it.archive.ubuntu.com oneiric/main Sources                                                                   
Trovato http://it.archive.ubuntu.com oneiric/restricted Sources                                                             
Trovato http://security.ubuntu.com oneiric-security/multiverse Translation-en                                               
Trovato http://security.ubuntu.com oneiric-security/restricted Translation-en                         
Trovato http://security.ubuntu.com oneiric-security/universe Translation-en                                                 
Trovato http://it.archive.ubuntu.com oneiric/universe Sources                                                               
Trovato http://it.archive.ubuntu.com oneiric/multiverse Sources                                                             
Ign http://ppa.launchpad.net oneiric/main Translation-it_IT                                                                 
Trovato http://it.archive.ubuntu.com oneiric/main amd64 Packages                                                            
Ign http://extras.ubuntu.com oneiric/main Translation-it_IT                                                                 
Ign http://ppa.launchpad.net oneiric/main Translation-it                                                                    
Trovato http://it.archive.ubuntu.com oneiric/restricted amd64 Packages                                
Ign http://extras.ubuntu.com oneiric/main Translation-it                                                                    
Ign http://ppa.launchpad.net oneiric/main Translation-en                                                                    
Trovato http://it.archive.ubuntu.com oneiric/universe amd64 Packages                                  
Ign http://extras.ubuntu.com oneiric/main Translation-en                                                   
Ign http://deb.opera.com stable/non-free Translation-it_IT                                                 
Trovato http://it.archive.ubuntu.com oneiric/multiverse amd64 Packages
Ign http://deb.opera.com stable/non-free Translation-it                           
Trovato http://it.archive.ubuntu.com oneiric/main i386 Packages                   
Ign http://deb.opera.com stable/non-free Translation-en                           
Trovato http://it.archive.ubuntu.com oneiric/restricted i386 Packages             
Trovato http://it.archive.ubuntu.com oneiric/universe i386 Packages
Trovato http://it.archive.ubuntu.com oneiric/multiverse i386 Packages
Trovato http://it.archive.ubuntu.com oneiric/main TranslationIndex
Trovato http://it.archive.ubuntu.com oneiric/multiverse TranslationIndex
Trovato http://it.archive.ubuntu.com oneiric/restricted TranslationIndex
Trovato http://it.archive.ubuntu.com oneiric/universe TranslationIndex
Trovato http://it.archive.ubuntu.com oneiric-updates/main Sources
Trovato http://it.archive.ubuntu.com oneiric-updates/restricted Sources
Trovato http://it.archive.ubuntu.com oneiric-updates/universe Sources
Trovato http://it.archive.ubuntu.com oneiric-updates/multiverse Sources
Trovato http://it.archive.ubuntu.com oneiric-updates/main amd64 Packages
Trovato http://it.archive.ubuntu.com oneiric-updates/restricted amd64 Packages
Trovato http://it.archive.ubuntu.com oneiric-updates/universe amd64 Packages
Trovato http://it.archive.ubuntu.com oneiric-updates/multiverse amd64 Packages
Trovato http://it.archive.ubuntu.com oneiric-updates/main i386 Packages
Trovato http://it.archive.ubuntu.com oneiric-updates/restricted i386 Packages
Trovato http://it.archive.ubuntu.com oneiric-updates/universe i386 Packages
Trovato http://it.archive.ubuntu.com oneiric-updates/multiverse i386 Packages
Trovato http://it.archive.ubuntu.com oneiric-updates/main TranslationIndex
Trovato http://it.archive.ubuntu.com oneiric-updates/multiverse TranslationIndex
Trovato http://it.archive.ubuntu.com oneiric-updates/restricted TranslationIndex
Trovato http://it.archive.ubuntu.com oneiric-updates/universe TranslationIndex
Trovato http://it.archive.ubuntu.com oneiric-backports/main Sources
Trovato http://it.archive.ubuntu.com oneiric-backports/restricted Sources
Trovato http://it.archive.ubuntu.com oneiric-backports/universe Sources
Trovato http://it.archive.ubuntu.com oneiric-backports/multiverse Sources
Trovato http://it.archive.ubuntu.com oneiric-backports/main amd64 Packages
Trovato http://it.archive.ubuntu.com oneiric-backports/restricted amd64 Packages
Trovato http://it.archive.ubuntu.com oneiric-backports/universe amd64 Packages
Trovato http://it.archive.ubuntu.com oneiric-backports/multiverse amd64 Packages                                            
Trovato http://it.archive.ubuntu.com oneiric-backports/main i386 Packages                                                   
Trovato http://it.archive.ubuntu.com oneiric-backports/restricted i386 Packages                                             
Trovato http://it.archive.ubuntu.com oneiric-backports/universe i386 Packages                                               
Trovato http://it.archive.ubuntu.com oneiric-backports/multiverse i386 Packages                                             
Trovato http://it.archive.ubuntu.com oneiric-backports/main TranslationIndex                                                
Trovato http://it.archive.ubuntu.com oneiric-backports/multiverse TranslationIndex                                          
Trovato http://it.archive.ubuntu.com oneiric-backports/restricted TranslationIndex                                          
Trovato http://it.archive.ubuntu.com oneiric-backports/universe TranslationIndex                                            
Trovato http://it.archive.ubuntu.com oneiric/main Translation-it                                                            
Trovato http://it.archive.ubuntu.com oneiric/main Translation-en                                                            
Trovato http://it.archive.ubuntu.com oneiric/multiverse Translation-it                                                      
Trovato http://it.archive.ubuntu.com oneiric/multiverse Translation-en                                                      
Trovato http://it.archive.ubuntu.com oneiric/restricted Translation-it                                                      
Trovato http://it.archive.ubuntu.com oneiric/restricted Translation-en                                                      
Trovato http://it.archive.ubuntu.com oneiric/universe Translation-it                                                        
Trovato http://it.archive.ubuntu.com oneiric/universe Translation-en                                                        
Trovato http://it.archive.ubuntu.com oneiric-updates/main Translation-en                                                    
Trovato http://it.archive.ubuntu.com oneiric-updates/multiverse Translation-en                                              
Trovato http://it.archive.ubuntu.com oneiric-updates/restricted Translation-en                                              
Trovato http://it.archive.ubuntu.com oneiric-updates/universe Translation-en                                                
Trovato http://it.archive.ubuntu.com oneiric-backports/main Translation-en                                                  
Trovato http://it.archive.ubuntu.com oneiric-backports/multiverse Translation-en                                            
Trovato http://it.archive.ubuntu.com oneiric-backports/restricted Translation-en                                            
Trovato http://it.archive.ubuntu.com oneiric-backports/universe Translation-en                                              
Recuperati 4074 B in 9s (409 B/s)                                                                                           
Lettura elenco dei pacchetti... Fatto
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 cpp-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 g++-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 gcc-4.6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 gcc-4.6-base : Rompe: gcc-4.6-base:i386 (!= 4.6.2-15) ma la versione 4.6.1-9ubuntu3 è installata
 gcc-4.6-base:i386 : Rompe: gcc-4.6-base (!= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 kdelibs5-plugins : Rompe: kdevelop (< 4:4.2) ma la versione 4:4.0.1-1 è installata
 kdevelop : Dipende: kdevplatform1-libs (>= 1.0.1) ma non è installabile
            Dipende: libqt4-webkit (>= 4:4.5.3) ma non è installato
            Dipende: libsublime1 (>= 1.0.1) ma non è installabile
            Dipende: kdevelop-data (>= 4:4.0.1-1) ma non è installato
            Dipende: lcov ma non è installato
 kdevelop-dev : Dipende: kdelibs5-dev ma non è installato
                Dipende: kdevplatform-dev ma non è installato
 libgcc1 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libgfortran3 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libgomp1 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libquadmath0 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libstdc++6 : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
 libstdc++6-4.6-dev : Dipende: gcc-4.6-base (= 4.6.1-9ubuntu3) ma la versione 4.6.2-15 è installata
E: Dipendenze non trovate. Riprovare usando -f.
MasterDavid Non specificato
Prode Principiante
 
Messaggi: 57
Iscrizione: aprile 2010

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda MasterDavid » sabato 7 aprile 2012, 21:08

Mah le ho provate davvero tutte ma non sono riuscito a sbloccare nulla...
Per non formattare, non c'è un modo per ripristinare kubuntu allo stato iniziale, o comunque in un punto precedente il danno (tipo ripristino configurazione di windows)?
Grazie mille
MasterDavid Non specificato
Prode Principiante
 
Messaggi: 57
Iscrizione: aprile 2010

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda MasterDavid » sabato 7 aprile 2012, 21:53

Oppure un comando per rimuovere forzatamente i pacchetti o per forzare la risoluzione delle dipendenze?
Ho provato con
Codice: Seleziona tutto
sudo dpkg --purge kdevelop

Beh, kdevelop con questo comando credo di averlo rimosso, dato che non figura più tra i pacchetti che creano problemi; è già un passo avanti!

Ma se provo lo stesso comando con un altro dei pacchetti bloccati ecco che succede.
Codice: Seleziona tutto
sudo dpkg --purge libgomp1
dpkg: problemi con le dipendenze impediscono la rimozione di libgomp1:
 inkscape dipende da libgomp1 (>= 4.2.1).
 enblend dipende da libgomp1 (>= 4.2.1).
 digikam dipende da libgomp1 (>= 4.2.1).
 ufraw-batch dipende da libgomp1 (>= 4.2.1).
 enfuse dipende da libgomp1 (>= 4.2.1).
 gcc-4.6 dipende da libgomp1 (>= 4.6.1-9ubuntu3), ma:
  Il pacchetto libgomp1 sta per essere rimosso.
 libmagickwand3 dipende da libgomp1 (>= 4.2.1).
 gettext dipende da libgomp1 (>= 4.2.1).
 libkdcraw20 dipende da libgomp1 (>= 4.2.1).
 kipi-plugins dipende da libgomp1 (>= 4.2.1).
 libmagickcore3 dipende da libgomp1 (>= 4.2.1).
 shotwell dipende da libgomp1 (>= 4.2.1).
dpkg: errore nell'elaborare libgomp1 (--purge):
 problemi con le dipendenze - rimozione non possibile
Si sono verificati degli errori nell'elaborazione:
 libgomp1


Non capisco proprio perchè non possa rimuoverlo... mi sembra assurdo che il sistema operativo non mi faccia rimuovere un pacchetto!
MasterDavid Non specificato
Prode Principiante
 
Messaggi: 57
Iscrizione: aprile 2010

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda TequilaMex » domenica 8 aprile 2012, 10:34

Codice: Seleziona tutto
sudo apt-get -s purge kdevelop


metti qui la risposta
Avatar utente
TequilaMex Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4511
Iscrizione: dicembre 2006

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda nibalart » lunedì 9 aprile 2012, 0:19

Ciao Tequila,
ho lo stesso problema .
ti posto quello che leggo da terminale dopo aver dato la tua istruzione:

Codice: Seleziona tutto
okonkwo@okonkwo:~$ sudo apt-get -s purge kdevelop
[sudo] password for okonkwo:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Il pacchetto kdevelop non è installato e quindi non è stato rimosso
0 aggiornati, 0 installati, 0 da rimuovere e 7 non aggiornati.
4 non completamente installati o rimossi.
Conf libgtk2.0-cil (2.12.10-2ubuntu1 Ubuntu:11.10/oneiric [i386])
Conf liblaunchpad-integration1.0-cil (0.1.54 Ubuntu:11.10/oneiric [i386])
Conf libmono-addins-gui0.2-cil (0.6.1-2ubuntu1 Ubuntu:11.10/oneiric [all])
Conf gbrainy (2.06-1ubuntu0.1 Ubuntu:11.10/oneiric-updates [all])
okonkwo@okonkwo:~$



spero di riuscire anche io a non formattare.
grazie per l'aiuto.
Nibalart
nibalart Non specificato
Prode Principiante
 
Messaggi: 56
Iscrizione: maggio 2010

Re: Impossibile aggiornare a causa di pacchetti bloccati

Messaggioda gyanny » lunedì 9 aprile 2012, 10:34

nibalart ha scritto:Ciao Tequila,
ho lo stesso problema .
ti posto quello che leggo da terminale dopo aver dato la tua istruzione:

Codice: Seleziona tutto
okonkwo@okonkwo:~$ sudo apt-get -s purge kdevelop
[sudo] password for okonkwo:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Il pacchetto kdevelop non è installato e quindi non è stato rimosso
0 aggiornati, 0 installati, 0 da rimuovere e 7 non aggiornati.
4 non completamente installati o rimossi.
Conf libgtk2.0-cil (2.12.10-2ubuntu1 Ubuntu:11.10/oneiric [i386])
Conf liblaunchpad-integration1.0-cil (0.1.54 Ubuntu:11.10/oneiric [i386])
Conf libmono-addins-gui0.2-cil (0.6.1-2ubuntu1 Ubuntu:11.10/oneiric [all])
Conf gbrainy (2.06-1ubuntu0.1 Ubuntu:11.10/oneiric-updates [all])
okonkwo@okonkwo:~$



spero di riuscire anche io a non formattare.
grazie per l'aiuto.
Nibalart

in sequenza da terminale
Codice: Seleziona tutto
sudo apt-get --purge remove libgtk2.0-cil liblaunchpad-integration1.0-cil libmono-addins-gui0.2-cil gbrainy

Codice: Seleziona tutto
sudo apt-get update

Codice: Seleziona tutto
sudo apt-get --purge autoremove

Codice: Seleziona tutto
sudo apt-get autoclean

Codice: Seleziona tutto
sudo apt-get clean

Codice: Seleziona tutto
sudo apt-get -f install

poi resta da capire perchè ti si è ripresentato un problema che avevi già risolto.
gyanny Maschile
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1894
Iscrizione: febbraio 2009
Località: Brianza
Distribuzione: Kubuntu 13.04
Desktop: KDE 4.10.2

Successiva

Torna a KDE

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 2 ospiti