Notizia:
  • Rilasciata Ubuntu 14.04 LTS Trusty Tahr. Per ottenerla, visitate questa pagina oppure visualizzate la dimostrazione.
  • È uscito il numero 26 della Newsletter italiana di Ubuntu. Lo trovate a questo indirizzo.
  • È uscito il numero 80 di Full Circle Magazine in italiano. Lo trovate a questo indirizzo.

ubuntu mac e masochismo?

Problematiche specifiche di hardware e software su un sistema PowerPC (Macintosh G3, G4, G5, iBook, PowerBook e PS3) e ARM (smartphone, tablet, ecc.).

ubuntu mac e masochismo?

Messaggioda kaliffo » martedì 24 gennaio 2012, 0:19

allora buona sera a tutti,
spero che qualcuno mi possa aiutare nel mio "piccolo" problemino. essendo io un tipo masochista non mi sono limitata ad ubuntu su un ppc, per semplificarmi la vita o optato per: ubuntu mini, su ppc, da usb, con fluxbox.
ora dopo varie peripezie sono riuscita a far funzionare il wireless , l'indicatore della batteria e la scheda audio... e qui casca l'asino, ubuntu mi parte dal prompt e se cerco la scheda audio da li non ho nessun problema,le canzoni vengono riprodotte alla perfezione, ma se mi azzardo a fare la stessa cosa all'interno di fluxbox(quindi dell'ambiente grafico), magia delle magie, non ho più una scheda audio. il bello e che se lancio alsamixer la vede, mentre con aplay -l assolutamente niente. ho installato anche gnome-volume-control e come aplay non sa che esiste.
fatto curioso e che se do aplay dal prompt e dopo entro su fluxbox, gnome la vede ,aplay no e se provo ad ascoltare una canzone si blocca il riproduttore e lo devo killare per toglierlo di torno.
mi scuso se ci sono molti errori, ma a causa del mio thema a volte le caselle di testo in cui scrivere le vedo completamenmte nere(compresi i font), quindi tendenzialmente non ho idea di cosa sto scrivendo a meno che non evidenzio tutto col mouse.
visto che ci sono, avrei un altro problemino, quando esco dall'ambiente grafico anzichè vedere delle lettere vedo tanti" _ ___ --___" non ho idea come risolverlo suggerimenti? comunque questo è un problema secondario.
se ve lo state chiedendo ho un ibook g4
grazie in anticipo
kaliffo Non specificato
Prode Principiante
 
Messaggi: 55
Iscrizione: gennaio 2012

Re: ubuntu mac e masochismo?

Messaggioda kaliffo » martedì 24 gennaio 2012, 2:14

sorpresa, funziona.
paradossalmente ho scoperto che era wmbatppc che gli dava problemi, infatti reinstallato la copia di backup e seguendo questa guida http://fedorasolved.org/Members/fenris0 ... orkarounds ho fatto funzionare l'audio che ha cessato subito dopo aver installato wmbatppc(ho anche riavviato per verifica e niente non andava). credo gli creasse problemi. quello che non ho capito e perchè adesso funzioni nonostante wmbatppc sia installato.che sia perchè ho cambiato l'ordine di installazione?
comunque il problema all'uscita di fluxbox persiste, suggerimenti su come posso cercare di risolverlo?
kaliffo Non specificato
Prode Principiante
 
Messaggi: 55
Iscrizione: gennaio 2012

Re: ubuntu mac e masochismo?

Messaggioda kaliffo » giovedì 16 febbraio 2012, 0:07

nessuno mi può spiegare perche la shell tty la vedo a lineette?
kaliffo Non specificato
Prode Principiante
 
Messaggi: 55
Iscrizione: gennaio 2012

Re: ubuntu mac e masochismo?

Messaggioda pierba » giovedì 16 febbraio 2012, 10:07

Non ho capito, le lineette le vedi quando spegni?

Potrebbe essere legato alla scheda video che probabilmente non e` riconosciuta al meglio da xserver.

Se hai una ati radeon, accertati che sia installato xserver-xorg-video-radeon; ma potrebbe non risolvere: purtroppo si tratta di un'architettura abbastanza obsoleta.

Succede anche quando lo utilizzi?

Che shell usi?

ciao
Pietro pagina personale - Avete domande sul forum? Leggendo le FAQ: potreste trovare la risposta.
La conoscenza deve essere collettiva, quindi, come da regolamento (Sez. II punto 15) i messaggi personali contententi richieste di assistenza tecnica verranno ignorati.
Avatar utente
pierba Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14531
Iscrizione: febbraio 2005

Re: ubuntu mac e masochismo?

Messaggioda kaliffo » giovedì 16 febbraio 2012, 22:42

è ubuntu mini 11.04 su cui ho messo fluxbox, il problema è appunto quando accedo a fluxbox,che non parte in automatico all'avvio,se poi lo chiudo tornando al prompt base, vedo solo tante lineette
kaliffo Non specificato
Prode Principiante
 
Messaggi: 55
Iscrizione: gennaio 2012

Re: ubuntu mac e masochismo?

Messaggioda pierba » venerdì 17 febbraio 2012, 9:10

Per farlo avviare in automatico, devi, nella pagina di login, andare su "seleziona sessione", o qualcosa di simile, nella barra in basso, e spuntare qualcosa tipo sessione fluxbox.

Fatto questo la prendera` come impostazione predefinita e si avviera` con fluxbox. Vado a ricordo, qualche imprecisione ci potrebbe essere.

Per le lineette; ricordo la loro presenza, ma non mi creavano problemi e non ho affrontato il fenomeno: non utilizzo piu` l'ibook da quattro anni.

ciao
Pietro pagina personale - Avete domande sul forum? Leggendo le FAQ: potreste trovare la risposta.
La conoscenza deve essere collettiva, quindi, come da regolamento (Sez. II punto 15) i messaggi personali contententi richieste di assistenza tecnica verranno ignorati.
Avatar utente
pierba Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14531
Iscrizione: febbraio 2005

Re: ubuntu mac e masochismo?

Messaggioda kaliffo » venerdì 17 febbraio 2012, 22:57

non mi interessa che si avvii in automatico, ho installato fluxbox solo perchè alle volte mi trovo a litigare con la configurazione wireless o per guardare foto o altro, il fatto e che se posso evito di entrarci, ma una volta che sono dentro non posso uscirne a causa di queste lineette rompi ... prompt, quello che vorrei fare io è: entro in fluxbox vedo foto e torno al mio prompt tutto nero e tutto testo, uso più links che firefox per navigare su internet.,insomma per mel'ambiente grafico  è come l'aspirina... al bisogno.
kaliffo Non specificato
Prode Principiante
 
Messaggi: 55
Iscrizione: gennaio 2012

Re: ubuntu mac e masochismo?

Messaggioda kaliffo » domenica 6 maggio 2012, 20:51

non sono riuscita a caricare l'immagine quindi metto il link, scusate la qualita ;P
http://imageshack.us/photo/my-images/259/image1ftk.jpg/
questa è la mia condizione prima di far partire l'ambiente gravico

http://imageshack.us/photo/my-images/854/imagefvki.jpg/
questa è la mia condizione dopo aver caricato fluxbox ed essere tornato alla shell tty1(crtl+alt+1 per capirci)

potete aiutarmi a capire dove sta il problema?
kaliffo Non specificato
Prode Principiante
 
Messaggi: 55
Iscrizione: gennaio 2012

Re: ubuntu mac e masochismo?

Messaggioda pierba » martedì 8 maggio 2012, 13:21

Quale gestore grafico hai installato, per l'avvio, intendo: gdm, lightdm, slim o altro?

Assieme a fluxbox hai installato anche Eterm? Tempo fa lo richiedeva.

Che comando dai per avviare fluxbox?

ciao
Pietro pagina personale - Avete domande sul forum? Leggendo le FAQ: potreste trovare la risposta.
La conoscenza deve essere collettiva, quindi, come da regolamento (Sez. II punto 15) i messaggi personali contententi richieste di assistenza tecnica verranno ignorati.
Avatar utente
pierba Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14531
Iscrizione: febbraio 2005

Re: ubuntu mac e masochismo?

Messaggioda kaliffo » martedì 8 maggio 2012, 22:13

Credo xdm, ma non ci metterei la mano sul fuoco.
No, eterm lo installato in un secondo momento e già prima di allora mi dava problemi, cmq eterm l'ho poi disinstallat, non mi piaceva .
Per avviare fluxbox do il comando startx da tty1.
kaliffo Non specificato
Prode Principiante
 
Messaggi: 55
Iscrizione: gennaio 2012

Re: ubuntu mac e masochismo?

Messaggioda pierba » mercoledì 9 maggio 2012, 7:26

Prova con
Codice: Seleziona tutto
sudo /etc/init.d/xdm start


In caso ti risponda che e` gia` attivo dai prima stop.

Vediamo come si comporta in questo caso.

ciao
Pietro pagina personale - Avete domande sul forum? Leggendo le FAQ: potreste trovare la risposta.
La conoscenza deve essere collettiva, quindi, come da regolamento (Sez. II punto 15) i messaggi personali contententi richieste di assistenza tecnica verranno ignorati.
Avatar utente
pierba Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14531
Iscrizione: febbraio 2005

Re: ubuntu mac e masochismo?

Messaggioda kaliffo » mercoledì 9 maggio 2012, 10:50

ma lo devo dare prima di entrare in fluxbox, quindi prima di dare il comando statx, oppure dopo da xtem?
kaliffo Non specificato
Prode Principiante
 
Messaggi: 55
Iscrizione: gennaio 2012

Re: ubuntu mac e masochismo?

Messaggioda pierba » mercoledì 9 maggio 2012, 13:02

Dalla consolle per avviare il sistema grafico, che comprende anche fluxbox.

ciao
Pietro pagina personale - Avete domande sul forum? Leggendo le FAQ: potreste trovare la risposta.
La conoscenza deve essere collettiva, quindi, come da regolamento (Sez. II punto 15) i messaggi personali contententi richieste di assistenza tecnica verranno ignorati.
Avatar utente
pierba Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14531
Iscrizione: febbraio 2005

Re: ubuntu mac e masochismo?

Messaggioda kaliffo » mercoledì 9 maggio 2012, 15:58

prima, dopo, manca solo durante, la risposta è sempre la stessa

sudo: /etc/init.d/xdm: command not found

solo per curiosità ho provato anche con gdm e kdm, ma con gli stessi risultati.
il fatto che fluxbox sia sotto la cartella /etc/X11 può aiutare?
kaliffo Non specificato
Prode Principiante
 
Messaggi: 55
Iscrizione: gennaio 2012

Re: ubuntu mac e masochismo?

Messaggioda pierba » mercoledì 9 maggio 2012, 17:04

Questo perche` hai un altro gestore grafico; controlla in /etc/ini.d se hai gdm o lightdm o slim o kdm.

In caso non ne trovassi nessuno, devi installarne uno; personalmente suggerisco lightdm che e` abbastanza leggero; in alternativa non riuscira` mai ad avviare un ambiente grafico che non c'e`. Per questo non ti funziona statx.

ciao
Pietro pagina personale - Avete domande sul forum? Leggendo le FAQ: potreste trovare la risposta.
La conoscenza deve essere collettiva, quindi, come da regolamento (Sez. II punto 15) i messaggi personali contententi richieste di assistenza tecnica verranno ignorati.
Avatar utente
pierba Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14531
Iscrizione: febbraio 2005

Re: ubuntu mac e masochismo?

Messaggioda kaliffo » mercoledì 9 maggio 2012, 21:31

No, non ci siamo capiti.
Startx funziona perfettamente.
Il problema è quando voglio chiudere l'ambiente grafico e tornare al solo testo che mi da problemi.
prima di avviare startx vedo la http://imageshack.us/photo/my-images/259/image1ftk.jpg/
una volta chiuso fluxbox quello che vedo è http://imageshack.us/photo/my-images/854/imagefvki.jpg/
il mio sistema è quasi tutto da linea di comando, ma se voglio aprire qualcosa di diverso mi tocca entrare in fluxbox, solo che poi non ne posso uscire. e vorrei capire cosa va storto, o almeno dove iniziare a cercare.

se può servire ho notato che se uso airodump e poi lo fermo, il cursore lampeggiante in quel terminale scompare, forse dipende dallo stesso problema.
kaliffo Non specificato
Prode Principiante
 
Messaggi: 55
Iscrizione: gennaio 2012

Re: ubuntu mac e masochismo?

Messaggioda Stealth » mercoledì 9 maggio 2012, 22:02

Dovresti sempre dirci quale servizio trovi, tra quelli indicati da pierba, in /etc/init.d. Nel frattempo facciamo un'altra prova....con la grafica avviata prova a schiacciare ctrl+alt+F2 e dovresti trovarti in una shell dove puoi loggarti e fare tutto. Per uscire e tornare alla grafica usa ctrl+alt+F7
ciao
Non nascondiamo le soluzioni tecniche nei messaggi personali, renderemmo inutile il forum. Non risponderò ai messaggi privati che chiedono assistenza. Per iniziare a orientarsi ci sono le Le FAQ del Forum.
Gianni
Avatar utente
Stealth Maschile
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15101
Iscrizione: gennaio 2006
Distribuzione: Ubuntu 12.04.1 LTS
Desktop: Unity

Re: ubuntu mac e masochismo?

Messaggioda kaliffo » giovedì 10 maggio 2012, 22:15

qui il contenuto di /etc/init.d

alsa-restore dmesg networking procps single umountfs
alsa-store dns-clean network-interface pulseaudio skeleton umountnfs.sh
anacron failsafe-x network-interface-security rc stop-bootlogd umountroot
apparmor halt ondemand rc.local stop-bootlogd-single unattended-upgrades
apport hostname pbbuttonsd rcS sudo urandom
atd hwclock plymouth README udev vsftpd
bitlbee hwclock-save plymouth-log reboot udev-fallback-graphics wicd
bootlogd irqbalance plymouth-splash rsync udev-finish x11-common
console-setup killprocs plymouth-stop rsyslog udevmonitor
cron module-init-tools plymouth-upstart-bridge sendsigs udevtrigger
dbus mouseemu pppd-dns setvtrgb ufw

il problema sussiste su tutte le tty dalla 1 alla 6
kaliffo Non specificato
Prode Principiante
 
Messaggi: 55
Iscrizione: gennaio 2012

Re: ubuntu mac e masochismo?

Messaggioda pierba » venerdì 11 maggio 2012, 11:25

Devi installare un gestore grafico, a scelta tra gdm, lightdm, slim, kdm; come affermavo nella mia precedente risposta.

Per curiosita` come avvii fluxbox?
E come ne esci?

ciao
Pietro pagina personale - Avete domande sul forum? Leggendo le FAQ: potreste trovare la risposta.
La conoscenza deve essere collettiva, quindi, come da regolamento (Sez. II punto 15) i messaggi personali contententi richieste di assistenza tecnica verranno ignorati.
Avatar utente
pierba Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14531
Iscrizione: febbraio 2005

Re: ubuntu mac e masochismo?

Messaggioda kaliffo » venerdì 11 maggio 2012, 21:29

per quel poco di lunix che conosco mi pare che un gestore grafico ci sia, altrimenti fluxbox non partirebbe,ma se voi dite che non c'è, mi fido.
quello che faccio:
1- avvio il pc, scelgo di avviare linux(aspetto 4 minuti e 10 secondi a causa di wlan0 cmq..)
2- mi si avvia tty1 chiede nome e passoword che io inserisco, mi da kaliffo@ubuntu:~$ ,
3- io inserisco startx e 2 secondi dopo sono qui http://imageshack.us/photo/my-images/593/imageydl.jpg/, per uscirne ... non ne esco. visto che non posso tornare alle tty, semplicemente apro un terminale e digito kaliffo@ubuntu:~$sudo halt e puf il mac si spegne.
lo so che può sembrare che alcune cose funzionino strane, o che funzionino anche quando non dovrebbero, ma un mio amico dice che io sono in grado di friggere un pc anche solo guardandolo, è una volta ho scritto un programma che funzionava col copia incolla(copiavo e incollavo senza modificarla sempre la stessa riga, si! funzionava).quindi che un mac funzioni come dovrebbe anche senza un pezzo base nel mio case è normalissimo.
kaliffo Non specificato
Prode Principiante
 
Messaggi: 55
Iscrizione: gennaio 2012

Successiva

Torna a PowerPC e ARM

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 2 ospiti