Olicard 145 TIM e ubuntu 11.04

Networking, configurazione della connessione, periferiche e condivisione di rete, ecc.

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda Sava » lunedì 9 aprile 2012, 22:01

...tutto come prima...
abbiamo un rapporto di successo di connessione molto basso.
:'(
Sava Non specificato
Prode Principiante
 
Messaggi: 84
Iscrizione: marzo 2012

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda supercar » lunedì 9 aprile 2012, 22:22

per la olicard 100
bisogna dare questo comando ogni volta che si inserisce la chiavetta avendo cura di aspettare una ventina di secondi
Codice: Seleziona tutto
eject /dev/sr1; sleep 5; sudo modprobe usbserial vendor=0x0b3c product=0xc000; 

sostituite questo /dev/sr1 con /dev/sr0 se usate un netbook

in seguito editate il file
Codice: Seleziona tutto
sudo gedit /etc/wvdial.conf

con questo semplice script eliminando prima il contenuto
Codice: Seleziona tutto
[Dialer Defaults]
Modem = /dev/ttyUSB0
ISDN = off
Modem Type = Analog Modem
Baud = 921600
Init1 = ATZ
Init2 = AT+CGDCONT=1,"IP","ibox.tim.it"
Phone = *99#
Dial Command = ATDT
 Dial Attempts = 1
Ask Password = off
Username = " "
Password = " "
Auto Reconnect = off
Abort on Busy = off
Carrier Check = on
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = on
Idle Seconds = 0
Auto DNS = on

ELIMINARE IL PIN ASSOLUTAMENTE altrimenti wvdial potrebbbe non funzionare

per la olicard 145 il sistema è simile se non altro si dovrebbe cambiare il comando sudo modprobe usbserial vendor=0x0b3c product=0xc000; con i codici identificativi dall'hardware
scusate l'intrusione
PS:scordatevi Networkmanager con queste orrende chiavette
il mio blog http://biagiosupercar.wordpress.com/

se fai del bene scordati, se fai del male pensaci
Avatar utente
supercar Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1115
Iscrizione: settembre 2008
Località: sicilia
Distribuzione: ubuntu 10.04 + 12.04 i686

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda Sava » martedì 10 aprile 2012, 0:11

ciao ma a perchè a me dice
impossibile trovare dev/sr0 (uso un netbook)

Ad ogni modo bypassando il primo comando al lancio di wdial dice che non è in grado di aprire un file ppp che cerca dei permessi dentro il .conf e dopo un po timed out ecc ecc
Ultima modifica di Sava il martedì 10 aprile 2012, 0:21, modificato 1 volta in totale.
Sava Non specificato
Prode Principiante
 
Messaggi: 84
Iscrizione: marzo 2012

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda supercar » martedì 10 aprile 2012, 2:13

Sava ha scritto:ciao ma a perchè a me dice
impossibile trovare dev/sr0 (uso un netbook)

Ad ogni modo bypassando il primo comando al lancio di wdial dice che non è in grado di aprire un file ppp che cerca dei permessi dentro il .conf e dopo un po timed out ecc ecc

va bè lascia /dev/sr1
per connetterti dai
Codice: Seleziona tutto
sudo wvdial

invece di
Codice: Seleziona tutto
wvdial

inoltre posta il log di errore che ti da wvdial e già che ci sei installa usb-modeswitch casomai non fosse presente
Codice: Seleziona tutto
sudo apt-get install usb-modeswitch

ed elimina il pin usando un cellulare
Ultima modifica di supercar il martedì 10 aprile 2012, 2:16, modificato 1 volta in totale.
il mio blog http://biagiosupercar.wordpress.com/

se fai del bene scordati, se fai del male pensaci
Avatar utente
supercar Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1115
Iscrizione: settembre 2008
Località: sicilia
Distribuzione: ubuntu 10.04 + 12.04 i686

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda Sava » martedì 10 aprile 2012, 11:56

L'errore lo dà anche con sr1

:~$ eject /dev/sr1; sleep 5; sudo modprobe usbserial vendor=0x0b3c product=0xc000;
eject: impossibile trovare o aprire il dispositivo "/dev/sr1"

e questo è il risultato di sudo wvdial
--> WvDial: Internet dialer version 1.61
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: AT+CGDCONT=1,"IP","ibox.tim.it"
AT+CGDCONT=1,"IP","ibox.tim.it"
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
ERROR
--> Invalid dial command.
--> Disconnecting at Tue Apr 10 10:49:02 2012
Sava Non specificato
Prode Principiante
 
Messaggi: 84
Iscrizione: marzo 2012

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda supercar » martedì 10 aprile 2012, 19:58

da terminale
Codice: Seleziona tutto
sudo gedit /etc/wvdial.conf

appena si apre vai alla riga
Codice: Seleziona tutto
Phone = *99#

e sostituisci con Phone = *99***#
salva, chiudi e ridai il comando
Codice: Seleziona tutto
sudo wvdial

(posta il risultato)
visto che lo script è per la TIM spero tu stia usando una scheda TIM  ;D
inoltre stiamo parlando di chiavetta olicard 100 e non 145 altrimenti c'è da modificare  sudo modprobe usbserial vendor=0x0b3c product=0xc000;

per la olicard 145 c'è questa ottima guida basta provare a seguirla, http://perfab.wordpress.com/2011/01/04/ ... -e-ubuntu/
Ultima modifica di supercar il martedì 10 aprile 2012, 20:10, modificato 1 volta in totale.
il mio blog http://biagiosupercar.wordpress.com/

se fai del bene scordati, se fai del male pensaci
Avatar utente
supercar Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1115
Iscrizione: settembre 2008
Località: sicilia
Distribuzione: ubuntu 10.04 + 12.04 i686

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda Sava » martedì 10 aprile 2012, 22:59

Si si uso la TIM ed è una 100  :)

ti posto il risultato
sava@sava-AOA150:~$ sudo gedit /etc/wvdial.conf

(gedit:2079): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Creazione del file "/root/.local/share/recently-used.xbel.FP5OCW" non riuscita: File o directory non esistente

(gedit:2079): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: File o directory non esistente

(gedit:2079): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Creazione del file "/root/.local/share/recently-used.xbel.VT8HCW" non riuscita: File o directory non esistente

(gedit:2079): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: File o directory non esistente

(gedit:2079): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Creazione del file "/root/.local/share/recently-used.xbel.H3YQCW" non riuscita: File o directory non esistente

(gedit:2079): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: File o directory non esistente

sava@sava-AOA150:~$ sudo wvdial

--> WvDial: Internet dialer version 1.61
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: AT+CGDCONT=1,"IP","ibox.tim.it"
AT+CGDCONT=1,"IP","ibox.tim.it"
OK
--> Modem initialized.
--> Sending: ATDT*99***#
--> Waiting for carrier.
--> Sending: ATDT*99***#
--> Waiting for carrier.
--> Timed out while dialing.  Trying again.

le ultime tre righe le ripete all'infinito.

Non capisco cosa sbaglio xkè ho inserito un'altra chiavetta creato la connessione con la wind e tutto funziona a meraviglia. E' proprio la chiavetta mia che rompe le scatole. Che nervoso! ::)
Sava Non specificato
Prode Principiante
 
Messaggi: 84
Iscrizione: marzo 2012

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda supercar » martedì 10 aprile 2012, 23:33

non stai sbagliando quel risultato dimostra che la chiavetta viene vista, ma, semplicemente non ti da la linea
non vorrei che l'offerta non si attiva o manchi il credito forse è meglio verificare con TIM

fai la prova del nove... metti la scheda Wind nella olicard 100 poi cambia il file
Codice: Seleziona tutto
sudo gedit /etc/wvdial.conf

alla riga
Codice: Seleziona tutto
AT+CGDCONT=1,"IP","ibox.tim.it"

sostituisci con
Codice: Seleziona tutto
AT+CGDCONT=1,"IP","internet.wind"

eventualmente prova a modificare il numero di telefono *99***#  con *99# come prima e viceversa
salvi e chiudi e provi ad avviare con sudo wvdial
se si connette con Wind vuol dire che Tim per qualche motivo non ti da la linea
posta sempre i risultati

a connessione stabilita il log del terminale dovrebbe finire con dei numeri (non chiudere il terminale e prova a navigare)
per disconnetterti devi dare dentro il terminale CTRL (lato destro tastiera)+ C
il mio blog http://biagiosupercar.wordpress.com/

se fai del bene scordati, se fai del male pensaci
Avatar utente
supercar Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1115
Iscrizione: settembre 2008
Località: sicilia
Distribuzione: ubuntu 10.04 + 12.04 i686

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda Sava » martedì 10 aprile 2012, 23:39

il fatto è che ho windows installato insieme a ubuntu e da windows funziona tutto bene, quindi escludo problemi di linea o di credito.
Sava Non specificato
Prode Principiante
 
Messaggi: 84
Iscrizione: marzo 2012

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda supercar » martedì 10 aprile 2012, 23:47

eppure non è un problema di riconoscimento, quell'errore dipende dal modem remoto di TIM
aspetta che la chiavetta dia il colore verde prima di lanciare wvdial , io l'ho usata per mesi e andava così, anche se
prima di farsi connettere impiegava un pò di tempo per passare dalla lucina rossa a quella blu ed il numero di telefono
è sempre stato *99#
il mio blog http://biagiosupercar.wordpress.com/

se fai del bene scordati, se fai del male pensaci
Avatar utente
supercar Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1115
Iscrizione: settembre 2008
Località: sicilia
Distribuzione: ubuntu 10.04 + 12.04 i686

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda Sava » martedì 10 aprile 2012, 23:57

ok proverò. grazie mille!
Sava Non specificato
Prode Principiante
 
Messaggi: 84
Iscrizione: marzo 2012

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda Sava » mercoledì 11 aprile 2012, 13:11

forse la soluzione migliore è cambiare chiavetta...
Sava Non specificato
Prode Principiante
 
Messaggi: 84
Iscrizione: marzo 2012

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda supercar » mercoledì 11 aprile 2012, 21:59

Sava ha scritto:forse la soluzione migliore è cambiare chiavetta...

posta il log
il mio blog http://biagiosupercar.wordpress.com/

se fai del bene scordati, se fai del male pensaci
Avatar utente
supercar Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1115
Iscrizione: settembre 2008
Località: sicilia
Distribuzione: ubuntu 10.04 + 12.04 i686

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda Sava » mercoledì 11 aprile 2012, 22:32

Prima ero connesso con wvdial.
mha...
Poi mentre ti scrivevo questo messaggio si è disconnesso al che ho ridato sudo wvdial e il log è stato
--> WvDial: Internet dialer version 1.61

--> Cannot open /dev/ttyUSB0: Device or resource busy

--> Cannot open /dev/ttyUSB0: Device or resource busy

--> Cannot open /dev/ttyUSB0: Device or resource busy

Ho inserito l'altra chiavetta (quella che di solito non dà problemi) e non la legge più!

Ad ogni modo il log precedente è stato:
ava@sava-AOA150:~$ sudo wvdial
--> WvDial: Internet dialer version 1.61
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: AT+CGDCONT=1,"IP","ibox.tim.it"
AT+CGDCONT=1,"IP","ibox.tim.it"
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
--> Sending: ATDT*99#
--> Waiting for carrier.
-> Timed out while dialing.  Trying again.

Ora ho riavviato ho messo la chiavetta che non dà problemi e funziona perfettamente
Ultima modifica di Sava il mercoledì 11 aprile 2012, 22:35, modificato 1 volta in totale.
Sava Non specificato
Prode Principiante
 
Messaggi: 84
Iscrizione: marzo 2012

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda supercar » giovedì 12 aprile 2012, 1:23

installa modemmanager e ozerocdoff da gestore pacchetti

ricordati che appena parte la connessione devi navigare sempre con il terminale aperto , perchè se chiudi cade la connessione
altra regola d'oro è dare
Codice: Seleziona tutto
sudo modprobe usbserial vendor=0x0b3c product=0xc000;
prima di connetterti  (yes)

quindi salvati quel comando da qualche parte, magari sulla scrivania gli dai i permessi per l'esecuzione come programma ed ogni volta che devi connetterti lo avvii, poi dai
Codice: Seleziona tutto
sudo wvdial
e navighi senza chiudere il terminale
per disconnettere punta il mouse dentro la finestra del terminale premi CTRL (lato destro tastiera)+C
il mio blog http://biagiosupercar.wordpress.com/

se fai del bene scordati, se fai del male pensaci
Avatar utente
supercar Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1115
Iscrizione: settembre 2008
Località: sicilia
Distribuzione: ubuntu 10.04 + 12.04 i686

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda Sava » giovedì 12 aprile 2012, 23:13

Io credo si possa mettere risolto  (good) (good) (good)
con wvdial dando prima il comando che mi hai scritto nel post precedente.
Sono molto contento e soprattutto grazie a tutti quanti soprattutto a supercar.
(good)
Sava Non specificato
Prode Principiante
 
Messaggi: 84
Iscrizione: marzo 2012

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda supercar » giovedì 12 aprile 2012, 23:24

Sava ha scritto:Io credo si possa mettere risolto  (good) (good) (good)
con wvdial dando prima il comando che mi hai scritto nel post precedente.
Sono molto contento e soprattutto grazie a tutti quanti soprattutto a supercar.
(good)

sia la olicard 100 che la 145 sono orribili su ubuntu , io ho usato la oli 100 per mesi e non e mai partita con NetworkManager... ogni volta prima il comando di sblocco riconoscimento e poi wvdial...

ho potuto aiutarti perchè ci avevo già sbattuto la testa e tutt'ora ogni tanto ne faccio uso
(mi passeresti il log della connessione?) pura curiosità  ;D
metti risolto così faciliterai gli altri nella ricerca
il mio blog http://biagiosupercar.wordpress.com/

se fai del bene scordati, se fai del male pensaci
Avatar utente
supercar Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1115
Iscrizione: settembre 2008
Località: sicilia
Distribuzione: ubuntu 10.04 + 12.04 i686

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda Sava » venerdì 13 aprile 2012, 9:59

sono molto contento che si sia risolto tutto per il meglio
metto risolto anche se la discussione non l'ho aperta io?

--> WvDial: Internet dialer version 1.61
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: AT+CGDCONT=1,"IP","ibox.tim.it"
AT+CGDCONT=1,"IP","ibox.tim.it"
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
CONNECT 7200000
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Fri Apr 13 09:49:33 2012
--> Pid of pppd: 1997
--> Using interface ppp0
--> local  IP address 2.197.92.176
--> remote IP address 10.64.64.64
--> primary  DNS address 213.230.130.222
--> secondary DNS address 217.200.200.42
Sava Non specificato
Prode Principiante
 
Messaggi: 84
Iscrizione: marzo 2012

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda supercar » venerdì 13 aprile 2012, 15:04

non sono sicuro , ma mi sembra che il titolo possa cambiarlo solo l'autore
il mio blog http://biagiosupercar.wordpress.com/

se fai del bene scordati, se fai del male pensaci
Avatar utente
supercar Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1115
Iscrizione: settembre 2008
Località: sicilia
Distribuzione: ubuntu 10.04 + 12.04 i686

Re: Olicard 145 TIM e ubuntu 11.04

Messaggioda Sava » venerdì 13 aprile 2012, 15:35

si. hai ragione
Sava Non specificato
Prode Principiante
 
Messaggi: 84
Iscrizione: marzo 2012

PrecedenteSuccessiva

Torna a Connessione e configurazione delle reti

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 9 ospiti