Notizia:
  • Rilasciata Ubuntu 14.04 LTS Trusty Tahr. Per ottenerla, visitate questa pagina oppure visualizzate la dimostrazione.
  • È uscito il numero 16 della Newsletter italiana di Ubuntu. Lo trovate a questo indirizzo.
  • È uscito il numero 79 di Full Circle Magazine in italiano. Lo trovate a questo indirizzo.

[Risolto] Non mi fa scegliere quale S.O. caricare

Configurazione e uso delle applicazioni del desktop manager alla base di Xubuntu.

[Risolto] Non mi fa scegliere quale S.O. caricare

Messaggioda anonimfiorentin » martedì 10 aprile 2012, 22:20

Salve a tutti, sono un nuovo acquisto di Xubuntu   (b2b)
Ormai diverse ore fa ho scaricato Xubuntu 11.10 su CD e l`ho istallato parallelamente a Windows XP.
Fin qui tutto ok, parte e funziona bene.
Il problema e` che quando accendo\riavvio il pc non mi fa scegliere quale Sistema Operativo caricare ma parte automaticamente Xubuntu.
Dov`e` che ho sbagliato? Come posso rimediare?  >:(
Ultima modifica di anonimfiorentin il giovedì 12 aprile 2012, 16:39, modificato 1 volta in totale.
anonimfiorentin Non specificato
Prode Principiante
 
Messaggi: 6
Iscrizione: aprile 2012

Re: Non mi fa scegliere quale S.O. caricare

Messaggioda Carlin0 » martedì 10 aprile 2012, 22:59

Dai questi comandi al terminale e incollaci qui le risposte usando il tag # che trovi sopra le faccine

Codice: Seleziona tutto
sudo fdisk -l


(è una elle)

Codice: Seleziona tutto
sudo update-grub
Carlin0 Maschile
Rampante Reduce
Rampante Reduce
 
Messaggi: 7453
Iscrizione: novembre 2009
Località: Augusta Taurinorum
Distribuzione: Debian Squeeze
Desktop: Gnome 2.30.2

Re: Non mi fa scegliere quale S.O. caricare

Messaggioda anonimfiorentin » martedì 10 aprile 2012, 23:19

fdisk -l:
Codice: Seleziona tutto
Disk /dev/sda: 82.0 GB, 81964302336 bytes
255 testine, 63 settori/tracce, 9964 cilindri, totale 160086528 settori
Unità = settori di 1 * 512 = 512 byte
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificativo disco: 0x808d808d

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   111286996    55643467    7  HPFS/NTFS/exFAT
/dev/sda2       111288318   160086015    24398849    5  Esteso
/dev/sda5       111288320   158826495    23769088   83  Linux
/dev/sda6       158828544   160086015      628736   82  Linux swap / Solaris


update-grub:
Codice: Seleziona tutto
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.0.0-17-generic
Found linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Microsoft Windows XP Professional on /dev/sda1
done
anonimfiorentin Non specificato
Prode Principiante
 
Messaggi: 6
Iscrizione: aprile 2012

Re: Non mi fa scegliere quale S.O. caricare

Messaggioda Carlin0 » martedì 10 aprile 2012, 23:27

Prova a riavviare e se ancora non ti fa scegliere posta anche
Codice: Seleziona tutto
cat /etc/default/grub
Carlin0 Maschile
Rampante Reduce
Rampante Reduce
 
Messaggi: 7453
Iscrizione: novembre 2009
Località: Augusta Taurinorum
Distribuzione: Debian Squeeze
Desktop: Gnome 2.30.2

Re: Non mi fa scegliere quale S.O. caricare

Messaggioda anonimfiorentin » martedì 10 aprile 2012, 23:38

-.- Ho riavviato e adesso dopo la schermata del bios si ferma e non succede nulla..
P.s.
Sto usando un'altro pc..
anonimfiorentin Non specificato
Prode Principiante
 
Messaggi: 6
Iscrizione: aprile 2012

Re: Non mi fa scegliere quale S.O. caricare

Messaggioda anonimfiorentin » mercoledì 11 aprile 2012, 9:30

Aggiorno la situazione:
Adesso mi son accorto che riesco a far partire ancora il Live CD e posso connettermi da la`, non ho bisogno di unsare un-altro PC.

Nessuno che abbia qualche idea sul da farsi?

---------------
[glow=red,2,300]Update[/glow]: Nel frattempo ho reinstallato Xubuntu sovrascrivendo quello esistente.. tutto è come all'inizio, (parte solamente Xubuntu senza possibilità di scegliere quale S.O. utilizzare), l'unica differenza rispetto a prima è che ora ho 2 partizioni Swap, ma non credo che questo crei problemi..
Ultima modifica di anonimfiorentin il mercoledì 11 aprile 2012, 13:26, modificato 1 volta in totale.
anonimfiorentin Non specificato
Prode Principiante
 
Messaggi: 6
Iscrizione: aprile 2012

Re: Non mi fa scegliere quale S.O. caricare

Messaggioda anonimfiorentin » mercoledì 11 aprile 2012, 15:29

rova a riavviare e se ancora non ti fa scegliere posta anche
Codice: Seleziona tutto
Codice:
cat /etc/default/grub


Nel frattempo ho fatto anche questo:
Codice: Seleziona tutto
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


>:(
anonimfiorentin Non specificato
Prode Principiante
 
Messaggi: 6
Iscrizione: aprile 2012

Re: Non mi fa scegliere quale S.O. caricare

Messaggioda -eternauta- » mercoledì 11 aprile 2012, 21:02

Mi viene da pensare che tu abbia lo stesso problema che è capitato a me e che capita con alcune schede video: Grub c'è ma non si vede.
Prova ad installare startupmanager e da li nella scheda "Avanzate" aumenta la risoluzione della schermata di Grub a quella immediatamente superiore. Se non dovesse funzionare riporta la risoluzione di Grub a quella originale prima di provare altre strade.
Ciao!
http://cinuda.wordpress.com Ubuntu user # 19841
La giovinezza sarebbe un periodo più bello se solo arrivasse un po' più tardi nella vita. (Charlie Chaplin)
Qui la mia chiave pubblica GPG: http://ubuntuone.com/32f3ohToAKiTEUoNHc2AQK
Avatar utente
-eternauta- Maschile
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 784
Iscrizione: maggio 2007
Località: Auronzo di Cadore (BL)
Distribuzione: Linux Mint 13 Maya 32 e 64 bit
Desktop: Xfce e Cinnamon

Re: Non mi fa scegliere quale S.O. caricare

Messaggioda daigo » mercoledì 11 aprile 2012, 21:35

oltre a quello che dice eternauta potresti anche provare(probabilmente dico una cavolata) la procedura per il ripristino di grub da live cd e vedi se cambia qualcosa...tentar non nuoce
http://wiki.ubuntu-it.org/Amministrazio ... Ripristino
Avatar utente
daigo Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 11255
Iscrizione: maggio 2011

Re: Non mi fa scegliere quale S.O. caricare

Messaggioda anonimfiorentin » giovedì 12 aprile 2012, 16:37

Grazie dei suggerimenti, purtroppo la situazione era più sottile di quanto sembrava, fortunatamente ne sono venuto a capo. Provo a descrivere il problema e a dirvi come l'ho risolto, non si sa mai che possa tornare utile a qualcuno in futuro..

Allora, GRUB c'è sempre stato ed ha sempre funzionato correttamente. In pratica quando avviavo il PC, subito dopo la schermata del BIOS, il monitor andava in stand-by per alcuni secondi, poi si riattivava e partiva Xubuntu. Una cosa simile accade ad esempio quando riavvio XP, (ad un certo punto per pochi secondi lo schermo va in stand-by e poi riparte tutto normalmente) ed è per questo che non mi ero mai curato della cosa. Il problema però era proprio lì.
Quei pochi secondi in cui lo schermo era in stand-by il GRUB mostrava il menu di scelta, e dopo 10 sec. (come da impostazione predefinita quando non si sceglie nessun S.O.) partiva Xubuntu.

Il problema l'ho risolto quando sono andato nel canale IRC Chat di supporto #ubuntu (solo dopo aver risolto il problema ho scoperto che esisteva anche un canale in italiano  >:( ).
Dopo aver spiegato il problema dettagliatamente e dopo diverse ore di tentativi dal terminale, abbiamo cambiato il valore del "GRUB_TIMEOUT" da "10" a "-1". (Credo di aver capito che GRUB_TIMEOUT=xx indichi quanto tempo deve restare attivo il menù di scelta del S.O., dopodiché parte in automatico uno dei due, e se si cambia il valore in -1, non raggiungendo mai quel valore, il menù resta all'infinito..). In questo modo lo schermo restava fisso in stand-by.
Dopo aver spiegato la mia idea a quegli angeli nella Chat, in 2 secondi hanno risolto il problema semplicemente facendomi cancellare il cancelletto davanti a "#GRUB_GFXMODE=640x480".

Ora funziona tutto perfettamente. (good)
anonimfiorentin Non specificato
Prode Principiante
 
Messaggi: 6
Iscrizione: aprile 2012


Torna a Xfce

Chi c’è in linea

Visualizzano questa sezione: claudio fontanelli e 6 ospiti