Utilizzo wxMaxima

Configurazione e uso del software educazionale (Edubuntu).

Utilizzo wxMaxima

Messaggioda frankie1962 » domenica 22 maggio 2016, 10:51

Salve a tutti.
Ho compilato i sorgenti ed istallato la versione wxmaxima 16.04.2 , avendo gà presenti nel sistema maxima e le wxWidgets: 3.0.2 .
Il programma parte normalmente ma si blocca 2 volte lasciando due messaggi di errore di cui riporto immagine , con backtrace:
Codice: Seleziona tutto
ASSERT INFO:
../src/gtk/bitmap.cpp(813): assert "IsOk()" failed in ConvertToImage(): invalid bitmap

BACKTRACE:
[1] wxBitmap::ConvertToImage() const
[2] wxObject::operator=(wxObject const&) /usr/include/wx-3.0-unofficial/wx/object.h:374
[3] wxObject::operator=(wxObject const&) /usr/include/wx-3.0-unofficial/wx/object.h:372
[4] wxMaximaFrame::ShowToolBar(bool) /home/francesco/cartella wxmaxima/wxmaxima-16.04.2/src/wxMaximaFrame.cpp:1465
[5] wxMaximaFrame::do_layout() /home/francesco/cartella wxmaxima/wxmaxima-16.04.2/src/wxMaximaFrame.cpp:399
[6] wxMaximaFrame::wxMaximaFrame(wxWindow*, int, wxString const&, wxPoint const&, wxSize const&, long) /home/francesco/cartella wxmaxima/wxmaxima-16.04.2/src/wxMaximaFrame.cpp:83
[7] wxMaxima::wxMaxima(wxWindow*, int, wxString, wxPoint, wxSize) /home/francesco/cartella wxmaxima/wxmaxima-16.04.2/src/wxMaxima.cpp:113
[8] MyApp::NewWindow(wxString, bool) /home/francesco/cartella wxmaxima/wxmaxima-16.04.2/src/main.cpp:243
[9] MyApp::OnInit() /home/francesco/cartella wxmaxima/wxmaxima-16.04.2/src/main.cpp:189
[10] wxEntry(int&, wchar_t**)
[11] main /home/francesco/cartella wxmaxima/wxmaxima-16.04.2/src/main.cpp:47
[12] __libc_start_main
[13] _start


e poi un secondo, con immagine e backtrace:
Codice: Seleziona tutto
ASSERT INFO:
../src/gtk/bitmap.cpp(626): assert "image.IsOk()" failed in wxBitmap(): invalid image

BACKTRACE:
[1] wxBitmap::wxBitmap(wxImage const&, int)
[2] ~wxObject /usr/include/wx-3.0-unofficial/wx/object.h:361
[3] wxObject::operator=(wxObject const&) /usr/include/wx-3.0-unofficial/wx/object.h:372
[4] wxMaximaFrame::ShowToolBar(bool) /home/francesco/cartella wxmaxima/wxmaxima-16.04.2/src/wxMaximaFrame.cpp:1465
[5] wxMaximaFrame::do_layout() /home/francesco/cartella wxmaxima/wxmaxima-16.04.2/src/wxMaximaFrame.cpp:399
[6] wxMaximaFrame::wxMaximaFrame(wxWindow*, int, wxString const&, wxPoint const&, wxSize const&, long) /home/francesco/cartella wxmaxima/wxmaxima-16.04.2/src/wxMaximaFrame.cpp:83
[7] wxMaxima::wxMaxima(wxWindow*, int, wxString, wxPoint, wxSize) /home/francesco/cartella wxmaxima/wxmaxima-16.04.2/src/wxMaxima.cpp:113
[8] MyApp::NewWindow(wxString, bool) /home/francesco/cartella wxmaxima/wxmaxima-16.04.2/src/main.cpp:243
[9] MyApp::OnInit() /home/francesco/cartella wxmaxima/wxmaxima-16.04.2/src/main.cpp:189
[10] wxEntry(int&, wchar_t**)
[11] main /home/francesco/cartella wxmaxima/wxmaxima-16.04.2/src/main.cpp:47
[12] __libc_start_main
[13] _start


premendo continue su entrambi i pulsanti, il programma si apre e funziona regolarmente.
Qualcuno può aiutarmi ad "eliminare" i due msg di errore ?
Il mio sistema è Kubuntu 14.04.4 64bit
Grazie
Allegati
Schermata6.png
primo msg di errore
schermata3.png
secondo msg di errore
Avatar utente
frankie1962
Prode Principiante
 
Messaggi: 72
Iscrizione: settembre 2006

Torna a Software educazionale

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite