Hardy non sa spegnere il mio notebook

Problemi riscontrati nella Hardy (Ubuntu 8.04) in fase di sviluppo.

Hardy non sa spegnere il mio notebook

Messaggioda palimmo » lunedì 14 aprile 2008, 10:33

Ciao!
Hardy beta non è in grado di spegnere il mio pc.
Eseguita la procedura tipica, si blocca con lo schermo nero.... e non accetta nessuna combinazione di tasti.
Quindi non posso far altro che spegnerlo tramite il tasto IO.
La cosa mi preoccupa parecchio perchè mentre è bloccato rimane accesa la spia dell'hard disk e sento un rumore come stesse leggermente lavorando ... :o

Leggendo qui:
http://www.logubuntu.it/kubuntu/hardy-h ... ere-il-pc/
dice di aggiungere il parametro
Codice: Seleziona tutto
acpi=force

al file
/boot/grub/menu.lst

E' una procedura indolore da eseguire senza nessun timore?
Non mi creerà nessun problema...ora e in futuro?

Nel dettaglio ecco il mio file /boot/grub/menu.lst:

Codice: Seleziona tutto
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default      0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout      10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title      Windows 95/98/NT/2000
# root      (hd0,0)
# makeactive
# chainloader   +1
#
# title      Linux
# root      (hd0,1)
# kernel   /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=5e0962c9-68fa-48fd-93e1-b215cc7e0988 ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,1)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash locale=it_IT

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title      Ubuntu hardy (development branch), kernel 2.6.24-16-generic
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.24-16-generic root=UUID=5e0962c9-68fa-48fd-93e1-b215cc7e0988 ro quiet splash locale=it_IT
initrd      /boot/initrd.img-2.6.24-16-generic
quiet

title      Ubuntu hardy (development branch), kernel 2.6.24-16-generic (recovery mode)
root      (hd0,1)
kernel      /boot/vmlinuz-2.6.24-16-generic root=UUID=5e0962c9-68fa-48fd-93e1-b215cc7e0988 ro single
initrd      /boot/initrd.img-2.6.24-16-generic

title      Ubuntu hardy (development branch), memtest86+
root      (hd0,1)
kernel      /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title      Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title      Microsoft Windows XP Professional
root      (hd0,0)
savedefault
makeactive
chainloader   +1


Dovrei aggiungere acpi=force a fianco di locale=it_IT
?
...vengono, vanno, ritornano...
e magari si fermano tanti giorni
http://aquilone.wordpress.com/
Avatar utente
palimmo Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1826
Iscrizione: marzo 2007

Re: Hardy non sa spegnere il mio notebook

Messaggioda ethyl » lunedì 14 aprile 2008, 10:39

la procedura è indolore
Dovrei aggiungere acpi=force a fianco di locale=it_IT
si , poi salvi e riavvii
Avatar utente
ethyl Non specificato
Rampante Reduce
Rampante Reduce
 
Messaggi: 7766
Iscrizione: gennaio 2007

Re: Hardy non sa spegnere il mio notebook

Messaggioda palimmo » lunedì 14 aprile 2008, 10:52

nessun problema in futuro? (in seguito ad aggiornamenti, eccc....)
Se mi cambierà il kernel, dovro' modificarlo manualmente...immagino....
...vengono, vanno, ritornano...
e magari si fermano tanti giorni
http://aquilone.wordpress.com/
Avatar utente
palimmo Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1826
Iscrizione: marzo 2007

Re: Hardy non sa spegnere il mio notebook

Messaggioda Pingu86 » lunedì 14 aprile 2008, 10:55

Con il rilascio di nuovi kernel il problema dovrebbe passare. Avevo un problema di questo tipo con un kernel di Feisty ed è passato quando passai a Gutsy e cambiò il kernel.

Ciao
Il computer non è una macchina intelligente che aiuta le persone stupide, anzi è una macchina stupida che funziona solo nelle mani delle persone intelligenti. [Umberto Eco]
Avatar utente
Pingu86 Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 793
Iscrizione: febbraio 2008
Località: Taranto - Puglia

Re: Hardy non sa spegnere il mio notebook

Messaggioda ethyl » lunedì 14 aprile 2008, 10:55

palimmo ha scritto:nessun problema in futuro? (in seguito ad aggiornamenti, eccc....)
Se mi cambierà il kernel, dovro' modificarlo manualmente...immagino....


si , ogni aggiornamento del kernel riscrive il menu.lst
Avatar utente
ethyl Non specificato
Rampante Reduce
Rampante Reduce
 
Messaggi: 7766
Iscrizione: gennaio 2007

Re: Hardy non sa spegnere il mio notebook

Messaggioda palimmo » lunedì 14 aprile 2008, 10:56

vado tranquillo... sperando in futuro sia il tutto messo a posto.


grazie!
...vengono, vanno, ritornano...
e magari si fermano tanti giorni
http://aquilone.wordpress.com/
Avatar utente
palimmo Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1826
Iscrizione: marzo 2007


Torna a Hardy 8.04

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite