scanner Epson non funzionante

Riconoscimento, installazione e configurazione delle periferiche.

scanner Epson non funzionante

Messaggioda ancarano » martedì 17 aprile 2012, 10:23

Ho da tempo uno scanner Epson Perfection 1250.
Ha sempre funzionato bene, ma da qualche tempo con Xsane (unico programma decente per scannerizzare) si comporta in modo strano:
la prima pagina viene acquisita bene, dalla seconda in poi viene scannerizzata metà pagina viola e l'altra correttamente.
Con altri software il problema non c'è, ma sono inutilizzabili in quanto lentissimi e non adatti al mio scopo.

Non è un problema dello scanner, in quanto su altri pc con stesso software (xsane 0.996, l'ultima presente nei repository) e stesso Ubuntu (10.04) funziona perfettamente.

Codice: Seleziona tutto
lsusb
Bus 006 Device 003: ID 04b8:010f Seiko Epson Corp. Perfection 1250


Codice: Seleziona tutto
sane-find-scanner
found USB scanner (vendor=0x04b8 [EPSON], product=0x010f [EPSON Scanner 010F], chip=LM9832/3) at libusb:006:003
Ultima modifica di ancarano il martedì 24 aprile 2012, 15:29, modificato 1 volta in totale.
Avatar utente
ancarano Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: febbraio 2008
Distribuzione: Ubuntu 13.10 x64
Desktop: gnome

Re: scanner non funzionante

Messaggioda Mad_Ghruned » mercoledì 18 aprile 2012, 17:03

non so se ti posso aiutare...io ho ubuntu 11.10...prova a vedere se hai installato SIMPLE SCAN, gestisce lo scanner in maniera molto semplice...ho visto che esiste anche per il 10.04
Avatar utente
Mad_Ghruned Non specificato
Prode Principiante
 
Messaggi: 3
Iscrizione: aprile 2012

Re: scanner non funzionante

Messaggioda magozurlinux » mercoledì 18 aprile 2012, 17:35

Ubuntu 12.04 LTS - Desktop i386 con Unity
Avatar utente
magozurlinux Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 12435
Iscrizione: marzo 2010
Località: Pisa
Distribuzione: 12.04 LTS i686 / Xubuntu 14.04 LTS
Desktop: Unity / Desktop

Re: scanner non funzionante

Messaggioda erotal » mercoledì 18 aprile 2012, 18:14

Se lo scanner ti funziona, avrai sicuramente installato i driver iscan, prova da terminale a digitare questo comando e ti compare la grafica di scannerizzazione della epson, vedi se con quella funziona.
El saòn no'l sa gnente, l'inteligente el sa poco, l'ignorante el sa tanto, el mona el sa tuto! Il saggio non sa niente, l'intelligente sa poco, l'ignorante sa tanto, l'imbecille sa tutto.
Xubuntu 13.10 su notebook. Ufficio e casa, Xubuntu 14.04
Avatar utente
erotal Maschile
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 969
Iscrizione: aprile 2008
Località: Treviso
Distribuzione: Xubuntu 13.04
Desktop: xfce

Re: scanner non funzionante

Messaggioda ancarano » venerdì 20 aprile 2012, 16:05

magozurlinux ha scritto:Segui la documentazione del Wiki:

http://wiki.ubuntu-it.org/Hardware/Stam ... annerEpson




seguendo questa guida sono indirizzato qui:
http://www.avasys.jp/lx-bin2/linux_e/scan/DL1.do
ma non ci sono pacchetti .deb per il mio scanner!

comunque leggendo il seguito della guida mi pare di capire che i driver sono installati correttamente:
Codice: Seleziona tutto
lsusb
Bus 006 Device 003: ID 04b8:010f Seiko Epson Corp. Perfection 1250


il pacchetto libltdl7 è già installato
Avatar utente
ancarano Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: febbraio 2008
Distribuzione: Ubuntu 13.10 x64
Desktop: gnome

Re: scanner non funzionante

Messaggioda erotal » venerdì 20 aprile 2012, 16:44

probabilmente non li hai proprio come io con il mio 3170, li devi convertire installando alien nel computer e poi convertirli con lo stesso programma.
da terminale, dopo che ti sei posto nella cartella dove hai salvato i due file, digita "sudo alien nomepacchetto" e lui da rpm li converte in deb.
Se dopo l'installazione non ti compare l'icona di avvio, digita da terminale iscan.

lsusb è il comando per verificare se il computer vede lo scanner, non se funziona, e relativi suoi indirizzi.
El saòn no'l sa gnente, l'inteligente el sa poco, l'ignorante el sa tanto, el mona el sa tuto! Il saggio non sa niente, l'intelligente sa poco, l'ignorante sa tanto, l'imbecille sa tutto.
Xubuntu 13.10 su notebook. Ufficio e casa, Xubuntu 14.04
Avatar utente
erotal Maschile
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 969
Iscrizione: aprile 2008
Località: Treviso
Distribuzione: Xubuntu 13.04
Desktop: xfce

Re: scanner non funzionante

Messaggioda ancarano » venerdì 20 aprile 2012, 18:30

ma se non fossero installati, non dovrebbe darmi errore anche alla prima pagina?
perche il primo documento lo scannerizza bene?
Avatar utente
ancarano Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: febbraio 2008
Distribuzione: Ubuntu 13.10 x64
Desktop: gnome

Re: scanner non funzionante

Messaggioda erotal » venerdì 20 aprile 2012, 18:36

xsane e iscan sono due cose diverse uno è open l'altro è proprietario.
E una prova da fare se iscan ti funziona bene, vuol dire che è xsane che non va, altrimenti è lo scanner.
El saòn no'l sa gnente, l'inteligente el sa poco, l'ignorante el sa tanto, el mona el sa tuto! Il saggio non sa niente, l'intelligente sa poco, l'ignorante sa tanto, l'imbecille sa tutto.
Xubuntu 13.10 su notebook. Ufficio e casa, Xubuntu 14.04
Avatar utente
erotal Maschile
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 969
Iscrizione: aprile 2008
Località: Treviso
Distribuzione: Xubuntu 13.04
Desktop: xfce

Re: scanner non funzionante

Messaggioda ancarano » venerdì 20 aprile 2012, 18:42

non riesco a convertire il pacchetto in .deb!
mi dice che è stato creato con successo, ma non lo trovo ne nella cartella dove sta il .rpm ne nella home  ???

altra domanda: i pacchetti presenti sono per architetture i386, mentre io sto su x64... vanno bene lo stesso?
Avatar utente
ancarano Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: febbraio 2008
Distribuzione: Ubuntu 13.10 x64
Desktop: gnome

Re: scanner non funzionante

Messaggioda erotal » venerdì 20 aprile 2012, 20:29

Questo è un problema che ho anche io, però ho sentito che canonical è riuscita a far supportare i driver a 32 su architetture da 64.
Per questo ti rimando ad un post che sto visionando perché per l'appunto intendo passare da ubuntustudio 32 a 64, ma come per te non ho i driver giusti.
Vedi qui http://forum.ubuntu-it.org/viewtopic.php?t=124858
oppure digita nel web  ubuntu driver 32 su 64 e segui le indicazioni.
Io da quì in avanti non sono in grado di aiutarti perchè devo provare anche io.
Ultimo consiglio, installa una versione live di ubuntu a 32 e prova ad installarci i driver che ti ho indicato o che hai già scaricato e vedi come si comporta lo scanner con iscan.

ancarano ha scritto:non riesco a convertire il pacchetto in .deb!
mi dice che è stato creato con successo, ma non lo trovo ne nella cartella dove sta il .rpm ne nella home  ???

prova a digitare con catfish il seguente comando iscan, seleziona la cartella home e vedi dove puo essere finito.
Per caso hai provato a vedere dentro la cartella rpm ?
El saòn no'l sa gnente, l'inteligente el sa poco, l'ignorante el sa tanto, el mona el sa tuto! Il saggio non sa niente, l'intelligente sa poco, l'ignorante sa tanto, l'imbecille sa tutto.
Xubuntu 13.10 su notebook. Ufficio e casa, Xubuntu 14.04
Avatar utente
erotal Maschile
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 969
Iscrizione: aprile 2008
Località: Treviso
Distribuzione: Xubuntu 13.04
Desktop: xfce

Re: scanner non funzionante

Messaggioda ancarano » sabato 21 aprile 2012, 8:50

forse allora potrebbe essere questo il problema?
perche sul portatile (32bit) funziona bene sia con xsane che con iscan!

prova a digitare con catfish il seguente comando iscan, seleziona la cartella home e vedi dove puo essere finito.
Per caso hai provato a vedere dentro la cartella rpm ?

niente non so dove vadano a finire...ho cercato in tutto l'hard disk  :-\
Avatar utente
ancarano Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: febbraio 2008
Distribuzione: Ubuntu 13.10 x64
Desktop: gnome

Re: scanner non funzionante

Messaggioda erotal » sabato 21 aprile 2012, 10:19

scrivimi per esteso il comando che hai dato da terminale che verifico eventuali errori.
El saòn no'l sa gnente, l'inteligente el sa poco, l'ignorante el sa tanto, el mona el sa tuto! Il saggio non sa niente, l'intelligente sa poco, l'ignorante sa tanto, l'imbecille sa tutto.
Xubuntu 13.10 su notebook. Ufficio e casa, Xubuntu 14.04
Avatar utente
erotal Maschile
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 969
Iscrizione: aprile 2008
Località: Treviso
Distribuzione: Xubuntu 13.04
Desktop: xfce

Re: scanner non funzionante

Messaggioda ancarano » sabato 21 aprile 2012, 10:48

erotal ha scritto:scrivimi per esteso il comando che hai dato da terminale che verifico eventuali errori.


sudo alien -d nomepacchetto.rpm

oppure

sudo alien nomepacchetto.rpm

stesso risultato.
output positivo ma pacchetto introvabile!
Avatar utente
ancarano Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: febbraio 2008
Distribuzione: Ubuntu 13.10 x64
Desktop: gnome

Re: scanner non funzionante

Messaggioda magozurlinux » sabato 21 aprile 2012, 11:22

Se il pacchetto .rpm viene convertito in .deb, il pacchetto trasformato lo trovi nella cartella dove hai messo i pacchetti .rpm; hai cercato nella cartella Scaricati o nella tua cartella home?
Ubuntu 12.04 LTS - Desktop i386 con Unity
Avatar utente
magozurlinux Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 12435
Iscrizione: marzo 2010
Località: Pisa
Distribuzione: 12.04 LTS i686 / Xubuntu 14.04 LTS
Desktop: Unity / Desktop

Re: scanner non funzionante

Messaggioda erotal » sabato 21 aprile 2012, 11:32

magozurlinux ha scritto:Se il pacchetto .rpm viene convertito in .deb, il pacchetto trasformato lo trovi nella cartella dove hai messo i pacchetti .rpm; hai cercato nella cartella Scaricati o nella tua cartella home?


Ha già guardato, vedi risposta 8
El saòn no'l sa gnente, l'inteligente el sa poco, l'ignorante el sa tanto, el mona el sa tuto! Il saggio non sa niente, l'intelligente sa poco, l'ignorante sa tanto, l'imbecille sa tutto.
Xubuntu 13.10 su notebook. Ufficio e casa, Xubuntu 14.04
Avatar utente
erotal Maschile
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 969
Iscrizione: aprile 2008
Località: Treviso
Distribuzione: Xubuntu 13.04
Desktop: xfce

Re: scanner non funzionante

Messaggioda ancarano » lunedì 23 aprile 2012, 20:15

magozurlinux ha scritto:Se il pacchetto .rpm viene convertito in .deb, il pacchetto trasformato lo trovi nella cartella dove hai messo i pacchetti .rpm; hai cercato nella cartella Scaricati o nella tua cartella home?


si...

comunque credo che, problema .rpm a parte, il malfunzionamento sia dovuto al fatto che non esistono driver per sistemi x64.
ho cercato nel forum di ubuntu in inglese e alcuni hanno lamentato problemi analoghi, sempre con sistemi x64.
Avatar utente
ancarano Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 272
Iscrizione: febbraio 2008
Distribuzione: Ubuntu 13.10 x64
Desktop: gnome


Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: cjfan e 14 ospiti