Macchina virtuale Ubuntu non pinga con macchina fisica win10

Installazione di Ubuntu su macchina virtuale (Virtualbox, Vmware, Qemu, Parallels, KVM, Xen, Virtual pc, ecc.), configurazione del software e gestione del sistema virtualizzato.

Macchina virtuale Ubuntu non pinga con macchina fisica win10

Messaggioda mrusso » giovedì 9 marzo 2017, 13:13

Macchina fisica (wi-fi) - Windows 10 64 bit - firewall disabilitato - LAN disabilitata:
IP: 192.168.238.143
mask: 255.255.255.0
gateway: 192.168.88.1
DNS pre: 8.8.8.8
DNS alt: 8.8.4.4

Macchina virtuale (VMware - VMnet8 - ens33) - Ubuntu 64 bit
IP: 192.168.238.142
mask: 255.255.255.0
gateway: 192.168.88.1
DNS pre: 8.8.8.8
DNS alt: 8.8.4.4

Come da titolo non si pingano tra di loro. HELP ME pleas!
mrusso
Prode Principiante
 
Messaggi: 20
Iscrizione: febbraio 2017

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda thece » giovedì 9 marzo 2017, 13:39

:ciao:

banalmente, hai controllato entrambi i due firewall?

La scheda di rete virtuale è collegata alla scheda di rete WIFI fisica?

La scheda di rete virtuale è in modalità "bridge"?
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 6908
Iscrizione: aprile 2007
Distribuzione: Debian 8 (Jessie) - KDE 4.14

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda mrusso » giovedì 9 marzo 2017, 13:52

per la prima domanda (se leggi la mia domanda c'è scritto che il firewall di win10 "macchina fisica" e disabilitato) l'altro non lo so. come faccio a controllare?
per le altre 2 domande non saprei rispondere...come faccio a controllare? sulla macchina virtuale ho ubunti 64 bit da terminale...dimmi i vari comandi e controllo....
mrusso
Prode Principiante
 
Messaggi: 20
Iscrizione: febbraio 2017

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda thece » giovedì 9 marzo 2017, 13:57

Per il firewall di Linux: output del comando

Codice: Seleziona tutto
sudo iptables-save

Per le altre due domande, un comando non so se c'è ... forse ... di sicuro se guardi nelle impostazioni della VM sul Pannello di Controllo di VMWare lo vedi
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 6908
Iscrizione: aprile 2007
Distribuzione: Debian 8 (Jessie) - KDE 4.14

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda axilot » giovedì 9 marzo 2017, 13:58

VMWare lo conosco poco perchè uso virtualbox, ma se la scheda di rete dell host è disabilitata non credo che tu possa pingare alcunchè.

per quanto riguarda quello che ha detto Thece (bridge mode) devi verificare le impostazioni della macchina virtuale
https://www.vmware.com/support/ws5/doc/ ... idged.html
https://www.vmware.com/support/ws5/doc/ ... nging.html
https://www.vmware.com/support/ws5/doc/ ... asics.html

ma se la macchina virtuale non deve andare in internet o in lan ti conviene settarla come Host-Only Networking
https://www.vmware.com/support/ws5/doc/ ... tonly.html

EDIT: VMnet8 vuol dire che sei in NAT per cui non puoi avere la stessa classe di indirizzi sull host e sul guest

The NAT device is connected to the VMnet8 virtual switch. Virtual machines connected to the NAT network also use the VMnet8 virtual switch
Ultima modifica di axilot il giovedì 9 marzo 2017, 14:08, modificato 2 volte in totale.
"Experience, the name men give to their mistakes" (O.Wilde)
Avatar utente
axilot
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1655
Iscrizione: luglio 2008
Distribuzione: Ubuntu 14.04 64bit

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda thece » giovedì 9 marzo 2017, 14:06

axilot Immagine ha scritto:VMWare lo conosco poco perchè uso virtualbox, ma se la scheda di rete dell host è disabilitata non credo che tu possa pingare alcunchè.

Se la scheda di rete virtuale è collegata alla scheda di rete WIFI fisica (potenzialmente) può pingare
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 6908
Iscrizione: aprile 2007
Distribuzione: Debian 8 (Jessie) - KDE 4.14

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda axilot » giovedì 9 marzo 2017, 14:12

Non avevo capito che stava usando il wifi, sinceramente ho sempre usato le interfacce ethernet ( e poi con Vbox), per cui potrebbe anche funzionare a parte il fatto che è in NAT ed ha pure impostato il guest nello stessa classe di indirizzi dell host.
Ultima modifica di axilot il giovedì 9 marzo 2017, 14:26, modificato 1 volta in totale.
"Experience, the name men give to their mistakes" (O.Wilde)
Avatar utente
axilot
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1655
Iscrizione: luglio 2008
Distribuzione: Ubuntu 14.04 64bit

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda thece » giovedì 9 marzo 2017, 14:17

axilot Immagine ha scritto:... per cui potrebbe anche funzionare ...

Togli pure il "potrebbe"

axilot Immagine ha scritto: a parte il fatto che è in NAT ed ha pure impostato il guest nello stessa classe di indirizzi dell host.

Aspetto di vedere uno screenshot (o equivalente) delle impostazioni di rete della VM per sbilanciarmi
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 6908
Iscrizione: aprile 2007
Distribuzione: Debian 8 (Jessie) - KDE 4.14

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda mrusso » giovedì 9 marzo 2017, 14:21

ho scritto nel "domanda" le info di rete....se ti serve altro dimmi e ti faccio lo screen
mrusso
Prode Principiante
 
Messaggi: 20
Iscrizione: febbraio 2017

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda thece » giovedì 9 marzo 2017, 14:27

mrusso Immagine ha scritto:ho scritto nel "domanda" le info di rete....se ti serve altro dimmi e ti faccio lo screen

Ti ho posto delle domande, hai controllato?

thece ha scritto:banalmente, hai controllato entrambi i due firewall?

La scheda di rete virtuale è collegata alla scheda di rete WIFI fisica?

La scheda di rete virtuale è in modalità "bridge"?

Per le ultime due se vuoi puoi farmi anche uno screenshot delle impostazioni di rete della VM. A me bastava una tua risposta scritta
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 6908
Iscrizione: aprile 2007
Distribuzione: Debian 8 (Jessie) - KDE 4.14

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda mrusso » giovedì 9 marzo 2017, 14:41

per la prima...ho eseguito il comando e non mi ha restituito nulla....per le altre 2 sto verificando come si fa...ad una prima occhiata correggimi se dico una cazzata...la macchina virtuale e collegata alla scheda (virtuale suppongo) VMnet8....almeno da come ho scritto io nell domanda principale
Allegati
screen_4.jpg
screen_2.jpg
screen_1.jpg
Ultima modifica di mrusso il giovedì 9 marzo 2017, 14:51, modificato 1 volta in totale.
mrusso
Prode Principiante
 
Messaggi: 20
Iscrizione: febbraio 2017

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda thece » giovedì 9 marzo 2017, 14:44

Quelle due schede di rete virtuali di VMWare (VMnet8 e ... dovrebbe essercene un'altra se non ricordo male) servono per altri tipi di configurazione di rete. Postami uno screenshot che facciamo prima
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 6908
Iscrizione: aprile 2007
Distribuzione: Debian 8 (Jessie) - KDE 4.14

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda mrusso » giovedì 9 marzo 2017, 14:53

scusami credevo di averli allegati invece no...ho fatto ora...controlla....in relata la machcina virtuale fornisce 2 schede per quello che ho capito io...VMnet1 e VMnet8...la prima non l'ho settata la seconda si...
mrusso
Prode Principiante
 
Messaggi: 20
Iscrizione: febbraio 2017

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda thece » giovedì 9 marzo 2017, 15:06

E' un pò che non uso VMWare, le mie conoscenze in merito sono un pò arrugginite

mrusso Immagine ha scritto:... la prima non l'ho settata la seconda si...

Cosa intendi esattamente?

Dalla VM dovresti riuscire a pingare verso l'esterno, ad esempio

Codice: Seleziona tutto
ping -c 4 8.8.8.8

il contrario non credo visto che la VM è in NAT

Hai impostato qualcosa in LAN segments ... o Advanced ... ?
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 6908
Iscrizione: aprile 2007
Distribuzione: Debian 8 (Jessie) - KDE 4.14

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda mrusso » giovedì 9 marzo 2017, 15:14

per non settata intendo che ho lasciato c'ho che c'era di default...ossia VMnet1, LAN segments e Advanced ho lasciato così com'e senza toccare nulla....e VMnet8 l'ho settata come ho scritto nel mio quesito iniziale.
Allegati
screen_5.jpg
mrusso
Prode Principiante
 
Messaggi: 20
Iscrizione: febbraio 2017

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda thece » giovedì 9 marzo 2017, 15:16

mrusso Immagine ha scritto:e VMnet8 l'ho settata come ho scritto nel mio quesito iniziale.

Valori a parte, come l'hai settata?
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 6908
Iscrizione: aprile 2007
Distribuzione: Debian 8 (Jessie) - KDE 4.14

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda mrusso » giovedì 9 marzo 2017, 15:21

ho messo in allegato gli screen relativi alla risp precedente....solo i valori di sopra...non ho fatto piu nulla....pannello di controllo \ connessioni di rete \ tasto destro su VMnet8 \ proprieta \ seleziono TCPipv4 e proprietà \ scrivo i valori che ho postato \ e do l'ok \ stop fine
Allegati
screen_6.jpg
mrusso
Prode Principiante
 
Messaggi: 20
Iscrizione: febbraio 2017

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda thece » giovedì 9 marzo 2017, 15:28

Non avendo VMWare non riesco a seguirti bene ...

Giusto per scrupolo, mi fai vedere come è impostata la scheda di rete all'interno della VM?

Codice: Seleziona tutto
ifconfig
route -n

non postare screenshot se non serve. Fai Copia&Incolla degli output dei comandi direttamente dal terminale


Riguardo allo screenshot che hai postato in merito alle impostazioni della scheda di rete virtuale: non mi torna!
Sulla sinistra c'è scritto "Network Adapter Custom VMnet8" sulla destra è selezionato NAT. Hai cambiato l'impostazione sulla destra e non hai confermato la modifica? Se si, scegli NAT, conferma la modifica e riavvia la VM. Dopo postami i due output che ti ho chiesto
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 6908
Iscrizione: aprile 2007
Distribuzione: Debian 8 (Jessie) - KDE 4.14

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda mrusso » giovedì 9 marzo 2017, 15:37

scusami ma non riesco a copiare l'output da terminale...quindi altro screen
Allegati
screen_7.jpg
mrusso
Prode Principiante
 
Messaggi: 20
Iscrizione: febbraio 2017

Re: Macchina virtuale Ubuntu non pinga con macchina fisica w

Messaggioda thece » giovedì 9 marzo 2017, 15:39

thece Immagine ha scritto:Riguardo allo screenshot che hai postato in merito alle impostazioni della scheda di rete virtuale: non mi torna!
Sulla sinistra c'è scritto "Network Adapter Custom VMnet8" sulla destra è selezionato NAT. Hai cambiato l'impostazione sulla destra e non hai confermato la modifica? Se si, scegli NAT, conferma la modifica e riavvia la VM. Dopo postami i due output che ti ho chiesto


Come hai assegnato l'indirizzo IP 192.168.238.142 alla scheda di rete? Hai usato il comando ifconfig?

Mi sono fatto l'idea che hai proceduto molto a tentoni e hai pasticciato qua e là ...
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 6908
Iscrizione: aprile 2007
Distribuzione: Debian 8 (Jessie) - KDE 4.14

Successiva

Torna a Ubuntu su macchina virtuale

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 2 ospiti