KDE Neon: problema splash screen in avvio

Informazioni, consigli e novità sulla galassia delle distribuzioni GNU/Linux, *nix, *BSD e su altri sistemi operativi non liberi.

KDE Neon: problema splash screen in avvio

Messaggioda Andrea/M » mercoledì 3 maggio 2017, 10:14

Ciao a tutti,
ho installato KDE Neon in multi boot con altre distrribuzioni linux (GRUB installato durante l'installazione di Linux Mint xfce 18.1) ma all'avvio dal menù di grub ho solo lo scrolling text e non l'immagine. Durante l'avvio delle altre due distribuzioni (Linux Mint xfce ed Elementary OS Loki) lo splash screen è in modalità grafica e mi sembra con una risoluzione corretta (1920x1200) così come il menù di GRUB. Voglio precisare che ho installato su Mint e Neon i drivers proprietari Nvidia ( e mi sembra che a causa di questo, durante l'avvio di Mint, dopo qualche momento il logo scompaia e rimangono soltanto i puntini luminosi) . Ho letto molte discussioni ma tutte riferite a distribuzioni precedenti al minimo di un paio di anni ma non sono riuscito a farmi un'idea chiara sul da farsi.
Grazie in anticipo per ivostri suggerimenti
Andrea/M
Prode Principiante
 
Messaggi: 10
Iscrizione: agosto 2008

Re: KDE Neon: problema splash screen in avvio

Messaggioda woddy68 » mercoledì 3 maggio 2017, 19:41

Scusa , il problema è lo splash screen o la schermata d'accesso del login ? O entrambe ?
Edit. Beh vedo di darti entrambe le soluzioni, sempre che funzionino, a me su Suse e Kubuntu ha funzionato alla perfezione.
Per lo splash screen apri con i privilegi di root e con un editor di testo, non so cosa c'è in Neon, in caso ci fosse kate (altrimenti cambialo con quello che hai)
Codice: Seleziona tutto
sudo kate /etc/default/grub

cerca la riga con
Codice: Seleziona tutto
GRUB_GFXMODE="auto"

e modificala al posto di "auto" con la risoluzione del tuo monitor, non sempre però funziona con tutte le risoluzioni, basta metterne una simile alla tua, ma provare non costa. In modo da ottenere una cosa simile
Codice: Seleziona tutto
GRUB_GFXMODE="1366x768"

Salva, chiudi riavvia.
Mentre per la schermata di login
Codice: Seleziona tutto
sudo kate  /etc/sddm.conf

se non c'è crealo
e nella sezione [XDisplay]
inserire
Codice: Seleziona tutto
ServerArguments=-nolisten tcp -dpi 94

se il file non c'è ricorda di mettere anche la sezione per avere una cosa del genere
Codice: Seleziona tutto
[XDisplay]
ServerArguments=-nolisten tcp -dpi 94

Salva, chiudi riavvia.

Ciao
Desktop - Acer Aspire M5500 (Nvidia) OpenSuse Leap 42.2 Kde -- Kubuntu 17.04 .
Notebook Acer Aspire E1 -522 (Amd) OpenSuse Tumbleweed Kde Plasma5
--Ho sempre accettato caramelle dagli sconosciuti--
Avatar utente
woddy68
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2883
Iscrizione: febbraio 2011
Località: Bellano Lc
Desktop: Kde Plasma5
Distribuzione: OpenSuse Leap 42.2 - Kubuntu 17.04
Sesso: Maschile

Re: KDE Neon: problema splash screen in avvio

Messaggioda Andrea/M » giovedì 4 maggio 2017, 21:13

Grazie per la risposta, dalla quale ho capito che forse non ho esposto con sufficiente chiarezza il problema (chiedo venia):
ho installato in una configurazione multiboot 3 diverse ditro Linux su un singolo HDD: Linux Mint 18.1 xfce (installando la quale ho installato il bootloader), Elementary OS Loki (senza installare GRUB: ubiquity -b), KDE Neon (senza installare GRUB: ubiquity -b).
Durante la fase di boot di KDE Neon anziche avere lo splash screen in modalità grafica ho lo scrolling text della fase di avvio fino alla normale comparsa della schermata di login che risulta essere nella corretta definizione (1920x1200) e mi permette di accedere senza problemi al sistema.
Riporto qui sotto il contenuto del file grub in /etc/default nei tre casi:
Linux Mint 18.1 XFCE
Codice: Seleziona tutto
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Elementary OS Loki
Codice: Seleziona tutto
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

KDE Neon
Codice: Seleziona tutto
GRUB_THEME=/boot/grub/themes/breeze/theme.txt

Ho installato poi KDE Neon su macchina virtuale e l'avvio avviene in modalità grafica senza scrolling text correttamente. In questo caso il file grub in /etc/default è:
Codice: Seleziona tutto
GRUB_THEME=/boot/grub/themes/breeze/theme.txt

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

GRUB_CMDLINE_LINUX=""


adesso il dubbio da parte mia è come riportare in modalità grafica lo splash screen all'avvio di KDE Neon, quali file editare (il file grub in /etc/default dell'installazione di KDE Neon o quello relativo all'installazione di Mint?) e come senza compromettere la funzionalità del sistema.
Andrea/M
Prode Principiante
 
Messaggi: 10
Iscrizione: agosto 2008

Re: KDE Neon: problema splash screen in avvio

Messaggioda Andrea/M » sabato 20 maggio 2017, 9:11

Credo di aver risolto anche se in modo "empirico" il problema:
avevo notato che nella installazione di KDE Neon il file grub in /etc/default era costituito di una unica riga:
Codice: Seleziona tutto
GRUB_THEME=/boot/grub/themes/breeze/theme.txt

mentre invece nella stessa installazione di KDE Neon su macchina virtuale (nella quale l'avvio avveniva normalmente in modalità grafica) lo stesso file si presentava in questo modo:
Codice: Seleziona tutto
GRUB_THEME=/boot/grub/themes/breeze/theme.txt
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Così ho copiato e incollato le due linee mancanti nel file grub in /etc/default tramite kwrite (accedendovi da root) della installazione "reale" e poi da terminale ho dato il comando:
Codice: Seleziona tutto
sudo update-grub

prima dall'installazione di KDE Neon e successivamente da Linux Mint 18.1 xfce (dal quale avevo installato il GRUB sul disco) e alla fine riavviando lo splash screen è tornato in modalità grafica.
Da ciò che ho letto mi sembra di aver capito che la riga che che contiene le istruzioni riguardo all'avvio in modalità grafica sia:
Codice: Seleziona tutto
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

e quindi forse sarebbe bastato inserire solo quella riga ma, ripeto, la mia è stata una soluzione "empirica" e non basata su una approfondita conoscenza delle opzioni del file di configurazione.
Andrea/M
Prode Principiante
 
Messaggi: 10
Iscrizione: agosto 2008


Torna a Altre distribuzioni e sistemi operativi

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 3 ospiti