Sony Vaio CW - Problemi e Soluzioni.

Riconoscimento dell'hardware, installazione e configurazione del portatile e delle periferiche PC Card.

Sony Vaio CW - Problemi e Soluzioni.

Messaggioda castigamatti81 » mercoledì 6 gennaio 2010, 16:08

Salve ragazzi visto che ho notato un buon numero di utilizzatori del Vaio CW, ho pensato di aprire una discussione dedicata a questo notebook dove poter raccogliere i problemi riscontrati con l'installazione di Ubuntu con le eventuali soluzioni.
Inizio con l'elencare i problemi riscontrati:

- [Risolto]Schermo Nero dopo l'installazione dei Driver Nvidia: problema ottimamente risolto in questa discussione: http://forum.ubuntu-it.org/viewtopic.php?t=331837

- Illuminazione dello schermo bloccata al massimo.

- [Risolto] Il microfono non funziona: Poblema risolto seguendo questa procedura: http://forum.ubuntu-it.org/viewtopic.ph ... 4#p2724974

- [Risolto] In alcuni casi si ha la difficoltà di visualizzare alcuni filmati in flash, chi dovesse avere questa problematica segua le indicazioni riportate dal link postato da Icabus: http://forum.ubuntu-it.org/viewtopic.php?t=335197

Per tutto il resto il Notebook sembra comportarsi perfettamente ;)
Ultima modifica di castigamatti81 il domenica 10 gennaio 2010, 18:17, modificato 1 volta in totale.
D.M.C. & MaleDucati - Italian Street Riders
Sfidatemi!!!: http://castigamatti81.mybrute.com
Avatar utente
castigamatti81 Non specificato
Prode Principiante
 
Messaggi: 118
Iscrizione: gennaio 2008

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda Fiera » mercoledì 6 gennaio 2010, 20:22

Il microfono non funziona neanche sul mio Sony Vaio CW1S1E.

Non sarebbe male risolvere anche questo problema.
Avatar utente
Fiera Non specificato
Prode Principiante
 
Messaggi: 70
Iscrizione: gennaio 2008

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda xalex » giovedì 7 gennaio 2010, 15:49

Nemmeno il mio microfono funziona. Usandolo spesso sarebbe una bella scocciatura non trovare una soluzione. Ho cercato in rete ma non ho trovato molto. Se ne parla qui http://bbs.archlinux.org/viewtopic.php?id=62196.
xalex Non specificato
Prode Principiante
 
Messaggi: 12
Iscrizione: gennaio 2010

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda Fiera » venerdì 8 gennaio 2010, 11:49

Ieri ho provato con un pò di amici di ninux.org al Fusolab a Roma (www.fusolab.net).

Abbiamo smanettato con alsamixer e con la sezione "audio" del pc (Sistema>Preferenze>Audio).

Nulla di nulla, il massimo è stato un bel fruscio.

Il microfono sulla partizione Windows funziona perfettamente.

Abbiamo consultato anche altri Thread e pagine su internet per provare a risolvere la situazione ve le scrivo senza nessun particolare ordine:

- http://ubuntuforums.org/showthread.php?t=1316136 (quando abbiamo visto che uno degli Audio Device è nVidia Corporation Device 0be2 (rev a1)  ), pare che anche qui avessero customizzato il file EDID del video e mi è venuto il dubbio che possa esserci una relazione tra le due cose visto che il microfono è sul bordo del pannello dello schermo. (Bhò!!)

- http://www.alsa-project.org/main/index.php/Main_Page (per provare ad aggiornare la versione di alsamixer) e anche questo http://ubuntuforums.org/showthread.php?p=6589810

-il Wiki di Alsamixer http://it.wikipedia.org/wiki/Alsamixer

- http://moosesoom.blogspot.com/2009/12/a ... audio.html (per disinstallare Pulseaudio e installare le versione 1.0.22 di alsamixer)

- Guida ad Alsa su Gentoo http://www.gentoo.org/doc/it/alsa-guide.xml

Risultati per ora zero.

Un altra delle questioni sollevate è se non sarebbe meglio installare la versione di Ubuntu 9.10 a 32 bit.

Qualcuno ha installato la 32bit ed ha avuto meno problemi di riconoscimento delle periferiche?
Qualcuno può fare delle prove da live cd o installando su una partizione la 32bit?

Io appena possibile mi adopero per la causa e posto i risultati.

Per ora è tutto.
Avatar utente
Fiera Non specificato
Prode Principiante
 
Messaggi: 70
Iscrizione: gennaio 2008

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda Fiera » venerdì 8 gennaio 2010, 13:33

Ho trovato anche questo: http://forum.ubuntu-it.org/viewtopic.php?t=336836
Senza risultato e si tratta di un modello di pc diverso.

Ho trovato anche questo ma non ho ancora provato: http://discoverylinux.wordpress.com/200 ... gn-sr220j/

E questo (non ho provato): http://forum.ubuntu-it.org/viewtopic.php?t=337405
Qui propongono una soluzione per il mic e anche per la luminosità dello schermo.

Si tratta di un altro modello Sony ma vedo che i problemi sono sempre gli stessi.
Chi avesse il tempo di fare delle prove sopratutto sull'ultimo thread, ci faccia sapere!!  :)

A presto!!
Ultima modifica di Fiera il venerdì 8 gennaio 2010, 13:41, modificato 1 volta in totale.
Avatar utente
Fiera Non specificato
Prode Principiante
 
Messaggi: 70
Iscrizione: gennaio 2008

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda castigamatti81 » venerdì 8 gennaio 2010, 16:02

Ciao fiera sto scrivendo proprio adesso dalla live di ubuntu a 32 bit, ma purtroppo anche in questo caso il microfono non viene riconosciuto, stessa cosa per la retroilluminazione...non c-[ differenza con la 64 bit.

Ora mi leggo anche gli altri link che hai postato, speriamo che funzionino.  :)
grazie!
D.M.C. & MaleDucati - Italian Street Riders
Sfidatemi!!!: http://castigamatti81.mybrute.com
Avatar utente
castigamatti81 Non specificato
Prode Principiante
 
Messaggi: 118
Iscrizione: gennaio 2008

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda Fiera » venerdì 8 gennaio 2010, 16:18

Ok.

Se hai tempo e sopratutto per non star dietro a tutto lo sfacelo che ho riportato, prova l'ultimo thread che ho postato, sembra essere quello più indicato per i nostri problemi, fatto salvo per il modello del Sony che è diverso.

A presto.
Avatar utente
Fiera Non specificato
Prode Principiante
 
Messaggi: 70
Iscrizione: gennaio 2008

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda castigamatti81 » venerdì 8 gennaio 2010, 16:23

Fiera sei un mito!
Il microfono funziona seguendo il link che hai riportato!
Tutto molto semplice.
Riassumendo:
Per Risolvere il problema del microfono:

1) Aprire il terminale e dare il comando:


Codice: Seleziona tutto
sudo gedit /etc/modprobe.d/alsa-base.conf


2) Modificare il file, aggiungendo alla fine la seguente riga:

Codice: Seleziona tutto
options snd-hda-intel model=toshiba-s06



3) Salvate il file e riavviate.
4) Appena il sistema si è riavviato, aprite il terminale.
5) Digitate il seguente comando:

Codice: Seleziona tutto
alsamixer



6) Con il tasto Tab, spostatevi nella scheda Capture.
7) Selezionate Int dMic come dispositivo d'ingresso.

Fonte: http://forum.ubuntu-it.org/viewtopic.php?t=337405
D.M.C. & MaleDucati - Italian Street Riders
Sfidatemi!!!: http://castigamatti81.mybrute.com
Avatar utente
castigamatti81 Non specificato
Prode Principiante
 
Messaggi: 118
Iscrizione: gennaio 2008

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda castigamatti81 » venerdì 8 gennaio 2010, 16:45

Fiera ho provato anche le modifiche per la retroilluminazione, purtroppo quelle non vanno.
Però quando hai tempo provaci anche tu non vorrei aver sbagliato qualcosa...cmq adesso ci riprovo.
;)
D.M.C. & MaleDucati - Italian Street Riders
Sfidatemi!!!: http://castigamatti81.mybrute.com
Avatar utente
castigamatti81 Non specificato
Prode Principiante
 
Messaggi: 118
Iscrizione: gennaio 2008

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda Fiera » venerdì 8 gennaio 2010, 16:50

Ok.
Mic abilitato anche per me!!!!  ;D

Per la retroilluminazione, sembra un pò più rognosa, provo anche io e ti faccio sapere.
Avatar utente
Fiera Non specificato
Prode Principiante
 
Messaggi: 70
Iscrizione: gennaio 2008

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda Fiera » venerdì 8 gennaio 2010, 17:06

Ah .... per evitare che ad ogni boot si debba aprire alsamixer e settare le impostazioni adatte al microfono segui questa guida, è l'ultimo post dello stesso thread:

Risolvo il problema di impostare di default il microfono interno:
1) Aprire il terminale e dare il comando:
Codice:

alsamixer

2) settare tutti i parametri desiderati: microfono predefinito (Int Mic), livelli, canali mutati/non mutati, etc...
3) Dare il comando:
Codice:

sudo alsactl store

4) Andare in "Sistema-->Preferenze-->Applicazioni d'avvio", nella scheda "Programmi d'avvio" premere "Aggiungi", impostare la voce "Comando" con:
Codice:

alsactl restore

5) Settare le voci "Nome" e "Commento" a proprio piacimento e cliccare su "Salva".

Chiudere tutto, riavviare: ora il microfono di default sarà quello interno!!!  Good

Ringraziamo 4javier che mi ha suggerito qui la soluzione che vi riporto.  Grin

Ciuaz
Avatar utente
Fiera Non specificato
Prode Principiante
 
Messaggi: 70
Iscrizione: gennaio 2008

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda castigamatti81 » venerdì 8 gennaio 2010, 17:30

Ottimo!!!  (good)
D.M.C. & MaleDucati - Italian Street Riders
Sfidatemi!!!: http://castigamatti81.mybrute.com
Avatar utente
castigamatti81 Non specificato
Prode Principiante
 
Messaggi: 118
Iscrizione: gennaio 2008

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda Fiera » venerdì 8 gennaio 2010, 17:44

Per la luminosità non ha funzionato neanche a me.

Mi sono accorto che all'interno della cartella /etc/acpi/events ci sono dei file simili a quelli che creiamo noi nella procedura solo che si chiamano asus-brightness-up, asus-brightness-down.

Mi viene il sospetto che vadano sostituiti, ma non oso toccarli, dovrei farlo in modalità root e preferisco chiedere ad altri più esperti prima di procedere.

Forse siamo sulla buona strada per la soluzione.
Avatar utente
Fiera Non specificato
Prode Principiante
 
Messaggi: 70
Iscrizione: gennaio 2008

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda Fiera » venerdì 8 gennaio 2010, 18:12

Ho trovato questo thread piuttosto vecchio che dà vari consigli con diverse procedure sulla configurazione manuale dei tasti: http://forum.ubuntu-it.org/viewtopic.php?t=136038
Non mi convince moltissimo.

Qui invece si parla di un interfaccia particolare per la precisione dell'interfaccia spicctrl : http://forum.ubuntu-it.org/viewtopic.php?t=136038

Sullo spicctrl forse c'è qualche spiegazione googlando un pò qui: http://linux.die.net/man/1/spicctrl
Avatar utente
Fiera Non specificato
Prode Principiante
 
Messaggi: 70
Iscrizione: gennaio 2008

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda castigamatti81 » venerdì 8 gennaio 2010, 18:21

Fiera ha scritto:Per la luminosità non ha funzionato neanche a me.

Mi sono accorto che all'interno della cartella /etc/acpi/events ci sono dei file simili a quelli che creiamo noi nella procedura solo che si chiamano asus-brightness-up, asus-brightness-down.

Mi viene il sospetto che vadano sostituiti, ma non oso toccarli, dovrei farlo in modalità root e preferisco chiedere ad altri più esperti prima di procedere.

Forse siamo sulla buona strada per la soluzione.

OT
fiera per le varie procedure da root (copia,incolla,rinomina ecc.) io ho seguito questa breve guida che mi permette di fare tutto direttamente da nautilus...senza dover scrivere tutto da terminale. http://www.filippo.panzera.name/wordpre ... ntu-linux/
Almeno a me ha semplificato non poco le varie procedure  :-[
D.M.C. & MaleDucati - Italian Street Riders
Sfidatemi!!!: http://castigamatti81.mybrute.com
Avatar utente
castigamatti81 Non specificato
Prode Principiante
 
Messaggi: 118
Iscrizione: gennaio 2008

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda Fiera » venerdì 8 gennaio 2010, 18:35

Si oppure semplicemente sul terminale digiti:
sudo nautilus

Ti apre la schermata grafica ma in modalità root.
Puoi operare direttamente da schermo ma devi essere consapevole che stai operando da root, quindi va fatto con un pò di accortezza in più rispetto ai normali copia/incolla e altro che si fanno.
Avatar utente
Fiera Non specificato
Prode Principiante
 
Messaggi: 70
Iscrizione: gennaio 2008

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda crystal86 » sabato 9 gennaio 2010, 20:35

grazie mille per questo post...ora microfono e video vanno alla grande!
Avatar utente
crystal86 Non specificato
Prode Principiante
 
Messaggi: 83
Iscrizione: agosto 2006

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda castigamatti81 » domenica 10 gennaio 2010, 17:02

Amici ho un altro problemino, ora vorrei capire se riguarda solo me (come penso).
In pratica alcuni video online in flash non riesco a vederli, quando clicco su lay non succede nulla.
Il video mostrato qui è un esempio: http://www.androidworld.it/?p=9833&utm_ ... gle+Reader

Voi riuscite a vederlo?
D.M.C. & MaleDucati - Italian Street Riders
Sfidatemi!!!: http://castigamatti81.mybrute.com
Avatar utente
castigamatti81 Non specificato
Prode Principiante
 
Messaggi: 118
Iscrizione: gennaio 2008

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda icabus » domenica 10 gennaio 2010, 17:25

Ciao castigamatti81, colgo l'occasione di ringraziare te e Fiera per le novità sul microfono e per il vostro aiuto. In questo caso spero di esserti d'aiuto io  :) inizialmente anche io avevo problemi con il pluginflash, avevo installato il non-free da repository. In seguito ho seguito l'indicazione di Janvitus in questo thread : http://forum.ubuntu-it.org/viewtopic.php?t=335197 e tutto si è sistemato  (good)
icabus Non specificato
Prode Principiante
 
Messaggi: 23
Iscrizione: giugno 2009

Re: Sony Vaio CW - Problemi e Soluzioni.

Messaggioda castigamatti81 » domenica 10 gennaio 2010, 17:56

icabus ha scritto:Ciao castigamatti81, colgo l'occasione di ringraziare te e Fiera per le novità sul microfono e per il vostro aiuto. In questo caso spero di esserti d'aiuto io  :) inizialmente anche io avevo problemi con il pluginflash, avevo installato il non-free da repository. In seguito ho seguito l'indicazione di Janvitus in questo thread : http://forum.ubuntu-it.org/viewtopic.php?t=335197 e tutto si è sistemato  (good)


Grande!!! Risolto anche questo problema.
Denghiu.  ;)
D.M.C. & MaleDucati - Italian Street Riders
Sfidatemi!!!: http://castigamatti81.mybrute.com
Avatar utente
castigamatti81 Non specificato
Prode Principiante
 
Messaggi: 118
Iscrizione: gennaio 2008

Successiva

Torna a Ubuntu su portatili

Chi c’è in linea

Visualizzano questa sezione: Google Feedfetcher e 4 ospiti