Notizia:
  • Rilasciata Ubuntu 14.04 LTS Trusty Tahr. Per ottenerla, visitate questa pagina oppure visualizzate la dimostrazione.
  • È uscito il numero 16 della Newsletter italiana di Ubuntu. Lo trovate a questo indirizzo.
  • È uscito il numero 79 di Full Circle Magazine in italiano. Lo trovate a questo indirizzo.

Beryl GIT (ex SVN) in pacchetti quotidiani (o quasi...)

Configurazione e uso dell'interfaccia utente predefinita di Ubuntu.

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda telperion » martedì 20 febbraio 2007, 21:30

Treviño ha scritto::o


E si cavolo, controlla di piu sto repository
un giorno si e l'altro pure è pieno di gente che non gli funziona questo o quello.

Buttalo via sto script del piffero che ti fa i pacchetti.
Avatar utente
telperion Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4997
Iscrizione: luglio 2006

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda fededs83 » martedì 20 febbraio 2007, 21:55

non voglio fare polemica, ma mi sembra fuori luogo prendersela con trevino; lo si sa che installando queste versioni ufficiose si corrono dei rischi quindi lo si fa a nostro rischio e pericolo..... ;)
Fede
fededs83 Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 480
Iscrizione: agosto 2006

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda telperion » martedì 20 febbraio 2007, 22:10

fededs83 ha scritto:non voglio fare polemica, ma mi sembra fuori luogo prendersela con trevino; lo si sa che installando queste versioni ufficiose si corrono dei rischi quindi lo si fa a nostro rischio e pericolo..... ;)
Fede


Mica polemica, io vorrei una maggiore qualità punto.
http://forum.ubuntu-it.org/viewtopic.ph ... 94#p366894
per i dettagli.
;D
Avatar utente
telperion Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4997
Iscrizione: luglio 2006

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda robren66 » mercoledì 21 febbraio 2007, 4:18

a me beryl funziona bene con i repo di trevino!!!! (b2b)
Avatar utente
robren66 Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 813
Iscrizione: settembre 2005
Località: sevilla

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda seawolf » mercoledì 21 febbraio 2007, 5:15

Sempre funzionato bene dal lontano mese di ottobre 06  ;D
continua così Treviño  (b2b)
seawolf
 

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda barker_cry » mercoledì 21 febbraio 2007, 7:40

Io ho dovuto mettere la versione di telperion... 
Avatar utente
barker_cry Non specificato
Prode Principiante
 
Messaggi: 139
Iscrizione: giugno 2006

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda aldolat » mercoledì 21 febbraio 2007, 8:10

Confermo che non ho mai avuto problemi coi repo di Trevino, a parte ieri; ma si sa, non sono pacchetti ufficiali.
Continua Trevino, non ti fermare.
Per avere il pieno valore della conoscenza ci vuole qualcuno col quale condividerla.
Avatar utente
aldolat Maschile
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 506
Iscrizione: agosto 2006
Località: Augusta (Siracusa)
Distribuzione: Ubuntu 13.04 (i686)
Desktop: KDE

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda frank_mackey » mercoledì 21 febbraio 2007, 8:40

frank_mackey ha scritto:Da qualche giorno a questa parte, credo in seguito a qualche update, beryl si blocca quando esce il riquadro con la richiesta di password degli aggiornamenti di ubuntu. Stessa cosa se apro synaptic. Crasha fisso e devo riavviare gnome con ctrl+alt+del.
Con metacity non succede.


Risolto...
Ho cancellato la cartella nascosta .beryl e rifatto tutti i settaggi (che palle!:)). Problema sparito. Evidentemente qualcosa si era corrotto.
Dreambox 7020S / 500S - Ubuntu Feisty + Beryl
Avatar utente
frank_mackey Non specificato
Prode Principiante
 
Messaggi: 63
Iscrizione: novembre 2006
Località: * Salento *

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda fededs83 » mercoledì 21 febbraio 2007, 10:57

ok, ho capito il motivo "della lamentela", in ogni modo ognuno contribuisce in modi diversi al bene della comunità e penso che quello che trevino faccia sia encomiabile......propongo questo: mettiamo in risalto che le versioni di trevino siano instabili e sottelineamo le due possibilità che ci sono: trevino con features più tempestive e aggiornate con possibilità di bug reporting, teleperion con meno aggiornamenti, ma con più stabilità.....
Fede
fededs83 Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 480
Iscrizione: agosto 2006

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda Treviño » mercoledì 21 febbraio 2007, 17:24

E se volete un repo unstable ma non troppo c'è già: http://unstable.beryl-project.org/

Resta il fatto che io butto quello che l'svn offre, se teleperion compilasse le stesse version svn (non solo del core ma anche del resto) alle mie avreste esattamente la stessa roba, quindi per favore non facciamo polemiche senza ALCUNA base tecnica.

Comunque sia, il problema dello schermo bianco non è dipendente da me, visto che io applico solo alcune patch in automatico (tipo, alcune per la compatibilità con feisty e per avere gli effetti lampada di aladino OSX-like) oltre ad inserire anche plugin extra (come il widget e lo screensaver ed altri presenti nelle branches dell'svn), ma dipende da esclusivamente da Xgl.

Un workaround pare essere quello di lanciare questo comando (downgrade di Xgl):
Codice: Seleziona tutto
sudo apt-get install xserver-xgl=7.0.0.git.20060725-0ubuntu2

Altri invece hanno rammentato che funziona anche il preload della libreria Ati, ma non posso confermare direttamente nessuna delle due soluzioni.

Usando AiGLX non sono stato in grado di notare questo bug durante i test pre-upload, visto che il mio script (e servono davvero poche conoscenze di bash per capirlo) non fa molto altro oltre a compilare e pacchettizzare il tutto, quindi per favore... Prima di offendere il lavoro altrui studiamolo e nel caso correggiamolo come l'oss insegna piuttosto che comportarsi in modo distruttivo.

Di fare flame inutili me ne frega il giusto quindi, usate cosa vi pare... Tra le decine di migliaia di utenti che ci sono ogni giorno non ci sono tutti questi "malcontenti", quindi per me finisce qui (spero).

PS: Non ho mai definito questo «Un repo per tutti», ma mi pare sostanzialmente usabile, al di là di piccole crucce che ci possono essere per definizione.
Avatar utente
Treviño Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 280
Iscrizione: gennaio 2006
Località: Treviño's World

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda l3on » mercoledì 21 febbraio 2007, 17:36

Treviño per favore inserisci un avviso nel primo post, in cui affermi che i tuoi pacchetti hanno problemi con XGL (o che xgl ha problemi...)!! (utilizzo anche io Xgl e ho riscontrato gli stessi errori di altri).

Dai un occhiata per esempio a questo wiki: http://wiki.ubuntu-it.org/XglBeryl (scritto da me): i tuoi repo sono inseriti, ma c'e' un avviso enorme che scoraggia i n00bs...

Nessuno ti vuole male, il tuo lavoro è eccellente, ma è vero: ci sono molte persone che lamento mal funzionamenti!... Se avessi specificato qualcosina in piu' (come ad esempio l'uso di AiGLX) magari qualcuno avrebbe pensato due volte prima di aggiungere i tuoi repo.

Ciao,
Leo.
Pagina Personale sul Wiki - Sito Personale - Blog | `l3on @ ubuntu.com`

Membro del Consiglio, Sysadmin e Web-Designer dei portali della comunità, Amministratore del Sito e tante altre cose... Con Ubuntu-it dal maggio del 2006.
Avatar utente
l3on Non specificato
Gruppo Web
Gruppo Web
 
Messaggi: 6443
Iscrizione: maggio 2006
Località: Bologna

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda Treviño » mercoledì 21 febbraio 2007, 17:46

L3oN ha scritto: Treviño per favore inserisci un avviso nel primo post, in cui affermi che i tuoi pacchetti hanno problemi con XGL (o che xgl ha problemi...)!! (utilizzo anche io Xgl e ho riscontrato gli stessi errori di altri).

Dai un occhiata per esempio a questo wiki: http://wiki.ubuntu-it.org/XglBeryl (scritto da me): i tuoi repo sono inseriti, ma c'e' un avviso enorme che scoraggia i n00bs...

Nessuno ti vuole male, il tuo lavoro è eccellente, ma è vero: ci sono molte persone che lamento mal funzionamenti!... Se avessi specificato qualcosina in piu' (come ad esempio l'uso di AiGLX) magari qualcuno avrebbe pensato due volte prima di aggiungere i tuoi repo.

Ciao,
Leo.
Considerando che questo errore esiste solo da ieri, non era il caso di mettere prima un avviso visto che normalmente il repository funziona correttamente per tutti, Xgl o no...

Tra l'altro a quanto mi hanno riportato anche la versione ufficiale aveva questo problema (e passando al mio repo si risolveva), tutto fino a ieri... Visto che pare siano state fatte modifiche non esattamente funzionanti (o per lo meno, non del tutto).
Avatar utente
Treviño Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 280
Iscrizione: gennaio 2006
Località: Treviño's World

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda l3on » mercoledì 21 febbraio 2007, 22:29

Treviño nessun problema...  ;)
Pagina Personale sul Wiki - Sito Personale - Blog | `l3on @ ubuntu.com`

Membro del Consiglio, Sysadmin e Web-Designer dei portali della comunità, Amministratore del Sito e tante altre cose... Con Ubuntu-it dal maggio del 2006.
Avatar utente
l3on Non specificato
Gruppo Web
Gruppo Web
 
Messaggi: 6443
Iscrizione: maggio 2006
Località: Bologna

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda aldolat » mercoledì 21 febbraio 2007, 22:53

Treviño ha scritto:Tra l'altro a quanto mi hanno riportato anche la versione ufficiale aveva questo problema (e passando al mio repo si risolveva), tutto fino a ieri... Visto che pare siano state fatte modifiche non esattamente funzionanti (o per lo meno, non del tutto).


Confermo, vista la mia esperienza e degli utenti del mio blog: passando ai pacchetti di Treviño risolvevano i loro problemi.

[edit]
Un workaround pare essere quello di lanciare questo comando (downgrade di Xgl):
Codice:
Codice: Seleziona tutto
sudo apt-get install xserver-xgl=7.0.0.git.20060725-0ubuntu2


Niente, non va.
Caspita, funzionava che era una meraviglia. Si era risolto pure il problema della lentezza dello scrolling di Firefox e tutto il desktop era un bijoux! Vabbè... pazienza. Attendiamo.

Purtroppo nella mia cache non ho i pacchetti antecedenti a quel malaugurato update.
E' possibile recuperarli da qualche parte, in modo da ripristinare lo stato di quel momento?
Ultima modifica di aldolat il mercoledì 21 febbraio 2007, 23:15, modificato 1 volta in totale.
Per avere il pieno valore della conoscenza ci vuole qualcuno col quale condividerla.
Avatar utente
aldolat Maschile
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 506
Iscrizione: agosto 2006
Località: Augusta (Siracusa)
Distribuzione: Ubuntu 13.04 (i686)
Desktop: KDE

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda Treviño » giovedì 22 febbraio 2007, 0:16

Potete scaricare i pacchetti precedenti da:
- http://download.tuxfamily.org/3v1deb/po ... /beryl-svn

Vi basta downgradare il core ;) (per ora QUESTO funziona ancora ;))
Avatar utente
Treviño Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 280
Iscrizione: gennaio 2006
Località: Treviño's World

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda AleXit » giovedì 22 febbraio 2007, 1:51

Treviño ha scritto:Potete scaricare i pacchetti precedenti da:
- http://download.tuxfamily.org/3v1deb/po ... /beryl-svn

Vi basta downgradare il core ;) (per ora QUESTO funziona ancora ;))
Confermo. Installando la versione precedente di beryl-core tutto torna a funzionare ;)
Grazie!
Avatar utente
AleXit Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3110
Iscrizione: gennaio 2006
Località: Firenze // Castel San Niccolò (Ar)

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda aldolat » giovedì 22 febbraio 2007, 7:57

Treviño ha scritto:Potete scaricare i pacchetti precedenti da:
- http://download.tuxfamily.org/3v1deb/po ... /beryl-svn

Vi basta downgradare il core ;) (per ora QUESTO funziona ancora ;))


Confermo anch'io: funziona. Grazie Treviño! ;)
Dunque il problema era Beryl e non Xgl, giusto Treviño?
Per avere il pieno valore della conoscenza ci vuole qualcuno col quale condividerla.
Avatar utente
aldolat Maschile
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 506
Iscrizione: agosto 2006
Località: Augusta (Siracusa)
Distribuzione: Ubuntu 13.04 (i686)
Desktop: KDE

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda Flavio Meazza » giovedì 22 febbraio 2007, 10:47

aldolat ha scritto:
Treviño ha scritto:Potete scaricare i pacchetti precedenti da:
- http://download.tuxfamily.org/3v1deb/po ... /beryl-svn

Vi basta downgradare il core ;) (per ora QUESTO funziona ancora ;))


Confermo trevino, il problema è proprio beryl-core.

Come facciamo a sapere quando sarà possibile riaggiornare ancora beryl-core?
Acer Aspire 3022 WLMI 1 GB RAM - Ubuntu7.10 Gutsy Gibbon
Avatar utente
Flavio Meazza Non specificato
Prode Principiante
 
Messaggi: 143
Iscrizione: agosto 2006
Località: MI

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda lordnisse » giovedì 22 febbraio 2007, 11:40

Trevino hai tutta la mia solidarietà.
Non puoi certo essere sicuro che i tuoi pacchetti funzionino con ogni configurazione, e non mi pare che la scritta SPERIMENTALE che si trova più o meno ovunque cercando i tuoi repository lasci dubbio all'interpretazione.
Ad ogni modo il problema l'ho visto presentarsi finora solo con ATI & Xgl ed è abbastanza risolvibile modificando nel menù delle impostazioni il Rendering Path da Automatico a Copia.
Questa opzione rallenta abbastanza beryl, tutto sommato rimane ancora utilizzabile con schede abbastanza recenti.
lordnisse Non specificato
Prode Principiante
 
Messaggi: 48
Iscrizione: giugno 2006

Re: Beryl svn in pacchetti quotidiani (o quasi...)

Messaggioda fobiah » giovedì 22 febbraio 2007, 19:29

Ciao ragazzi, anch'io ho avuto diversi problemi con beryl e xgl, ed ho in parte risolto forzando la versione precedente di beryl-core. Tuttavia ho un altro grosso problema: il plugin del cubo non funziona: se provo ad attivarlo dal menù di beryl dopo 2 secondi il sistema passa a metacity e nn c'è verso di tornare a beryl se prima non si è tolta l'opzione del cubo. C'è qualche rimedio per caso? dimenticavo: ho una scheda nvidia 7600...
Avatar utente
fobiah Non specificato
Prode Principiante
 
Messaggi: 22
Iscrizione: maggio 2006

PrecedenteSuccessiva

Torna a Unity

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 0 ospiti