Notizia:
  • Rilasciata Ubuntu 14.04 LTS Trusty Tahr. Per ottenerla, visitate questa pagina oppure visualizzate la dimostrazione.
  • È uscito il numero 26 della Newsletter italiana di Ubuntu. Lo trovate a questo indirizzo.
  • È uscito il numero 80 di Full Circle Magazine in italiano. Lo trovate a questo indirizzo.

[Risolto] chromium, flash obsoleto

Installazione, configurazione e utilizzo di applicativi multimediali, masterizzazione, acquisizione e codec audio/video, streaming, ecc.

[Risolto] chromium, flash obsoleto

Messaggioda battaman » lunedì 5 marzo 2012, 22:03

ciao a tutti, ho visto che è un argomento pluritrattato e ho provato a seguire più di un topic per provare a risolvere..ma niente da fare.

Ho ubuntu 11.10  con installato chromium.
Da un paio di settimane mi appare l'avviso che il plug in di flash player è obsoleto.

Ho provato dapprima a seguire il link dell aggiornamento dal sito adobe, non ha funzionato e ho cominciato a smanettare dal gestore pacchetti..niente da fare...disintallato e reinstallato in mille modi diversi ma non cambia nulla.

Mi basterebbe anche solo eliminare l'avviso e tenere la vecchia versione, che tanto mi andava benone  (mad)

cosa può essere andato storto?
Ultima modifica di battaman il martedì 13 marzo 2012, 19:42, modificato 1 volta in totale.
battaman Non specificato
Prode Principiante
 
Messaggi: 111
Iscrizione: ottobre 2007

Re: chromium, flash obsoleto

Messaggioda PamPam » martedì 6 marzo 2012, 12:01

Io ho seguito questo consiglio e ho risolto
http://it.paperblog.com/chromium-o-chro ... ux-869502/
PamPam Non specificato
Prode Principiante
 
Messaggi: 1
Iscrizione: novembre 2009

Re: chromium, flash obsoleto

Messaggioda battaman » mercoledì 7 marzo 2012, 20:28

niente da fare.
Io ho scaricato la versione 32 bit in quanto ho installato ubuntu 32bit.
La cartella non esisteva, forse perchè avevo provato a disinstallare tutto, così l'ho creata
battaman Non specificato
Prode Principiante
 
Messaggi: 111
Iscrizione: ottobre 2007

Re: chromium, flash obsoleto

Messaggioda battaman » domenica 11 marzo 2012, 21:43

possibile che solo io non riesco a risolvere il problema?
battaman Non specificato
Prode Principiante
 
Messaggi: 111
Iscrizione: ottobre 2007

Re: chromium, flash obsoleto

Messaggioda GatoLopez70 » domenica 11 marzo 2012, 21:55

Dai a terminale:
Codice: Seleziona tutto
sudo updatedb

poi
Codice: Seleziona tutto
locate libflash
RevolutionOS per non dimenticare chi siamo...
If the doors of perception were cleansed, everything would appear to man as it truly is, infinite. (W. Blake)
Avatar utente
GatoLopez70 Maschile
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2371
Iscrizione: gennaio 2009
Località: Cagliari
Distribuzione: ubuntu 12.04
Desktop: KDE

Re: chromium, flash obsoleto

Messaggioda battaman » domenica 11 marzo 2012, 22:35

ce n'è quanti ne vuoi

/home/batta/libflashplayer.so
/home/batta/.local/share/Trash/files/libflashplayer.2.so
/home/batta/.local/share/Trash/files/libflashplayer.so
/home/batta/.local/share/Trash/info/libflashplayer.2.so.trashinfo
/home/batta/.local/share/Trash/info/libflashplayer.so.trashinfo
/home/batta/.mozilla/plugins/libflashplayer.so
/home/batta/Scaricati/install_flash_player_10_linux/libflashplayer.so
/home/batta/usr/libflashplayer.so
/usr/lib/adobe-flashplugin/libflashplayer.so
/usr/lib/chromium-browser/plugins/libflashplayer.so
/usr/lib/libreoffice/basis3.4/program/libflashli.so
battaman Non specificato
Prode Principiante
 
Messaggi: 111
Iscrizione: ottobre 2007

Re: chromium, flash obsoleto

Messaggioda Carlin0 » domenica 11 marzo 2012, 22:37

Hai mica installato gnash o swfdec ?

Codice: Seleziona tutto
dpkg -l | grep gnash
dpkg -l | grep swf
Carlin0 Maschile
Rampante Reduce
Rampante Reduce
 
Messaggi: 7453
Iscrizione: novembre 2009
Località: Augusta Taurinorum
Distribuzione: Debian Squeeze
Desktop: Gnome 2.30.2

Re: chromium, flash obsoleto

Messaggioda GatoLopez70 » domenica 11 marzo 2012, 23:04

Codice: Seleziona tutto
sudo cp /usr/lib/adobe-flashplugin/libflashplayer.so /usr/lib/chromium-browser/plugins


se vuoi creare un link tra il file libflashplayer.so della cartella /adobe-flashplugin con la cartella /plugins di chromium-browser in modo da tenere tale file sempre aggiornato...
dopo aver rimosso (o rinominato) il file libflashplayer.so della cartella di chromium crea un link:

Codice: Seleziona tutto
sudo ln -s /usr/lib/adobe-flashplugin/libflashplayer.so /usr/lib/chromium-browser/plugins


Se invece ti va di fare a manina da interfaccia grafica:
Codice: Seleziona tutto
sudo nautilus

copi i file, crei i link che ti occorrono etc...
Stai attento a quello che fai con questo comando perchè ti da accesso in scrittura alla maggior parte dei file di /system (tutti quelli che non hanno l'attributo "immutabile").

Ovviamente fai anche la verifica che ti ha suggerito Carlin0.
Per sicurezza apri una nuova TAB del browser e dai:
Codice: Seleziona tutto
about:plugins

posta il risultato.
RevolutionOS per non dimenticare chi siamo...
If the doors of perception were cleansed, everything would appear to man as it truly is, infinite. (W. Blake)
Avatar utente
GatoLopez70 Maschile
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2371
Iscrizione: gennaio 2009
Località: Cagliari
Distribuzione: ubuntu 12.04
Desktop: KDE

Re: chromium, flash obsoleto

Messaggioda battaman » lunedì 12 marzo 2012, 20:32

ho copia incollato quanto postato da carlin0 ma non ho capito cosa dovrei ottenere...il terminale non ha fatto nulla.

sappiate che sono un po niubbo con ubuntu!

ho guardato i plugins:

Codice: Seleziona tutto
Remoting Viewer
Nome:   Remoting Viewer
Versione:   
Percorso:   internal-remoting-viewer
Tipo:   PPAPI (in-process)
     Disabilita
Tipi MIME:   
Tipo MIME   Descrizione   Estensioni file
application/vnd.chromium.remoting-viewer      
.
pepper-application/x-chromoting      
.
Disabilita   Consenti
Flash (3 files) - Versione: 10.2 r159 Scarica aggiornamento della protezione ad alta priorità
Shockwave Flash 10.2 r159
Nome:   Shockwave Flash
Versione:   10.2 r159
Percorso:   /usr/lib/chromium-browser/plugins/libflashplayer.so
Tipo:   NPAPI
     Disabilita
Tipi MIME:   
Tipo MIME   Descrizione   Estensioni file
application/x-shockwave-flash   Shockwave Flash   
.swf
application/futuresplash   FutureSplash Player   
.spl
Nome:   Shockwave Flash
Versione:   11.1 r102
Percorso:   /home/batta/.mozilla/plugins/libflashplayer.so
Tipo:   NPAPI
     Disabilita
Tipi MIME:   
Tipo MIME   Descrizione   Estensioni file
application/x-shockwave-flash   Shockwave Flash   
.swf
application/futuresplash   FutureSplash Player   
.spl
Nome:   Shockwave Flash
Versione:   11.1 r102
Percorso:   /usr/lib/adobe-flashplugin/libflashplayer.so
Tipo:   NPAPI
     Disabilita
Tipi MIME:   
Tipo MIME   Descrizione   Estensioni file
application/x-shockwave-flash   Shockwave Flash   
.swf
application/futuresplash   FutureSplash Player   
.spl
Disabilita   Consenti
IcedTea-Web Plugin (using IcedTea-Web 1.1.3 (1.1.3-1ubuntu1.1))
The IcedTea-Web Plugin executes Java applets.
Nome:   IcedTea-Web Plugin (using IcedTea-Web 1.1.3 (1.1.3-1ubuntu1.1))
Descrizione:   The IcedTea-Web Plugin executes Java applets.
Versione:   
Percorso:   /usr/lib/jvm/java-6-openjdk/jre/lib/i386/IcedTeaPlugin.so
Tipo:   NPAPI
     Disabilita
Tipi MIME:   
Tipo MIME   Descrizione   Estensioni file
application/x-java-vm   IcedTea   
.class   .jar
application/x-java-applet   IcedTea   
.class   .jar
application/x-java-applet;version=1.1   IcedTea   
.class   .jar
application/x-java-applet;version=1.1.1   IcedTea   
.class   .jar
application/x-java-applet;version=1.1.2   IcedTea   
.class   .jar
application/x-java-applet;version=1.1.3   IcedTea   
.class   .jar
application/x-java-applet;version=1.2   IcedTea   
.class   .jar
application/x-java-applet;version=1.2.1   IcedTea   
.class   .jar
application/x-java-applet;version=1.2.2   IcedTea   
.class   .jar
application/x-java-applet;version=1.3   IcedTea   
.class   .jar
application/x-java-applet;version=1.3.1   IcedTea   
.class   .jar
application/x-java-applet;version=1.4   IcedTea   
.class   .jar
application/x-java-applet;version=1.4.1   IcedTea   
.class   .jar
application/x-java-applet;version=1.4.2   IcedTea   
.class   .jar
application/x-java-applet;version=1.5   IcedTea   
.class   .jar
application/x-java-applet;version=1.6   IcedTea   
.class   .jar
application/x-java-applet;jpi-version=1.6.0_50   IcedTea   
.class   .jar
application/x-java-bean   IcedTea   
.class   .jar
application/x-java-bean;version=1.1   IcedTea   
.class   .jar
application/x-java-bean;version=1.1.1   IcedTea   
.class   .jar
application/x-java-bean;version=1.1.2   IcedTea   
.class   .jar
application/x-java-bean;version=1.1.3   IcedTea   
.class   .jar
application/x-java-bean;version=1.2   IcedTea   
.class   .jar
application/x-java-bean;version=1.2.1   IcedTea   
.class   .jar
application/x-java-bean;version=1.2.2   IcedTea   
.class   .jar
application/x-java-bean;version=1.3   IcedTea   
.class   .jar
application/x-java-bean;version=1.3.1   IcedTea   
.class   .jar
application/x-java-bean;version=1.4   IcedTea   
.class   .jar
application/x-java-bean;version=1.4.1   IcedTea   
.class   .jar
application/x-java-bean;version=1.4.2   IcedTea   
.class   .jar
application/x-java-bean;version=1.5   IcedTea   
.class   .jar
application/x-java-bean;version=1.6   IcedTea   
.class   .jar
application/x-java-bean;jpi-version=1.6.0_50   IcedTea   
.class   .jar
application/x-java-vm-npruntime   IcedTea   
.
Disabilita   Consenti
VLC Multimedia Plugin (compatible Totem 3.0.1)
The Totem 3.0.1 plugin handles video and audio streams.
Nome:   VLC Multimedia Plugin (compatible Totem 3.0.1)
Descrizione:   The Totem 3.0.1 plugin handles video and audio streams.
Versione:   
Percorso:   /usr/lib/mozilla/plugins/libtotem-cone-plugin.so
Tipo:   NPAPI
     Disabilita
Tipi MIME:   
Tipo MIME   Descrizione   Estensioni file
application/x-vlc-plugin   VLC Multimedia Plugin   
.
application/vlc   VLC Multimedia Plugin   
.
video/x-google-vlc-plugin   VLC Multimedia Plugin   
.
application/x-ogg   File multimediale Ogg   
.ogg
application/ogg   File multimediale Ogg   
.ogg
audio/ogg   Audio Ogg   
.oga
audio/x-ogg   Audio Ogg   
.ogg
video/ogg   Video Ogg   
.ogv
video/x-ogg   Video Ogg   
.ogg
application/annodex   Formato di scambio Annodex   
.anx
audio/annodex   Audio Annodex   
.axa
video/annodex   Video Annodex   
.axv
video/mpeg   Video MPEG   
.mpg   .mpeg   .mpe
audio/wav   Audio WAV   
.wav
audio/x-wav   Audio WAV   
.wav
audio/mpeg   Audio MP3   
.mp3
application/x-nsv-vp3-mp3   Video NullSoft   
.nsv
video/flv   Video Flash   
.flv
video/webm   Video WebM   
.webm
application/x-totem-plugin   Totem Multimedia plugin   
.
audio/midi   Audio MIDI   
.mid   .midi
Disabilita   Consenti
Windows Media Player Plug-in 10 (compatible; Totem)
The Totem 3.0.1 plugin handles video and audio streams.
Nome:   Windows Media Player Plug-in 10 (compatible; Totem)
Descrizione:   The Totem 3.0.1 plugin handles video and audio streams.
Versione:   
Percorso:   /usr/lib/mozilla/plugins/libtotem-gmp-plugin.so
Tipo:   NPAPI
     Disabilita
Tipi MIME:   
Tipo MIME   Descrizione   Estensioni file
application/x-mplayer2   Video AVI   
.avi   .wma   .wmv
video/x-ms-asf-plugin   Video ASF   
.asf   .wmv
video/x-msvideo   Video AVI   
.asf   .wmv
video/x-ms-asf   Video ASF   
.asf
video/x-ms-wmv   Video Windows Media   
.wmv
video/x-wmv   Video Windows Media   
.wmv
video/x-ms-wvx   Video Windows Media   
.wmv
video/x-ms-wm   Video Windows Media   
.wmv
video/x-ms-wmp   Video Windows Media   
.wmv
application/x-ms-wms   Video Windows Media   
.wms
application/x-ms-wmp   Video Windows Media   
.wmp
application/asx   Scaletta Microsoft ASX   
.asx
audio/x-ms-wma   Audio Windows Media   
.wma
Disabilita   Consenti
DivX® Web Player
DivX Web Player version 1.4.0.233
Nome:   DivX® Web Player
Descrizione:   DivX Web Player version 1.4.0.233
Versione:   
Percorso:   /usr/lib/mozilla/plugins/libtotem-mully-plugin.so
Tipo:   NPAPI
     Disabilita
Tipi MIME:   
Tipo MIME   Descrizione   Estensioni file
video/divx   Video AVI   
.divx
Disabilita   Consenti
QuickTime Plug-in 7.6.6
The Totem 3.0.1 plugin handles video and audio streams.
Nome:   QuickTime Plug-in 7.6.6
Descrizione:   The Totem 3.0.1 plugin handles video and audio streams.
Versione:   
Percorso:   /usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so
Tipo:   NPAPI
     Disabilita
Tipi MIME:   
Tipo MIME   Descrizione   Estensioni file
video/quicktime   Video QuickTime   
.mov
video/mp4   Video MPEG-4   
.mp4
image/x-macpaint   Immagine Bitmap MacPaint   
.pntg
image/x-quicktime   Disegno Macintosh Quickdraw/PICT   
.pict   .pict1   .pict2
video/x-m4v   Video MPEG-4   
.m4v
Disabilita   Consenti


non ho invece capito bene quello che mi hai descritto per fare il collegamento...dovrebbe risolvere il problema?
battaman Non specificato
Prode Principiante
 
Messaggi: 111
Iscrizione: ottobre 2007

Re: chromium, flash obsoleto

Messaggioda battaman » lunedì 12 marzo 2012, 20:38

e altra domandona: perchè ho un file usr/lib/kde4/kcm_adobe_flash_player.so  ??? non ho cartelle di adobe da queste parti
battaman Non specificato
Prode Principiante
 
Messaggi: 111
Iscrizione: ottobre 2007

Re: chromium, flash obsoleto

Messaggioda GatoLopez70 » lunedì 12 marzo 2012, 20:42

battaman ha scritto:ho copia incollato quanto postato da carlin0 ma non ho capito cosa dovrei ottenere...il terminale non ha fatto nulla.

Vuol dire solo che non hai nè swfdec nè gnash istallati. Bene.


Codice: Seleziona tutto

Shockwave Flash 10.2 r159
Nome:   Shockwave Flash
Versione:   10.2 r159
Percorso:   /usr/lib/chromium-browser/plugins/libflashplayer.so

Versione:   11.1 r102
Percorso:   /home/batta/.mozilla/plugins/libflashplayer.so

Versione:   11.1 r102
Percorso:   /usr/lib/adobe-flashplugin/libflashplayer.so

Come vedi Firefox e Adobe-flashplayer hanno la stessa versione di libflashplayer.so più recente rispetto alla versione che usa chromium.

non ho invece capito bene quello che mi hai descritto per fare il collegamento...dovrebbe risolvere il problema?

Sicchè dai a terminale:
Codice: Seleziona tutto
sudo nautilus

e copi il file che trovi in questa cartella:
Codice: Seleziona tutto
/usr/lib/adobe-flashplugin/libflashplayer.so

nella cartella dei plugin di chromium:
Codice: Seleziona tutto
/usr/lib/chromium-browser/plugins


Oppure dai questo comando a terminale e fa tutto lui:
Codice: Seleziona tutto
sudo cp /usr/lib/adobe-flashplugin/libflashplayer.so /usr/lib/chromium-browser/plugins
Ultima modifica di GatoLopez70 il lunedì 12 marzo 2012, 21:04, modificato 1 volta in totale.
RevolutionOS per non dimenticare chi siamo...
If the doors of perception were cleansed, everything would appear to man as it truly is, infinite. (W. Blake)
Avatar utente
GatoLopez70 Maschile
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2371
Iscrizione: gennaio 2009
Località: Cagliari
Distribuzione: ubuntu 12.04
Desktop: KDE

Re: chromium, flash obsoleto

Messaggioda battaman » martedì 13 marzo 2012, 19:42

non so come (forse con gli aggiornamenti automatici) ma il problema è scomparso. il bello è che dentro lib non ho ne la cartella di adobe ne quella di chromium.. e ho abilitato la visualizzazione file nascosti. non so davvero che dire. però va -.- facciamo finta che è tutto ok e vi ringrazio  (b2b)
battaman Non specificato
Prode Principiante
 
Messaggi: 111
Iscrizione: ottobre 2007

Re: chromium, flash obsoleto

Messaggioda GatoLopez70 » martedì 13 marzo 2012, 19:47

battaman ha scritto:non so come (forse con gli aggiornamenti automatici) ma il problema è scomparso. il bello è che dentro lib non ho ne la cartella di adobe ne quella di chromium.. e ho abilitato la visualizzazione file nascosti. non so davvero che dire. però va -.- facciamo finta che è tutto ok e vi ringrazio  (b2b)

::)
Tra questo:
Codice: Seleziona tutto
/lib

e questo:
Codice: Seleziona tutto
/usr/lib

noti differenze?
RevolutionOS per non dimenticare chi siamo...
If the doors of perception were cleansed, everything would appear to man as it truly is, infinite. (W. Blake)
Avatar utente
GatoLopez70 Maschile
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2371
Iscrizione: gennaio 2009
Località: Cagliari
Distribuzione: ubuntu 12.04
Desktop: KDE


Torna a Multimediale

Chi c’è in linea

Visualizzano questa sezione: guglicap e 5 ospiti