Notizia:
  • Rilasciata Ubuntu 14.04 LTS Trusty Tahr. Per ottenerla, visitate questa pagina oppure visualizzate la dimostrazione.
  • È uscito il numero 16 della Newsletter italiana di Ubuntu. Lo trovate a questo indirizzo.
  • È uscito il numero 79 di Full Circle Magazine in italiano. Lo trovate a questo indirizzo.

[RISOLTO]Problema microfono esterno con Ubuntu 12.04

Riconoscimento, installazione e configurazione delle periferiche.

[RISOLTO]Problema microfono esterno con Ubuntu 12.04

Messaggioda xflea » giovedì 17 maggio 2012, 17:35

Salve a tutti, apro questo topic per parlarvi del mio problema che mi assilla da un paio di giorni :(
Spero di aver postato nella sezione giusta, se non è così, mi scuso in anticipo.

Premetto di aver già cercato e provato diverse soluzioni che proponeva il web, smanettare con le opzioni audio o con il comando da terminale "alsamixer" senza ottenere nessun risultato. Premetto anche di non essere molto esperto al riguardo.

Ho recentemente aggiornato la mia distribuzione alla versione 12.04, ma ho un problema che per me è abbastanza "rognoso" visto che uso molto Skype e simili... in poche parole ho comprato queste cuffie ----> http://www.euronics.it/productimages/big/112028449.jpg , soltanto che una volta collegate al mio portatile (Acer) il microfono di esse non funziona (o almeno da quanto ho capito smanettando nel pannello di controllo di PulseAudio, il microfono esterno non viene riconosciuto), ma non quello interno del portatile (infatto quest'ultimo funziona normalmente), mentre le cuffie funzionano.

Ho anche provato con diversi programmi di registrare qualche traccia audio (Sound Recorder per esempio), ottenendo solamente un fastidiosissimo fruscio, mentre se registro con il microfono interno il problema non sembra presentarsi.

Spero di esser stato il più preciso possibile con la descrizione del mio intoppo, spero fiducioso nel vostro aiuto :D
Ultima modifica di xflea il mercoledì 13 giugno 2012, 22:59, modificato 1 volta in totale.
xflea Non specificato
Prode Principiante
 
Messaggi: 25
Iscrizione: maggio 2012
Distribuzione: Ubuntu 12.04 LTS

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda Talasai » lunedì 21 maggio 2012, 8:57

Ciao, prova così

Avvia il terminale e digita

sudo apt-get install pavucontrol

A questo punto vai in Regolazione del volume PulseAudio (Applicazioni -> Audio e Video -> Regolazione del volume PulseAudio oppure dal Dash digitando Regolazione del volume) e vai al tab ingressi, li troverai Frontale Sinistro e Frontale Destro, abbassa completamente il volume del Frontale Sinistro e lascia alto invece il Frontale Destro.

Nel mio caso ha funzionato, non ho avevo il tuo problema ma molto simile. Comunque smanetta nelle impostazione di regolazione del volume!
Spero di esserti stato d'aiuto! :-)
Talasai Maschile
Prode Principiante
 
Messaggi: 30
Iscrizione: febbraio 2009
Distribuzione: Ubuntu 12.04 LTS i686
Desktop: cairo-dock

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda xflea » lunedì 21 maggio 2012, 16:41

grazie per la risposta, ho provato la tua soluzione, ma non ha funzionato :( ho provato anche a fare il contrario (tappare il dx ed alzare il sx) ma niente.... questo microfono non vuole proprio funzionare
xflea Non specificato
Prode Principiante
 
Messaggi: 25
Iscrizione: maggio 2012
Distribuzione: Ubuntu 12.04 LTS

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda xflea » venerdì 25 maggio 2012, 23:33

UP :(
xflea Non specificato
Prode Principiante
 
Messaggi: 25
Iscrizione: maggio 2012
Distribuzione: Ubuntu 12.04 LTS

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda Dr_Berta » venerdì 25 maggio 2012, 23:42

Le cuffie con microfono hanno due connettori o un connettore solo?
Sul portatile hai un connettore solo o due connettori (uno per le cuffie e uno per il mic)?

Ciao
Ubuntu user #35116. Linux user #550996 - Il cervello è come un paracadute, funziona solo se si apre [Einstein]
Avatar utente
Dr_Berta Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1730
Iscrizione: luglio 2011
Località: Carpi (MO)
Distribuzione: Ubuntu 12.04 x86_64 LTS
Desktop: Gnome classic

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda xflea » sabato 26 maggio 2012, 16:12

le cuffie con il microfono hanno 2 connettore differenti, idem per il portatile... quando inserisco il connettore del microfono nel portatile e provo a ragistrare qualcosa, silenzio assoluto
xflea Non specificato
Prode Principiante
 
Messaggi: 25
Iscrizione: maggio 2012
Distribuzione: Ubuntu 12.04 LTS

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda Dr_Berta » sabato 26 maggio 2012, 17:18

Posta alsamixer dopo aver premuto F5. Allarga bene la schermata così che si vedano tutte le colonne.
Ciao
Ubuntu user #35116. Linux user #550996 - Il cervello è come un paracadute, funziona solo se si apre [Einstein]
Avatar utente
Dr_Berta Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1730
Iscrizione: luglio 2011
Località: Carpi (MO)
Distribuzione: Ubuntu 12.04 x86_64 LTS
Desktop: Gnome classic

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda xflea » domenica 27 maggio 2012, 22:11

(con spinotto del microfono esterno inserito)

Immagine
xflea Non specificato
Prode Principiante
 
Messaggi: 25
Iscrizione: maggio 2012
Distribuzione: Ubuntu 12.04 LTS

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda Dr_Berta » domenica 27 maggio 2012, 23:47

Forse ho capito. Il chip audio selezionato è quello dell'HDMI e nonquello dell'audio analogico.
Apri alsamixer e premi F6. Poi seleziona il tuo chip audio.
Disabilita anche la colonna automute.

Premi ESC per uscire a riavvia

Ciao
Ubuntu user #35116. Linux user #550996 - Il cervello è come un paracadute, funziona solo se si apre [Einstein]
Avatar utente
Dr_Berta Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1730
Iscrizione: luglio 2011
Località: Carpi (MO)
Distribuzione: Ubuntu 12.04 x86_64 LTS
Desktop: Gnome classic

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda xflea » lunedì 28 maggio 2012, 13:40

se premo F6, e poi invio su "default" in alto compare sempre "Intel CougarPoint HDMI" e non default o.O
xflea Non specificato
Prode Principiante
 
Messaggi: 25
Iscrizione: maggio 2012
Distribuzione: Ubuntu 12.04 LTS

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda Dr_Berta » lunedì 28 maggio 2012, 23:06

No, non devi mettere default. Dovresti avere una voce del tipo "HDA ATI SB" o "HDA INTEL"

Postami la schermata di alsamixer dopo aver premuto F6 che vedo cosa ti dice

Ciao

EDIT: posta anche il comando
Codice: Seleziona tutto
aplay -l
(è una elle)
Ubuntu user #35116. Linux user #550996 - Il cervello è come un paracadute, funziona solo se si apre [Einstein]
Avatar utente
Dr_Berta Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1730
Iscrizione: luglio 2011
Località: Carpi (MO)
Distribuzione: Ubuntu 12.04 x86_64 LTS
Desktop: Gnome classic

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda xflea » lunedì 28 maggio 2012, 23:47

da terminale:

Codice: Seleziona tutto
xflea@ubuntu:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


la schermata invece:
Immagine
xflea Non specificato
Prode Principiante
 
Messaggi: 25
Iscrizione: maggio 2012
Distribuzione: Ubuntu 12.04 LTS

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda Dr_Berta » lunedì 28 maggio 2012, 23:55

Premi F6 e seleziona "HDA INTEL PCH"
Premi ESc per uscire e riavvia

Postami anche il file /etc/modprobe.d/alsa-base.conf

Ciao
Ubuntu user #35116. Linux user #550996 - Il cervello è come un paracadute, funziona solo se si apre [Einstein]
Avatar utente
Dr_Berta Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1730
Iscrizione: luglio 2011
Località: Carpi (MO)
Distribuzione: Ubuntu 12.04 x86_64 LTS
Desktop: Gnome classic

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda xflea » martedì 29 maggio 2012, 18:14

continua a non funzionare.....


Codice: Seleziona tutto
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
xflea Non specificato
Prode Principiante
 
Messaggi: 25
Iscrizione: maggio 2012
Distribuzione: Ubuntu 12.04 LTS

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda Dr_Berta » martedì 29 maggio 2012, 18:57

Prova ad aggiungere alla fine di alsa-base.conf la seguente riga:
Codice: Seleziona tutto
options snd-hda-intel model=auto

Poi salva e riavvia

Ciao
Ubuntu user #35116. Linux user #550996 - Il cervello è come un paracadute, funziona solo se si apre [Einstein]
Avatar utente
Dr_Berta Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1730
Iscrizione: luglio 2011
Località: Carpi (MO)
Distribuzione: Ubuntu 12.04 x86_64 LTS
Desktop: Gnome classic

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda xflea » mercoledì 30 maggio 2012, 15:57

nemmeno in questo modo si risolve il problema :(
comunque grazie per il tempo che stai dedicando al mio problema, lo apprezzo molto :D
xflea Non specificato
Prode Principiante
 
Messaggi: 25
Iscrizione: maggio 2012
Distribuzione: Ubuntu 12.04 LTS

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda Dr_Berta » mercoledì 30 maggio 2012, 22:20

Con questa impostazione postami la schermata di alsamixer dopo aver premuto F5 come hai fatto prima.
e anche la schermata della sezione ingresso di pavucontrol

Ciao
Ubuntu user #35116. Linux user #550996 - Il cervello è come un paracadute, funziona solo se si apre [Einstein]
Avatar utente
Dr_Berta Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1730
Iscrizione: luglio 2011
Località: Carpi (MO)
Distribuzione: Ubuntu 12.04 x86_64 LTS
Desktop: Gnome classic

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda xflea » giovedì 31 maggio 2012, 16:16

Immagine

Immagine
xflea Non specificato
Prode Principiante
 
Messaggi: 25
Iscrizione: maggio 2012
Distribuzione: Ubuntu 12.04 LTS

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda Dr_Berta » giovedì 31 maggio 2012, 22:43

La schermata di pavucontrol sembra andare bene, ma hai ancora selezionato l'HDMI! Con l'HDMI il microfono non va.
Se premi F6 e scegli la riga 0 HDA INTEL PCH hai quel settaggio?

Se sì postami il comando
Codice: Seleziona tutto
aplay -l

Se no seleziona quella riga e premi il testo esc per uscire da alsamixer
Poi per sicurezza esegui il comando
Codice: Seleziona tutto
sudo alsactl store

e riavvia

Ciao
Ubuntu user #35116. Linux user #550996 - Il cervello è come un paracadute, funziona solo se si apre [Einstein]
Avatar utente
Dr_Berta Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1730
Iscrizione: luglio 2011
Località: Carpi (MO)
Distribuzione: Ubuntu 12.04 x86_64 LTS
Desktop: Gnome classic

Re: Problema microfono esterno con Ubuntu 12.04

Messaggioda xflea » venerdì 1 giugno 2012, 15:16

ho sempre lo stesso settaggio, anche se seleziono HDA INTEL PCH :(

ecco l'output di aplay -l:
Codice: Seleziona tutto
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
xflea Non specificato
Prode Principiante
 
Messaggi: 25
Iscrizione: maggio 2012
Distribuzione: Ubuntu 12.04 LTS

Successiva

Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: Google Feedfetcher, ivan montorsi, Lapo76, Tigre F e 19 ospiti