[Risolto] GNOME non si avvia dopo disinstallazione Evolution

Configurazione e uso delle applicazioni del desktop manager alla base di Ubuntu e di Ubuntu GNOME.

Re: Ubuntu non si avvia più

Messaggioda pablyto87 » mercoledì 17 maggio 2017, 20:24

Ok, ci siamo quasi! Da una live ubuntu, chroot funziona regolarmente, ho fatto dist-upgrade ma...ancora non va :nono:
Come da te suggeritomi, ho provato anche ad istallare il pacchetto gnome-desktop, ma da terminale (sempre con chroot, tutto regolarmente montato, rete funzionante) mi restituisce questo:

Codice: Seleziona tutto
root@ubuntu-budgie:/# apt install gnome-desktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package gnome-desktop


Possibile che debba fare qualcosa tipo apt install gnome-shell e apt install ubuntu-gnome-desktop (come ho leggiucchiato in giro)?
Però ripeto, vorrei evitare di perdere tutte le mie impostazioni di gnome (tema, estensioni, etc), se possibile...
Revolution starts at home, preferably in the bathroom mirror

Hüsker Dü
Avatar utente
pablyto87
Prode Principiante
 
Messaggi: 99
Iscrizione: ottobre 2010

Re: Ubuntu non si avvia più

Messaggioda steff » mercoledì 17 maggio 2017, 20:56

Potevi rinominare il file per adesso prima di creare il link, ma magari meglio provare con la ubuntu.
La Documentazione da consultare e la FAQ sul uso del forum
$ rsync -auv --delete /home/NOME/ /media/disco_USB/BACKUP
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu virtuale in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 36019
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: Ubuntu non si avvia più

Messaggioda pablyto87 » mercoledì 17 maggio 2017, 21:19

Scusa, non ho capito...
Sono su una live ubuntu in questo momento (ubuntu budgie 17.04, per la precisione).
Revolution starts at home, preferably in the bathroom mirror

Hüsker Dü
Avatar utente
pablyto87
Prode Principiante
 
Messaggi: 99
Iscrizione: ottobre 2010

Re: Ubuntu non si avvia più

Messaggioda steff » mercoledì 17 maggio 2017, 21:21

Oops, mi sono sfuggiti i tuoi ultimi messaggi sulla 2° pagina, niente.
Prova magari installare solo evolution, per gnome non sono ferrato.
La Documentazione da consultare e la FAQ sul uso del forum
$ rsync -auv --delete /home/NOME/ /media/disco_USB/BACKUP
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu virtuale in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 36019
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: Ubuntu non si avvia più

Messaggioda pablyto87 » mercoledì 17 maggio 2017, 22:05

Ho installato evlution ed a sto punto sto provando ad installare tutto in resto dei pacchetti che m'avava suggerito la modalità di ripristino, nello specifico:

Codice: Seleziona tutto
apt install bluez-obexd chrome-gnome-shell gdm3 gnome-bluetooth gnome-calendar gnome-contacts gnome-orca gnome-shell gnome-shell-extension gnome-user-share libfolks-eds25
 python3-brlapi python3-louis python3-pyatspi python3-speechd rhythmbox-plugin-magnatune ubuntu-gnome-desktop ubuntu-release-upgrader-gtk update-manager update-notifier xbrlapi


Ora riavvio, vediamo un po'.
Revolution starts at home, preferably in the bathroom mirror

Hüsker Dü
Avatar utente
pablyto87
Prode Principiante
 
Messaggi: 99
Iscrizione: ottobre 2010

Re: Ubuntu non si avvia più

Messaggioda pablyto87 » mercoledì 17 maggio 2017, 22:28

ANDATA!!!

Riassumendo:

1) Non disinstallare Evolution
2) NON DISINSTALLARE IL DANNATO EVOLUTION, MAI!
3) Se incautamente hai disinstallato evolution da GNOME 3, vai in modalità di ripristino, selezioni "ripara pacchetti danneggiati", dai d e copia i pacchetti che suggerisce di installare
4) Avvia una live di ubuntu da chiavetta o CD (no altre distro)
5) Individua la partizione dove è installato il tuo sistema (es. /dev/sda1 ), e da terminale fai un chroot digitando
Codice: Seleziona tutto
sudo mount /dev/sda1 /mnt [sostituisci ad sda1 la tua patizione]
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo mount -o bind /run /mnt/run
sudo chroot /mnt

6) Una volta fatto il chroot, sempre da terminale (io ho fatto così, ma a posteriori questo forse è superfluo)
Codice: Seleziona tutto
apt update
apt dist-upgrade

7) Installa i pacchetti suggeriti dalla modalità di ripristino (punto 3), nel mio caso
Codice: Seleziona tutto
apt install evolution bluez-obexd chrome-gnome-shell gdm3 gnome-bluetooth gnome-calendar gnome-contacts gnome-orca gnome-shell gnome-shell-extension gnome-user-share libfolks-eds25
 python3-brlapi python3-louis python3-pyatspi python3-speechd rhythmbox-plugin-magnatune ubuntu-gnome-desktop ubuntu-release-upgrader-gtk update-manager update-notifier xbrlapi

8 ) Riavvia il sistema e risvegliati da un incubo.

Il mio sistema è Ubuntu GNOME 16.04. Adesso, a parte la schermata di login un po' diversa, tutto è tornato come prima, incluso tema, icone ed estensioni.

Grazie infinite a @steff per l'aiuto! Se sei di Roma o passi di qui prossimamente, dimmelo che ti offro (almeno) una birra! :birra:
Revolution starts at home, preferably in the bathroom mirror

Hüsker Dü
Avatar utente
pablyto87
Prode Principiante
 
Messaggi: 99
Iscrizione: ottobre 2010

Re: [RISOLTO] GNOME non si avvia dopo disinstallazione Evolu

Messaggioda steff » mercoledì 17 maggio 2017, 23:45

Son contento per te, intanto va aggiornato la guida nel wiki, grazie a te che hai fatto da cavia :)
La Documentazione da consultare e la FAQ sul uso del forum
$ rsync -auv --delete /home/NOME/ /media/disco_USB/BACKUP
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu virtuale in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 36019
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Precedente

Torna a GNOME

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 4 ospiti