[Ubuntu1604]driver rtl8723be installati ma non riconosciuti

Riconoscimento, installazione e configurazione delle periferiche.

[Ubuntu1604]driver rtl8723be installati ma non riconosciuti

Messaggioda Skagigi » venerdì 19 maggio 2017, 19:26

Salve,
come da titolo ho installato ubuntu 16.04 su hp pavillon gaming 15 ak112nl, dotato di scheda di rete rtl8723be; ci sono numerosi topic al riguardo (la scheda non funziona o funziona male cosa fare?). Nel mio caso la scheda veniva riconosciuta ma la potenza del segnale era bassissima (rispetto a windows e rispetto ad uno xubuntu già configurato che ho su un altro laptop)

Io ho installato i driver forniti da hp tramite ndiswrapper (http://wiki.ubuntu-it.org/Hardware/Disp ... diswrapper); l'installazione è andata a buon fine.

Riavvio.

La scheda di rete non viene più riconosciuta, i.e. l'output di iwconfig è

lo no wireless extensions.

eth0 no wireless extensions.

Cosa faccio XD?

Grazie mille!
Skagigi
Prode Principiante
 
Messaggi: 24
Iscrizione: settembre 2010

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda magozurlinux » venerdì 19 maggio 2017, 19:49

Ciao.

Questa discussione l'hai seguita?

viewtopic.php?p=4894198
Ubuntu14.04 LTS Desktop i686 con Unity
Avatar utente
magozurlinux
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 17792
Iscrizione: marzo 2010
Località: Pisa
Desktop: Unity / Desktop
Distribuzione: Ubuntu 14.04 LTS i686 con Unity

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda Skagigi » venerdì 19 maggio 2017, 19:52

Si l'avevo vista ma avevo deciso di provare ad installare i driver di windows e di vedere cosa succedeva; tu dici di farla, anche se a questo punto non riconosce più la scheda?
Skagigi
Prode Principiante
 
Messaggi: 24
Iscrizione: settembre 2010

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda Skagigi » venerdì 19 maggio 2017, 20:13

Allora, ho seguito la procedure indicata nella discussione viewtopic.php?p=4894198, andata a buon fine. La scheda di rete si è attivata, ma ha sempre una potenza di segnale bassissima. Inoltre ho riavviato il pc, ed è scomparsa di nuovo la scheda di rete
Skagigi
Prode Principiante
 
Messaggi: 24
Iscrizione: settembre 2010

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda VitoDoc » venerdì 19 maggio 2017, 20:29

Devi far partire il modulo della scheda all'avvio del sistema, ovvero, aprendo un editor di testo come amministratore e inserendo il nome del modulo da caricare nel file /etc/modules
Avatar utente
VitoDoc
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1640
Iscrizione: maggio 2012
Desktop: plasma
Distribuzione: Kubuntu 16.04.2 LTS x86_64
Sesso: Maschile

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda Skagigi » venerdì 19 maggio 2017, 22:01

Allora il file è vuoto, è normale? Comunque come faccio a sapere il nome del modulo da caricare? E quale è la sintassi? Grazie
Skagigi
Prode Principiante
 
Messaggi: 24
Iscrizione: settembre 2010

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda VitoDoc » venerdì 19 maggio 2017, 22:15

Postami il contenuto del file /etc/modprobe.d/rtl8723be.conf
Avatar utente
VitoDoc
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1640
Iscrizione: maggio 2012
Desktop: plasma
Distribuzione: Kubuntu 16.04.2 LTS x86_64
Sesso: Maschile

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda Skagigi » venerdì 19 maggio 2017, 22:34

Ho riavviato adesso riconosce la scheda ma il wi fi comunque non va.
Ecco il contenuto

options rtl8723be fwlps=N ips=N
Skagigi
Prode Principiante
 
Messaggi: 24
Iscrizione: settembre 2010

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda VitoDoc » venerdì 19 maggio 2017, 22:36

Prova modificando quella stringa con questo
Codice: Seleziona tutto
options rtl8723be fwlps=0 swlps=0
Avatar utente
VitoDoc
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1640
Iscrizione: maggio 2012
Desktop: plasma
Distribuzione: Kubuntu 16.04.2 LTS x86_64
Sesso: Maschile

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda Skagigi » sabato 20 maggio 2017, 10:41

Allora ragazzi
problema 1) ho provato le impostazioni suggerite da VitoDoc e il wifi non funziona lo stesso;
problema 2) Ogni volta che riavvio il file etc/modprobe.d/rtl8723be.conf si svuota (apro con gedit ed è vuoto)
Skagigi
Prode Principiante
 
Messaggi: 24
Iscrizione: settembre 2010

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda magozurlinux » sabato 20 maggio 2017, 11:57

Da terminale postami questi comandi:

Codice: Seleziona tutto
sudo ifconfig -a


Codice: Seleziona tutto
iwconfig


Codice: Seleziona tutto
cat /etc/modprobe.d/rtl8723be.conf
Ubuntu14.04 LTS Desktop i686 con Unity
Avatar utente
magozurlinux
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 17792
Iscrizione: marzo 2010
Località: Pisa
Desktop: Unity / Desktop
Distribuzione: Ubuntu 14.04 LTS i686 con Unity

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda xavier77 » sabato 20 maggio 2017, 12:41

Faccio un piccolo off topic (ma neanche tanto).
Siccome purtroppo le schede di rete non supportate da linux possono essere una brutta rogna, e spesso non si riesce a risolvere il problema al 100%, spendendo poche decine d'euro si può sostituire la scheda wifi con una supportata (10, fino a 30/40 a seconda del modello, se è nuovo o di seconda mano ecc.).
Alcune marche (tipo Intel) sono solitamente supportate bene da Linux. Sostituire una scheda di solito è un operazione molto semplice (quasi quanto sostituire la RAM).
Ovviamente è da valutare caso per caso.
:ciao:
Avatar utente
xavier77
Gruppo Documentazione
Gruppo Documentazione
 
Messaggi: 3981
Iscrizione: settembre 2012
Desktop: Xfce - LXDE - Openbox
Distribuzione: Xubuntu 16.04
Sesso: Maschile

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda Skagigi » sabato 20 maggio 2017, 13:21

E si lo so, se non trovo altra soluzione cambio scheda di rete e bona.
Intanto ci provo. Ecco i dati richiesti (per adesso sono collegato a internet tramite hotspot dal cellulare):
Codice: Seleziona tutto
eno1      Link encap:Ethernet  IndirizzoHW 70:5a:0f:1a:61:8e 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000
          Byte RX:0 (0.0 B)  Byte TX:0 (0.0 B)

lo        Link encap:Loopback locale 
          indirizzo inet:127.0.0.1  Maschera:255.0.0.0
          indirizzo inet6: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1039 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1039 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1
          Byte RX:119438 (119.4 KB)  Byte TX:119438 (119.4 KB)

wlo1      Link encap:Ethernet  IndirizzoHW 44:1c:a8:7b:80:75 
          indirizzo inet:192.168.43.90  Bcast:192.168.43.255  Maschera:255.255.255.0
          indirizzo inet6: fe80::ad45:59d0:8063:6d0f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14058 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10286 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000
          Byte RX:15158790 (15.1 MB)  Byte TX:1276476 (1.2 MB)


Codice: Seleziona tutto
lo        no wireless extensions.

eno1      no wireless extensions.

wlo1      IEEE 802.11  ESSID:"AndroidAP" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: C0:11:73:72:FF:25   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=36/70  Signal level=-74 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:76   Missed beacon:0


Codice: Seleziona tutto
options rtl8723be fwlps=0 swlps=0
Skagigi
Prode Principiante
 
Messaggi: 24
Iscrizione: settembre 2010

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda Skagigi » sabato 20 maggio 2017, 13:29

xavier77 Immagine ha scritto:Faccio un piccolo off topic (ma neanche tanto).
Siccome purtroppo le schede di rete non supportate da linux possono essere una brutta rogna, e spesso non si riesce a risolvere il problema al 100%, spendendo poche decine d'euro si può sostituire la scheda wifi con una supportata (10, fino a 30/40 a seconda del modello, se è nuovo o di seconda mano ecc.).
Alcune marche (tipo Intel) sono solitamente supportate bene da Linux. Sostituire una scheda di solito è un operazione molto semplice (quasi quanto sostituire la RAM).
Ovviamente è da valutare caso per caso.
:ciao:


In ogni caso sapresti consigliarmene una o comunque linkarmi qualcosa dove si discutono i modelli?
Skagigi
Prode Principiante
 
Messaggi: 24
Iscrizione: settembre 2010

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda xavier77 » sabato 20 maggio 2017, 14:55

Skagigi Immagine ha scritto:
xavier77 Immagine ha scritto:Faccio un piccolo off topic (ma neanche tanto).
Siccome purtroppo le schede di rete non supportate da linux possono essere una brutta rogna, e spesso non si riesce a risolvere il problema al 100%, spendendo poche decine d'euro si può sostituire la scheda wifi con una supportata (10, fino a 30/40 a seconda del modello, se è nuovo o di seconda mano ecc.).
Alcune marche (tipo Intel) sono solitamente supportate bene da Linux. Sostituire una scheda di solito è un operazione molto semplice (quasi quanto sostituire la RAM).
Ovviamente è da valutare caso per caso.
:ciao:


In ogni caso sapresti consigliarmene una o comunque linkarmi qualcosa dove si discutono i modelli?

be', per evitare di suggerirti inesattezze meglio che apri una discussione in Consigli per gli acquisti, fornendo modello pc e caratteristiche scheda attuale.
Avatar utente
xavier77
Gruppo Documentazione
Gruppo Documentazione
 
Messaggi: 3981
Iscrizione: settembre 2012
Desktop: Xfce - LXDE - Openbox
Distribuzione: Xubuntu 16.04
Sesso: Maschile

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda Skagigi » sabato 20 maggio 2017, 15:34

grazie xavier77, vedo se con il vostro aiuto riesco a risolvere se no seguirò il tuo consiglio.
Skagigi
Prode Principiante
 
Messaggi: 24
Iscrizione: settembre 2010

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda magozurlinux » sabato 20 maggio 2017, 17:17

wlo1 Link encap:Ethernet IndirizzoHW 44:1c:a8:7b:80:75
indirizzo inet:192.168.43.90 Bcast:192.168.43.255 Maschera:255.255.255.0
indirizzo inet6: fe80::ad45:59d0:8063:6d0f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:14058 errors:0 dropped:0 overruns:0 frame:0
TX packets:10286 errors:0 dropped:0 overruns:0 carrier:0
collisioni:0 txqueuelen:1000
Byte RX:15158790 (15.1 MB) Byte TX:1276476 (1.2 MB)


Hai l'IPv6 attivo.

Da terminale dai questi comandi:

Codice: Seleziona tutto
sudo gedit /etc/sysctl.conf


alla fine del file copia e incolla queste righe:

Codice: Seleziona tutto
# Disable IPV6
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1


salva ed esci dall'editor di testo.

Un altro controllo che puoi fare è andare su Firefox: Preferenze > Avanzate > Rete > Impostazioni; controlla che sia impostato su Nessun proxy.

Riavvia il pc.

Da terminale postami questo comando:

Codice: Seleziona tutto
ls -l /etc/modprobe.d/
Ubuntu14.04 LTS Desktop i686 con Unity
Avatar utente
magozurlinux
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 17792
Iscrizione: marzo 2010
Località: Pisa
Desktop: Unity / Desktop
Distribuzione: Ubuntu 14.04 LTS i686 con Unity

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda Skagigi » sabato 20 maggio 2017, 17:31

Fatto tutto, ancora non va. Ecco i dati
Codice: Seleziona tutto
totale 52
-rw-r--r-- 1 root root 2507 lug 31  2015 alsa-base.conf
-rw-r--r-- 1 root root  325 mar 13  2016 blacklist-ath_pci.conf
-rw-r--r-- 1 root root 1603 mar 13  2016 blacklist.conf
-rw-r--r-- 1 root root  210 mar 13  2016 blacklist-firewire.conf
-rw-r--r-- 1 root root  697 mar 13  2016 blacklist-framebuffer.conf
-rw-r--r-- 1 root root  156 lug 31  2015 blacklist-modem.conf
lrwxrwxrwx 1 root root   41 mag 20 09:42 blacklist-oss.conf -> /lib/linux-sound-base/noOSS.modprobe.conf
-rw-r--r-- 1 root root  583 mar 13  2016 blacklist-rare-network.conf
-rw-r--r-- 1 root root 1077 mar 13  2016 blacklist-watchdog.conf
-rw-r--r-- 1 root root  390 apr 12  2016 fbdev-blacklist.conf
-rw-r--r-- 1 root root  347 mar 13  2016 iwlwifi.conf
-rw-r--r-- 1 root root  104 mar 13  2016 mlx4.conf
-rw-r--r-- 1 root root   34 mag 20 12:36 rtl8723be.conf
-rw-r--r-- 1 root root   30 gen 26 19:31 vmwgfx-fbdev.conf
Skagigi
Prode Principiante
 
Messaggi: 24
Iscrizione: settembre 2010

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda magozurlinux » sabato 20 maggio 2017, 18:01

Da terminale dai questi comandi:

Codice: Seleziona tutto
sudo gedit /etc/modprobe.d/rtl8723be.conf


cancella il contenuto; copia e incolla quesrta riga:

Codice: Seleziona tutto
options rtl8723be ips=0 fwlps=0 ant_sel=1


salva ed esci dall'editor di testo.

Riavvia il pc.
Ubuntu14.04 LTS Desktop i686 con Unity
Avatar utente
magozurlinux
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 17792
Iscrizione: marzo 2010
Località: Pisa
Desktop: Unity / Desktop
Distribuzione: Ubuntu 14.04 LTS i686 con Unity

Re: [Ubuntu1604]driver rtl8723be installati ma non riconosci

Messaggioda Skagigi » sabato 20 maggio 2017, 18:11

Niente non va. Se può essere d'aiuto mentre salvavo su gedit il terminale ha dato questo:
Codice: Seleziona tutto
(gedit:2393): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (gedit:2393): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-spell-enabled non supportata

** (gedit:2393): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-encoding non supportata

** (gedit:2393): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-position non supportata
Skagigi
Prode Principiante
 
Messaggi: 24
Iscrizione: settembre 2010

Successiva

Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: CGP, criceto45 e 13 ospiti