Non mi funzionano piu' alcuni tasti della tastiera

Configurazione e uso delle applicazioni del desktop manager alla base di Kubuntu.

Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda nuk3r » lunedì 9 luglio 2007, 15:39

Non mi vanno le lettere accentate, il tasto WIN, la chiocciola etc....

su windows non ho questo problema! Ho provato a mettere la tastiera come modello "Generico 105 tasti (internazionale)" e riavviare, ma niente

che faccio?

grazie
Avatar utente
nuk3r Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1611
Iscrizione: gennaio 2007
Località: Berghem

Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda dangp » lunedì 9 luglio 2007, 15:45

dai il comando da konsole
sudo kwrite /etc/X11/xorg.conf
e controlla se nella parte
Codice: Seleziona tutto
Section "InputDevice"
  Identifier "Generic Keyboard"
  Driver "kbd"
  option "CoreKeyboard"
  option "XkbRules" "xorg"
  option "XkbModel" "pc105"
  option "XkbLayout" "it"
  option "XkbOptions" "lv3:ralt_switch"
EndSection

c'è la scritta
option "XkbLayout" "it"
Avatar utente
dangp Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 676
Iscrizione: marzo 2007

Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda nuk3r » lunedì 9 luglio 2007, 18:31

fatto, e' come il tuo

Codice: Seleziona tutto
Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "it"
   Option       "XkbOptions"    "lv3:ralt_switch"
EndSection
Avatar utente
nuk3r Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1611
Iscrizione: gennaio 2007
Località: Berghem

Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda nuk3r » lunedì 9 luglio 2007, 20:13

altre idee? Vi prego aiutatemi cosi' e' un casino!
Avatar utente
nuk3r Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1611
Iscrizione: gennaio 2007
Località: Berghem

Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda dangp » lunedì 9 luglio 2007, 23:23

menu-->impostazioni di sistema-->lingua & localizzazione-->mappatura tastiera
spunta abilita le mappature della tastiera e aggiungi it e togli us.
Avatar utente
dangp Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 676
Iscrizione: marzo 2007

Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda nuk3r » martedì 10 luglio 2007, 0:05

gia fatto!!!

dai possibile che il pinguino mi abbia rotto i tasti?!

HELP! :(
Avatar utente
nuk3r Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1611
Iscrizione: gennaio 2007
Località: Berghem

Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda Frantzizko » martedì 10 luglio 2007, 11:19

nuk3r ha scritto:dai possibile che il pinguino mi abbia rotto i tasti?!


Se una persona che entra in questo Forum si mettesse a leggere tutto ciò che Ubuntu fantomaticamente rompe ai nuovi utenti, avremmo:

· rompe gli HD (l'ho letto)
· brucia gli schermi (l'ho letto)
· rompe la scheda video (o audio, ora non ricordo esattamente...comunque l'ho letto)
· rompe la tastiera (l'ho letto adesso)

Perché mai una persona sana di mente dovrebbe installare Ubuntu, a questo punto?
Ovviamente sono solo battute, ma ti rendi conto anche tu che è impossibile che un SO ti possa rompere la tastiera, considerato il fatto che alla maggior parte degli utenti funziona tutto perfettamente...il problema, evidentemente, non è il SO.

;)
GNOME. Perché l'etica è superiore ad ogni estetica.
"La conoscenza ti fa dubitare. Soprattutto del potere. Di ogni potere." Dario Fo
Avatar utente
Frantzizko Non specificato
Prode Principiante
 
Messaggi: 242
Iscrizione: gennaio 2007
Località: ~

Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda nuk3r » martedì 10 luglio 2007, 11:26

.........scherzavo.......  ;)

io questo SO lo adoro, almeno mi permette di intervenire su qualsiasi cosa, a patto di avere le conoscenze necessarie (che in questo caso io non ho  :P )....pero' la mia era una battuta....
Avatar utente
nuk3r Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1611
Iscrizione: gennaio 2007
Località: Berghem

Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda Frantzizko » martedì 10 luglio 2007, 11:28

nuk3r ha scritto:io questo SO lo adoro, almeno mi permette di intervenire su qualsiasi cosa, a patto di avere le conoscenze necessarie (che in questo caso io non ho)....pero' la mia era una battuta....


Ah, allora lol...spesso c'è gente che crede sul serio che Ubuntu possa danneggiare componenti hardware, per cui in questi casi è sempre meglio rispondere seriamente piuttosto che credere che sia una battuta.

Meglio così, allora.

:)
GNOME. Perché l'etica è superiore ad ogni estetica.
"La conoscenza ti fa dubitare. Soprattutto del potere. Di ogni potere." Dario Fo
Avatar utente
Frantzizko Non specificato
Prode Principiante
 
Messaggi: 242
Iscrizione: gennaio 2007
Località: ~

Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda nuk3r » martedì 10 luglio 2007, 11:39

c'è gente che crede sul serio che Ubuntu possa danneggiare componenti hardware


(rotfl)

il problema e' chi sta davanti al pc, non quello che ci sta dentro (a meno che non sia linux-based  ;D)

............
....
............
.................ma la mia tastiera?  >:(  >:(

:(
Avatar utente
nuk3r Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1611
Iscrizione: gennaio 2007
Località: Berghem

Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda nuk3r » martedì 10 luglio 2007, 18:06

giuro, ho dovuto usare windows!!!

dovevo scrivere un documento e in questo modo e' impossibile!!

vi prego datemi idee, anche stupide vanno bene....

tipo da qualche parte ho letto di usare il comando

Codice: Seleziona tutto
setxkbmap -model pc105 -layout it


ma mi restituisce

Codice: Seleziona tutto
Error loading new keyboard description


Non c' e' qualcuno bravo in queste cose?  :(
Avatar utente
nuk3r Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1611
Iscrizione: gennaio 2007
Località: Berghem


Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda loolee » mercoledì 11 luglio 2007, 20:36

è successo anche a me, ma ero stata io (e non ubuntu) a danneggiare il file xorg.conf  :-[

mi sa che devi riconfigurarlo...
Love Music Hate Racism
Avatar utente
loolee Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 583
Iscrizione: maggio 2007

Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda nuk3r » mercoledì 11 luglio 2007, 20:49

innanzitutto ti ringrazio di avermi risposto!  ;D

ci stavo pensando anch io ma volevo prima sapere se cosi facendo rischio di compromettere anche le impostazioni della scheda video che dopo tanta fatica funziona benissimo (anche con beryl e giochi)
Avatar utente
nuk3r Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1611
Iscrizione: gennaio 2007
Località: Berghem

Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda loolee » mercoledì 11 luglio 2007, 21:37

nuk3r ha scritto:innanzitutto ti ringrazio di avermi risposto!  ;D

ci stavo pensando anch io ma volevo prima sapere se cosi facendo rischio di compromettere anche le impostazioni della scheda video che dopo tanta fatica funziona benissimo (anche con beryl e giochi)




sono la persona meno adatta per parlare di schede video.  ;D

sorry, non so aiutarti di più.
Love Music Hate Racism
Avatar utente
loolee Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 583
Iscrizione: maggio 2007

Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda nuk3r » mercoledì 11 luglio 2007, 22:30

:( non c'e' problema grazie lo stesso

allora giro la richiesta a qualcun altro....per favore non abbandonatemi, mi servere davvero risolvere questo problema!!!  :(
Avatar utente
nuk3r Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1611
Iscrizione: gennaio 2007
Località: Berghem

Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda nuk3r » domenica 15 luglio 2007, 15:10

ho scoperto una cosa: poiche' ho anche una sessione con gnome, ho provato ad accedervi e a modificare le impostazioni della tastiera da li e ho ricevuto questo messaggio di errore:

Codice: Seleziona tutto

Errore nell'attivare la configurazione di XKB.
Cio' si potrebbe verificare sotto diverse circostanze:
- un bug nella libreria libxklavier
- un bug nel server X (nei programmi di utilita' xkbcomp o xmodmap)
- un server X con una implementazione di libxkbfile non compatibile

Dati della versione del server X:
The X.Org Foundation
70000000

Se si riporta questa situazione come bug, includere:
- Il risultato di xprop -root | grep XKB
- Il risultato di gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd



e su un forum ho letto che si risolve cosi:

Codice: Seleziona tutto

xprop -root -f _XKB_RULES_NAMES 8s -set _XKB_RULES_NAMES xorg && setxkbmap -model pc105 -layout it -variant basic




ma purtroppo a me viene restituito:

Codice: Seleziona tutto

Error loading new keyboard description




che e' lo stesso errore che ricevo quando faccio:

Codice: Seleziona tutto

sudo setxkbmap -layout "it"




che e' lo stesso comando per cambiare la mappatura della tastiera!!!!

secondo me il problema sta nel "Error loading new keyboard description" e bisogna tentare di risolvere quello....

ho trovato un po' di roba su google ma non ci capisco niente.... :'(

grazie a tutti!
Ultima modifica di nuk3r il domenica 15 luglio 2007, 15:44, modificato 1 volta in totale.
Avatar utente
nuk3r Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1611
Iscrizione: gennaio 2007
Località: Berghem


Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda nuk3r » domenica 5 agosto 2007, 19:23

nessuno riesce ad aiutarmi?!  :(
Avatar utente
nuk3r Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1611
Iscrizione: gennaio 2007
Località: Berghem

Re: Non mi funzionano piu' alcuni tasti della tastiera

Messaggioda arale » domenica 5 agosto 2007, 19:31

Scusa ma che tastiera (Hw) hai ?
arale Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 750
Iscrizione: giugno 2007

Successiva

Torna a KDE

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 3 ospiti