webcam trust

Riconoscimento, installazione e configurazione delle periferiche.

webcam trust

Messaggioda zell » martedì 20 giugno 2006, 11:48

allora volevo installare la mia mini-webcam della trust
ho cercato sul wiki  e ho trovato questo:

http://wiki.ubuntu-it.org/PatchPerWebCamTrust?highlight=%28webcam%29

solo che all'ultimo passaggio, mi da questo problema

dani@dada:~/spca5xx-20060501$ sudo modprobe spca5xx
FATAL: Error inserting spca5xx (/lib/modules/2.6.15-25-386/kernel/drivers/usb/media/spca5xx.ko): Invalid module format

mentre tutti gli altri comandi precedenti sono andati a buon fine
sapete aiutarmi??

grazie a chi mi risponderà
zell Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 265
Iscrizione: febbraio 2006

Re: webcam trust

Messaggioda marco8330 » martedì 20 giugno 2006, 14:24

Questo errore in genere indica che il modulo è stato compilato per un kernel diverso da quello in uso. Sicuro di non avere un kernel installato a seguito di un aggiornamento e gli header invece di un kernel più vecchio? Inoltre la guida riguarderebbe Breezy non Dapper tu che usi? Perché la procedura serve per sostituire un driver già presente nel kernel quindi con Dapper non dovrebbe essere necessario fare nulla.....
marco8330 Non specificato
Prode Principiante
 
Messaggi: 65
Iscrizione: maggio 2006

Re: webcam trust

Messaggioda zell » martedì 20 giugno 2006, 14:48

si ho dapper però non mi funziona la webcam allora ho cercato sul wiki e ho provato a fare quello che diceva...
quindi ora cosa mi consigli?
zell Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 265
Iscrizione: febbraio 2006

Re: webcam trust

Messaggioda marco8330 » martedì 20 giugno 2006, 15:53

Cancella /lib/modules/2.6.15-25-386/kernel/drivers/usb/media/spca5xx.ko per sicurezza poi vai su Applicazioni -> Aggiungi/Rimuovi poi vai su avanzate, cerca il pacchetto linux-restricted-modules-(ci sarà la versione del kernel) e digli di reinstallarlo. In questo modo riporterai il tutto alla configurazione originale. Dopodiché prova a dare il comando sudo modprobe spca5xx . Accertati comunque che questo sia il driver giusto per il tuo modello di webcam, fai una ricerca su internet.....
marco8330 Non specificato
Prode Principiante
 
Messaggi: 65
Iscrizione: maggio 2006

Re: webcam trust

Messaggioda zell » martedì 20 giugno 2006, 18:48

dani@dada:~$ modprobe spca5xx
FATAL: Module spca5xx not found.

mi dice così...su internet ho provato a cercare ma non ho trovato nulla
zell Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 265
Iscrizione: febbraio 2006

Re: webcam trust

Messaggioda marco8330 » martedì 20 giugno 2006, 19:38

Allora prova questo, assicurati di avere abilitato i repository universe per i sorgenti e la connessione abilitata poi fai:

$ sudo apt-get install spca5xx-source
$ sudo apt-get install module-assistant
$ sudo module-assistant prepare,update
$ sudo module-assistant build,install spca5xx
$ sudo depmod -a
$ sudo modprobe spca5xx

L'ho provato sulla mia macchina anche se non ho la webcam il modulo viene caricato senza problemi.... buona fortuna!  ;D
marco8330 Non specificato
Prode Principiante
 
Messaggi: 65
Iscrizione: maggio 2006

Re: webcam trust

Messaggioda zell » mercoledì 21 giugno 2006, 10:02

grazie mille!!!
ora funziona tutto!!!
zell Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 265
Iscrizione: febbraio 2006

Re: webcam trust

Messaggioda fabioamd87 » sabato 24 giugno 2006, 18:25

ragazzi sto smanettando anche io un pochetto solo che io ho una fotocamera della trust che fa anche da webcam, non vale anche per me la cosa vero? non posso sfruttarla?
Avatar utente
fabioamd87 Non specificato
Rampante Reduce
Rampante Reduce
 
Messaggi: 5365
Iscrizione: dicembre 2005
Località: Cassino
Distribuzione: Arch Linux
Desktop: GNOME Shell

errore camorama

Messaggioda Gizzo » venerdì 17 novembre 2006, 19:03

salve a tutti. mi hanno (ahime) regalato una webcam trust...
ovviamente gli improperi si sprecano. Ho seguito la wiki, i consigli degli utenti qui sopra, e ho anche installato camorama.
connetto la webcam, lancio camorama ma nulla, mi esce un errore di questo tipo "could not connect to video device (/dev/video0). please check connection

qualcuno ha idee, suggerimenti, santi a cui votarsi???

grazie!!
.......ma il cielo e' sempre piu' blu!!!
Avatar utente
Gizzo Non specificato
Prode Principiante
 
Messaggi: 99
Iscrizione: ottobre 2006
Località: Carlow, Ireland


Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: enricoflor, ilovelinux, Yahoo [Bot] e 19 ospiti