Notizia:
  • Rilasciata Ubuntu 14.04 LTS Trusty Tahr. Per ottenerla, visitate questa pagina oppure visualizzate la dimostrazione.
  • È uscito il numero 16 della Newsletter italiana di Ubuntu. Lo trovate a questo indirizzo.
  • È uscito il numero 79 di Full Circle Magazine in italiano. Lo trovate a questo indirizzo.

[Boot] Non vedo più xp nel boot loader

Installazione, configurazione e uso di programmi e strumenti.

[Boot] Non vedo più xp nel boot loader

Messaggioda Husker » martedì 14 aprile 2009, 23:02

Salve a tutti, premetto che non sono riuscito a trovare una discussione che potesse aiutarmi, il mio problema è che dopo aver installato ubuntu 8.10, all'avvio non vedo più xp nel boot loader, purtroppo parte automaticamente ubuntu 8.10, posso modificare il menu.lst per poter rivedere xp all'avvio, grazie a tutti.
Husker Non specificato
Prode Principiante
 
Messaggi: 18
Iscrizione: marzo 2009

Re: [Boot] Non vedo più xp nel boot loader

Messaggioda The Doctor » martedì 14 aprile 2009, 23:08

Ciao. Scusa ma sia nel forum che nel wiki ci sono centinaia di post e guide che ne parlano. Ti consiglio una ricerchina più approfondita ;)
Avatar utente
The Doctor Maschile
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1722
Iscrizione: marzo 2008
Distribuzione: Ubuntu 12.04 LTS i686
Desktop: ubuntu

Re: [Boot] Non vedo più xp nel boot loader

Messaggioda dani.deb » martedì 14 aprile 2009, 23:09

si ci metti un attimo
da terminale digita:
Codice: Seleziona tutto
sudo gedit /boot/grub/menu.lst


posta il risultato e vediamo dov'è il problema

The Doctor ha scritto:Ciao. Scusa ma sia nel forum che nel wiki ci sono centinaia di post e guide che ne parlano. Ti consiglio una ricerchina più approfondita ;)


è vero, ma appena arrivati non è sempre una cosa semplice agire su grub.. :)
dani.deb Maschile
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3902
Iscrizione: dicembre 2008
Distribuzione: ubuntu 12.04 64bit + 13.04
Desktop: Lubuntu + Unity + Kubuntu

Re: [Boot] Non vedo più xp nel boot loader

Messaggioda Husker » martedì 14 aprile 2009, 23:14

Scusate, ma quello che ho trovato ioè l'inverso, cioè dopo installazione xp non vedevano più ubuntu, comque ecco lst:
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 3

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=53e1b816-d88d-4016-a4ac-3a6c135cbfb6 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=53e1b816-d88d-4016-a4ac-3a6c135cbfb6

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title Ubuntu 8.10, kernel 2.6.27-11-generic
uuid 53e1b816-d88d-4016-a4ac-3a6c135cbfb6
kernel /boot/vmlinuz-2.6.27-11-generic root=UUID=53e1b816-d88d-4016-a4ac-3a6c135cbfb6 ro quiet splash
initrd /boot/initrd.img-2.6.27-11-generic
quiet

title Ubuntu 8.10, kernel 2.6.27-11-generic (recovery mode)
uuid 53e1b816-d88d-4016-a4ac-3a6c135cbfb6
kernel /boot/vmlinuz-2.6.27-11-generic root=UUID=53e1b816-d88d-4016-a4ac-3a6c135cbfb6 ro  single
initrd /boot/initrd.img-2.6.27-11-generic

title Ubuntu 8.10, kernel 2.6.27-7-generic
uuid 53e1b816-d88d-4016-a4ac-3a6c135cbfb6
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=53e1b816-d88d-4016-a4ac-3a6c135cbfb6 ro quiet splash
initrd /boot/initrd.img-2.6.27-7-generic
quiet

title Ubuntu 8.10, kernel 2.6.27-7-generic (recovery mode)
uuid 53e1b816-d88d-4016-a4ac-3a6c135cbfb6
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=53e1b816-d88d-4016-a4ac-3a6c135cbfb6 ro  single
initrd /boot/initrd.img-2.6.27-7-generic

title Ubuntu 8.10, memtest86+
uuid 53e1b816-d88d-4016-a4ac-3a6c135cbfb6
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST
Husker Non specificato
Prode Principiante
 
Messaggi: 18
Iscrizione: marzo 2009

Re: [Boot] Non vedo più xp nel boot loader

Messaggioda Husker » martedì 14 aprile 2009, 23:16

In caso servisse posto anche questo.
Disco /dev/sda: 250.0 GB, 250059350016 byte
255 testine, 63 settori/tracce, 30401 cilindri
Unità = cilindri di 16065 * 512 = 8225280 byte
Identificativo disco: 0xe987e987

Dispositivo Boot      Start        End      Blocks  Id  System
/dev/sda1  *          1      30025  241175781  83  Linux
/dev/sda2          30026      30401    3020220    5  Esteso
/dev/sda5          30026      30401    3020188+  82  Linux swap / Solaris

Disco /dev/sdb: 81.9 GB, 81964302336 byte
255 testine, 63 settori/tracce, 9964 cilindri
Unità = cilindri di 16065 * 512 = 8225280 byte
Identificativo disco: 0xeb68eb68

Dispositivo Boot      Start        End      Blocks  Id  System
/dev/sdb1              1        9963    80027766    7  HPFS/NTFS
Husker Non specificato
Prode Principiante
 
Messaggi: 18
Iscrizione: marzo 2009

Re: [Boot] Non vedo più xp nel boot loader

Messaggioda dani.deb » martedì 14 aprile 2009, 23:24

guarda questa sezione:
Codice: Seleziona tutto
## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout      3

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
hiddenmenu


e cambi timeout da 3 in 10
poi davanti all'ultima riga devi mettere #, in modo che diventi così:
Codice: Seleziona tutto
#hiddenmenu


dopodichè ti mancano le righe per windows, che devi aggiungere alla fine, dopo:
Codice: Seleziona tutto
### END DEBIAN AUTOMAGIC KERNELS LIST

ma da quello che hai postato ce l'hai su un secondo hard disk, no?
da due hard disk non l'ho mai fatto, aspetta consigli migliori o cerca sul wiki, questo lo trovi di sicuro

se cambi le righe che ti ho detto e aggiungi quelle per win, poi sei a posto
se non riesci riposta
dani.deb Maschile
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3902
Iscrizione: dicembre 2008
Distribuzione: ubuntu 12.04 64bit + 13.04
Desktop: Lubuntu + Unity + Kubuntu

Re: [Boot] Non vedo più xp nel boot loader

Messaggioda badìl » martedì 14 aprile 2009, 23:24

Ma XP ce l'hai ancora?

Che hai sull'HD da 80 GB?
Avatar utente
badìl Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14806
Iscrizione: agosto 2007

Re: [Boot] Non vedo più xp nel boot loader

Messaggioda Husker » martedì 14 aprile 2009, 23:26

Si xp è su hd 80 gb
Husker Non specificato
Prode Principiante
 
Messaggi: 18
Iscrizione: marzo 2009

Re: [Boot] Non vedo più xp nel boot loader

Messaggioda badìl » martedì 14 aprile 2009, 23:35

Codice: Seleziona tutto
sudo gedit /boot/grub/menu.lst

Aggiungi questo in fondo
Codice: Seleziona tutto
title Windows
rootnoverify (hd0,0)
map (hd0) (hd1)
map (hd1) (hd0)
savedefault
makeactive
chainloader +1
boot

Salva e riavvia.

Dimmi se funziona o no.
Avatar utente
badìl Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14806
Iscrizione: agosto 2007

Re: [Boot] Non vedo più xp nel boot loader

Messaggioda Husker » martedì 14 aprile 2009, 23:45

Purtroppo non funziona mi da:
ERROR13: INVALID OR UNSUPPORTED EXECUTABLE FORMAT
Husker Non specificato
Prode Principiante
 
Messaggi: 18
Iscrizione: marzo 2009

Re: [Boot] Non vedo più xp nel boot loader

Messaggioda dani.deb » martedì 14 aprile 2009, 23:47

@ badìl

è questa la parte che serve in caso di boot da secondo hard disk?
Codice: Seleziona tutto
map (hd0) (hd1)
map (hd1) (hd0)


per il resto vedo che sono le stesse righe che ho anche io per un dual boot su hd unico
dani.deb Maschile
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3902
Iscrizione: dicembre 2008
Distribuzione: ubuntu 12.04 64bit + 13.04
Desktop: Lubuntu + Unity + Kubuntu

Re: [Boot] Non vedo più xp nel boot loader

Messaggioda badìl » martedì 14 aprile 2009, 23:48

Prova rimodifica il file così
Codice: Seleziona tutto
title Windows
rootnoverify (hd0,0)
map (hd1) (hd0)
map (hd0) (hd1)
savedefault
makeactive
chainloader +1
boot


Ho invertito i due map

Poi salva e riavvia.
@dani.deb: Non ho ancora ben capito come funziona la stroria dei map, sto andando a tentativi...

patel dove sei???  :P
Avatar utente
badìl Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14806
Iscrizione: agosto 2007

Re: [Boot] Non vedo più xp nel boot loader

Messaggioda Husker » martedì 14 aprile 2009, 23:57

Nulla da fare, mi da sempre:
ERROR13: INVALID OR UNSUPPORTED EXECUTABLE FORMAT
Husker Non specificato
Prode Principiante
 
Messaggi: 18
Iscrizione: marzo 2009

Re: [Boot] Non vedo più xp nel boot loader

Messaggioda badìl » mercoledì 15 aprile 2009, 0:00

Husker ha scritto:Nulla da fare, mi da sempre:
ERROR13: INVALID OR UNSUPPORTED EXECUTABLE FORMAT


Preso dalla guida sugli errori di grub
AmministrazioneSistema/Grub/Errori

Modifica così
Codice: Seleziona tutto
title              Windows XP
root               (hd1,0)
savedefault
makeactive
map                (hd0) (hd1)
map                (hd1) (hd0)
chainloader        +1


Se funziona ho capito la storia di map...
Avatar utente
badìl Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14806
Iscrizione: agosto 2007

Re: [Boot] Non vedo più xp nel boot loader

Messaggioda Husker » mercoledì 15 aprile 2009, 0:07

OK il comando è giusto ma mi da NTLDR mancante, probabilmente quando ho installato Ubuntu ho inavvertitamente cancellato [mbr]
sul disco da 250 gb, mi sa che dovrò reinstallare xp, grazie a tutti
Husker Non specificato
Prode Principiante
 
Messaggi: 18
Iscrizione: marzo 2009

Re: [Boot] Non vedo più xp nel boot loader

Messaggioda badìl » mercoledì 15 aprile 2009, 0:10

Aspetta, se è XP puoi provare a seguire questa guida per ripristinare il MBR, poi ripristinerai anche grub se non parte più ubuntu (ma forse non serve essendo XP su sdb)
AmministrazioneSistema/RipristinoMbrWindows
Avatar utente
badìl Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14806
Iscrizione: agosto 2007

Re: [Boot] Non vedo più xp nel boot loader

Messaggioda dani.deb » mercoledì 15 aprile 2009, 0:10

prima di reinstallare, guarda che da disco di avvio o di ripristino di xp dovrebbe essere possibile ripristinare il loader..
se riesci, ti risparmi quelle orette di reinstallazione win  ;D

@ badil: ops..
però forse adesso ho capito anche io la storia dei map  ;D
dani.deb Maschile
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3902
Iscrizione: dicembre 2008
Distribuzione: ubuntu 12.04 64bit + 13.04
Desktop: Lubuntu + Unity + Kubuntu


Torna a Applicazioni

Chi c’è in linea

Visualizzano questa sezione: OneLove e 23 ospiti