Windows non visto all'avvio in dual boot

Domande e richieste di un principiante alle prime armi con Ubuntu e il mondo GNU/Linux in generale. Per domande specifiche, utilizzare le altre sezioni.
Regole della sezione
In questa sezione possono inserire nuove discussioni solo coloro che fanno parte del livello "Prode Principiante", tutti gli altri possono comunque rispondere regolarmente. Se si fa parte di questo livello e si è registrati al forum prima del 24 aprile 2012, data del passaggio al nuovo forum, consultare questa discussione.

Immagine Come usare UbuntuIntroduzione a UbuntuPrimi passi su Ubuntu Immagine Amministrazione del sistemaComandi di baseInstallare programmiLog di sistemaRiga di comandoSudo

Windows non visto all'avvio in dual boot

Messaggioda lardossan » venerdì 19 giugno 2009, 16:03

Ciao ho installato la Jaunty Jackalope sul mio portatile che aveva windows xp e invece di di lasciar fare tutto ad ubuntu credo di aver sbagliato la partizione e nel bootloader non c'è la possibilità di avviare windows......ma cerco di spiegare meglio:
hd con tre partizioni,la prima da 2,5 Gb che era residua di una vecchia formattazzione (e da quì è nato il problema!!),la seconda da 50 Gb dove c'era xp e la terza da 30 Gb che avevo svuotato per ubuntu.Prima di installare ho copiato tutto quello che c'era nella prima partizione in una cartella e l'ho messa nella partizione di Windows e volevo usarla per gli swap  e ho avviato l'installazione.Appena riavviato ho capito che windows bootava da quella prima partizione da 2,5 ormai formattata e contenente gli swap.
risultato:da tre giorni sto smanettando su ubuntu  e non penso di voler usare più windows ma vorrei anche sa
pere se è possibile farlo ripartire in qualche modo.ho cercato in giro per il forum e sto iniziando a capire come si usa il terminale ma ho bisogno di aiuto per andare avanti.......intanto aggiungo questo se può essre di aiuto:

Disco /dev/sda: 80.0 GB, 80026361856 byte
255 testine, 63 settori/tracce, 9729 cilindri
Unità = cilindri di 16065 * 512 = 8225280 byte
Identificativo disco: 0xc3bf4bd9

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1         306     2457913+  82  Linux swap / Solaris
/dev/sda2             307        5966    45463950    7  HPFS/NTFS
/dev/sda3            5967        9729    30226297+   f  W95 Esteso (LBA)
/dev/sda5            5967        9729    30226266   83  Linux



Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sdb1               1       19457   156288321    c  W95 FAT32 (LBA)
Ultima modifica di lardossan il sabato 20 giugno 2009, 12:01, modificato 1 volta in totale.
I'm Drexciyan Cruiser Control X 205. If you have any problems let me know. Bubble Control 1 Out.
Avatar utente
lardossan Non specificato
Prode Principiante
 
Messaggi: 117
Iscrizione: giugno 2009
Località: black sea

Re: partizione manuale sbagliata....winzozz non compare nel bootoader

Messaggioda steff » venerdì 19 giugno 2009, 16:06

Dovevi fare una partizione estesa con partizioni logiche nella quarta. Non credo che ci sia da fare qualcosa, se avevi fatto un immagine disco forse. Puoi formattarla e ricopiare i file (era in fat?) ma ci credo poco.
La Documentazione da consultare e la FAQ sul uso del forum
$ rsync -auv --delete /home/NOME/ /media/disco_USB/BACKUP
:: ArchLinux KDE 4.13.2 ::::  Xu|Lu|U|buntu su macchine virtuali ::
Avatar utente
steff Maschile
Moderatore Globale
Moderatore Globale
 
Messaggi: 31595
Iscrizione: febbraio 2007
Località: Toscana
Distribuzione: Arch Linux 64bit
Desktop: Kde con desktop LXQT

Re: partizione manuale sbagliata....winzozz non compare nel bootoader

Messaggioda Stealth » venerdì 19 giugno 2009, 16:06

Cambia il titolo (tasto modifica) modificando il nome del sistema operativo. Meglio non usare dispregiativi, chiamiamolo windows  ;)
ciao
Non nascondiamo le soluzioni tecniche nei messaggi personali, renderemmo inutile il forum. Non risponderò ai messaggi privati che chiedono assistenza. Per iniziare a orientarsi ci sono le Le FAQ del Forum.
Gianni
Avatar utente
Stealth Maschile
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15101
Iscrizione: gennaio 2006
Distribuzione: Ubuntu 12.04.1 LTS
Desktop: Unity

Re: Windows non visto all'avvio in dual boot

Messaggioda sono io il vero spillo » mercoledì 24 giugno 2009, 8:11

posta il risultato di
Codice: Seleziona tutto
cat /boot/grub/menu.lst
Avatar utente
sono io il vero spillo Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1590
Iscrizione: dicembre 2006
Località: casa mia

Re: Windows non visto all'avvio in dual boot

Messaggioda lardossan » sabato 27 giugno 2009, 10:28

Codice: Seleziona tutto
machno@lardossa:~$ cat /boot/grub/menu.lst
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default      0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout      3

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title      Windows 95/98/NT/2000
# root      (hd0,0)
# makeactive
# chainloader   +1
#
# title      Linux
# root      (hd0,1)
# kernel   /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=b21c484e-0e98-4d8a-bddf-08069e43ee68 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=b21c484e-0e98-4d8a-bddf-08069e43ee68

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## specify if running in Xen domU or have grub detect automatically
## update-grub will ignore non-xen kernels when running in domU and vice versa
## e.g. indomU=detect
##      indomU=true
##      indomU=false
# indomU=detect

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title      Ubuntu 9.04, kernel 2.6.28-11-generic
uuid      b21c484e-0e98-4d8a-bddf-08069e43ee68
kernel      /boot/vmlinuz-2.6.28-11-generic root=UUID=b21c484e-0e98-4d8a-bddf-08069e43ee68 ro quiet splash
initrd      /boot/initrd.img-2.6.28-11-generic
quiet

title      Ubuntu 9.04, kernel 2.6.28-11-generic (recovery mode)
uuid      b21c484e-0e98-4d8a-bddf-08069e43ee68
kernel      /boot/vmlinuz-2.6.28-11-generic root=UUID=b21c484e-0e98-4d8a-bddf-08069e43ee68 ro  single
initrd      /boot/initrd.img-2.6.28-11-generic

title      Ubuntu 9.04, memtest86+
uuid      b21c484e-0e98-4d8a-bddf-08069e43ee68
kernel      /boot/memtest86+.bin
quiet

title        Microsoft Windows XP Home Edition
root        (hd0,1)
savedefault
makeactive
chainloader    +1
### END DEBIAN AUTOMAGIC KERNELS LIST
machno@lardossa:~$
I'm Drexciyan Cruiser Control X 205. If you have any problems let me know. Bubble Control 1 Out.
Avatar utente
lardossan Non specificato
Prode Principiante
 
Messaggi: 117
Iscrizione: giugno 2009
Località: black sea

Re: Windows non visto all'avvio in dual boot

Messaggioda Mozo » sabato 27 giugno 2009, 10:51

Ma qual'è l'errore che compare se cerchi di avviare windows?
Non ho mai incontrato un uomo così ignorante dal quale non abbia potuto imparare qualcosa. [Galileo Galilei]
I got power, I'm proud to be loud; my signal goes out clear - I want everybody to know that Mozo is here - On the air…
Wiki-Documentazione - Cerca in ubuntu-it
Avatar utente
Mozo Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2354
Iscrizione: marzo 2006

Re: partizione manuale sbagliata....winzozz non compare nel bootoader

Messaggioda steff » sabato 27 giugno 2009, 11:17

steff ha scritto:Dovevi fare una partizione estesa con partizioni logiche nella quarta. Non credo che ci sia da fare qualcosa, se avesti fatto un immagine disco forse. Puoi formattarla e ricopiarci i file (era in fat?) ma ci credo poco.


Hai provato? E' l'unica cosa che potrebbe funzionare, a parte reinstallare windows
La Documentazione da consultare e la FAQ sul uso del forum
$ rsync -auv --delete /home/NOME/ /media/disco_USB/BACKUP
:: ArchLinux KDE 4.13.2 ::::  Xu|Lu|U|buntu su macchine virtuali ::
Avatar utente
steff Maschile
Moderatore Globale
Moderatore Globale
 
Messaggi: 31595
Iscrizione: febbraio 2007
Località: Toscana
Distribuzione: Arch Linux 64bit
Desktop: Kde con desktop LXQT

Re: Windows non visto all'avvio in dual boot

Messaggioda Mozo » sabato 27 giugno 2009, 11:23

Scusa steff... ma sda3 non è estesa? con sda5 logica?    ::)
Non ho mai incontrato un uomo così ignorante dal quale non abbia potuto imparare qualcosa. [Galileo Galilei]
I got power, I'm proud to be loud; my signal goes out clear - I want everybody to know that Mozo is here - On the air…
Wiki-Documentazione - Cerca in ubuntu-it
Avatar utente
Mozo Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2354
Iscrizione: marzo 2006

Re: Windows non visto all'avvio in dual boot

Messaggioda steff » sabato 27 giugno 2009, 11:30

giusto, non so come sono arrivato a pensare questo. cmq bisognerebbe cercare di restaurare la sda1...
La Documentazione da consultare e la FAQ sul uso del forum
$ rsync -auv --delete /home/NOME/ /media/disco_USB/BACKUP
:: ArchLinux KDE 4.13.2 ::::  Xu|Lu|U|buntu su macchine virtuali ::
Avatar utente
steff Maschile
Moderatore Globale
Moderatore Globale
 
Messaggi: 31595
Iscrizione: febbraio 2007
Località: Toscana
Distribuzione: Arch Linux 64bit
Desktop: Kde con desktop LXQT

Re: Windows non visto all'avvio in dual boot

Messaggioda lardossan » sabato 27 giugno 2009, 14:49

premettendo che nel menù del grub sono andato io ad aggiungere
Codice: Seleziona tutto
title        Microsoft Windows XP Home Edition
root        (hd0,1)
savedefault
makeactive
chainloader    +1

con  (hd0,0) dice: error13 invalid or unsupported executable format
ho provato a cambiarlo con (hd0,1) come sopra e l'errore se non ricordo male era ntldr qualcosa 8)
comunque la partizione logica non l'ho fatta perchè non ero sicuro sul da farsi e non volevo rischiare di fare ancora danno.restaurare la sda1 non saprei proprio come fare....
I'm Drexciyan Cruiser Control X 205. If you have any problems let me know. Bubble Control 1 Out.
Avatar utente
lardossan Non specificato
Prode Principiante
 
Messaggi: 117
Iscrizione: giugno 2009
Località: black sea

Re: Windows non visto all'avvio in dual boot

Messaggioda steff » sabato 27 giugno 2009, 14:56

dicevi che hai copiati i file che c'erano in una cartella sulla partizione di windows, no? Se la ritrovi potresti provare di formattarla in fat e ricopiarci i file della cartella, mettendo (hd0,0) nel menu di grub per provare di avviare
La Documentazione da consultare e la FAQ sul uso del forum
$ rsync -auv --delete /home/NOME/ /media/disco_USB/BACKUP
:: ArchLinux KDE 4.13.2 ::::  Xu|Lu|U|buntu su macchine virtuali ::
Avatar utente
steff Maschile
Moderatore Globale
Moderatore Globale
 
Messaggi: 31595
Iscrizione: febbraio 2007
Località: Toscana
Distribuzione: Arch Linux 64bit
Desktop: Kde con desktop LXQT

Re: Windows non visto all'avvio in dual boot

Messaggioda lardossan » sabato 27 giugno 2009, 15:35

si ma  la swap devo spostarla,quindi fare una nuova partizione e poi formattare la sda1........con gparted si può fare ?stavo leggendo il wiki su come creare un nuovo file swap ma vorrei essere sicuro prima di metterci mano ;D
I'm Drexciyan Cruiser Control X 205. If you have any problems let me know. Bubble Control 1 Out.
Avatar utente
lardossan Non specificato
Prode Principiante
 
Messaggi: 117
Iscrizione: giugno 2009
Località: black sea

Re: Windows non visto all'avvio in dual boot

Messaggioda steff » sabato 27 giugno 2009, 15:45

Se hai tanta ram (1gb o più) puoi anche andare senza per il momento. Devi ridurre sda5 e crearla in quel spazio, con gparted, ma devi aggiornare l'uuid in /etc/fstab anche.
La Documentazione da consultare e la FAQ sul uso del forum
$ rsync -auv --delete /home/NOME/ /media/disco_USB/BACKUP
:: ArchLinux KDE 4.13.2 ::::  Xu|Lu|U|buntu su macchine virtuali ::
Avatar utente
steff Maschile
Moderatore Globale
Moderatore Globale
 
Messaggi: 31595
Iscrizione: febbraio 2007
Località: Toscana
Distribuzione: Arch Linux 64bit
Desktop: Kde con desktop LXQT

Re: Windows non visto all'avvio in dual boot

Messaggioda lardossan » sabato 27 giugno 2009, 16:30

ma la sda1 devo formattarla in fat? perchè non ricordo prima com'era.........e poi su gparted c'è il boot sulla flag dell' sda1 devo cambiarlo?
I'm Drexciyan Cruiser Control X 205. If you have any problems let me know. Bubble Control 1 Out.
Avatar utente
lardossan Non specificato
Prode Principiante
 
Messaggi: 117
Iscrizione: giugno 2009
Località: black sea

Re: Windows non visto all'avvio in dual boot

Messaggioda steff » sabato 27 giugno 2009, 17:07

il flag è a posto. Proverei con fat.
La Documentazione da consultare e la FAQ sul uso del forum
$ rsync -auv --delete /home/NOME/ /media/disco_USB/BACKUP
:: ArchLinux KDE 4.13.2 ::::  Xu|Lu|U|buntu su macchine virtuali ::
Avatar utente
steff Maschile
Moderatore Globale
Moderatore Globale
 
Messaggi: 31595
Iscrizione: febbraio 2007
Località: Toscana
Distribuzione: Arch Linux 64bit
Desktop: Kde con desktop LXQT

Re: Windows non visto all'avvio in dual boot

Messaggioda lardossan » sabato 27 giugno 2009, 17:32

ok formattata fat32 ma come faccio a rimetterci dentro i file  vecchi?da terminale .......... ???
I'm Drexciyan Cruiser Control X 205. If you have any problems let me know. Bubble Control 1 Out.
Avatar utente
lardossan Non specificato
Prode Principiante
 
Messaggi: 117
Iscrizione: giugno 2009
Località: black sea

Re: Windows non visto all'avvio in dual boot

Messaggioda steff » sabato 27 giugno 2009, 17:53

dovresti vederla in "computer", cliccaci

ps: forse devi riavviare la live...
La Documentazione da consultare e la FAQ sul uso del forum
$ rsync -auv --delete /home/NOME/ /media/disco_USB/BACKUP
:: ArchLinux KDE 4.13.2 ::::  Xu|Lu|U|buntu su macchine virtuali ::
Avatar utente
steff Maschile
Moderatore Globale
Moderatore Globale
 
Messaggi: 31595
Iscrizione: febbraio 2007
Località: Toscana
Distribuzione: Arch Linux 64bit
Desktop: Kde con desktop LXQT

Re: Windows non visto all'avvio in dual boot

Messaggioda lardossan » sabato 27 giugno 2009, 18:10

:'( spostati i file e riavviato mi dice this is not a bootable disk.creo non si possa fare più niente vero?
dimmelo così non ci penso più  ;D
I'm Drexciyan Cruiser Control X 205. If you have any problems let me know. Bubble Control 1 Out.
Avatar utente
lardossan Non specificato
Prode Principiante
 
Messaggi: 117
Iscrizione: giugno 2009
Località: black sea

Re: Windows non visto all'avvio in dual boot

Messaggioda steff » sabato 27 giugno 2009, 19:37

Credo che è così, pace all'anima sua  8)
La Documentazione da consultare e la FAQ sul uso del forum
$ rsync -auv --delete /home/NOME/ /media/disco_USB/BACKUP
:: ArchLinux KDE 4.13.2 ::::  Xu|Lu|U|buntu su macchine virtuali ::
Avatar utente
steff Maschile
Moderatore Globale
Moderatore Globale
 
Messaggi: 31595
Iscrizione: febbraio 2007
Località: Toscana
Distribuzione: Arch Linux 64bit
Desktop: Kde con desktop LXQT


Torna a Dilemmi del principiante

Chi c’è in linea

Visualizzano questa sezione: ancxjo e 1 ospite