[Risolto] Ancora problemi con Internet Key Huawei e169 della tre

Networking, configurazione della connessione, periferiche e condivisione di rete, ecc.

[Risolto] Ancora problemi con Internet Key Huawei e169 della tre

Messaggioda alesi2 » martedì 16 febbraio 2010, 9:22

Buongiorno a tutti.
Sono nuovo del forum e del mondo Linux ed ho necessità di utilizzare la chiavetta tre in questione sul mio PC Ubuntu.
Ho provato a seguire le indicazione di decine di forum e tutorial: sono arrivato a al punto in cui il la chiavetta viene riconosciuta come modem, ho superato il problema del NO CARRIER ma ancora non sono arrivato al traguardo della connessione.
Ringrazio in anticipo chiunque sia disposto ad aiutarmi!

Elenco direttamente tutte le info che credo possano essere utili:

SO:
root@UBUNTU:~# uname -a
Linux UBUNTU 2.6.31-14-generic #48lp451337apw1 SMP Wed Oct 28 13:48:18 UTC 2009 i686 GNU/Linux


Ho aggiornato il kernel con il pacchetto:
linux-image-2.6.31-14-generic_2.6.31-14.48lp451337apw1_i386.deb

Stato slot USB:
root@UBUNTU:~# lsusb
Bus 001 Device 004: ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem
Bus 001 Device 002: ID 413c:3012 Dell Computer Corp. Optical Wheel Mouse
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


wvdial.conf
[Dialer e169]
Modem = /dev/ttyUSB2
ISDN = 0
Modem Type = USB
Modem Baud = 460800
Init = ATZ
Init2 = AT+CGDCONT=1,"ip","datacard.tre.it",,0,0  ( "datacard.tre.it" preso dalla configurazione del software di connessione Windows)
Phone = *99# (preso dalla configurazione del software di connessione Windows)
Dial Attempts = 1
Dial Command = ATM0L0DT
Ask Password = off
Username = tre
Password = tre
Auto Reconnect = on
Abort on Busy = off
Carrier Check = off
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = on
Idle Seconds = 0
Auto DNS = on


Tentativo di connessione
root@UBUNTU:~# wvdial e169
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: AT+CGDCONT=1,"ip","datacard.tre.it",,0,0
AT+CGDCONT=1,"ip","datacard.tre.it",,0,0
OK
--> Modem initialized.
--> Sending: ATM0L0DT*99#
--> Waiting for carrier.
ATM0L0DT*99#
CONNECT
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Mon Feb 15 21:11:26 2010
--> Pid of pppd: 2554
--> Using interface ppp0
--> pppd: 0���8�[01] ��[01] [01]
--> pppd: 0���8�[01] ��[01] [01]
--> pppd: 0���8�[01] ��[01] [01]
--> pppd: 0���8�[01] ��[01] [01]
--> pppd: 0���8�[01] ��[01] [01]
--> pppd: 0���8�[01] ��[01] [01]
--> pppd: 0���8�[01] ��[01] [01]
--> Disconnecting at Mon Feb 15 21:11:56 2010
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds
--> Cannot get information for serial port.


Log da /var/log/messages
Feb 16 09:11:03 UBUNTU kernel: [ 1657.964161] usb 1-3: new full speed USB device using ohci_hcd and address 3
Feb 16 09:11:03 UBUNTU kernel: [ 1658.192150] usb 1-3: configuration #1 chosen from 1 choice
Feb 16 09:11:03 UBUNTU kernel: [ 1658.419781] Initializing USB Mass Storage driver...
Feb 16 09:11:03 UBUNTU kernel: [ 1658.427640] usb 1-3: USB disconnect, address 3
Feb 16 09:11:03 UBUNTU kernel: [ 1658.432994] scsi2 : SCSI emulation for USB Mass Storage devices
Feb 16 09:11:03 UBUNTU kernel: [ 1658.433337] usbcore: registered new interface driver usb-storage
Feb 16 09:11:03 UBUNTU kernel: [ 1658.433347] USB Mass Storage support registered.
Feb 16 09:11:04 UBUNTU kernel: [ 1658.932244] usb 1-3: new full speed USB device using ohci_hcd and address 4
Feb 16 09:11:04 UBUNTU kernel: [ 1659.150044] usb 1-3: configuration #1 chosen from 1 choice
Feb 16 09:11:04 UBUNTU kernel: [ 1659.189102] scsi6 : SCSI emulation for USB Mass Storage devices
Feb 16 09:11:04 UBUNTU kernel: [ 1659.264609] usbcore: registered new interface driver usbserial
Feb 16 09:11:04 UBUNTU kernel: [ 1659.264655] USB Serial support registered for generic
Feb 16 09:11:04 UBUNTU kernel: [ 1659.264774] usbcore: registered new interface driver usbserial_generic
Feb 16 09:11:04 UBUNTU kernel: [ 1659.264780] usbserial: USB Serial Driver core
Feb 16 09:11:04 UBUNTU kernel: [ 1659.284462] USB Serial support registered for GSM modem (1-port)
Feb 16 09:11:04 UBUNTU kernel: [ 1659.284584] option 1-3:1.0: GSM modem (1-port) converter detected
Feb 16 09:11:04 UBUNTU kernel: [ 1659.284894] usb 1-3: GSM modem (1-port) converter now attached to ttyUSB0
Feb 16 09:11:04 UBUNTU kernel: [ 1659.284926] option 1-3:1.1: GSM modem (1-port) converter detected
Feb 16 09:11:04 UBUNTU kernel: [ 1659.285049] usb 1-3: GSM modem (1-port) converter now attached to ttyUSB1
Feb 16 09:11:04 UBUNTU kernel: [ 1659.285075] option 1-3:1.2: GSM modem (1-port) converter detected
Feb 16 09:11:04 UBUNTU kernel: [ 1659.285213] usb 1-3: GSM modem (1-port) converter now attached to ttyUSB2
Feb 16 09:11:04 UBUNTU kernel: [ 1659.285259] usbcore: registered new interface driver option
Feb 16 09:11:04 UBUNTU kernel: [ 1659.285266] option: v0.7.2:USB Driver for GSM modems
Feb 16 09:11:09 UBUNTU kernel: [ 1664.224969] scsi 6:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
Feb 16 09:11:09 UBUNTU kernel: [ 1664.235978] scsi 6:0:0:1: Direct-Access     HUAWEI   SD Storage       2.31 PQ: 0 ANSI: 2
Feb 16 09:11:09 UBUNTU kernel: [ 1664.322421] sr1: scsi-1 drive
Feb 16 09:11:09 UBUNTU kernel: [ 1664.323042] sr 6:0:0:0: Attached scsi generic sg2 type 5
Feb 16 09:11:09 UBUNTU kernel: [ 1664.323322] sd 6:0:0:1: Attached scsi generic sg3 type 0
Feb 16 09:11:09 UBUNTU kernel: [ 1664.387688] sd 6:0:0:1: [sdb] Attached SCSI removable disk
Feb 16 09:15:15 UBUNTU pppd[2388]: pppd 2.4.5 started by root, uid 0
Feb 16 09:15:15 UBUNTU pppd[2388]: Using interface ppp0
Feb 16 09:15:15 UBUNTU pppd[2388]: Connect: ppp0 <--> /dev/ttyUSB2
Feb 16 09:15:45 UBUNTU pppd[2388]: LCP: timeout sending Config-Requests
Feb 16 09:15:45 UBUNTU pppd[2388]: Connection terminated.
Feb 16 09:15:45 UBUNTU pppd[2388]: Receive serial link is not 8-bit clean:
Feb 16 09:15:45 UBUNTU pppd[2388]: Problem: all had bit 7 set to 0
Feb 16 09:15:46 UBUNTU pppd[2388]: Modem hangup
Feb 16 09:15:46 UBUNTU pppd[2388]: Exit.


...credo sia tutto. Scusate la lunghezza del post ma ho preferito inserire subito tutte le info che, nella mia inesperienza, penso possano essere utili.

Ale
Ultima modifica di alesi2 il martedì 16 febbraio 2010, 12:38, modificato 1 volta in totale.
Avatar utente
alesi2 Non specificato
Prode Principiante
 
Messaggi: 17
Iscrizione: febbraio 2010
Località: Roma

Re: [Internet] Ancora problemi con Internet Key Huawei e169 della tre

Messaggioda Devnull » martedì 16 febbraio 2010, 11:28

Hai generato il file di configurazione della connessione con il comando

Codice: Seleziona tutto
sudo wvdialconf /etc/wvdial.conf
?

Una volta che lo hai ottento aggiungi al file /etc/wvdial.conf l'apn e il numero telefonico.

Ciao.
Da regolamento (Sez. I punto 15) è vietato inviare messaggi privati per richieste di supporto tecnico, si prega di aprire una discussione nella giusta sezione.
Hai domande sul forum? Leggi le FAQ e il Regolamento.
→ → → → Partecipa alla documentazione ← ← ← ←
Avatar utente
Devnull Non specificato
Moderatore Globale
Moderatore Globale
 
Messaggi: 8078
Iscrizione: novembre 2005
Località: Ancona

Re: [Internet] Ancora problemi con Internet Key Huawei e169 della tre

Messaggioda alesi2 » martedì 16 febbraio 2010, 12:13

Mille grazie Devnull!

Avevo semplicemente copiato i vari file di configurazione di wvdial.conf presi dai vari tutorial.... non conoscevo il comando wcdialconf!  :-[

Ho generato il file ed aggiunto i dati mancanti. Ora il wvdial.conf è cosi:

[Dialer e169]
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=1,"ip","datacard.tre.it",,0,0
Modem Type = Analog Modem
Phone = *99#
ISDN = 0
Username = tre
Init1 = ATZ
Password = tre
Modem = /dev/ttyUSB0
Baud = 9600


e la connessione funziona bene.

Ne approfitto per fare una domanda: che differenza c'è tra l'utilizzo di wvdial ed il network manager?

Ancora grazie
Ale
Avatar utente
alesi2 Non specificato
Prode Principiante
 
Messaggi: 17
Iscrizione: febbraio 2010
Località: Roma

Re: [Internet] Ancora problemi con Internet Key Huawei e169 della tre

Messaggioda Devnull » martedì 16 febbraio 2010, 12:43

alesi2 ha scritto:Avevo semplicemente copiato i vari file di configurazione di wvdial.conf presi dai vari tutorial.... non conoscevo il comando wcdialconf!  :-[


Personalmente ho letto un sacco di guide su internet sull'utilizzo di wvdial ma tutte scritte male. Il copia e incolla da internet non va bene molte volte.  ;D

alesi2 ha scritto:Ne approfitto per fare una domanda: che differenza c'è tra l'utilizzo di wvdial ed il network manager?

Ancora grazie
Ale


Se il fine è creare una connessione non vedo differenza.

Se poi hai un sistema server a riga di comando, c'è solo da utilizzare wvdial magari per mettere su un router hsdpa con un vecchio pc.  ;)

Ciao.
Da regolamento (Sez. I punto 15) è vietato inviare messaggi privati per richieste di supporto tecnico, si prega di aprire una discussione nella giusta sezione.
Hai domande sul forum? Leggi le FAQ e il Regolamento.
→ → → → Partecipa alla documentazione ← ← ← ←
Avatar utente
Devnull Non specificato
Moderatore Globale
Moderatore Globale
 
Messaggi: 8078
Iscrizione: novembre 2005
Località: Ancona

Re: [Risolto] Ancora problemi con Internet Key Huawei e169 della tre

Messaggioda dav2dev » martedì 16 febbraio 2010, 14:23

lsusb
Bus 001 Device 004: ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem

anche a me la riconosce così, ma la mia chiavetta è una e1550...
comunque funziona bene con networkmanager (quindi è molto più comodo di wvdial), però io ho networkmanager aggiornato alla 0.8~rc4, magari con la versione originale di karmic non funziona, non saprei...
«Dice fai così e così e vedi se c'è da qualche parte (!) la riga... se non c'è aggiungila... A chi? Ma se mi sono presentato come "meno che neofita"!  Scusa dav2dev, ma tu così spaventi la gente!»
dav2dev Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2053
Iscrizione: ottobre 2006

Re: [Risolto] Ancora problemi con Internet Key Huawei e169 della tre

Messaggioda alesi2 » martedì 16 febbraio 2010, 15:22

Ciao dav2dev,
in effetti con la versione aggiornata di NetworkManager (v 0.7.996) la connessione funziona bene.
Però volevo riuscire a farla funzionare anche con wvdial.
La cosa che ancora non ho capito è fino a che punto wvdial e network manager sono indipendenti? Sono solamente due 'interfacce' che controllano lo stesso meccanismo sottostante e sono due cose distinte?
Mi scuso per la banalità di questa domanda che potrebbe sembrare futile ma sono nuovo del mondo Linux e sono molto interessato a capire (sono uno sviluppatore Java e vorrei trasferire ambiente di sviluppo e tutto il resto in ambiente Linux).

Grazie
Ale
Avatar utente
alesi2 Non specificato
Prode Principiante
 
Messaggi: 17
Iscrizione: febbraio 2010
Località: Roma

Re: [Risolto] Ancora problemi con Internet Key Huawei e169 della tre

Messaggioda dav2dev » martedì 16 febbraio 2010, 15:49

per la connessione usano entrambi pppd, quindi non può succedere che uno "va più veloce" dell'altro, o è "più stabile" o altro.
Wvdial usa wvdialconf per esplorare i dispositivi alla ricerca di porte seriali che rispondano ai comandi AT oppure  puoi configurare manualmente la porta giusta, networkmanager usa invece modemmanager che vuole fare tutto da solo ma al momento è un po' acerbo. Comunque modemmanager ha molte più potenzialità di wvdial, per esempio se una chiavetta ha bisogno di comandi AT specifici (che manderebbero in crash altre chiavette), modemmanager può gestire tutto da solo senza che l'utente faccia niente, mentre con wvdial devi andare su internet alla ricerca di qualcuno che abbia risolto lo stesso problema... Un problema che ho avuto di recente con modemmanager è che usava la porta seriale sbagliata (/dev/ttyUSB2 invece di /dev/ttyUSB1 su una chiavetta alcatel X020), in questo caso l'utente non ha controllo sulla situazione e non puoi connetterti con networkmanager; invece con wvdial è bastato entrare nella configurazione e impostare la porta giusta, e la connessione è andata. In ogni caso ho segnalato il bug di modemmanager e hanno prontamente risolto il problema, quindi adesso anche con quella chiavetta fila tutto liscio :)
«Dice fai così e così e vedi se c'è da qualche parte (!) la riga... se non c'è aggiungila... A chi? Ma se mi sono presentato come "meno che neofita"!  Scusa dav2dev, ma tu così spaventi la gente!»
dav2dev Non specificato
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2053
Iscrizione: ottobre 2006

Re: [Risolto] Ancora problemi con Internet Key Huawei e169 della tre

Messaggioda Rob68 » venerdì 4 giugno 2010, 19:31

quoto
Rob68 Non specificato
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 331
Iscrizione: novembre 2006

Re: [Risolto] Ancora problemi con Internet Key Huawei e169 della tre

Messaggioda albyman78 » venerdì 4 giugno 2010, 22:31

Ciao a tutti,
mi inserisco nella discussione per chiedervi un aiuto!
Anche io ho una Huawei e169 della Tre e la connessione fuonziona (sebbene non sia velecissima).
Il problema consiste nel fatto che una volta disconnesso, per potermi connettere nuovamente devo scollegare la chiavetta e reinserirla!
Praticamente, mi riconosce la connesione ma non vuole saperne a connettersi!
Come mai?
Spero di essere stato più o meno chiaro!
Grazie fin da ora!

Alberto
Avatar utente
albyman78 Non specificato
Prode Principiante
 
Messaggi: 149
Iscrizione: gennaio 2009

Re: [Risolto] Ancora problemi con Internet Key Huawei e169 della tre

Messaggioda pierluigi64 » lunedì 22 novembre 2010, 0:36

Da poco sono passato a linux .Ho installato lubuntu 10.04 su un pc dove era installato xp. Non riesco ad installare la chiavetta della tre E122 .Sono riuscito ad installare solo usb-Modeswitch- data era un .deb e ho fatto doppio clic,  per usb-modeswitch non so come installarlo è un tar.bz2 Se qualcuno mi spiega la procedura passopasso per l installazione della chiavetta. Grazie
pierluigi64 Non specificato
Prode Principiante
 
Messaggi: 7
Iscrizione: novembre 2010


Torna a Connessione e configurazione delle reti

Chi c’è in linea

Visualizzano questa sezione: Vicar e 7 ospiti