Notizia:
  • Rilasciata Ubuntu 13.10 Saucy Salamander. Per ottenerla, visitate questa pagina oppure visualizzate la dimostrazione.
  • È uscito il numero 15 della Newsletter italiana di Ubuntu. Lo trovate a questo indirizzo.
  • È uscito il numero 79 di Full Circle Magazine in italiano. Lo trovate a questo indirizzo.

[Boot] problema all avvio mbr

Configurazione e uso delle versioni live di Ubuntu.

[Boot] problema all avvio mbr

Messaggioda s4v1o » venerdì 9 marzo 2012, 16:28

salve ho comprato ieri il mio netbook asus 1015px con linux preinstallato, ci ho smanettato un pò e avevo intenzione di visualizzare il boot per il ripristino solo per capire come funzionasse ma adesso il netbook non si avvia più, si blocca con una scritta mbr
soluzioni ??
s4v1o Non specificato
Prode Principiante
 
Messaggi: 14
Iscrizione: marzo 2012

Re: [Boot] problema all avvio mbr

Messaggioda sbalgio senpre » venerdì 9 marzo 2012, 16:31

Ciao, benvenuto  :)
Di quale linux parli? Se si tratta di Ubuntu 10.04 o successivo devi seguire questa guida: AmministrazioneSistema/Grub/Ripristino
Avatar utente
sbalgio senpre Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4791
Iscrizione: novembre 2011

Re: [Boot] problema all avvio mbr

Messaggioda s4v1o » venerdì 9 marzo 2012, 16:46

nel mio netbook era installata la 10.04, posso installare tranquillamente la 11.10 ? oppure me la sconsiglia ?
lei mi sa dire come si è fatto a corrompere il sistema, ho premuto solo f9

dimenticavo il mio netbook non ha lettore cd e presenta una partizione nascosta, però non si avvia  ::)
s4v1o Non specificato
Prode Principiante
 
Messaggi: 14
Iscrizione: marzo 2012

Re: [Boot] problema all avvio mbr

Messaggioda sbalgio senpre » venerdì 9 marzo 2012, 17:04

Se è d'accordo possiamo darci del tu com'è consuetudine sul forum.
Il suo netbook dovrebbe avere 1 GB di RAM che sono appena sufficienti per la 11.10. Diciamo che ci sta un po' strettina. Meglio tenere l'ottima 10.04 che è una versione LTS.
Premendo F9 probabilmente ha fatto partire la procedura di recovery del sistema che evidentemente si è interrotta per qualche motivo. Ciò ha creato problemi all'MBR il che impedisce l'avvio di GRUB e di Ubuntu.
Per creare una chiavetta USB avviabile, al posto del classico cd o dvd d'installazione, è sufficiente che scarichi l'immagine iso da qui e la prepari così. E' importante che scarichi l'immagine iso corrispondente al sistema installato sul netbook, quindi scarichi la 32-bit s'è installato Ubuntu 32 bit o la 64-bit s'è è installato il 64-bit.
Con tale chiavetta potrà seguire la guida che le ho postato in precedenza.
Ultima modifica di sbalgio senpre il venerdì 9 marzo 2012, 17:06, modificato 1 volta in totale.
Avatar utente
sbalgio senpre Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4791
Iscrizione: novembre 2011

Re: [Boot] problema all avvio mbr

Messaggioda s4v1o » venerdì 9 marzo 2012, 17:09

grazie per la risposta

il mio netbook ha 2 gb di ram però non so se c'era installata la versione da 32 o 64 bit riesco a leggerlo dal bios ?

ho avviato la penna usb e sono nell istallazione, mi chiede dove installare ubuntu ci sono 3 partizione dev/sda1 dev/sda2 e dev/sda3 ubuntu 10.10
presumo che le prime due sono le partizioni del ripristino quindi non devo cancellarle dovrei installare nella terza partizione sda3 come faccio ?
sono entrato in ubuntu senza installarlo e trovo il file system della partizione nascosta è possibile installare la recovery da netbook acceso ?
Ultima modifica di s4v1o il venerdì 9 marzo 2012, 19:32, modificato 1 volta in totale.
s4v1o Non specificato
Prode Principiante
 
Messaggi: 14
Iscrizione: marzo 2012

Re: [Boot] problema all avvio mbr

Messaggioda sbalgio senpre » venerdì 9 marzo 2012, 21:02

Con 2 GB di RAM puoi installare tranquillamente anche la 11.10.
Cosa vuoi fare, riparare solo l'MBR o installare la 11.10?
Avatar utente
sbalgio senpre Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4791
Iscrizione: novembre 2011

Re: [Boot] problema all avvio mbr

Messaggioda s4v1o » venerdì 9 marzo 2012, 21:47

sono nuovo di linux 5 ore scarse di utilizzo e ho già creato problemi al netbook  >:(
vorrei installare la versione che consuma meno per risparmiare in batteria, qual'è 11.10 o 10.04 ?
mbr sarebbe la partizione nascosta danneggiata ? in tal caso si vorrei ripararla

al momento della formattazione si presentano 3 partizioni quale devo formattare ? non vorrei eliminare la partizione nascosta
dev/sda1 2 gb dev/sda2 2.1 gb e dev/sda3 300 gb
s4v1o Non specificato
Prode Principiante
 
Messaggi: 14
Iscrizione: marzo 2012

Re: [Boot] problema all avvio mbr

Messaggioda giulux » venerdì 9 marzo 2012, 22:09

vediamo di capire meglio come stanno le cose
avviando con la pennetta, apri un terminale (Ctr+Alt+T) e digita
Codice: Seleziona tutto
sudo fdisk -l
alla richiesta di password essendo in live basterà spingere invio
evidenzia e copia tutto il contenuto del terminale e postalo qui, incollandolo tra i tag [ code] che si aprono cliccando su # che vedi sopra le faccine della finestra dove scrivi

avvia gparted (lo trovi in Sistema/amministrazione) e fai una copia della sua finestra pigiando contemporaneamente Maiusc+Stamp: la salvi sulla scrivania e la alleghi al post usando Opzioni aggiuntive (in basso a sx, fuori della finestra di scrittura)

poi parliamo di cosa installare
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux Maschile
Moderatore Globale
Moderatore Globale
 
Messaggi: 10923
Iscrizione: gennaio 2010
Località: Roma
Distribuzione: Ubuntu 12.04.1 LTS i686
Desktop: xubuntu

Re: [Boot] problema all avvio mbr

Messaggioda s4v1o » venerdì 9 marzo 2012, 22:48

Usage:
fdisk [options]     change partition table
fdisk [options] -l list partition table(s)
fdisk -s       give partition size(s) in blocks

Options:
-b                 sector size (512, 1024, 2048 or 4096)
-c                        switch off DOS-compatible mode
-h                        print help
-u                 give sizes in sectors instead of cylinders
-v                        print version
-C               specify the number of cylinders
-H               specify the number of heads
-S               specify the number of sectors per track

gparted crasha non si apre
s4v1o Non specificato
Prode Principiante
 
Messaggi: 14
Iscrizione: marzo 2012

Re: [Boot] problema all avvio mbr

Messaggioda sbalgio senpre » sabato 10 marzo 2012, 0:43

Probabilmente hai sbagliato a digitare. L'ultimo carattere è una elle minuscola.
Ridigita:
Codice: Seleziona tutto
sudo fdisk -l

Posta anche
Codice: Seleziona tutto
sudo parted -l


Per risponderti sull'MBR, non è una partizione, sono i primi 512 byte del disco fisso. In essi sono contenuti la tabella delle partizioni ed il codice necessario ad avviare il bootloader: http://it.wikipedia.org/wiki/Master_boot_record
A seguito di operazioni errate questi dati possono essere danneggiati o cancellati e vanno ripristinati.
Avatar utente
sbalgio senpre Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4791
Iscrizione: novembre 2011

Re: [Boot] problema all avvio mbr

Messaggioda s4v1o » sabato 10 marzo 2012, 12:35

ieri sera ho deciso di formattare la partizione sda3 non so se ho cancellato la partizione nascosta, nel sda2 ho inserito lo swap


Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000eaa63

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1  *          1        244    1951744    b  W95 FAT32
/dev/sda2            244        498    2046976  82  Linux swap / Solaris
/dev/sda3            498      38914  308571136  83  Linux




Model: ATA Hitachi HTS54323 (scsi)
Disk /dev/sda: 320GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start  End    Size    Type    File system    Flags
1      1049kB  2000MB  1999MB  primary  fat32          boot
2      2000MB  4096MB  2096MB  primary  linux-swap(v1)
3      4096MB  320GB  316GB  primary  ext3

è ancora rimediabile il boot ?

inizialmente avevo installato ubuntu 10.04 desktop ma finita l installazione mi dava una serie di errori e non mi compariva nulla sul desktop, ora ho installato 10.10 netbook sembra che vada tutto bene però è tutto in inglese anche se nelle lingue ho impostato italiano.
quindi su netbook posso essere installate solo le versioni netbook di ubuntu ?
s4v1o Non specificato
Prode Principiante
 
Messaggi: 14
Iscrizione: marzo 2012

Re: [Boot] problema all avvio mbr

Messaggioda sbalgio senpre » sabato 10 marzo 2012, 15:03

No, sui netbook si può installare anche una versione desktop, infatti dalla 11.04 in poi, se non erro, non ci sono più le versioni netbook.
La partizione "nascosta" credo sia sda1.
Se vuoi ripristinare GRUB nell'MBR segui la guida che ti ho postato (se trovi delle difficoltà chiedi pure).
Se invece vuoi installare la 11.10 scaricala da: http://www.ubuntu-it.org/scopri-ubuntu/download
Avatar utente
sbalgio senpre Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4791
Iscrizione: novembre 2011

Re: [Boot] problema all avvio mbr

Messaggioda s4v1o » sabato 10 marzo 2012, 20:07

sto leggendo la guida per risolvere mbr ma non capisco quale dispositivi devo montare

io ho installato ubuntu in sda3 e in sda1 ci dovrebbe essere il boot la guida dice di lanciare un cd live di ubuntu e di montare la partizione dove risiede il sistema (nel mio caso sda3 ? ) e in seguito gli altri dispositivi dev, proc e sys, io visto che ce l ho installato devo evitare di montare il dev, proc e sys ?
s4v1o Non specificato
Prode Principiante
 
Messaggi: 14
Iscrizione: marzo 2012

Re: [Boot] problema all avvio mbr

Messaggioda sbalgio senpre » sabato 10 marzo 2012, 20:39

Allora, nel primo punto monti sda3 e poi segui tutta la guida pari pari eccetto la seconda parte del punto 4, dove spiega come montare un'eventuale boot separata.
Tu non hai la boot separata. Il flag "boot" di sda1 è un altra cosa, non c'entra.
Avatar utente
sbalgio senpre Non specificato
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4791
Iscrizione: novembre 2011

Re: [Boot] problema all avvio mbr

Messaggioda s4v1o » domenica 11 marzo 2012, 19:17

ho seguito alla lettera la guida eccetto il primo punto come mi hai detto però all'avvio premo f9 e si avvia il ripristino ....

sudo mount /dev/sda3 /mnt

sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys

sudo chroot /mnt

grub-install --recheck /dev/sda ....... forse ho sbagliato qui avrei dovuto installarlo in un'altra partizione ?

exit

cd ~
sudo umount /mnt/dev
sudo umount /mnt/proc
sudo umount /mnt/sys
sudo umount /mnt/
s4v1o Non specificato
Prode Principiante
 
Messaggi: 14
Iscrizione: marzo 2012

Re: [Boot] problema all avvio mbr

Messaggioda Diabolik62 » domenica 11 marzo 2012, 19:20

riepeti i primi 5 comandi, seguiti da questi
grub-install /dev/sda
update-grub2
posta risposte
Diabolik62 Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14287
Iscrizione: dicembre 2009
Distribuzione: windows8

Re: [Boot] problema all avvio mbr

Messaggioda s4v1o » domenica 11 marzo 2012, 20:55

per fare il comando update ci vuole la connessione ad internet ?
s4v1o Non specificato
Prode Principiante
 
Messaggi: 14
Iscrizione: marzo 2012

Re: [Boot] problema all avvio mbr

Messaggioda Diabolik62 » domenica 11 marzo 2012, 20:57

s4v1o ha scritto:per fare il comando update ci vuole la connessione ad internet ?

no
Diabolik62 Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14287
Iscrizione: dicembre 2009
Distribuzione: windows8

Re: [Boot] problema all avvio mbr

Messaggioda s4v1o » domenica 11 marzo 2012, 21:39

ti posto tutto quello che ho digitato

savio@savio-1015PX:~$ sudo mount /dev/sda3 /mnt
[sudo] password for savio:
savio@savio-1015PX:~$ sudo mount --bind /dev /mnt/dev
savio@savio-1015PX:~$ sudo mount --bind /proc /mnt/proc
savio@savio-1015PX:~$ sudo mount --bind /sys /mnt/sys
savio@savio-1015PX:~$ sudo chroot /mnt
root@savio-1015PX:/# grub-install /dev/sda
Installation finished. No error reported.
root@savio-1015PX:/# update-grub2
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.35-22-generic
Found initrd image: /boot/initrd.img-2.6.35-22-generic
Found memtest86+ image: /boot/memtest86+.bin
done
s4v1o Non specificato
Prode Principiante
 
Messaggi: 14
Iscrizione: marzo 2012

Re: [Boot] problema all avvio mbr

Messaggioda Diabolik62 » domenica 11 marzo 2012, 21:44

dalla risposta del terminale vedo installato solo linux, dovrebbe avviarsi credo, prova.
Diabolik62 Non specificato
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14287
Iscrizione: dicembre 2009
Distribuzione: windows8

Successiva

Torna a Live CD e USB

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 4 ospiti