[Risolto]Spegnimento lento

Configurazione e uso delle applicazioni del desktop manager predefinito a partire dalla versione 18.04 di Ubuntu.

[Risolto]Spegnimento lento

Messaggioda frankie1962 » lunedì 3 giugno 2019, 13:05

Salve a tutti; il mio sistema è ubuntu gnome 18.04 64 bit, connessione tim 200Mbit, 12 Gb Ram, installato su una pendrive sandisk 64GB.
E' un po' che noto uno spegnimento lento, ma da poco ho saputo che è possibile in fase di spegnimento vedere i msg del sistema, ed a questo proposito mi sono accorto che il sistema ha una "pausa" costante di 90 secondi, visualizzando il messaggio
Codice: Seleziona tutto
A stop job is running for session 2 of user ....

e l'utente specificato sono io.
Ho cercato su google il msg ed ho trovato varie indagini, senza però purtroppo arrivare a nulla :muro: .
C'è qualcuno che può suggerire qualcosa ?
Grazie
Ultima modifica di trekfan1 il mercoledì 5 giugno 2019, 15:02, modificato 2 volte in totale.
Motivazione: Per il futuro evita il tutto maiuscolo nel [Risolto], grazie
Avatar utente
frankie1962
Prode Principiante
 
Messaggi: 109
Iscrizione: settembre 2006

Re: Spegnimento lento

Messaggioda Pike » lunedì 3 giugno 2019, 13:17

frankie1962 Immagine ha scritto: installato su una pendrive sandisk 64GB.

E ti fai pure la domanda?
Perchè rispondere a tema quando la puoi mandare in vacca? Ah già.... dimenticavo. C'è chi ha ragione per regolamento.
Come certificato dalla moderazione, incivile e maleducato. You have been warned.
Se il tuo tempo è più importante del mio, allora non hai bisogno del mio tempo.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3754
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Bionic Beaver i686 (18.04)

Re: Spegnimento lento

Messaggioda axilot » lunedì 3 giugno 2019, 14:44

Pike Immagine ha scritto:
frankie1962 Immagine ha scritto: installato su una pendrive sandisk 64GB.

E ti fai pure la domanda?

:D :D

Comunque prova prima a disconnetterti e poi arrestare il sistema.

Edit:qui ho trovato qualcosa a riguardo dacci un occhiata
https://unix.stackexchange.com/question ... 745#423745
in particolare prova così tante volte funzionasse.
The solution is to open shell and "shutdown now" then when the machine comes back on then do a "reboot" and the message goes away and future reboots do not hang anymore.
"Experience, the name men give to their mistakes" (O.Wilde)
Pc principale: Ubuntu 16.04 64Bit - Pc secondario: Xubuntu 18.04 32 Bit - Raspberry Pi: Rpi 1B+, Rpi 2, Rpi 3+, Rpi Zero W
Avatar utente
axilot
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2696
Iscrizione: luglio 2008
Distribuzione: Ubuntu 16.04 64bit

Re: Spegnimento lento

Messaggioda frankie1962 » lunedì 3 giugno 2019, 18:34

axilot Immagine ha scritto:
Pike Immagine ha scritto:
frankie1962 Immagine ha scritto: installato su una pendrive sandisk 64GB.

E ti fai pure la domanda?

:D :D

Comunque prova prima a disconnetterti e poi arrestare il sistema.

Edit:qui ho trovato qualcosa a riguardo dacci un occhiata
https://unix.stackexchange.com/question ... 745#423745
in particolare prova così tante volte funzionasse.
The solution is to open shell and "shutdown now" then when the machine comes back on then do a "reboot" and the message goes away and future reboots do not hang anymore.


Potrebbe stupirvi la velocità ... :lol: :lol:
Riassumo: ho provato a disconnettermi e poi a spegnere, stesso problema. Ho provato a fare uno "shutdown now" ma anche in questo caso, invece di spegnersi immediatamente, si è rifermato per i soliti 90 secondi. Altre idee ?
Avatar utente
frankie1962
Prode Principiante
 
Messaggi: 109
Iscrizione: settembre 2006

Re: Spegnimento lento

Messaggioda frankie1962 » martedì 4 giugno 2019, 8:40

Nuove informazioni ...
Ho provato a staccare la rete prima di accendere il PC: ebbene, dopo l'accensione ed il normale login , a sistema funzionante insomma, a parte la rete inesistente, il sistema si è spento immediatamente ...
Credo che questa sia un'informazione importante, a questo punto che mi dite ? :)
Avatar utente
frankie1962
Prode Principiante
 
Messaggi: 109
Iscrizione: settembre 2006

Re: Spegnimento lento

Messaggioda Pike » martedì 4 giugno 2019, 9:00

Lanciare lo spegnimento ed andare a bere un bicchiere d'acqua (o in bagno, o fare qualcos'altro) è una opzione che può aver senso per te?

Mi rendo conto che sarebbe bello avere uno shutdown in 9 secondi invece che 90... però...
Perchè rispondere a tema quando la puoi mandare in vacca? Ah già.... dimenticavo. C'è chi ha ragione per regolamento.
Come certificato dalla moderazione, incivile e maleducato. You have been warned.
Se il tuo tempo è più importante del mio, allora non hai bisogno del mio tempo.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3754
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Bionic Beaver i686 (18.04)

Re: Spegnimento lento

Messaggioda axilot » martedì 4 giugno 2019, 10:08

frankie1962 Immagine ha scritto:Nuove informazioni ...
Ho provato a staccare la rete prima di accendere il PC: ebbene, dopo l'accensione ed il normale login , a sistema funzionante insomma, a parte la rete inesistente, il sistema si è spento immediatamente ...
Credo che questa sia un'informazione importante, a questo punto che mi dite ? :)


evidentemente è qualche processo legato alla connessione di rete magari il networkmanager che rallenta al chiusura.
Hai per caso l'SSH abilitato?
vedi qui
https://unix.stackexchange.com/a/440049
"Experience, the name men give to their mistakes" (O.Wilde)
Pc principale: Ubuntu 16.04 64Bit - Pc secondario: Xubuntu 18.04 32 Bit - Raspberry Pi: Rpi 1B+, Rpi 2, Rpi 3+, Rpi Zero W
Avatar utente
axilot
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2696
Iscrizione: luglio 2008
Distribuzione: Ubuntu 16.04 64bit

Re: Spegnimento lento

Messaggioda frankie1962 » martedì 4 giugno 2019, 12:52

Risolto :birra:
Ho disattivato l'interfaccia di rete cablata: l'identificativo lo trovo con
Codice: Seleziona tutto
ifconfig


e poi, a fine lavoro prima di spegnere do
Codice: Seleziona tutto
sudo ifconfig nome_interfaccia down

e lo spegnimento torna quasi istantaneo.
Rimane una richiesta: come posso impostare il comando in modo che venga automaticamente eseguito in fase di chiusura ?
Avatar utente
frankie1962
Prode Principiante
 
Messaggi: 109
Iscrizione: settembre 2006

Re: Spegnimento lento

Messaggioda Pike » martedì 4 giugno 2019, 13:31

Crea un file batch per disattivare la scheda di rete e spegnere la postazione. E poi ci fai doppio click per spegnere il pc.
Perchè rispondere a tema quando la puoi mandare in vacca? Ah già.... dimenticavo. C'è chi ha ragione per regolamento.
Come certificato dalla moderazione, incivile e maleducato. You have been warned.
Se il tuo tempo è più importante del mio, allora non hai bisogno del mio tempo.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3754
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Bionic Beaver i686 (18.04)

Re: Spegnimento lento

Messaggioda frankie1962 » martedì 4 giugno 2019, 15:28

Ho parlato troppo presto :muro: è successo una volta, le successive no...
proverò a indagare circa l'SSH
Avatar utente
frankie1962
Prode Principiante
 
Messaggi: 109
Iscrizione: settembre 2006

Re: Spegnimento lento

Messaggioda frankie1962 » mercoledì 5 giugno 2019, 12:27

Ho provato a disabilitare i servizi di rete con
Codice: Seleziona tutto
systemctr disable networkmanager
systemctl stop networkmanager

ma senza risolvere il problema.
Axilot, ti chiederei come si controlla se SSH è abilitato ...
Avatar utente
frankie1962
Prode Principiante
 
Messaggi: 109
Iscrizione: settembre 2006

Re: Spegnimento lento

Messaggioda Pike » mercoledì 5 giugno 2019, 13:26

Networkmanager non è "i servizi di rete". E' il gestore delle configurazioni delle interfacce di rete.
Perchè rispondere a tema quando la puoi mandare in vacca? Ah già.... dimenticavo. C'è chi ha ragione per regolamento.
Come certificato dalla moderazione, incivile e maleducato. You have been warned.
Se il tuo tempo è più importante del mio, allora non hai bisogno del mio tempo.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3754
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Bionic Beaver i686 (18.04)

Re: Spegnimento lento

Messaggioda frankie1962 » mercoledì 5 giugno 2019, 14:55

Ok Pike, grazie della dovuta correzione.
Ho risolto; in realtà all'avvio avevo predisposto il montaggio di alcune risorse , una ftp ed una webdav. Smontate queste prima dello spegnimento, questo è ora praticamente istantaneo.
:birra:
Avatar utente
frankie1962
Prode Principiante
 
Messaggi: 109
Iscrizione: settembre 2006

Re: [RISOLTO]Spegnimento lento

Messaggioda trekfan1 » mercoledì 5 giugno 2019, 15:02

In futuro però evita di mettere il [Risolto] tutto maiuscolo, grazie.
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 19689
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Gnome
Distribuzione: Ubuntu 19.04 e 19.10 (dev) 64 bit
Sesso: Maschile

Re: [Risolto]Spegnimento lento

Messaggioda paciugOne » martedì 13 agosto 2019, 21:44

ciao Frankie!
all'avvio avevo predisposto il montaggio di alcune risorse , una ftp ed una webdav. Smontate queste prima dello spegnimento, questo è ora praticamente istantaneo

anche io vedo un rallentamento nello spegnimento che non avevo mai sperimentato prima
sono su Ubuntu 16.04 e ho uno scanner su ftp
la tua soluzione, dunque, mi interessa molto...
ma... (scusa l'ignoranza...) come si fa a smontare una risorsa ftp???
Ubuntu User # 32762
Chiavetta Infocert per Polisweb su Ubuntu http://forum.ubuntu-it.org/viewtopic.ph ... 3#p3024123
Openoffice writer; Impaginare a libro http://forum.ubuntu-it.org/viewtopic.ph ... 9#p2952849
paciugOne
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 334
Iscrizione: gennaio 2010


Torna a GNOME

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 3 ospiti