Ubuntu 17.10 Gnome con Wayland: apport non funziona?

Prossima versione di Ubuntu in fase di sviluppo e test. Per i precedenti rilasci, consultare «Archivio del forum».

Ubuntu 17.10 Gnome con Wayland: apport non funziona?

Messaggioda corradoventu » venerdì 5 maggio 2017, 12:15

Ubuntu 17.10 Gnome:
Ho provato a far partire gparted su wayland: non va - problema noto:
GParted does not work in GNOME on Wayland https://bugs.launchpad.net/ubuntu-gnome/+bug/1652282
mi sono accodato ma la cosa strana è che il bug si è aperto solo quando sono uscito dalla sessione wayland e sono tornato a quella x11. in pratica sembra che il crash venga scritto in /var/crash ma poi su wayland non venga gestito mentre viene gestito nella sessione x11.
ne sapete qualcosa? colpa di apport?
Stesso problema con un crash di synaptic:
synaptic does not run over gnome wayland session https://bugs.launchpad.net/ubuntu/+sour ... ug/1551951
Ultima modifica di corradoventu il venerdì 5 maggio 2017, 15:38, modificato 1 volta in totale.
Con o senza religione, i buoni si comportano bene e i cattivi male, ma ci vuole la religione per far comportare male i buoni. (Steven Weinberg)
PC di casa: https://drive.google.com/folderview?id= ... sp=sharing
Avatar utente
corradoventu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1057
Iscrizione: aprile 2008
Località: Bogliasco (GE) o Rezzoaglio (GE)
Desktop: unity->gnome
Distribuzione: Ubuntu 16.04, 18.04, 18.10 x86_64
Sesso: Maschile

Re: Wayland: apport non funziona?

Messaggioda Janvitus » venerdì 5 maggio 2017, 14:38

Per Gparted basta usare Dischi, per Synaptic potresti usare gnome-packagekit, o usare al linea di comando.
Avatar utente
Janvitus
Amministratore
Amministratore
 
Messaggi: 17432
Iscrizione: aprile 2005
Località: Potenza
Desktop: GNOME Shell 3.28
Distribuzione: Fedora/Ubuntu
Sesso: Maschile

Re: Wayland: apport non funziona?

Messaggioda corradoventu » venerdì 5 maggio 2017, 15:38

Posso anche usare Gnome shell senza Wayland, sto testando Wayland e cercando di trovare i suoi buchi visto che in futuro potrebbe caderci addosso.
MA SONO CURIOSO e mi chiedo come mai apport sembri scattare solo ripartendo su Gnome shell dopo una sessione con Wayland.
Nel frattempo ho trovato un altro crash che avviene ad ogni signon su Wayland:
Title: update-notifier crashed with SIGSEGV in g_hash_table_lookup()
ma non trovo un bug aperto in proposito, tranne uno vecchissimo e incompleto:
https://bugs.launchpad.net/ubuntu/+sour ... +bug/95727
Cambio il titolo della discussione perchè confonde.
Con o senza religione, i buoni si comportano bene e i cattivi male, ma ci vuole la religione per far comportare male i buoni. (Steven Weinberg)
PC di casa: https://drive.google.com/folderview?id= ... sp=sharing
Avatar utente
corradoventu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1057
Iscrizione: aprile 2008
Località: Bogliasco (GE) o Rezzoaglio (GE)
Desktop: unity->gnome
Distribuzione: Ubuntu 16.04, 18.04, 18.10 x86_64
Sesso: Maschile

Re: Ubuntu 17.10 Gnome con Wayland: apport non funziona?

Messaggioda corradoventu » martedì 9 maggio 2017, 10:12

Guardando in System Settings -> Security&privacy -> Diagnostics -> Previous Reports vedo tutti(?) i miei crash, sia quelli da Artful Unity che quelli da Artful GNOME Classic e Wayland. A quanto pare i crash vengono trasmessi a errors.ubuntu.com anche se Apport non apre Launcpad.
Allegati
crash.png
crash1.png
Con o senza religione, i buoni si comportano bene e i cattivi male, ma ci vuole la religione per far comportare male i buoni. (Steven Weinberg)
PC di casa: https://drive.google.com/folderview?id= ... sp=sharing
Avatar utente
corradoventu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1057
Iscrizione: aprile 2008
Località: Bogliasco (GE) o Rezzoaglio (GE)
Desktop: unity->gnome
Distribuzione: Ubuntu 16.04, 18.04, 18.10 x86_64
Sesso: Maschile


Torna a Artful Aardvark 17.10

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 2 ospiti