Kubuntu 13.04 beta2 (4 Aprile) problema installazione GNOME

Prossima versione di Ubuntu in fase di sviluppo e test. Per i precedenti rilasci, consultare «Archivio del forum».
Avatar utente
zago84
Prode Principiante
Messaggi: 121
Iscrizione: giovedì 31 maggio 2007, 16:37
Desktop: GNOME 3.10
Distribuzione: Ubuntu Gnome 14.04 (64bit)
Località: Caltagirone (CT)

Kubuntu 13.04 beta2 (4 Aprile) problema installazione GNOME

Messaggio da zago84 » sabato 6 aprile 2013, 14:57

Salve,

premesso che:

1 - ho scaricato ed installato Kubuntu 13.04 64bit beta 2 (o "final beta" del 4 Aprile);
2 - installato i driver NVIDIA 173 riavviato e constatato che KDE funziona egregiamente;
3 - per comodità personale e soggettiva ho installato "Ubuntu Software Center";
4 - ho proseguito tramite USC all'installazione di GNOME selezionando il pacchetto "Full GNOME Desktop Environment, with extra components";

Al riavvio selezionando GNOME, GNOME FALLBACK e GNOME FALLBACK (no effects) funziona tutto regolarmente, invece accedendo a KDE PLASMA DESKTOP non si visualizzano più le barre di sopra delle finestre come potete vedere nell'allegato lo screenshot:

Immagine
Ultima modifica di zago84 il domenica 7 aprile 2013, 23:20, modificato 2 volte in totale.
Chi non ride mai non è una persona seria.
- Chopin -

Avatar utente
zago84
Prode Principiante
Messaggi: 121
Iscrizione: giovedì 31 maggio 2007, 16:37
Desktop: GNOME 3.10
Distribuzione: Ubuntu Gnome 14.04 (64bit)
Località: Caltagirone (CT)

Re: Kubuntu 13.04 final beta (4 Aprile) problema install. G

Messaggio da zago84 » domenica 7 aprile 2013, 20:25

Up
Chi non ride mai non è una persona seria.
- Chopin -

caturen
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 16078
Iscrizione: giovedì 8 aprile 2010, 18:41
Desktop: diversi
Distribuzione: debian

Re: Kubuntu 13.04 final beta (4 Aprile) problema install. G

Messaggio da caturen » domenica 7 aprile 2013, 22:23

Io non ho mai usato kde, ma da quello che hai postato sembra che il windows manager di kde, kwin non parta. Ho trovato questo che forse fa al caso tuo:
OK, I have solved the problem.

I did the following:

sudo aptitude remove kdelibs5

This told me amongst other that the following packages should be removed:

Remove the following packages:
1) kgrubeditor
2) kvkbd
3) kwin-kde4

Especially the 3rd one is interesting. Then I just reinstalled the kubuntu desktop package:
sudo aptitude install kubuntu-desktop

Which did not reinstall kwin-kde4:
The following NEW packages will be installed:
kdelibs5{a} khelpcenter4 kubuntu-desktop kvkbd plasma-widget-folderview

kwin --replace
And after that, everything is back to normal.

Thanks for your time, I hope this helps somebody else as well.

Avatar utente
zago84
Prode Principiante
Messaggi: 121
Iscrizione: giovedì 31 maggio 2007, 16:37
Desktop: GNOME 3.10
Distribuzione: Ubuntu Gnome 14.04 (64bit)
Località: Caltagirone (CT)

Re: Kubuntu 13.04 final beta (4 Aprile) problema install. G

Messaggio da zago84 » domenica 7 aprile 2013, 23:07

Intanto ti ringrazio per l'interessamento.

Purtroppo ho provato a rimuovere quanto descritto ma nessuno dei pacchetti succitati è presente nel mio sistema.
Però ho avuto un riscontro da quanto sopra descritto: ho lanciato da terminale kwin --replace ed ora funziona il gestore finestre però non so come fare per avviarlo all'avvio quando seleziono KDE.

Ho provato a mettere il comando kwin --replace in avvio automatico del sistema e quando seleziono KDE funziona tutto ma se seleziono qualunque GNOME non funziona proprio per questo comando impostato all'avvio (si vede solo il cursore del mouse e tutto nero).

E' un workaround che può andar bene temporaneamente ma non è una soluzione normale ed è poco pratica per uno come me che ama con un click cambiare DE... :cry:
Chi non ride mai non è una persona seria.
- Chopin -

caturen
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 16078
Iscrizione: giovedì 8 aprile 2010, 18:41
Desktop: diversi
Distribuzione: debian

Re: Kubuntu 13.04 final beta (4 Aprile) problema install. G

Messaggio da caturen » lunedì 8 aprile 2013, 12:52

zago84 [url=http://forum.ubuntu-it.org/viewtopic.php?p=4362262#p4362262][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Intanto ti ringrazio per l'interessamento.

Purtroppo ho provato a rimuovere quanto descritto ma nessuno dei pacchetti succitati è presente nel mio sistema.
Però ho avuto un riscontro da quanto sopra descritto: ho lanciato da terminale kwin --replace ed ora funziona il gestore finestre però non so come fare per avviarlo all'avvio quando seleziono KDE.

Ho provato a mettere il comando kwin --replace in avvio automatico del sistema e quando seleziono KDE funziona tutto ma se seleziono qualunque GNOME non funziona proprio per questo comando impostato all'avvio (si vede solo il cursore del mouse e tutto nero).

E' un workaround che può andar bene temporaneamente ma non è una soluzione normale ed è poco pratica per uno come me che ama con un click cambiare DE... :cry:

Infatti quel comando non lo puoi mettere in avvio automatico perchè, come hai scritto tu, partirebbe anche con gnome sballando il tutto. Bisognerebbe metterlo solo in avvio di kde, ma non saprei come farlo. Bisognerebbe fare una ricerca.

Avatar utente
zago84
Prode Principiante
Messaggi: 121
Iscrizione: giovedì 31 maggio 2007, 16:37
Desktop: GNOME 3.10
Distribuzione: Ubuntu Gnome 14.04 (64bit)
Località: Caltagirone (CT)

Re: Kubuntu 13.04 beta2 (4 Aprile) problema installazione GN

Messaggio da zago84 » lunedì 8 aprile 2013, 13:15

Intanto ho appena aperto un topic nel forum ufficiale di Kubuntu, magari là mi aiutano per la risoluzione:

http://www.kubuntuforums.net/showthread ... ling-GNOME

Se qualcuno sa come aiutarmi a risolvere, ne sarei grato. ;)
Chi non ride mai non è una persona seria.
- Chopin -

Avatar utente
mibofra
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2075
Iscrizione: venerdì 25 maggio 2012, 0:01
Desktop: Mate
Distribuzione: Ubuntu 17.04/ParrotSec OS
Sesso: Maschile
Località: Palermo
Contatti:

Re: Kubuntu 13.04 beta2 (4 Aprile) problema installazione GN

Messaggio da mibofra » giovedì 11 aprile 2013, 22:30

Qui mi puzza di bug al gestore delle finestre (compiz).
Portatile principale: ASUS X550JX con Ubuntu 17.04 e ParrotSec OS 3.7 onboard
Portatile secondario: ASUS T200TA con Ubuntu 17.04 onboard
Server "domestico": ASUS Q170T + i7 6700 + 32 GB RAM Corsair Vengeance con OpenSUSE Tumbleweed onboard

Avatar utente
zago84
Prode Principiante
Messaggi: 121
Iscrizione: giovedì 31 maggio 2007, 16:37
Desktop: GNOME 3.10
Distribuzione: Ubuntu Gnome 14.04 (64bit)
Località: Caltagirone (CT)

Re: Kubuntu 13.04 beta2 (4 Aprile) problema installazione GN

Messaggio da zago84 » giovedì 11 aprile 2013, 22:42

Io direi KWIN dato che il problema è su KDE...
Chi non ride mai non è una persona seria.
- Chopin -

Avatar utente
mibofra
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2075
Iscrizione: venerdì 25 maggio 2012, 0:01
Desktop: Mate
Distribuzione: Ubuntu 17.04/ParrotSec OS
Sesso: Maschile
Località: Palermo
Contatti:

Re: Kubuntu 13.04 beta2 (4 Aprile) problema installazione GN

Messaggio da mibofra » giovedì 11 aprile 2013, 23:05

Sai se ci sono gli effetti grafici solitamente l'accopiata è kwin/compiz.
Portatile principale: ASUS X550JX con Ubuntu 17.04 e ParrotSec OS 3.7 onboard
Portatile secondario: ASUS T200TA con Ubuntu 17.04 onboard
Server "domestico": ASUS Q170T + i7 6700 + 32 GB RAM Corsair Vengeance con OpenSUSE Tumbleweed onboard

Scrivi risposta

Ritorna a “Raring Ringtail 13.04”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 1 ospite