[Risolto]Trusty mi ha cancellato tutto da opensuse?

Prossima versione di Ubuntu in fase di sviluppo e test. Per i precedenti rilasci, consultare «Archivio del forum».
Avatar utente
gian64
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 3024
Iscrizione: mercoledì 7 novembre 2007, 15:33
Desktop: Openbox-Gnome
Distribuzione: SalentOS 2.0-Ubuntu 19.10
Sesso: Maschile
Località: Torino
Contatti:

Re: Trusty mi ha cancellato tutto da opensuse?

Messaggio da gian64 » venerdì 28 marzo 2014, 10:31

Da live

Per lost+found dolphin mi da il messaggio "Could not enter folder /media/kubuntu/dd0cd566-23a2-49f8-96c8-fb39d4b12390/lost+found."

Mentre la cartella utente risulta completamente piena di cartelle (248) nominate recup_dir<da1 a 248> (probabilmente create da photorec al quale non credo di aver dato quell'indirizzo per il salvataggio, ma del resto non so usarlo molto bene) che non si possono cestinare in quanto da menù contestuale non risulta esserci questa opzione
Ma quanto è variegato il mondo Linux…

Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 21565
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 20.10 e 21.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Trusty mi ha cancellato tutto da opensuse?

Messaggio da trekfan1 » venerdì 28 marzo 2014, 11:13

@gian64 per la questione HD puoi verificarlo usando il gestore dischi di Ubuntu (da LIVE o installato) e guardare lo stato SMART

Avatar utente
milazzo87
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1958
Iscrizione: sabato 17 dicembre 2011, 16:51
Desktop: GNOME
Distribuzione: Ubuntu 17.10

Re: Trusty mi ha cancellato tutto da opensuse?

Messaggio da milazzo87 » venerdì 28 marzo 2014, 11:16

gian64 [url=http://forum.ubuntu-it.org/viewtopic.php?p=4553859#p4553859][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Da live

Per lost+found dolphin mi da il messaggio "Could not enter folder /media/kubuntu/dd0cd566-23a2-49f8-96c8-fb39d4b12390/lost+found."
Prova da terminale,

Codice: Seleziona tutto

sudo su
e poi

Codice: Seleziona tutto

dolphin
La pisciata in compagnia è di sinistra, il cesso è sempre in fondo a destra. [cit. G. Gaber]

Avatar utente
gian64
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 3024
Iscrizione: mercoledì 7 novembre 2007, 15:33
Desktop: Openbox-Gnome
Distribuzione: SalentOS 2.0-Ubuntu 19.10
Sesso: Maschile
Località: Torino
Contatti:

Re: Trusty mi ha cancellato tutto da opensuse?

Messaggio da gian64 » venerdì 28 marzo 2014, 11:54

trekfan1 [url=http://forum.ubuntu-it.org/viewtopic.php?p=4553877#p4553877][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:@gian64 per la questione HD puoi verificarlo usando il gestore dischi di Ubuntu (da LIVE o installato) e guardare lo stato SMART
C'è qualcosa di simile al gestore disco su kubuntu? io al momento dispongo solo della live di kubuntu che sto usando in questo momento
milazzo87 ha scritto:
gian64 [url=http://forum.ubuntu-it.org/viewtopic.php?p=4553859#p4553859][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Da live

Per lost+found dolphin mi da il messaggio "Could not enter folder /media/kubuntu/dd0cd566-23a2-49f8-96c8-fb39d4b12390/lost+found."
Prova da terminale,

Codice: Seleziona tutto

sudo su
e poi

Codice: Seleziona tutto

dolphin
E mai avatar (che strizza l'occhietto) fu più azzeccato del tuo... :D Almeno questa l'abbiamo risolta, e ho anche eliminato tutte le recup_dir presenti nella mia cartella utente.

Adesso provo a riavviare...

Bene, sono riuscito a riavviare kubuntu. per opensuse oggi vedrò e farò sapere.
Ma quanto è variegato il mondo Linux…

Avatar utente
steff
Moderatore Globale
Moderatore Globale
Messaggi: 39144
Iscrizione: domenica 18 febbraio 2007, 19:48
Desktop: LXQt
Distribuzione: Arch 64bit | Debian 32bit
Sesso: Maschile
Località: Toscana
Contatti:

Re: Trusty mi ha cancellato tutto da opensuse?

Messaggio da steff » venerdì 28 marzo 2014, 13:05

gian64 ha scritto:piena di cartelle (248) nominate recup_dir<da1 a 248>
Infatti sono cartelle di photorec, ma è completamente inutile salvare sulla stessa partizione in quanto comincia di sovrascrivere i dati prima di trovarli... se c'è qualcosa di utile dentro salvalo e poi elmina (del+maiusc) con da una finestra di

Codice: Seleziona tutto

sudo nautilus
PS:non avevo letto la risposta precedente...
Hai fatto un backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox

Avatar utente
gian64
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 3024
Iscrizione: mercoledì 7 novembre 2007, 15:33
Desktop: Openbox-Gnome
Distribuzione: SalentOS 2.0-Ubuntu 19.10
Sesso: Maschile
Località: Torino
Contatti:

Re: Trusty mi ha cancellato tutto da opensuse?

Messaggio da gian64 » venerdì 28 marzo 2014, 13:55

steff [url=http://forum.ubuntu-it.org/viewtopic.php?p=4553942#p4553942][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:
gian64 ha scritto:piena di cartelle (248) nominate recup_dir<da1 a 248>
Infatti sono cartelle di photorec, ma è completamente inutile salvare sulla stessa partizione in quanto comincia di sovrascrivere i dati prima di trovarli... se c'è qualcosa di utile dentro salvalo e poi elmina (del+maiusc) con da una finestra di

Codice: Seleziona tutto

sudo nautilus
PS:non avevo letto la risposta precedente...
In effetti dentro non c'era niente che non fosse già stato recuperato e salvato nelle proprie cartelle di appartenenza già sulla /home di opensuse, inltre moltissime cartelle erano piene di icone, disegnini e altre cose più o meno inutili. E non capisco perchè oltre a salvare i file recuperati normalmente mi ha pure creato tutte quelle recup_dir, anche perchè da photorec io ho selezionato per il recupero /dev/sda7 (/home di opensuse), e /dev/sda9 (/home di kubuntu) non l'ho proprio sfiorato, anche se devo dire che ancora non ho capito molto bene l'uso di questo programma.

Adesso provo ad avviare opensuse.
Ma quanto è variegato il mondo Linux…

Avatar utente
gian64
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 3024
Iscrizione: mercoledì 7 novembre 2007, 15:33
Desktop: Openbox-Gnome
Distribuzione: SalentOS 2.0-Ubuntu 19.10
Sesso: Maschile
Località: Torino
Contatti:

Re: Trusty mi ha cancellato tutto da opensuse?

Messaggio da gian64 » sabato 29 marzo 2014, 11:51

Ultimo (penso) aggiornamento sulla questione: al momento, dopo aver eliminato tutte le cartelle di recupero, Le cose sembrano essersi sistemate: entrambi i sistemi si avviano correttamente, anche se comunque gran parte delle impostazioni grafiche sono andate perdute. Devo ancora fare una controprova di cui poi comunicherò i risultati su questo stesso post se confermerà quanto mi sembra di aver notato.

Rimane un mistero però come possa essere successo tutto questo, in particolare la questione della /home di kubuntu, che in quest'ultima occasione era piena delle recup-dir di photorec, ma la prima volta non aveva nulla di archiviato ma risultava piena, e non avevo ancora usato photorec...

EDIT: ho verificato una cosa stranissima, che prova anche che in qualche modo i due sistemi sono stranamente collegati. Ieri sera ho installato su kubuntu alcuni temi grafici, tra cui anche alcuni cursori del mouse. Stamattina sranamente li ho ritrovati anche su opensuse. Per controprova ne ho installato adesso uno su kubuntu e me lo ritrovo anche su opensuse. Adesso provo l'inverso...

RIEDIT: confermo che accade anche l'inverso, ho installato un tema cursore su opensuse e me lo sono ritrovato anche su kubuntu.
Mi pare che questo provi che in qualche modo i due sistemi sono correlati pur risiedendo su partizioni diverse com'è naturale che sia...

Questo accade solo con i cursori, con altri temi no...

Qualcino ha qualche idea su questa cosa mai vista?
Ma quanto è variegato il mondo Linux…

Avatar utente
steff
Moderatore Globale
Moderatore Globale
Messaggi: 39144
Iscrizione: domenica 18 febbraio 2007, 19:48
Desktop: LXQt
Distribuzione: Arch 64bit | Debian 32bit
Sesso: Maschile
Località: Toscana
Contatti:

Re: Trusty mi ha cancellato tutto da opensuse?

Messaggio da steff » sabato 29 marzo 2014, 13:45

Io penso che la spiegazione dei misteri sta a 30 cm dal monitor ;)

Non hai collegamenti nelle home da una all'altra?
Posta da entrambi sistemi:

Codice: Seleziona tutto

mount
lsblk
Hai fatto un backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox

Avatar utente
enziosavio
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 2416
Iscrizione: sabato 27 novembre 2010, 13:20
Desktop: Plasma e Gnome
Distribuzione: 64bit
Sesso: Maschile

Re: Trusty mi ha cancellato tutto da opensuse?

Messaggio da enziosavio » sabato 29 marzo 2014, 13:46

È praticamente impossibile , o hai creato TU il collegamento tra le cartelle , di suo non lo fa .
Ecco perchè dico che troppi OS Linux e quindi partizioni e /home duplicate generano solo confusione , meglio concentrarsi su UN solo sistema , cosi lo si impara e lo si utilizza al meglio .
Buon Weekend
Rivestì la corazza come gigante , cinse l'armatura di guerra e impegnò battaglia difendendo il campo con la spada

Avatar utente
gian64
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 3024
Iscrizione: mercoledì 7 novembre 2007, 15:33
Desktop: Openbox-Gnome
Distribuzione: SalentOS 2.0-Ubuntu 19.10
Sesso: Maschile
Località: Torino
Contatti:

Re: Trusty mi ha cancellato tutto da opensuse?

Messaggio da gian64 » sabato 29 marzo 2014, 16:48

steff [url=http://forum.ubuntu-it.org/viewtopic.php?p=4554444#p4554444][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Io penso che la spiegazione dei misteri sta a 30 cm dal monitor ;)

Non hai collegamenti nelle home da una all'altra?
Posta da entrambi sistemi:

Codice: Seleziona tutto

mount
lsblk
Non mi risulta di aver mai fatto collegamenti tra l'una e l'altra /home, tra l'altro non saprei nemmeno come fare...

output dei due comandi da kubuntu

Codice: Seleziona tutto

gian64@gian64-Laptop:~$ mount
/dev/sda8 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/cgroup type tmpfs (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
none on /sys/fs/pstore type pstore (rw)
/dev/sda9 on /home type ext4 (rw)
systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd)

Codice: Seleziona tutto

gian64@gian64-Laptop:~$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 111,8G  0 disk 
├─sda1   8:1    0   4,9G  0 part 
├─sda2   8:2    0  31,5G  0 part 
├─sda3   8:3    0     1K  0 part 
├─sda5   8:5    0     2G  0 part [SWAP]
├─sda6   8:6    0  12,3G  0 part 
├─sda7   8:7    0  30,3G  0 part 
├─sda8   8:8    0   9,8G  0 part /
└─sda9   8:9    0    21G  0 part /home
sr0     11:0    1  1024M  0 rom  
Adesso riavvio da opensuse e lo posto pure da li

Output da opensuse

Codice: Seleziona tutto

gian64@linux-pdxd:~$ mount
devtmpfs on /dev type devtmpfs (rw,relatime,size=882200k,nr_inodes=220550,mode=755)
tmpfs on /dev/shm type tmpfs (rw,relatime)
tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
/dev/sda6 on / type ext4 (rw,relatime,data=ordered)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=36,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
tmpfs on /var/run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
tmpfs on /var/lock type tmpfs (rw,nosuid,nodev,relatime,mode=755)
/dev/sda9 on /home type ext4 (rw,relatime,data=ordered)                         
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
gvfsd-fuse on /var/run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)

Codice: Seleziona tutto

gian64@linux-pdxd:~$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 111,8G  0 disk 
├─sda1   8:1    0   4,9G  0 part 
├─sda2   8:2    0  31,5G  0 part 
├─sda3   8:3    0     1K  0 part 
├─sda5   8:5    0     2G  0 part [SWAP]
├─sda6   8:6    0  12,3G  0 part /
├─sda7   8:7    0  30,3G  0 part 
├─sda8   8:8    0   9,8G  0 part 
└─sda9   8:9    0    21G  0 part /home
sr0     11:0    1  1024M  0 rom  
Eggià, gli output di kubuntu sono corretti per quanto riguarda le partizioni, mentre da quelli di opensuse risulta montata come /home /dev/sda9 che è la /home di kubuntu, quella di opensuse era, prima di installare kubuntu, /dev/sda7...

Ulteriori stranezze

/fstab di kubuntu

Codice: Seleziona tutto

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda8 during installation
UUID=9684bccd-cadc-4e53-b485-3096be1a6542 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda9 during installation
UUID=dd0cd566-23a2-49f8-96c8-fb39d4b12390 /home           ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=dbc2ae6f-7809-4081-9497-7439d7ca4e98 none            swap    sw              0       0
/fstab di opensuse

Codice: Seleziona tutto

dev/disk/by-id/ata-ST9120821A_3PL0TY85-part5 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-ST9120821A_3PL0TY85-part8 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-ST9120821A_3PL0TY85-part9 /home                ext4   
Se capisco bene dallo /fstab di opensuse risulta come partizione / /dev/sda8 mentre dai comandi precedenti risulta correttamente /dev/sda6...

Invio anche una schermata di gparted da opensuse, mi risultano montate due / e la /home sbagliata...

E del resto mesi fa, quando ho installato opensuse, avevo anche etichettato le partizioni relative, come si vede dall'immagine allegata.
Allegati
schermata1.png
Ma quanto è variegato il mondo Linux…

Avatar utente
gian64
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 3024
Iscrizione: mercoledì 7 novembre 2007, 15:33
Desktop: Openbox-Gnome
Distribuzione: SalentOS 2.0-Ubuntu 19.10
Sesso: Maschile
Località: Torino
Contatti:

Re: Trusty mi ha cancellato tutto da opensuse?

Messaggio da gian64 » sabato 29 marzo 2014, 19:27

Ho risolto, mi è bastato modificare /etc/fstab di opensuse ed è adato tutto a posto, almeno spero. Sta di fatto che al riavvio ho ritrovato le vecchie impostazioni grafiche che avevo prima di tutto questo pasticcio, e anche tutti i file che parevano spariti. Devo ancora verificare che non ci siano doppioni per l'uso di photorec...

Anche da gparted appare tutto normale...

/fstab

Codice: Seleziona tutto

dev/disk/by-id/ata-ST9120821A_3PL0TY85-part5 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-ST9120821A_3PL0TY85-part6 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-ST9120821A_3PL0TY85-part7 /home                ext4       defaults              1 2
comando <mount>

Codice: Seleziona tutto

ian64@linux-pdxd:~> mount
devtmpfs on /dev type devtmpfs (rw,relatime,size=882200k,nr_inodes=220550,mode=755)
tmpfs on /dev/shm type tmpfs (rw,relatime)
tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
/dev/sda6 on / type ext4 (rw,relatime,data=ordered)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=36,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
tmpfs on /var/run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
tmpfs on /var/lock type tmpfs (rw,nosuid,nodev,relatime,mode=755)
/dev/sda7 on /home type ext4 (rw,relatime,data=ordered)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
gvfsd-fuse on /var/run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
comando <lsblk>

Codice: Seleziona tutto

gian64@linux-pdxd:~> lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 111,8G  0 disk 
├─sda1   8:1    0   4,9G  0 part 
├─sda2   8:2    0  31,5G  0 part 
├─sda3   8:3    0   512B  0 part 
├─sda5   8:5    0     2G  0 part [SWAP]
├─sda6   8:6    0  12,3G  0 part /
├─sda7   8:7    0  30,3G  0 part /home
├─sda8   8:8    0   9,8G  0 part 
└─sda9   8:9    0    21G  0 part 
sr0     11:0    1  1024M  0 rom  
Grazie per l'aiuto a tutti :D :D
Ma quanto è variegato il mondo Linux…

Avatar utente
steff
Moderatore Globale
Moderatore Globale
Messaggi: 39144
Iscrizione: domenica 18 febbraio 2007, 19:48
Desktop: LXQt
Distribuzione: Arch 64bit | Debian 32bit
Sesso: Maschile
Località: Toscana
Contatti:

Re: [Risolto]Trusty mi ha cancellato tutto da opensuse?

Messaggio da steff » sabato 29 marzo 2014, 19:45

Ecco :)
Mai usare /dev/sdXY in fstab. Usare
UUID=xxxx
o meglio ancora per non fare confusione:
LABEL=abc
e assegnare delle etichette alle partizioni. Tipo "suse" "kubuntu" per la partizione del sistema e home-suse e home-kubuntu per le home.
Hai fatto un backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox

Avatar utente
gian64
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 3024
Iscrizione: mercoledì 7 novembre 2007, 15:33
Desktop: Openbox-Gnome
Distribuzione: SalentOS 2.0-Ubuntu 19.10
Sesso: Maschile
Località: Torino
Contatti:

Re: [Risolto]Trusty mi ha cancellato tutto da opensuse?

Messaggio da gian64 » sabato 29 marzo 2014, 19:56

steff [url=http://forum.ubuntu-it.org/viewtopic.php?p=4554644#p4554644][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Ecco :)
Mai usare /dev/sdXY in fstab. Usare
UUID=xxxx
o meglio ancora per non fare confusione:
LABEL=abc
e assegnare delle etichette alle partizioni. Tipo "suse" "kubuntu" per la partizione del sistema e home-suse e home-kubuntu per le home.
A quel che ho visto, ogni distro ha il suo /fstab, organizzato in maniera propria, quello di *buntu è diverso da quello di opensuse...
Io su quest'ultimo mi sono limitato a cambiare i numeri delle partizioni.

Infatti io uso le etichette, ma su kubuntu non le avevo ancora aggiornate...

In che senso dici ?
Mai usare /dev/sdXY in fstab. Usare
UUID=xxxx
Il file /fstab si crea da se, non lo creo io...
Ma quanto è variegato il mondo Linux…

Avatar utente
steff
Moderatore Globale
Moderatore Globale
Messaggi: 39144
Iscrizione: domenica 18 febbraio 2007, 19:48
Desktop: LXQt
Distribuzione: Arch 64bit | Debian 32bit
Sesso: Maschile
Località: Toscana
Contatti:

Re: [Risolto]Trusty mi ha cancellato tutto da opensuse?

Messaggio da steff » sabato 29 marzo 2014, 21:03

Di solito vengono usati gli UUID, bene in quanto questo non cambiano mai se cancelli, dividi un partizione o fai qual cos'altro con le partizioni.

E fstab puoi modificare. Esempio come non dovrebbe mai essere:

Codice: Seleziona tutto

/dev/sda9   /   ext4  rw,relatime,data=ordered        0 1
/dev/sda4  /home ext4  rw,relatime,data=ordered        0 2


Assegni un etichetta da qparted, gestore disco o da terminale:

Codice: Seleziona tutto

sudo e2label /dev/sda9 sistema 
sudo e2label /dev/sda4 home
E fstab modifichi in questo modo:

Codice: Seleziona tutto

LABEL=sistema   /   ext4  rw,relatime,data=ordered        0 1
LABEL=home    /home ext4  rw,relatime,data=ordered        0 2
Hai fatto un backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox

Avatar utente
gian64
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 3024
Iscrizione: mercoledì 7 novembre 2007, 15:33
Desktop: Openbox-Gnome
Distribuzione: SalentOS 2.0-Ubuntu 19.10
Sesso: Maschile
Località: Torino
Contatti:

Re: [Risolto]Trusty mi ha cancellato tutto da opensuse?

Messaggio da gian64 » sabato 29 marzo 2014, 22:58

steff [url=http://forum.ubuntu-it.org/viewtopic.php?p=4554677#p4554677][img]http://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Di solito vengono usati gli UUID, bene in quanto questo non cambiano mai se cancelli, dividi un partizione o fai qual cos'altro con le partizioni.

E fstab puoi modificare. Esempio come non dovrebbe mai essere:

Codice: Seleziona tutto

/dev/sda9   /   ext4  rw,relatime,data=ordered        0 1
/dev/sda4  /home ext4  rw,relatime,data=ordered        0 2


Assegni un etichetta da qparted, gestore disco o da terminale:

Codice: Seleziona tutto

sudo e2label /dev/sda9 sistema 
sudo e2label /dev/sda4 home
E fstab modifichi in questo modo:

Codice: Seleziona tutto

LABEL=sistema   /   ext4  rw,relatime,data=ordered        0 1
LABEL=home    /home ext4  rw,relatime,data=ordered        0 2
Sarebbe come dire che questo (OS)

Codice: Seleziona tutto

/dev/disk/by-id/ata-ST9120821A_3PL0TY85-part5 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-ST9120821A_3PL0TY85-part6 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-ST9120821A_3PL0TY85-part7 /home                ext4       defaults              1 2
diventerebbe questo,

Codice: Seleziona tutto

LABEL=swap rw,relatime,data=ordered       0 1
LABEL=suse   /   ext4  rw,relatime,data=ordered        0 2
LABEL=homesuse    /home ext4  rw,relatime,data=ordered        0 3
(ho anche la swap)

dopo aver assegnato le etichette con un

Codice: Seleziona tutto

sudo e2label /dev/sda5 swap 
sudo e2label /dev/sda6 suse
sudo e2label /dev/sda7 homesuse
Chiariscimi solo per favore come immettere la voce per la swap, che non sono sicuro di quel che ho scritto... :nono:

EDIT: Suppongo anche lo stesso procedimento potrei seguire anche per kubuntu, anche perchè in effetti OS e la sua /home sono già etichettati, quindi dovrei solo in questo caso modificare /fstab.

Attendo una tua conferma prima di procedere.

PS
Non devo necessariamente eseguire questo da live immagino, o mi conviene prendere questa precauzione?
Ma quanto è variegato il mondo Linux…

Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 21565
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 20.10 e 21.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: [Risolto]Trusty mi ha cancellato tutto da opensuse?

Messaggio da trekfan1 » domenica 30 marzo 2014, 6:48

In ogni caso bisogna riavviare dopo avere modificato.

Avatar utente
steff
Moderatore Globale
Moderatore Globale
Messaggi: 39144
Iscrizione: domenica 18 febbraio 2007, 19:48
Desktop: LXQt
Distribuzione: Arch 64bit | Debian 32bit
Sesso: Maschile
Località: Toscana
Contatti:

Re: [Risolto]Trusty mi ha cancellato tutto da opensuse?

Messaggio da steff » domenica 30 marzo 2014, 8:36

Non ho mai visto un fstab con /dev/disk-by-id... solo UUID=cee15eca-5b2e-48ad-9735-eae5ac14bc90 ...

Cmq si può fare dal sistema tranquillamente. Devi modificare solo l'inizio delle righe.
Hai fatto un backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox

Avatar utente
gian64
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 3024
Iscrizione: mercoledì 7 novembre 2007, 15:33
Desktop: Openbox-Gnome
Distribuzione: SalentOS 2.0-Ubuntu 19.10
Sesso: Maschile
Località: Torino
Contatti:

Re: [Risolto]Trusty mi ha cancellato tutto da opensuse?

Messaggio da gian64 » domenica 30 marzo 2014, 13:56

Ho cambiato lo fstab di opensuse, dopo aver attribuito l'etichetta "swap" da gparted e ho modificato lo fstab come nel post precedente

Codice: Seleziona tutto

LABEL=swap rw,relatime,data=ordered       0 1
LABEL=suse   /   ext4  rw,relatime,data=ordered        0 2
LABEL=homesuse    /home ext4  rw,relatime,data=ordered        0 3
Ho riavviato un paio di volte e tutto sembra funzionare a dovere, in ogni caso ho fatto un backup dello fstab originale...

Però noto che né dal comando mount né da lsblk risulti il punto di montaggio swap, è normale?
Ma quanto è variegato il mondo Linux…

Avatar utente
steff
Moderatore Globale
Moderatore Globale
Messaggi: 39144
Iscrizione: domenica 18 febbraio 2007, 19:48
Desktop: LXQt
Distribuzione: Arch 64bit | Debian 32bit
Sesso: Maschile
Località: Toscana
Contatti:

Re: [Risolto]Trusty mi ha cancellato tutto da opensuse?

Messaggio da steff » domenica 30 marzo 2014, 14:28

mount non lo mostra (da me su arch), lsblk sì.

Codice: Seleziona tutto

lsblk
NAME            MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda               8:0    0 298,1G  0 disk  
├─sda1            8:1    0   855M  0 part  /boot
└─sda2            8:2    0 297,3G  0 part  
  └─main        254:0    0 297,3G  0 crypt 
    ├─main-root 254:1    0    15G  0 lvm   /
    ├─main-home 254:2    0   270G  0 lvm   /home
    ├─main-swap 254:3    0     5G  0 lvm   [SWAP]
    └─main-var  254:4    0   7,3G  0 lvm   /var
sr0              11:0    1  1024M  0 rom   
Controlla se è attiva:

Codice: Seleziona tutto

cat /proc/swaps
Hai fatto un backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox

Avatar utente
gian64
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 3024
Iscrizione: mercoledì 7 novembre 2007, 15:33
Desktop: Openbox-Gnome
Distribuzione: SalentOS 2.0-Ubuntu 19.10
Sesso: Maschile
Località: Torino
Contatti:

Re: [Risolto]Trusty mi ha cancellato tutto da opensuse?

Messaggio da gian64 » domenica 30 marzo 2014, 14:38

output:

Codice: Seleziona tutto

ian64@linux-pdxd:~> cat /proc/swaps
Filename                                Type            Size    Used    Priority
/dev/sda5                               partition       2136608 0       -1
E' attiva o no?

PS ho ripristinato il vecchio fstab, non capisco perchè ma mi ha creato di problemi, in particolare mancata apertura del menù se non dopo vari tentativi...
Ma quanto è variegato il mondo Linux…

Scrivi risposta

Ritorna a “Trusty Tahr 14.04”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 1 ospite