Bumblebee + nVidia proprietari: could not load GPU driver

Prossima versione di Ubuntu in fase di sviluppo e test. Per i precedenti rilasci, consultare «Archivio del forum».
Avatar utente
zanardi84
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 306
Iscrizione: mercoledì 29 marzo 2006, 10:35

Bumblebee + nVidia proprietari: could not load GPU driver

Messaggio da zanardi84 »

Come da titolo, ho installato tutto il pacchetto bumblebee nvidia con le dipendenze solite (mi pare siano le stesse di 14.04 su cui funziona bene, se non con un piccola modifica ad un file) + i driver 346.xx (i 304 non sono supportati dalla mia 750m) .
Ho messo virtualgl installato esternamente perchè non sono più stati inseriti i pacchetti (no problem, sono gli stessi usati per le vecchie release).

La cosa più importante, cioè che la scheda video sia spenta è ok: infatti dando optirun --status la scheda discreta è OFF.

dando però un optirun firefox, per esempio, compare:

Codice: Seleziona tutto

[  639.285444] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[  639.285512] [ERROR]Aborting because fallback start is disabled.
Ora: il modulo nvidia_346 sembra caricato all'avvio, modprobe nvidia_356 non restituisce problemi (modprobe nvidia non esiste il modulo) e ho provato a modificare il file bumblebee.onf (il demone sembra essere stato avviato) inserendo al posto di nvidia-current il driver nvidia-346.. nessun risultato, ma un altro messaggio di errore che non ricordo in questo momento preciso.

Ho provato pure ad installare dal ppa xorg-edgers ma senza risultati (non ho aggiornato però il driver intel integrato perchè mi pare che dia problemi con unity)

Mi vien da pensare che ci sia qualche problema con systemd.. I pacchetti driver penso che siano patchati per il kernel 3.19

mi potete aiutare?

Grazie.
Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7711
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome
Distribuzione: 18.04-20.04-20.10-21.04 (NO UEFI)
Località: Ancona

Re: Bumblebee + nVidia proprietari: could not load GPU drive

Messaggio da et4beta »

Non so la ragione per cui tu abbia installato Bumblebee per gestire la grafica ibrida del tuo PC.
E' ormai dalla versione 319 dei suoi driver che la Nvidia da supporto diretto alla tecnologia Optimus anche in Linux, quindi essi gestiscono direttamente entrambe le GPU, quella integrata e quella aggiuntiva.
Inoltre anche l'installazione dei driver 346 che hai fatto associandoli a Bumblebee non è corretta, perché l'applicazione se li prende da sola i driver con cui è compatibile ed i 346 non sono ancora neanche tra gli "ufficiali".
Quindi disinstalla tutto, riparti dai nouveau, ed installa solamente i driver ufficiali che trovi nei repo(li trovi anche in "Synaptic") e che al momento sono i 331(scegli gli "updates").
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.
Avatar utente
zanardi84
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 306
Iscrizione: mercoledì 29 marzo 2006, 10:35

Re: Bumblebee + nVidia proprietari: could not load GPU drive

Messaggio da zanardi84 »

Io ero rimasto ai driver proprietari incapaci di spegnere la vga nvidia.. hanno risolto questo problema?
Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7711
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome
Distribuzione: 18.04-20.04-20.10-21.04 (NO UEFI)
Località: Ancona

Re: Bumblebee + nVidia proprietari: could not load GPU drive

Messaggio da et4beta »

Sì, come dicevo, dai driver 319 Nvidia supporta, anche per Linux, la tecnologia Optimus e gestisce entrambe le GPU.
Disinstalla tutto e poi installa i driver ufficiali, ma non i 346 che oltretutto hanno ancora non pochi problemi. Per la verità anche i 331 non sono perfetti, infatti in occasione degli upgrade del kernel, un messaggio di errore sul file 331-uvm. ma è sufficiente andare in Synaptic o nel terminale e reinstallare solo quello.
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.
Scrivi risposta

Ritorna a “Vivid Vervet 15.04”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 2 ospiti