ubuntu mate non si mette in italiano

Configurazione e uso delle applicazioni del desktop manager alla base di Ubuntu MATE.

Re: ubuntu mate non si mette in italiano

Messaggioda Roberto Pontecorvi » giovedì 29 marzo 2018, 8:42

Premi -> Install/remove languege e spunta l'Italiano.
Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4717
Iscrizione: maggio 2009
Località: Versilia
Distribuzione: 16.4 mate - 18.4 mate
Sesso: Maschile

Re: ubuntu mate non si mette in italiano

Messaggioda caturen » giovedì 29 marzo 2018, 19:12

caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15021
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: ubuntu mate non si mette in italiano

Messaggioda samuele gubbiotti » giovedì 29 marzo 2018, 20:12

ho gia provato ma non va
samuele gubbiotti
Prode Principiante
 
Messaggi: 78
Iscrizione: marzo 2016
Desktop: lxde
Distribuzione: lubuntu
Sesso: Maschile

Re: ubuntu mate non si mette in italiano

Messaggioda Roberto Pontecorvi » domenica 1 aprile 2018, 9:22

La risposta era per ne o @caturen?? Fai attenzione che per il link di @caturen devi mettere le indicazioni per l'italiano. Dal comando
Codice: Seleziona tutto
sudo dpkg-reconfigure locales

nella lista cerca:
Codice: Seleziona tutto
it_IT.UTF-8 UTF-8

se non c'è l'asterisco lo scegli e lo confermi.
Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4717
Iscrizione: maggio 2009
Località: Versilia
Distribuzione: 16.4 mate - 18.4 mate
Sesso: Maschile

Re: ubuntu mate non si mette in italiano

Messaggioda samuele gubbiotti » domenica 1 aprile 2018, 21:36

Codice: Seleziona tutto
 sudo locale-gen it_IT.UTF-8
[sudo] password for samuele:
Generating locales (this might take a while)...
  it_IT.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
Generation complete.


Codice: Seleziona tutto
sudo dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
   LANGUAGE = "en",
   LC_ALL = (unset),
   LC_PAPER = "it_IT.UTF-8",
   LC_ADDRESS = "it_IT.UTF-8",
   LC_MONETARY = "it_IT.UTF-8",
   LC_NUMERIC = "it_IT.UTF-8",
   LC_TELEPHONE = "it_IT.UTF-8",
   LC_IDENTIFICATION = "it_IT.UTF-8",
   LC_MEASUREMENT = "it_IT.UTF-8",
   LC_TIME = "it_IT.UTF-8",
   LC_NAME = "it_IT.UTF-8",
   LANG = "it_IT.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales (this might take a while)...
  en_AG.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  en_AU.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  en_BW.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  en_CA.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  en_DK.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  en_GB.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  en_HK.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  en_IE.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  en_IN.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  en_NG.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  en_NZ.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  en_PH.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  en_SG.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  en_US.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  en_ZA.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  en_ZM.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  en_ZW.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  it_CH.ISO-8859-1...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  it_CH.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  it_IT.ISO-8859-1...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  it_IT.UTF-8...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
  it_IT.ISO-8859-15@euro...localedef: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
 done
Generation complete.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
   LANGUAGE = "en",
   LC_ALL = (unset),
   LC_TIME = "it_IT.UTF-8",
   LC_MONETARY = "it_IT.UTF-8",
   LC_ADDRESS = "it_IT.UTF-8",
   LC_TELEPHONE = "it_IT.UTF-8",
   LC_NAME = "it_IT.UTF-8",
   LC_MEASUREMENT = "it_IT.UTF-8",
   LC_IDENTIFICATION = "it_IT.UTF-8",
   LC_NUMERIC = "it_IT.UTF-8",
   LC_PAPER = "it_IT.UTF-8",
   LANG = "C"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
   LANGUAGE = "en",
   LC_ALL = (unset),
   LC_TIME = "it_IT.UTF-8",
   LC_MONETARY = "it_IT.UTF-8",
   LC_ADDRESS = "it_IT.UTF-8",
   LC_TELEPHONE = "it_IT.UTF-8",
   LC_NAME = "it_IT.UTF-8",
   LC_MEASUREMENT = "it_IT.UTF-8",
   LC_IDENTIFICATION = "it_IT.UTF-8",
   LC_NUMERIC = "it_IT.UTF-8",
   LC_PAPER = "it_IT.UTF-8",
   LANG = "C"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
samuele gubbiotti
Prode Principiante
 
Messaggi: 78
Iscrizione: marzo 2016
Desktop: lxde
Distribuzione: lubuntu
Sesso: Maschile

Re: ubuntu mate non si mette in italiano

Messaggioda Roberto Pontecorvi » lunedì 2 aprile 2018, 9:25

Controlla che i file -> libc.so.6 e libc-2.23.so siano presenti nelle directory:
/lib/x86_64-linux-gnu
/lib/i386-linux-gnu
/lib32
dato che ci siamo da i seguenti comandi:
Codice: Seleziona tutto
sudo update-initramfs -u
sudo dpkg --configure -a

e riavvia il pc.
Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4717
Iscrizione: maggio 2009
Località: Versilia
Distribuzione: 16.4 mate - 18.4 mate
Sesso: Maschile

Re: ubuntu mate non si mette in italiano

Messaggioda samuele gubbiotti » lunedì 2 aprile 2018, 12:22

i file ci sono
Codice: Seleziona tutto
sudo update-initramfs -u
[sudo] password for samuele:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
   LANGUAGE = "en",
   LC_ALL = (unset),
   LC_TIME = "it_IT.UTF-8",
   LC_MONETARY = "it_IT.UTF-8",
   LC_ADDRESS = "it_IT.UTF-8",
   LC_TELEPHONE = "it_IT.UTF-8",
   LC_NAME = "it_IT.UTF-8",
   LC_MEASUREMENT = "it_IT.UTF-8",
   LC_IDENTIFICATION = "it_IT.UTF-8",
   LC_NUMERIC = "it_IT.UTF-8",
   LC_PAPER = "it_IT.UTF-8",
   LANG = "it_IT.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
update-initramfs: Generating /boot/initrd.img-4.13.0-37-generic
samuele gubbiotti
Prode Principiante
 
Messaggi: 78
Iscrizione: marzo 2016
Desktop: lxde
Distribuzione: lubuntu
Sesso: Maschile

Re: ubuntu mate non si mette in italiano

Messaggioda Roberto Pontecorvi » lunedì 2 aprile 2018, 20:15

Controlla se è installato il file -> perl
Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4717
Iscrizione: maggio 2009
Località: Versilia
Distribuzione: 16.4 mate - 18.4 mate
Sesso: Maschile

Re: ubuntu mate non si mette in italiano

Messaggioda samuele gubbiotti » lunedì 2 aprile 2018, 21:24

si è istallato
samuele gubbiotti
Prode Principiante
 
Messaggi: 78
Iscrizione: marzo 2016
Desktop: lxde
Distribuzione: lubuntu
Sesso: Maschile

Re: ubuntu mate non si mette in italiano

Messaggioda Roberto Pontecorvi » martedì 3 aprile 2018, 8:20

Prova ad disinstallarlo e reinstallarlo.
Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4717
Iscrizione: maggio 2009
Località: Versilia
Distribuzione: 16.4 mate - 18.4 mate
Sesso: Maschile

Re: ubuntu mate non si mette in italiano

Messaggioda samuele gubbiotti » martedì 3 aprile 2018, 18:34

fatto ma non è cambiato niente
samuele gubbiotti
Prode Principiante
 
Messaggi: 78
Iscrizione: marzo 2016
Desktop: lxde
Distribuzione: lubuntu
Sesso: Maschile

Re: ubuntu mate non si mette in italiano

Messaggioda Roberto Pontecorvi » martedì 3 aprile 2018, 20:40

In questa disussione @giulux da un suggerimento con la reinstallazione dei pacchetti in italiano di gnome -> viewtopic.php?f=10&t=567496 se vuoi provare, io non so più cosa suggerire se non la reinstallazione del SO???
Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4717
Iscrizione: maggio 2009
Località: Versilia
Distribuzione: 16.4 mate - 18.4 mate
Sesso: Maschile

Re: ubuntu mate non si mette in italiano

Messaggioda Roberto Pontecorvi » sabato 7 aprile 2018, 10:44

Ultimo tentativo. Controlla se sono installati i seguenti pacchetti:
- languge-pack-it
- languge-pack-it-base
- languge-pack-gnome-it
- languge-pack-gnome-it-base
- languge-common
- languge-gnome
Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4717
Iscrizione: maggio 2009
Località: Versilia
Distribuzione: 16.4 mate - 18.4 mate
Sesso: Maschile

Precedente

Torna a MATE

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 3 ospiti