schermo nero autologin lightdm

Configurazione e uso delle applicazioni del desktop manager alla base di Ubuntu MATE.

schermo nero autologin lightdm

Messaggioda cokiere » domenica 6 gennaio 2019, 13:02

salve
vorrei fare l'autologin con lightdm. Il problema, come da titolo, è che non avvia il desktop. Sembra in sospensione. Devo muovere il mouse o pigiare velocemente qualche tasto. Tutto normale con user name e password

ho provato varie impostazioni ma non è cambiato niente. Compreso sudo dpkg-reconfigure lightdm e reinstall

[LightDM]
minimum-vt=7 << questa è di default ma ho provato con tutte le console senza risultato
autologin-user = graziella
autologin-user-timeout = 0

[Seat:*]

autologin-user=graziella
autologin-user-timeout=0

Ora non ho il file xorg.conf. L'ho configurato un sacco di volte senza risultato. Ora ho solo questo:

tentativo per disattivare DPMS
10-monitor.conf
Section "Monitor"
Identifier "LVDS-1"
Option "DPMS" "Disable"
EndSection

e questo:
10-radeon-conf
Section "OutputClass"
Identifier "Radeon"
MatchDriver "radeon"
Driver "radeon"
Option "AccelMethod" "exa"
Option "TearFree" "on"
EndSection

disattivato gestione alimentazione.
Ho letto riletto varie guide: Arch, debian, ubuntu, ecc. Ho chiesto in vari forum senza trovare spiegazione.
Non saprei dove sbattere la testa. Sostituito lightdm con slim e altri ma il problema rimane.

Grazie a tutti
cokiere
Prode Principiante
 
Messaggi: 12
Iscrizione: giugno 2012
Desktop: gnome
Distribuzione: 11.10

Re: schermo nero autologin lightdm

Messaggioda caturen » domenica 6 gennaio 2019, 14:24

che versione di ubuntu e che DE stai usando? Aggiorna il tuo profilo. Nel caso si tratti di mate https://ubuntu-mate.community/t/auto-lo ... desktop/60
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15310
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: schermo nero autologin lightdm

Messaggioda cokiere » domenica 6 gennaio 2019, 17:23

salve
si uso mate. ho gia provato la soluzione che hai linkato. non ha funzionato.
Ho provato anche nodm senza risultato.
Sto ancora ripassando tutti i log senza trovare un errore che mi possa indirizzare verso questo problema.
In realta l'autologin c'è ma non si avvia il desktop. Lo schermo è acceso ( vedo le lampade accese) ma il desktop non si avvia. Dico non si avvia perchè guardando di scorcio o puntando una luce normalmente si vede il desktop. In questo caso non si vede niente nemmeno un cursone che lampeggia.
Ho provato un sacco di volte: dpkg-reconfigure lightdm, sudo dpkg-reconfigure xserver-xorg-video-radeon.
ho provato anche le seguenti guide senza risolvere:
https://wiki.archlinux.org/index.php/SLiM_(Italiano)#Autologin
https://wiki.debian.org/it/LightDM#Abil ... automatico
https://wiki.archlinux.org/index.php/Au ... _(Italiano)
https://wiki.archlinux.org/index.php/ge ... al_console
...e altre ancora.
Se ci fosse qualcosa che mi indirizzasse verso un problema di driver lo seguire ma non lo trovo...
Ripeto inserendo username e password tutto si avvia normalmente sempre su tty7.
Grazie mille per qualsiasi suggerimento
ciao
cokiere
Prode Principiante
 
Messaggi: 12
Iscrizione: giugno 2012
Desktop: gnome
Distribuzione: 11.10

Re: schermo nero autologin lightdm

Messaggioda cokiere » domenica 6 gennaio 2019, 17:39

... altre info:
sudo dmesg | egrep 'drm|radeon'

Codice: Seleziona tutto
[    2.624615] [drm] radeon kernel modesetting enabled.
[    2.624706] fb: switching to radeondrmfb from EFI VGA
[    2.625232] [drm] initializing kernel modesetting (CEDAR 0x1002:0x68E0 0x1043:0x1BF2 0x00).
[    2.625368] radeon 0000:01:00.0: VRAM: 512M 0x0000000000000000 - 0x000000001FFFFFFF (512M used)
[    2.625370] radeon 0000:01:00.0: GTT: 1024M 0x0000000020000000 - 0x000000005FFFFFFF
[    2.625374] [drm] Detected VRAM RAM=512M, BAR=256M
[    2.625375] [drm] RAM width 64bits DDR
[    2.625505] [drm] radeon: 512M of VRAM memory ready
[    2.625507] [drm] radeon: 1024M of GTT memory ready.
[    2.625523] [drm] Loading CEDAR Microcode
[    2.625573] radeon 0000:01:00.0: firmware: direct-loading firmware radeon/CEDAR_pfp.bin
[    2.625608] radeon 0000:01:00.0: firmware: direct-loading firmware radeon/CEDAR_me.bin
[    2.625639] radeon 0000:01:00.0: firmware: direct-loading firmware radeon/CEDAR_rlc.bin
[    2.625682] radeon 0000:01:00.0: firmware: direct-loading firmware radeon/CEDAR_smc.bin
[    2.625688] [drm] Internal thermal controller without fan control
[    2.654194] [drm] radeon: dpm initialized
[    2.654302] radeon 0000:01:00.0: firmware: direct-loading firmware radeon/CYPRESS_uvd.bin
[    2.654346] [drm] GART: num cpu pages 262144, num gpu pages 262144
[    2.676767] [drm] PCIE GART of 1024M enabled (table at 0x000000000014C000).
[    2.676931] radeon 0000:01:00.0: WB enabled
[    2.676937] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000020000c00 and cpu addr 0x(____ptrval____)
[    2.676942] radeon 0000:01:00.0: fence driver on ring 3 use gpu addr 0x0000000020000c0c and cpu addr 0x(____ptrval____)
[    2.677323] radeon 0000:01:00.0: fence driver on ring 5 use gpu addr 0x000000000005c418 and cpu addr 0x(____ptrval____)
[    2.677327] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    2.677329] [drm] Driver supports precise vblank timestamp query.
[    2.677332] radeon 0000:01:00.0: radeon: MSI limited to 32-bit
[    2.677421] radeon 0000:01:00.0: radeon: using MSI.
[    2.677467] [drm] radeon: irq initialized.
[    2.694686] [drm] ring test on 0 succeeded in 1 usecs
[    2.694695] [drm] ring test on 3 succeeded in 3 usecs
[    2.871021] [drm] ring test on 5 succeeded in 1 usecs
[    2.871034] [drm] UVD initialized successfully.
[    2.871337] [drm] ib test on ring 0 succeeded in 0 usecs
[    2.871402] [drm] ib test on ring 3 succeeded in 0 usecs
[    3.021778] [drm] ib test on ring 5 succeeded
[    3.022553] [drm] forcing VGA-1 connector off
[    3.022587] [drm] Radeon Display Connectors
[    3.022588] [drm] Connector 0:
[    3.022588] [drm]   LVDS-1
[    3.022590] [drm]   DDC: 0x6560 0x6560 0x6564 0x6564 0x6568 0x6568 0x656c 0x656c
[    3.022591] [drm]   Encoders:
[    3.022591] [drm]     LCD1: INTERNAL_UNIPHY
[    3.022592] [drm] Connector 1:
[    3.022592] [drm]   HDMI-A-1
[    3.022593] [drm]   HPD1
[    3.022595] [drm]   DDC: 0x6440 0x6440 0x6444 0x6444 0x6448 0x6448 0x644c 0x644c
[    3.022595] [drm]   Encoders:
[    3.022596] [drm]     DFP1: INTERNAL_UNIPHY1
[    3.022596] [drm] Connector 2:
[    3.022597] [drm]   VGA-1
[    3.022598] [drm]   DDC: 0x64d8 0x64d8 0x64dc 0x64dc 0x64e0 0x64e0 0x64e4 0x64e4
[    3.022599] [drm]   Encoders:
[    3.022599] [drm]     CRT1: INTERNAL_KLDSCP_DAC1
[    3.400860] [drm] fb mappable at 0xC034D000
[    3.400861] [drm] vram apper at 0xC0000000
[    3.400863] [drm] size 4325376
[    3.400864] [drm] fb depth is 24
[    3.400866] [drm]    pitch is 5632
[    3.401145] fbcon: radeondrmfb (fb0) is primary device
[    4.025179] radeon 0000:01:00.0: fb0: radeondrmfb frame buffer device
[    4.038901] [drm] Initialized radeon 2.50.0 20080528 for 0000:01:00.0 on minor 0


sudo dmesg | egrep ACPI:

Codice: Seleziona tutto
[    0.000000] BIOS-e820: [mem 0x00000000becf1000-0x00000000bed35fff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000bed47000-0x00000000bed58fff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000bed62000-0x00000000bed69fff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000bed83000-0x00000000bed83fff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000bed9a000-0x00000000bed9cfff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000bed9f000-0x00000000bed9ffff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000beda4000-0x00000000beda6fff] ACPI data
[    0.000000] BIOS-e820: [mem 0x00000000bedac000-0x00000000bedb9fff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000bedd0000-0x00000000bedd1fff] ACPI NVS
[    0.000000] efi:  ACPI 2.0=0xbeda6f98  SMBIOS=0xbee01018
[    0.017857] ACPI: Early table checksum verification disabled
[    0.017861] ACPI: RSDP 0x00000000BEDA6F98 000024 (v02 _ASUS_)
[    0.017866] ACPI: XSDT 0x00000000BEDA5E18 00005C (v01 _ASUS_ Notebook 06222004 MSFT 00010013)
[    0.017873] ACPI: FACP 0x00000000BED83C18 0000F4 (v04 _ASUS_ Notebook 06222004 MSFT 00010013)
[    0.017881] ACPI: DSDT 0x00000000BED47018 0117C5 (v01 _ASUS_ Notebook 00000000 INTL 20051117)
[    0.017885] ACPI: FACS 0x00000000BEDB7F40 000040
[    0.017889] ACPI: FACS 0x00000000BEDD1D40 000040
[    0.017892] ACPI: APIC 0x00000000BEDA4F18 00008C (v02 _ASUS_ Notebook 06222004 MSFT 00010013)
[    0.017897] ACPI: DBGP 0x00000000BEDA6F18 000034 (v01 _ASUS_ Notebook 06222004 MSFT 00010013)
[    0.017901] ACPI: ECDT 0x00000000BEDD1A18 0000C1 (v01 _ASUS_ Notebook 06222004 AMI. 00000003)
[    0.017905] ACPI: MCFG 0x00000000BEDD0D18 00003C (v01 _ASUS_ Notebook 06222004 MSFT 00000097)
[    0.017909] ACPI: HPET 0x00000000BEDD0C98 000038 (v01 _ASUS_ Notebook 06222004 AMI. 00000003)
[    0.017913] ACPI: SSDT 0x00000000BED9F018 0009F1 (v01 PmRef  CpuPm    00003000 INTL 20051117)
[    0.017927] ACPI: Local APIC address 0xfee00000
[    0.055355] ACPI: PM-Timer IO Port: 0x408
[    0.055359] ACPI: Local APIC address 0xfee00000
[    0.055386] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
[    0.055388] ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
[    0.055390] ACPI: IRQ0 used by override.
[    0.055391] ACPI: IRQ9 used by override.
[    0.055394] Using ACPI (MADT) for SMP configuration information
[    0.055396] ACPI: HPET id: 0x8086a701 base: 0xfed00000
[    0.354350] ACPI: Core revision 20180810
[    0.403239] PM: Registering ACPI NVS region [mem 0xbecf1000-0xbed35fff] (282624 bytes)
[    0.403239] PM: Registering ACPI NVS region [mem 0xbed47000-0xbed58fff] (73728 bytes)
[    0.403239] PM: Registering ACPI NVS region [mem 0xbed62000-0xbed69fff] (32768 bytes)
[    0.403239] PM: Registering ACPI NVS region [mem 0xbed83000-0xbed83fff] (4096 bytes)
[    0.403239] PM: Registering ACPI NVS region [mem 0xbed9a000-0xbed9cfff] (12288 bytes)
[    0.403239] PM: Registering ACPI NVS region [mem 0xbed9f000-0xbed9ffff] (4096 bytes)
[    0.403239] PM: Registering ACPI NVS region [mem 0xbedac000-0xbedb9fff] (57344 bytes)
[    0.403239] PM: Registering ACPI NVS region [mem 0xbedd0000-0xbedd1fff] (8192 bytes)
[    0.403246] ACPI FADT declares the system doesn't support PCIe ASPM, so disable it
[    0.403246] ACPI: bus type PCI registered
[    0.403246] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
[    0.403628] ACPI: Added _OSI(Module Device)
[    0.403628] ACPI: Added _OSI(Processor Device)
[    0.403628] ACPI: Added _OSI(3.0 _SCP Extensions)
[    0.403628] ACPI: Added _OSI(Processor Aggregator Device)
[    0.403628] ACPI: Added _OSI(Linux)
[    0.403628] ACPI: EC: EC started
[    0.403628] ACPI: EC: interrupt blocked
[    0.403628] ACPI: \: Used as first EC
[    0.403628] ACPI: \: GPE=0x1b, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.403628] ACPI: \: Used as boot ECDT EC to handle transactions
[    0.418321] ACPI: 2 ACPI AML tables successfully acquired and loaded
[    0.421970] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query honored via cmdline
[    0.427059] ACPI: Dynamic OEM Table Load:
[    0.427066] ACPI: SSDT 0xFFFF9C9F72F60800 0003B5 (v01 PmRef  Cpu0Ist  00003000 INTL 20051117)
[    0.427540] ACPI: Dynamic OEM Table Load:
[    0.427546] ACPI: SSDT 0xFFFF9C9F73924000 0008A9 (v01 PmRef  Cpu0Cst  00003001 INTL 20051117)
[    0.428255] ACPI: Dynamic OEM Table Load:
[    0.428260] ACPI: SSDT 0xFFFF9C9F72850000 000303 (v01 PmRef  ApIst    00003000 INTL 20051117)
[    0.428604] ACPI: Dynamic OEM Table Load:
[    0.428608] ACPI: SSDT 0xFFFF9C9F72F6B200 000119 (v01 PmRef  ApCst    00003000 INTL 20051117)
[    0.431174] ACPI: Interpreter enabled
[    0.431203] ACPI: (supports S0 S3 S4 S5)
[    0.431205] ACPI: Using IOAPIC for interrupt routing
[    0.431241] PCI: Ignoring host bridge windows from ACPI; if necessary, use "pci=use_crs" and report a bug
[    0.431544] ACPI: Enabled 12 GPEs in block 00 to 3F
[    0.443914] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-fe])
[    0.451865] ACPI: PCI Interrupt Link [LNKA] (IRQs 1 3 4 5 6 7 10 12 14 15) *11
[    0.451930] ACPI: PCI Interrupt Link [LNKB] (IRQs 1 3 4 5 6 7 11 12 14 15) *10
[    0.451993] ACPI: PCI Interrupt Link [LNKC] (IRQs 1 3 *4 5 6 7 10 12 14 15)
[    0.452056] ACPI: PCI Interrupt Link [LNKD] (IRQs 1 3 4 *5 6 7 11 12 14 15)
[    0.452118] ACPI: PCI Interrupt Link [LNKE] (IRQs 1 3 4 5 6 7 10 12 14 15) *0, disabled.
[    0.452180] ACPI: PCI Interrupt Link [LNKF] (IRQs 1 3 4 5 6 7 11 12 14 15) *0, disabled.
[    0.452243] ACPI: PCI Interrupt Link [LNKG] (IRQs 1 *3 4 5 6 7 10 12 14 15)
[    0.452309] ACPI: PCI Interrupt Link [LNKH] (IRQs 1 3 4 5 6 7 11 12 14 15) *10
[    0.452362] ACPI: PCI Root Bridge [CPBG] (domain 0000 [bus ff])
[    0.453030] ACPI: EC: interrupt unblocked
[    0.453040] ACPI: EC: event unblocked
[    0.453049] ACPI: \_SB_.PCI0.SBRG.EC0_: GPE=0x1b, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.453051] ACPI: \_SB_.PCI0.SBRG.EC0_: Used as boot DSDT EC to handle transactions and events
[    0.498744] PCI: Using ACPI for IRQ routing
[    0.523988] pnp: PnP ACPI init
[    0.524270] system 00:00: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.524303] pnp 00:01: Plug and Play ACPI device, IDs PNP0b00 (active)
[    0.524364] system 00:02: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.524441] pnp 00:03: Plug and Play ACPI device, IDs ETD0001 SYN0a00 SYN0002 PNP0f03 PNP0f13 PNP0f12 (active)
[    0.524487] pnp 00:04: Plug and Play ACPI device, IDs PNP0303 PNP030b (active)
[    0.525031] system 00:05: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.525195] pnp: PnP ACPI: found 6 devices
[    2.368677] ACPI: Lid Switch [LID]
[    2.368783] ACPI: Sleep Button [SLPB]
[    2.368866] ACPI: Power Button [PWRF]
[    2.371225] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
[    2.400616] ACPI: Thermal Zone [THRM] (63 C)
[    2.441987] ACPI: bus type USB registered
[    2.469551] ACPI Warning: SystemIO range 0x000000000000E000-0x000000000000E01F conflicts with OpRegion 0x000000000000E000-0x000000000000E00F (\SMB0) (20180810/utaddress-213)
[    2.469563] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    2.873303] ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
[    2.873379] ata1.00: ACPI cmd ef/10:06:00:00:00:a0 (SET FEATURES) succeeded
[    2.873453] ata1.00: ACPI cmd ef/90:03:00:00:00:a0 (SET FEATURES) succeeded
[    2.877748] ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
[    2.877817] ata1.00: ACPI cmd ef/10:06:00:00:00:a0 (SET FEATURES) succeeded
[    2.877886] ata1.00: ACPI cmd ef/90:03:00:00:00:a0 (SET FEATURES) succeeded
[    5.890888] ACPI: AC Adapter [AC0] (on-line)
[    5.969207] battery: ACPI: Battery Slot [BAT0] (battery present)


grazie di nuovo
cokiere
Prode Principiante
 
Messaggi: 12
Iscrizione: giugno 2012
Desktop: gnome
Distribuzione: 11.10

Re: schermo nero autologin lightdm

Messaggioda caturen » domenica 6 gennaio 2019, 22:11

installati un altro display manager e vedi come funziona
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15310
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: schermo nero autologin lightdm

Messaggioda cokiere » lunedì 7 gennaio 2019, 0:56

caturen Immagine ha scritto:installati un altro display manager e vedi come funziona


ciao
ho già provato con: slim, sddm, mdm. Il problema rimane solo impostando autologin.
Provato anche togliere Dm e impostare systemd ma non ce modo di risolvere
grazie
ogni suggerimento, idee, ecc sono graditi
cokiere
Prode Principiante
 
Messaggi: 12
Iscrizione: giugno 2012
Desktop: gnome
Distribuzione: 11.10

Re: schermo nero autologin lightdm

Messaggioda caturen » lunedì 7 gennaio 2019, 6:43

caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15310
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: schermo nero autologin lightdm

Messaggioda Roberto Pontecorvi » venerdì 29 marzo 2019, 21:38

Puoi provare così:
Codice: Seleziona tutto
sudo pluma /etc/lightdm/lightdm.conf

sostituisci il contenuto con:
Codice: Seleziona tutto
[SeatDefaults]
autologin-guest=false
autologin-user=nomeutente
autologin-user-timeout=0
autologin-session=lightdm-autologin


Ovviamente al posto di nomeutente dovete inserire il vostro username (quello che utilizzate per il login di Ubuntu).
Salvate il file, chiudi pluma riavvia il computer.
Roberto Pontecorvi
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4791
Iscrizione: maggio 2009
Località: Versilia
Distribuzione: 16.4 mate - 18.4 mate
Sesso: Maschile


Torna a MATE

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite