apt numero pacchetti da aggiornare errato

Installazione, configurazione e uso di Ubuntu come server: web, ftp, mail, news, proxy, dns, ecc.

apt numero pacchetti da aggiornare errato

Messaggioda minotaur » mercoledì 13 giugno 2018, 9:55

Ciao a tutti,
entrando sul server noto questo messaggio che indica che ci sono 10 pacchetti da aggiornare+10 di sicurezza.
10 packages can be updated.
10 updates are security updates.


ma facendo un apt list --upgradable
mi riporta questa lista e sono solo 6
# apt list --upgradable
Listing... Done
gnupg/xenial-updates,xenial-security 1.4.20-1ubuntu3.2 amd64 [upgradable from: 1.4.20-1ubuntu3.1]
gpgv/xenial-updates,xenial-security 1.4.20-1ubuntu3.2 amd64 [upgradable from: 1.4.20-1ubuntu3.1]
linux-generic/xenial-updates,xenial-security 4.4.0.128.134 amd64 [upgradable from: 4.4.0.127.133]
linux-headers-generic/xenial-updates,xenial-security 4.4.0.128.134 amd64 [upgradable from: 4.4.0.127.133]
linux-image-generic/xenial-updates,xenial-security 4.4.0.128.134 amd64 [upgradable from: 4.4.0.127.133]
linux-libc-dev/xenial-updates,xenial-security 4.4.0-128.154 amd64 [upgradable from: 4.4.0-127.153]


Qualcuno mi potrebbe spiegare il perchè di questi "conteggi errati" ?
Ho già provato ad aspettare qualche giorno e lanciare degli apt update ma nulla è cambiato.
Grazie
minotaur
Prode Principiante
 
Messaggi: 4
Iscrizione: aprile 2014
Distribuzione: ubuntu server 16.04

Re: apt numero pacchetti da aggiornare errato

Messaggioda Stealth » mercoledì 13 giugno 2018, 11:41

Te ne elenca 6 perchè sono quelli aggiornabili. Il tuo comando chiedeva di "listarti gli upgradables". Poi in tutto sono 10 perchè gli altri 4 sono il kernel nuovo, da installare e non da aggiornare. Prova con
Codice: Seleziona tutto
apt upgrade

e vedrai che li vedi tutti. E non preoccuparti, ti chiede conferma prima di fare qualsiasi cosa e puoi rifiutare
ciao
Avatar utente
Stealth
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15339
Iscrizione: gennaio 2006
Desktop: Unity
Distribuzione: Ubuntu 18.04 LTS

Re: apt numero pacchetti da aggiornare errato

Messaggioda minotaur » mercoledì 13 giugno 2018, 11:49

Stealth Immagine ha scritto:Te ne elenca 6 perchè sono quelli aggiornabili. Il tuo comando chiedeva di "listarti gli upgradables". Poi in tutto sono 10 perchè gli altri 4 sono il kernel nuovo, da installare e non da aggiornare. Prova con
Codice: Seleziona tutto
apt upgrade

e vedrai che li vedi tutti. E non preoccuparti, ti chiede conferma prima di fare qualsiasi cosa e puoi rifiutare
ciao


Grazie, gentilissimo! Un ultima cosa... nel numero dei "packages can be updated" sono sempre inclusi i "security updates" giusto? Oppure sono 2 conteggi seprati?
minotaur
Prode Principiante
 
Messaggi: 4
Iscrizione: aprile 2014
Distribuzione: ubuntu server 16.04

Re: apt numero pacchetti da aggiornare errato

Messaggioda Stealth » mercoledì 13 giugno 2018, 12:58

Non ho mai verificato ma darei per certo che sì, siano sempre inclusi. Credo vengano evidenziati a parte perchè alcuni non aggiornano nulla se non quelli, e spesso neanche tutti. Ci possono essere problemi con versioni di librerie, e/o incompatibilità con applicativi personalizzati o proprietari, e poi c'è sempre la solita vecchia storia che, finchè il sistema funziona, non si tocca.
ciao
Avatar utente
Stealth
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15339
Iscrizione: gennaio 2006
Desktop: Unity
Distribuzione: Ubuntu 18.04 LTS


Torna a Ubuntu su server

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 5 ospiti