Pagina 1 di 1

[RISOLTO]Settare password in MySql dove non c'è

MessaggioInviato: lunedì 1 giugno 2009, 17:57
da greenm4n
Ciao a tutti,

quando ho installato MySql non ho inserito nessuna password, ora necessito di inserirla, come faccio ?

Ho guardato in giro, ma tramite il comando "sudo mysql -u root" mi da questo errore:

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

Uguale se uso Webmin e provo a cambiare password mi da un messaggio similare.

Come faccio ?

Grazie

Re: Settare password in MySql dove non c'è

MessaggioInviato: martedì 2 giugno 2009, 0:07
da Super Cicco
mysql -u root -p

dopo aver dato questo comando ti chiede la password, inserisci la password dell'utente root e a questo punto dovresti poter accedere.

Re: Settare password in MySql dove non c'è

MessaggioInviato: martedì 2 giugno 2009, 9:45
da greenm4n
Mi da lo stesso errore ma sto giro in fondo alla stringa c'è YES

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

Con Webmin invece mi da questo:

Failed to change administration password : DBI connect failed : Access denied for user ''@'localhost' to database 'mysql'

Re: Settare password in MySql dove non c'è

MessaggioInviato: martedì 2 giugno 2009, 11:07
da Super Cicco
sul web ho trovato questo procedimento:
ti ho scritto sia i comandi che devi dare, sia più o meno l'output che ti dovrebbe uscire. In questo modo credo che sia più facile seguire il procedimento.
ovviamente tu devi dare solo i comandi che compaiono dopo $, # o mysql> che sono i prompt della shell ($,#) e di mysql(mysql>) e ovviamente non devi scriverli, li ho messi solo per farti capire quali sono i comandi che devi dare tu.
Codice: Seleziona tutto
$ sudo -s
inserisci la password di root

# /etc/init.d/mysql stop
Stopping MySQL database server: mysqld.

# mysqld_safe --skip-grant-tables &
[1] 29756
Starting mysqld daemon with databases from /var/lib/mysql
mysqld_safe[29793]: started

# mysql -u root

Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 1
Server version: 5.0.32-Debian_7etch5-log Debian etch distribution

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the buffer.

mysql> use mysql;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

mysql> update user set password=PASSWORD(’__NEW__PASSWORD__’) where User=’root’;
Query OK, 2 rows affected (0.02 sec)
Rows matched: 2 Changed: 2 Warnings: 0

mysql> flush privileges;
Query OK, 0 rows affected (0.00 sec)

mysql> \q
Bye

# kill 29756 && /etc/init.d/mysql start


ovviamente al posto di __NEW__PASSWORD__ ci devi mettere la password che ti pare a te

alla fine del procedimento dovresti riuscire a connetterti con:
mysql -u root -p
e inserendo la nuova password

spero funzioni ciao!

Re: Settare password in MySql dove non c'è

MessaggioInviato: martedì 2 giugno 2009, 11:23
da greenm4n
Nel punto di codice dove scrivi:

mysqld_safe –skip-grant-tables &
[1] 29756

il pezzo [1] 29756 mi dice che non trova cos'è il comando [1]

Re: Settare password in MySql dove non c'è

MessaggioInviato: martedì 2 giugno 2009, 11:54
da Super Cicco
quello è un output, in particolare è il pid(identificatore di processo) del processo che hai lanciato col comando precedente (quindi a te uscirà un numero diverso)
tu devi dare SOLO i comandi che si trovano su una riga che comincia con $ o # o mysql>, tutto il resto sono output.

Ti riscrivo tutti i comandi senza output:
ti ricordo che devi dare i comandi senza scrivere $, # o mysql>, ma solo quello che segue
Codice: Seleziona tutto
$ sudo -s

# /etc/init.d/mysql stop

# mysqld_safe --skip-grant-tables &

# mysql -u root

mysql> use mysql;

mysql> update user set password=PASSWORD(’__NEW__PASSWORD__’) where User=’root’;

mysql> flush privileges;

mysql> \q

# kill 29756 && /etc/init.d/mysql start

Re: Settare password in MySql dove non c'è

MessaggioInviato: martedì 2 giugno 2009, 12:28
da greenm4n
continua a non funzionare, non capisco.

mi dice:

Starting mysqld daemon with databases from /var/lib/mysql
mysqld_safe[29111]: started

poi subito dopo

STOPPING server from pid file /var/run/mysqld/mysqld.pid
mysqld_safe[29112]: ended


e naturalmente i comandi dopo non vanno

Re: Settare password in MySql dove non c'è

MessaggioInviato: martedì 2 giugno 2009, 12:56
da Super Cicco
dopo aver dato il comando
mysqld_safe –skip-grant-tables &

prova a postare l'output di:
sudo tail /var/log/mysqld.log

Re: Settare password in MySql dove non c'è

MessaggioInviato: martedì 2 giugno 2009, 14:07
da greenm4n
se digito il comando tail etc etc dopo quello mysqld_safe mi dice che non esiste il file

Re: Settare password in MySql dove non c'è

MessaggioInviato: martedì 2 giugno 2009, 14:19
da greenm4n
ce l'ho fatta, ho trovato un'altra guida, penso che il problema fosse nel doppio meno prima di skip

quindi:

--skip..etc

e non

-skip..etc

Grazie comunque

Re: [RISOLTO]Settare password in MySql dove non c'è

MessaggioInviato: martedì 2 giugno 2009, 14:20
da Super Cicco
azz...scusa! ho fatto copia/incolla senza pensarci, ora provvedo a editare i vecchi post!

Re: [RISOLTO]Settare password in MySql dove non c'è

MessaggioInviato: martedì 2 giugno 2009, 14:49
da greenm4n
Non c'è problema, mi hai aiutato comunque.

Grazie ancora (good)