[Risolto] Spamassassin non si avvia all'avvio del sistema

Installazione, configurazione e uso di Ubuntu come server: web, ftp, mail, news, proxy, dns, ecc.

[Risolto] Spamassassin non si avvia all'avvio del sistema

Messaggioda Sam9999 » venerdì 26 ottobre 2018, 22:45

Noto che se riavvio il pc e chiedo lo stato di spamassassin "service spamassassin status" lo stesso risulta inattivo,

Codice: Seleziona tutto
● spamassassin.service - Perl-based spam filter using text analysis
   Loaded: loaded (/lib/systemd/system/spamassassin.service; disabled; vendor preset: enabled)
   Active: inactive (dead)


se successivamente lo avvio "service spamassassin start" lo stesso poi risulta avviato e funzionante.

Codice: Seleziona tutto
 spamassassin.service - Perl-based spam filter using text analysis
   Loaded: loaded (/lib/systemd/system/spamassassin.service; disabled; vendor preset: enabled)
   Active: active (running) since Fri 2018-10-26 22:31:11 CEST; 12min ago
  Process: 19111 ExecStart=/usr/sbin/spamd -d --pidfile=/var/run/spamd.pid $OPTIONS (code=exited, status=0/SUCCESS)
 Main PID: 19129 (/usr/sbin/spamd)
    Tasks: 3 (limit: 4645)
   CGroup: /system.slice/spamassassin.service
           ├─19129 /usr/sbin/spamd -d --pidfile=/var/run/spamd.pid --create-prefs --max-children 5 --username spamd --helper-home-dir ${SPAMD
           ├─19131 spamd child
           └─19134 spamd child

Oct 26 22:31:07 locale-c systemd[1]: Starting Perl-based spam filter using text analysis...
Oct 26 22:31:11 locale-c systemd[1]: Started Perl-based spam filter using text analysis.


Ho controllato e in configurazione /etc/default/spamassassin il demone risulta abilitato:

Codice: Seleziona tutto
# /etc/default/spamassassin
# Duncan Findlay

# WARNING: please read README.spamd before using.
# There may be security risks.

# If you're using systemd (default for jessie), the ENABLED setting is
# not used. Instead, enable spamd by issuing:
# systemctl enable spamassassin.service
# Change to "1" to enable spamd on systems using sysvinit:
ENABLED=1

# Options
# See man spamd for possible options. The -d option is automatically added.

# SpamAssassin uses a preforking model, so be careful! You need to
# make sure --max-children is not set to anything higher than 5,
# unless you know what you're doing.

# OPTIONS="--create-prefs --max-children 5 --helper-home-dir"
SPAMD_HOME="/home/spamd/"

# OPTIONS="--create-prefs --max-children 5 --username spamd --helper-home-dir ${SAHOME} -s ${SAHOME}spamd.log"
OPTIONS="--create-prefs --max-children 5 --username spamd --helper-home-dir ${SPAMD_HOME} -s ${SPAMD_HOME}spamd.log"

# Pid file
# Where should spamd write its PID to file? If you use the -u or
# --username option above, this needs to be writable by that user.
# Otherwise, the init script will not be able to shut spamd down.
# PIDFILE="/var/run/spamd.pid"
# PIDFILE="${SAHOME}spamd.pid"
PIDFILE="${SPAMD_HOME}spamd.pid"

# Set nice level of spamd
#NICE="--nicelevel 15"

# Cronjob
# Set to anything but 0 to enable the cron job to automatically update
# spamassassin's rules on a nightly basis
CRON=1

# SAHOME="/var/lib/spamassassin/"


Non riesco a capire perché non si avvia con il sistema.

Ho trovato da dover dare il comando "systemctl enable spamassassin.service" ora dopo il riavvio:
Codice: Seleziona tutto
spamassassin.service - Perl-based spam filter using text analysis
   Loaded: loaded (/lib/systemd/system/spamassassin.service; enabled; vendor preset: enabled)
   Active: activating (start) since Fri 2018-10-26 22:57:20 CEST; 22s ago
Cntrl PID: 1345 (/usr/sbin/spamd)
    Tasks: 2 (limit: 3524)
   CGroup: /system.slice/spamassassin.service
           ├─1345 /usr/sbin/spamd -d --pidfile=/var/run/spamd.pid --create-prefs --max-children 5 -
           └─2244 /usr/sbin/spamd -d --pidfile=/var/run/spamd.pid --create-prefs --max-children 5 -

Oct 26 22:57:20 locale-c systemd[1]: Starting Perl-based spam filter using text analysis...


Sembra si sia avviato...

[offtopic]
ma com'è che non arrivo alal soluzione e dopo che scrivo sul forum la trovo? :birra:
[\offtopic]
-------------
S. @-M.
-------------
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1343
Iscrizione: giugno 2014
Località: BO
Desktop: Studio Xfce
Distribuzione: Ubuntu 18.10 (Cosmic Cuttlefish)

Re: [Risolto] Spamassassin non si avvia all'avvio del sistem

Messaggioda Pike » sabato 27 ottobre 2018, 1:27

Perchè per esporre il problema in modo comprensibile lo rianalizzi, lo smonti e metti in ordine i punti. Per poi dire "e se facessi..."
Incivile e maleducato. Come certificato dalla moderazione. You have been warned. Pigroidiorazione. Non fallisce MAI. Specialmente nel considerare offensivi solo certi contenuti.
Se pensi che il tuo tempo sia più importante del mio, significa che non hai bisogno del mio tempo.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3469
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Bionic Beaver i686 (18.04)


Torna a Ubuntu su server

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 5 ospiti