Strano comportamento VSFtp

Installazione, configurazione e uso di Ubuntu come server: web, ftp, mail, news, proxy, dns, ecc.

Strano comportamento VSFtp

Messaggioda spadino_74 » sabato 27 aprile 2019, 12:44

Buongiorno a tutti ho un server che inizialmente aveva ubuntu server 14.04 lts ho fatto l'aggiornamento al 16.04 lts e stranamente vsftp ora funziona in modo anomalo nel senso che appena avviato il servizio mi permette di accedere, caricare e scaricare file e girovagare per le varie cartelle. se pero un secondo utente o lo stesso utente che si è scollegato in precedenza, tenta di collegarsi, resta in attesa del messaggio di benvenuto senza dare piu alcun segnale.
se riavvio vsftp funziona nuovamente per il primo accesso.
lato client ho utilizzato sia un collegamento da terminale linux, terminale dos e anche filezilla, sempre con il medesimo risultato

Ringrazio in anticipo
spadino_74
Prode Principiante
 
Messaggi: 45
Iscrizione: ottobre 2012
Desktop: ubuntu
Distribuzione: ubuntu
Sesso: Maschile

Re: Strano comportamento VSFtp

Messaggioda Stealth » sabato 27 aprile 2019, 13:11

Da come la racconti sembra che si "spenga", ma in teoria dovrebbe lasciar traccia. Hai cercato nei files di log?
ciao
Avatar utente
Stealth
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 16055
Iscrizione: gennaio 2006
Desktop: Gnome
Distribuzione: Ubuntu 18.04 LTS

Re: Strano comportamento VSFtp

Messaggioda spadino_74 » sabato 27 aprile 2019, 14:05

no il servizio è perfettamente in esecuzione... ma dopo il primo accesso nessuno puo piu accedere

queste le ultime righe del log di vsftpd:
Codice: Seleziona tutto
Sat Apr 27 11:15:45 2019 [pid 18619] CONNECT: Client "192.168.0.15"
Sat Apr 27 13:42:03 2019 [pid 14420] CONNECT: Client "192.168.0.202"
Sat Apr 27 13:42:28 2019 [pid 14501] CONNECT: Client "192.168.0.202"
Sat Apr 27 12:21:01 2019 [pid 31089] CONNECT: Client "192.168.0.112"
Sat Apr 27 12:20:36 2019 [pid 31011] CONNECT: Client "192.168.0.112"
Sat Apr 27 14:31:19 2019 [pid 24068] CONNECT: Client "192.168.0.202"
Sat Apr 27 14:31:47 2019 [pid 24157] CONNECT: Client "192.168.0.202"
Sat Apr 27 14:32:00 2019 [pid 24227] CONNECT: Client "192.168.0.202"
Sat Apr 27 14:32:00 2019 [pid 24226] [marco] OK LOGIN: Client "192.168.0.202"
Sat Apr 27 15:00:26 2019 [pid 29683] CONNECT: Client "192.168.0.112"
Sat Apr 27 15:00:28 2019 [pid 29682] [marco] OK LOGIN: Client "192.168.0.112"
Sat Apr 27 15:01:50 2019 [pid 30012] CONNECT: Client "192.168.0.112"
spadino_74
Prode Principiante
 
Messaggi: 45
Iscrizione: ottobre 2012
Desktop: ubuntu
Distribuzione: ubuntu
Sesso: Maschile

Re: Strano comportamento VSFtp

Messaggioda Pike » sabato 27 aprile 2019, 15:17

Hai compreso ogni parametro della configurazione vsftp sta usando?
"Più sono vuote le teste, più sono lunghe le lingue" Bruce Lee.
Come certificato dalla moderazione, incivile e maleducato. You have been warned.
Se pensi che il tuo tempo sia più importante del mio, significa che non hai bisogno del mio tempo.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3636
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Bionic Beaver i686 (18.04)

Re: Strano comportamento VSFtp

Messaggioda spadino_74 » sabato 27 aprile 2019, 15:46

in realta con la versione 14 funzionava, da quando ho fatto l'aggiornamento mi da questo problema
spadino_74
Prode Principiante
 
Messaggi: 45
Iscrizione: ottobre 2012
Desktop: ubuntu
Distribuzione: ubuntu
Sesso: Maschile

Re: Strano comportamento VSFtp

Messaggioda Pike » sabato 27 aprile 2019, 15:48

Lo prendo per un "no, non lo so". Ergo non posso aiutarti
"Più sono vuote le teste, più sono lunghe le lingue" Bruce Lee.
Come certificato dalla moderazione, incivile e maleducato. You have been warned.
Se pensi che il tuo tempo sia più importante del mio, significa che non hai bisogno del mio tempo.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3636
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Bionic Beaver i686 (18.04)

Re: Strano comportamento VSFtp

Messaggioda spadino_74 » sabato 27 aprile 2019, 15:51

si i parametri impostati li ho capiti.... ma voleva essere un ulteriore delucidazione sul fatto che non è una nuova installazione...
spadino_74
Prode Principiante
 
Messaggi: 45
Iscrizione: ottobre 2012
Desktop: ubuntu
Distribuzione: ubuntu
Sesso: Maschile

Re: Strano comportamento VSFtp

Messaggioda Pike » sabato 27 aprile 2019, 16:57

Nei parametri impostati è consentita più di una sessione?
Il firewall è impostato per più di una sessione?
"Più sono vuote le teste, più sono lunghe le lingue" Bruce Lee.
Come certificato dalla moderazione, incivile e maleducato. You have been warned.
Se pensi che il tuo tempo sia più importante del mio, significa che non hai bisogno del mio tempo.
Pike
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3636
Iscrizione: gennaio 2008
Desktop: xubuntu
Distribuzione: Bionic Beaver i686 (18.04)

Re: Strano comportamento VSFtp

Messaggioda spadino_74 » sabato 27 aprile 2019, 18:01

nessuna impostazione sul limite di sessioni e firewall disabilitato
spadino_74
Prode Principiante
 
Messaggi: 45
Iscrizione: ottobre 2012
Desktop: ubuntu
Distribuzione: ubuntu
Sesso: Maschile

Re: Strano comportamento VSFtp

Messaggioda Hosting80 » domenica 28 aprile 2019, 20:01

spadino_74 Immagine ha scritto:nessuna impostazione sul limite di sessioni e firewall disabilitato


ciao.

io credo invece che l'aggiornamento non sia proprio andato a buon fine.

Lo scrivo con molta sicurezza perchè ho avuto un problema simile su un server di un cliente che con grande insistenza per sua convinzione magico-informatico secondo lui era meglio e testuali parole da chi non ci capisce nulla ed e convinto di saperne più di te "non si sa mai può sempre servire" con successiva frase "lo so fare anche io ma non ho tempo".

Questo è successo perchè l'upgrade e avvenuto con diversi errori di fatto SFTP,FTP,MYSQL server in esecuzione ma di fatto in down.

Quello che sta capitando e che stai usando un file di configurazione del server ssh della 14 sulla 16,simili ma diverse!

Puoi risolvere con la rimozione di opnesshserver, una bella pulizia e la reinstallazione, dovrebbe ritornare tutto apposto anche se dubito che sia l'unico servizio che non ti dia noie.

Sarebbe il caso di fare queste prove in una vm prima degli upgrade.
Hosting80
Prode Principiante
 
Messaggi: 69
Iscrizione: agosto 2016
Sesso: Maschile


Torna a Ubuntu su server

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 5 ospiti