Installazione andata storta 19.10

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.

Installazione andata storta 19.10

Messaggioda samfrog » giovedì 7 novembre 2019, 10:32

Buongiorno, ho un piccolo problema: da Ubuntu 19.04 sono passato al 19.10. Tutto ok, direte voi, invece quando vado a caricare il sistema operativo (sono in dual boot con windows) mi da questo errore: "è necessario caricare il kernel prima". Inizialmente non caricava nemmeno windows dandomi questo errore. Dopo aver spento, dato che non potevo fare nulla ho riavviato e almeno windows funzionava. Ora ho ripreso Ubuntu ma non va comunque. Cosa devo fare? Vorrei chiaramente provare a recuperare i dati. Da windows non mi pare di poter accedere alla partizione e ho provato da una chiavetta usando la modalità di prova ma anche lì non funziona. Avete idee?
samfrog
Prode Principiante
 
Messaggi: 18
Iscrizione: marzo 2018
Località: Torino
Desktop: ubuntu
Distribuzione: Ubuntu 19.04 x86_64
Sesso: Maschile

Re: Installazione andata storta 19.10

Messaggioda lollo360 » giovedì 7 novembre 2019, 11:12

ho provato da una chiavetta usando la modalità di prova ma anche lì non funziona


che vuol dire che non funziona? Ti da qualche errore? Dalla modalità live dovresti poter accedere alla tua partizione con Ubuntu e recuperare i dati.
Avatar utente
lollo360
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 593
Iscrizione: dicembre 2008
Località: Perugia
Desktop: Unity
Distribuzione: 18.04

Re: Installazione andata storta 19.10

Messaggioda samfrog » giovedì 7 novembre 2019, 11:15

Era praticamente bloccata. Nessun tasto era cliccabile, ho provato entrando in modalità di prova. Ora sto riprovando a ricreare una chiavetta con la versione 19.10. È probabile che non fosse precisa. Comunque in caso funzionasse potrei ripristinare il sistema come farei con windows?
samfrog
Prode Principiante
 
Messaggi: 18
Iscrizione: marzo 2018
Località: Torino
Desktop: ubuntu
Distribuzione: Ubuntu 19.04 x86_64
Sesso: Maschile

Re: Installazione andata storta 19.10

Messaggioda trekfan1 » giovedì 7 novembre 2019, 12:13

Puoi tentare una riparazione, avvia la LIVE (Prova Ubuntu senza installare) e poi segui la guida del Ripristino del GRUB fino al punto 4 poi dai
Codice: Seleziona tutto
dpkg --configure -a
(due trattini prima di configure) per verificare che non siano rimasti residui da configurare, poi
Codice: Seleziona tutto
apt update && apt dist-upgrade
esci dal chroot e quindi dai
Codice: Seleziona tutto
sudo reboot
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 20073
Iscrizione: maggio 2006
Località: Formigine (MO) | Accecante Asceta
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile

Re: Installazione andata storta 19.10

Messaggioda samfrog » venerdì 8 novembre 2019, 0:26

trekfan1 Immagine ha scritto:Puoi tentare una riparazione, avvia la LIVE (Prova Ubuntu senza installare) e poi segui la guida del Ripristino del GRUB fino al punto 4 poi dai
Codice: Seleziona tutto
dpkg --configure -a
(due trattini prima di configure) per verificare che non siano rimasti residui da configurare, poi
Codice: Seleziona tutto
apt update && apt dist-upgrade
esci dal chroot e quindi dai
Codice: Seleziona tutto
sudo reboot

Ci ho provato ma non ha funzionato. Però almeno ho salvato i file. Quindi rifaccio la chiavetta e lo reinstallo. Oltretutto da adesso Ubuntu ha l'opzione per le schede grafiche che creano problemi come la mai quindi è tutto molto più semplice. E almeno faccio la reinstallazione pulita di cui avevo bisogno per risolvere la sua lentezza all'avvio. Grazie comunque! :D
samfrog
Prode Principiante
 
Messaggi: 18
Iscrizione: marzo 2018
Località: Torino
Desktop: ubuntu
Distribuzione: Ubuntu 19.04 x86_64
Sesso: Maschile

Re: Installazione andata storta 19.10

Messaggioda samfrog » venerdì 8 novembre 2019, 1:29

trekfan1 Immagine ha scritto:Puoi tentare una riparazione, avvia la LIVE (Prova Ubuntu senza installare) e poi segui la guida del Ripristino del GRUB fino al punto 4 poi dai
Codice: Seleziona tutto
dpkg --configure -a
(due trattini prima di configure) per verificare che non siano rimasti residui da configurare, poi
Codice: Seleziona tutto
apt update && apt dist-upgrade
esci dal chroot e quindi dai
Codice: Seleziona tutto
sudo reboot

Continua a non funzionare:
Codice: Seleziona tutto
error: Unknown TMP error.
ripetuto molte volte e infine
Codice: Seleziona tutto
error: you need to load the kernel first

Ho rifatto una installazione pulita o almeno il più possibile, pensavo di esserci riuscito a sistemare la faccenda
samfrog
Prode Principiante
 
Messaggi: 18
Iscrizione: marzo 2018
Località: Torino
Desktop: ubuntu
Distribuzione: Ubuntu 19.04 x86_64
Sesso: Maschile

Re: Installazione andata storta 19.10

Messaggioda caturen » venerdì 8 novembre 2019, 5:48

caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15353
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Installazione andata storta 19.10

Messaggioda frapox » venerdì 8 novembre 2019, 6:36

samfrog ha scritto:
trekfan1 Immagine ha scritto:Puoi tentare una riparazione, avvia la LIVE (Prova Ubuntu senza installare) e poi segui la guida del Ripristino del GRUB fino al punto 4 poi dai
Codice: Seleziona tutto
dpkg --configure -a
(due trattini prima di configure) per verificare che non siano rimasti residui da configurare, poi
Codice: Seleziona tutto
apt update && apt dist-upgrade
esci dal chroot e quindi dai
Codice: Seleziona tutto
sudo reboot

Continua a non funzionare:
Codice: Seleziona tutto
error: Unknown TMP error.
ripetuto molte volte e infine
Codice: Seleziona tutto
error: you need to load the kernel first

Ho rifatto una installazione pulita o almeno il più possibile, pensavo di esserci riuscito a sistemare la faccenda

Vedo che qualcuno ha avuto lo stesso problema tuo col passaggio dalla 19.04 alla 19.10:
https://bugs.launchpad.net/ubuntu/+sour ... ug/1848892

Quindi come prima cosa proverei a disattivare il Secure Boot E il TPM dall'interfaccia dell Uefi.

En passant: di che PC si tratta? Marca e modello, grazie.
Avatar utente
frapox
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 475
Iscrizione: dicembre 2005
Località: Lombardia
Desktop: Gnome 3, Plasma 5
Distribuzione: Arch, Debian, Ubuntu

Re: Installazione andata storta 19.10

Messaggioda samfrog » venerdì 8 novembre 2019, 10:47

frapox Immagine ha scritto:
samfrog ha scritto:
trekfan1 Immagine ha scritto:Puoi tentare una riparazione, avvia la LIVE (Prova Ubuntu senza installare) e poi segui la guida del Ripristino del GRUB fino al punto 4 poi dai
Codice: Seleziona tutto
dpkg --configure -a
(due trattini prima di configure) per verificare che non siano rimasti residui da configurare, poi
Codice: Seleziona tutto
apt update && apt dist-upgrade
esci dal chroot e quindi dai
Codice: Seleziona tutto
sudo reboot

Continua a non funzionare:
Codice: Seleziona tutto
error: Unknown TMP error.
ripetuto molte volte e infine
Codice: Seleziona tutto
error: you need to load the kernel first

Ho rifatto una installazione pulita o almeno il più possibile, pensavo di esserci riuscito a sistemare la faccenda

Vedo che qualcuno ha avuto lo stesso problema tuo col passaggio dalla 19.04 alla 19.10:
https://bugs.launchpad.net/ubuntu/+sour ... ug/1848892

Quindi come prima cosa proverei a disattivare il Secure Boot E il TPM dall'interfaccia dell Uefi.

En passant: di che PC si tratta? Marca e modello, grazie.

È un Asus rog fx553V processore i7 7th gen, ram 8 Gb, 1Tb hdd e scheda video Nvidia gtx 1050.
Ho visto nel link e effettivamente dice che il problema si presenta in Asus e su alcuni dell quindi potrebbe essere quello il caso
samfrog
Prode Principiante
 
Messaggi: 18
Iscrizione: marzo 2018
Località: Torino
Desktop: ubuntu
Distribuzione: Ubuntu 19.04 x86_64
Sesso: Maschile

Re: Installazione andata storta 19.10

Messaggioda samfrog » venerdì 8 novembre 2019, 12:39

samfrog Immagine ha scritto:
frapox Immagine ha scritto:
samfrog ha scritto:
trekfan1 Immagine ha scritto:Puoi tentare una riparazione, avvia la LIVE (Prova Ubuntu senza installare) e poi segui la guida del Ripristino del GRUB fino al punto 4 poi dai
Codice: Seleziona tutto
dpkg --configure -a
(due trattini prima di configure) per verificare che non siano rimasti residui da configurare, poi
Codice: Seleziona tutto
apt update && apt dist-upgrade
esci dal chroot e quindi dai
Codice: Seleziona tutto
sudo reboot

Continua a non funzionare:
Codice: Seleziona tutto
error: Unknown TMP error.
ripetuto molte volte e infine
Codice: Seleziona tutto
error: you need to load the kernel first

Ho rifatto una installazione pulita o almeno il più possibile, pensavo di esserci riuscito a sistemare la faccenda

Vedo che qualcuno ha avuto lo stesso problema tuo col passaggio dalla 19.04 alla 19.10:
https://bugs.launchpad.net/ubuntu/+sour ... ug/1848892

Quindi come prima cosa proverei a disattivare il Secure Boot E il TPM dall'interfaccia dell Uefi.

En passant: di che PC si tratta? Marca e modello, grazie.

È un Asus rog fx553V processore i7 7th gen, ram 8 Gb, 1Tb hdd e scheda video Nvidia gtx 1050.
Ho visto nel link e effettivamente dice che il problema si presenta in Asus e su alcuni dell quindi potrebbe essere quello il caso

Ho tolto il secure boot ma la possibilità di disattivare il tmp dall'interfaccia uefi non l'ho trovata (cosa comune a quanto pare nei pc Asus perché altri utenti non ce l'hanno fatta). Ho comunque provato il boot dato che a qualcuno è bastato disattivare il secure boot. Invece sembrava che ce la facesse e invece niente si è bloccato in un loop nella schermata di caricamento di Ubuntu. Cioè faceva l'animazione dei 4 puntini che cambiano colore sotto il logo ma se premeva un tasto per vedere le operazioni era cicliche e ad un certo punto si è proprio fermato per 5/10 minuti
samfrog
Prode Principiante
 
Messaggi: 18
Iscrizione: marzo 2018
Località: Torino
Desktop: ubuntu
Distribuzione: Ubuntu 19.04 x86_64
Sesso: Maschile

Re: Installazione andata storta 19.10

Messaggioda trekfan1 » venerdì 8 novembre 2019, 16:22

@samfrog:

1) Non fare messaggi consecutivi ma se non ci sono risposte clicca su Modifica e aggiungi il nuovo testo eventualmente preceduto da EDIT

2) Evita di quotare troppo, alla lunga il post diventa chilometrico, grazie
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 20073
Iscrizione: maggio 2006
Località: Formigine (MO) | Accecante Asceta
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile

Re: Installazione andata storta 19.10

Messaggioda willy54 » venerdì 8 novembre 2019, 16:28

Dalla live, se non si avvia l'installato, vedi se la 2a casella nella App Sostware e aggiornamenti è spuntata
Nel terminale :
Codice: Seleziona tutto
sudo apt install inxi
inxi -Fz
efibootmgr -v

posta i 2 ultimi comandi.
Ultima modifica di willy54 il mercoledì 13 novembre 2019, 13:13, modificato 1 volta in totale.
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio (provvisorio)
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10
Avatar utente
willy54
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3946
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Installazione andata storta 19.10

Messaggioda frapox » venerdì 8 novembre 2019, 17:18

samfrog Immagine ha scritto:Ho tolto il secure boot ma la possibilità di disattivare il tmp dall'interfaccia uefi non l'ho trovata (cosa comune a quanto pare nei pc Asus perché altri utenti non ce l'hanno fatta). Ho comunque provato il boot dato che a qualcuno è bastato disattivare il secure boot. Invece sembrava che ce la facesse e invece niente si è bloccato in un loop nella schermata di caricamento di Ubuntu. Cioè faceva l'animazione dei 4 puntini che cambiano colore sotto il logo ma se premeva un tasto per vedere le operazioni era cicliche e ad un certo punto si è proprio fermato per 5/10 minuti

Quando si incanta sulla schermata animata dei pallini, premi ESC, riesci a vedere su quale messaggio si incanta e a farci una foto così che lo vediamo anche noi?
Avatar utente
frapox
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 475
Iscrizione: dicembre 2005
Località: Lombardia
Desktop: Gnome 3, Plasma 5
Distribuzione: Arch, Debian, Ubuntu

Re: Installazione andata storta 19.10

Messaggioda samfrog » lunedì 11 novembre 2019, 14:52

Stasera se riesco mi metto a provare, intanto grazie! :)
samfrog
Prode Principiante
 
Messaggi: 18
Iscrizione: marzo 2018
Località: Torino
Desktop: ubuntu
Distribuzione: Ubuntu 19.04 x86_64
Sesso: Maschile

Re: Installazione andata storta 19.10

Messaggioda noel80 » mercoledì 13 novembre 2019, 12:34

Leggevo che per quel Laptop ci sian problemi che riguardano la scheda grafica, una soluzione sarebbe di aggiungere
Codice: Seleziona tutto
nouveau.modeset=0

sulla linea
Codice: Seleziona tutto
GRUB_CMDLINE_LINUX_DEFAULT

e riaggiornando il grub (ma cosi' utilizzera solo i driver Intel).

O puoi avviare Ubuntu e quando appare la schermata del grub/bootloader schiacci il tasto "e", e cambiare la linea
Codice: Seleziona tutto
nomodeset
con
Codice: Seleziona tutto
nouveau.modeset=0
Premi F10.
Installando correttamente i driver Nvidia dovrebbe funzionare comunque... ( https://askubuntu.com/questions/747314/ ... 429#747429 )
Avatar utente
noel80
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1037
Iscrizione: settembre 2014
Località: Rest of the World
Desktop: i3 , plasma
Distribuzione: Arch

Re: Installazione andata storta 19.10

Messaggioda samfrog » domenica 17 novembre 2019, 23:03

Sì la scheda grafica è una croce. Alla fine ho mollato l'idea di mettere la 19.10 e ho messo la 18.04 lts, perché oggettivamente ho bisogno di un sistema linux per l'università, quindi una versione più stabile lts penso sia più sicura. Per la scheda grafica avevo già risolto usando i driver giusti e disattivandola, per cui ho ripetuto l'operazione e ho risolto il problema :) Grazie a tutti della disponibilità!
samfrog
Prode Principiante
 
Messaggi: 18
Iscrizione: marzo 2018
Località: Torino
Desktop: ubuntu
Distribuzione: Ubuntu 19.04 x86_64
Sesso: Maschile

Re: Installazione andata storta 19.10

Messaggioda frapox » domenica 17 novembre 2019, 23:33

samfrog Immagine ha scritto:Sì la scheda grafica è una croce. Alla fine ho mollato l'idea di mettere la 19.10 e ho messo la 18.04 lts, perché oggettivamente ho bisogno di un sistema linux per l'università, quindi una versione più stabile lts penso sia più sicura. Per la scheda grafica avevo già risolto usando i driver giusti e disattivandola, per cui ho ripetuto l'operazione e ho risolto il problema :) Grazie a tutti della disponibilità!

Bene così! ;)

Ricordati di aggiungere [Risolto] al primo post, all'inizio del titolo.
Avatar utente
frapox
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 475
Iscrizione: dicembre 2005
Località: Lombardia
Desktop: Gnome 3, Plasma 5
Distribuzione: Arch, Debian, Ubuntu


Torna a Installazione e aggiornamento del sistema operativo

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 10 ospiti