[Risolto] Testando Live 20.04 wifi spento

Riconoscimento, installazione e configurazione delle periferiche.
Scrivi risposta
Avatar utente
clango
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1083
Iscrizione: martedì 23 dicembre 2008, 20:38
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04.3 LTS
Sesso: Maschile
Località: Milano

[Risolto] Testando Live 20.04 wifi spento

Messaggio da clango »

Ciao,

sto testando la live per una installazione su un Dell. La connessione di rete via cavo funziona correttamente, ma il wifi mi dice che è spento.
Ciò potrebbe essere un problema se installo solo Ubuntu con questa scheda di rete?

edit: il sistema mi chiede di accenderlo, ma in realtà non riesco.
Ultima modifica di clango il giovedì 23 settembre 2021, 8:15, modificato 1 volta in totale.
caturen
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 16814
Iscrizione: giovedì 8 aprile 2010, 18:41
Desktop: diversi
Distribuzione: debian

Re: Testando Live 20.04 wifi spento

Messaggio da caturen »

No, non è un gran problema. Il fatto è che una volta installato dovrai sistemare il wifi altrimenti non lo potrai usare.
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 22464
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 21.10 x64
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Testando Live 20.04 wifi spento

Messaggio da trekfan1 »

@clango Sei iscritto dal 2008 dovresti sapere che se non posti le caratteristiche del pc è difficile (se non impossibile) aiutare, sposto in Driver
Avatar utente
clango
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1083
Iscrizione: martedì 23 dicembre 2008, 20:38
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04.3 LTS
Sesso: Maschile
Località: Milano

Re: Testando Live 20.04 wifi spento

Messaggio da clango »

Preciso che il PC è un

Codice: Seleziona tutto

Dell E7270 
Processore Intel Core i5 - 6300 CPU@2.4 Ghz
Ram installata 8 Gb (7,67 utilizzabile)
Scheda di rete 
Intel Dual Band Wireless Gigabit
Intel Dual Band Wireless-AC 8260
La cosa strana è anche che il collegamento via cavo con la rete Ethernet funziona correttamente. Ubuntu Live richiede di accendere il Wi-fi che risulta spento, ma premendo da live "Accendi Wi-fi" non accade nulla
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 23364
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: Testando Live 20.04 wifi spento

Messaggio da magozurlinux »

Ciao.

Da terminale postami questi comandi:

Codice: Seleziona tutto

lspci -nnk | grep -A5 -i net

Codice: Seleziona tutto

rfkill list

Codice: Seleziona tutto

nmcli radio

Codice: Seleziona tutto

sudo lshw -C network

Codice: Seleziona tutto

dmesg | grep iwl
Xubuntu 20.04 LTS amd64 :ciao:
Avatar utente
clango
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1083
Iscrizione: martedì 23 dicembre 2008, 20:38
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04.3 LTS
Sesso: Maschile
Località: Milano

Re: Testando Live 20.04 wifi spento

Messaggio da clango »

grazie. ecco i risultati:

Codice: Seleziona tutto

ubuntu@ubuntu:~$ lspci -nnk | grep -A5 -i net
00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection I219-LM [8086:156f] (rev 21)
	Subsystem: Dell Ethernet Connection I219-LM [1028:06db]
	Kernel driver in use: e1000e
	Kernel modules: e1000e
01:00.0 Network controller [0280]: Intel Corporation Wireless 8260 [8086:24f3] (rev 3a)
	Subsystem: Intel Corporation Wireless 8260 [8086:0850]
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
02:00.0 Network controller [0280]: Intel Corporation Device [8086:093c] (rev 3a)
	Subsystem: Intel Corporation Device [8086:2181]
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader [10ec:525a] (rev 01)
	Subsystem: Dell RTS525A PCI Express Card Reader [1028:06db]
	Kernel driver in use: rtsx_pci
	Kernel modules: rtsx_pci

Codice: Seleziona tutto

ubuntu@ubuntu:~$ rfkill list
0: dell-wifi: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
1: dell-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: yes
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Codice: Seleziona tutto

ubuntu@ubuntu:~$ nmcli radio
WIFI-HW    WIFI          WWAN-HW    WWAN      
abilitato  disabilitato  abilitato  abilitato 

Codice: Seleziona tutto

ubuntu@ubuntu:~$ sudo lshw -C network
  *-network DISABLED        
       description: Wireless interface
       product: Wireless 8260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wlp1s0
       version: 3a
       serial: b8:08:cf:58:6a:52
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.8.0-43-generic firmware=36.77d01142.0 8000C-36.ucode latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:131 memory:e1200000-e1201fff
  *-network UNCLAIMED
       description: Network controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 3a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:e1100000-e1101fff
  *-network
       description: Ethernet interface
       product: Ethernet Connection I219-LM
       vendor: Intel Corporation
       physical id: 1f.6
       bus info: pci@0000:00:1f.6
       logical name: enp0s31f6
       version: 21
       serial: d4:81:d7:80:2e:8d
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=0.13-3 ip=192.168.1.232 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:128 memory:e1300000-e131ffff

Codice: Seleziona tutto

ubuntu@ubuntu:~$ dmesg | grep iwl
[  245.703204] iwlwifi 0000:01:00.0: Found debug destination: EXTERNAL_DRAM
[  245.703207] iwlwifi 0000:01:00.0: Found debug configuration: 0
[  245.703754] iwlwifi 0000:01:00.0: loaded firmware version 36.77d01142.0 8000C-36.ucode op_mode iwlmvm
[  245.704083] iwlwifi 0000:01:00.0: Direct firmware load for iwl-debug-yoyo.bin failed with error -2
[  245.980211] iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 8260, REV=0x208
[  245.989264] iwlwifi 0000:01:00.0: Applying debug destination EXTERNAL_DRAM
[  245.989739] iwlwifi 0000:01:00.0: Allocated 0x00400000 bytes for firmware monitor.
[  246.060522] iwlwifi 0000:01:00.0: base HW address: b8:08:cf:58:6a:52
[  246.135021] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[  246.229802] iwlwifi 0000:01:00.0 wlp1s0: renamed from wlan0
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 23364
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: Testando Live 20.04 wifi spento

Messaggio da magozurlinux »

clango ha scritto:
martedì 21 settembre 2021, 20:59
grazie. ecco i risultati:

ubuntu@ubuntu:~$ rfkill list
0: dell-wifi: Wireless LAN
Soft blocked: no
Hard blocked: yes
1: dell-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: yes
2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
[/code]

ubuntu@ubuntu:~$ nmcli radio
WIFI-HW WIFI WWAN-HW WWAN
abilitato disabilitato abilitato abilitato

ubuntu@ubuntu:~$ dmesg | grep iwl
[ 245.703204] iwlwifi 0000:01:00.0: Found debug destination: EXTERNAL_DRAM
[ 245.703207] iwlwifi 0000:01:00.0: Found debug configuration: 0
[ 245.703754] iwlwifi 0000:01:00.0: loaded firmware version 36.77d01142.0 8000C-36.ucode op_mode iwlmvm
[ 245.704083] iwlwifi 0000:01:00.0: Direct firmware load for iwl-debug-yoyo.bin failed with error -2
[ 245.980211] iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 8260, REV=0x208
[ 245.989264] iwlwifi 0000:01:00.0: Applying debug destination EXTERNAL_DRAM
[ 245.989739] iwlwifi 0000:01:00.0: Allocated 0x00400000 bytes for firmware monitor.
[ 246.060522] iwlwifi 0000:01:00.0: base HW address: b8:08:cf:58:6a:52
[ 246.135021] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[ 246.229802] iwlwifi 0000:01:00.0 wlp1s0: renamed from wlan0
Ciao.

Non trova il firmware: iwl-debug-yoyo.bin.

Da terminale dai questi comandi:

Codice: Seleziona tutto

sudo rfkill unblock all

Codice: Seleziona tutto

sudo nmcli radio wifi on

Codice: Seleziona tutto

sudo modprobe -rv iwlwifi

Codice: Seleziona tutto

sudo modprobe -v iwlwifi
questo va dato una volta sola:

Codice: Seleziona tutto

echo options iwlwifi enable_ini=N | sudo tee /etc/modprobe.d/iwl-wifi.conf
riavvia il pc.
Xubuntu 20.04 LTS amd64 :ciao:
Avatar utente
clango
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1083
Iscrizione: martedì 23 dicembre 2008, 20:38
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04.3 LTS
Sesso: Maschile
Località: Milano

Re: Testando Live 20.04 wifi spento

Messaggio da clango »

Perciò prima procedo alla installazione di Ubuntu e poi applico i tuoi suggerimenti per risolvere i problemi del wifi?
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 23364
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: Testando Live 20.04 wifi spento

Messaggio da magozurlinux »

clango ha scritto:
mercoledì 22 settembre 2021, 11:54
Perciò prima procedo alla installazione di Ubuntu e poi applico i tuoi suggerimenti per risolvere i problemi del wifi?
E' possibile che dopo l'installazione del sistema il wifi si riattivi tornando funzionante, se non dovesse essere così, procedi con quei comandi.
Xubuntu 20.04 LTS amd64 :ciao:
Avatar utente
clango
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1083
Iscrizione: martedì 23 dicembre 2008, 20:38
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04.3 LTS
Sesso: Maschile
Località: Milano

Re: Testando Live 20.04 wifi spento

Messaggio da clango »

magozurlinux ha scritto:
mercoledì 22 settembre 2021, 12:51
E' possibile che dopo l'installazione del sistema il wifi si riattivi tornando funzionante, se non dovesse essere così, procedi con quei comandi.
Ho installato e poi aggiornato i software, ma dopo il riavvio non funzionava ancora.
Perciò ho inserito i comandi da terminale nella sequenza ma il wi-fi non funziona ancora. Sono ancora nella situazione in cui non riesco ad accenderlo.
Ti posto perciò la situazione attuale:

Codice: Seleziona tutto

laudio@claudio-Latitude-E7270:~$ lspci -nnk | grep -A5 -i net
00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection I219-LM [8086:156f] (rev 21)
	Subsystem: Dell Ethernet Connection I219-LM [1028:06db]
	Kernel driver in use: e1000e
	Kernel modules: e1000e
01:00.0 Network controller [0280]: Intel Corporation Wireless 8260 [8086:24f3] (rev 3a)
	Subsystem: Intel Corporation Wireless 8260 [8086:0850]
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
02:00.0 Network controller [0280]: Intel Corporation Device [8086:093c] (rev 3a)
	Subsystem: Intel Corporation Device [8086:2181]
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader [10ec:525a] (rev 01)
	Subsystem: Dell RTS525A PCI Express Card Reader [1028:06db]
	Kernel driver in use: rtsx_pci
	Kernel modules: rtsx_pci

Codice: Seleziona tutto

laudio@claudio-Latitude-E7270:~$ rfkill list
0: dell-wifi: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
1: dell-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: yes
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Codice: Seleziona tutto

claudio@claudio-Latitude-E7270:~$ nmcli radio
WIFI-HW    WIFI          WWAN-HW    WWAN      
abilitato  [b]disabilitato[/b]  abilitato  abilitato 

Codice: Seleziona tutto

claudio@claudio-Latitude-E7270:~$ sudo lshw -C network
[sudo] password di claudio: 
  *-network DISABLED        
       description: Wireless interface
       product: Wireless 8260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wlp1s0
       version: 3a
       serial: b8:08:cf:58:6a:52
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.11.0-36-generic firmware=36.77d01142.0 8000C-36.ucode latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:130 memory:e1200000-e1201fff
  *-network UNCLAIMED
       description: Network controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 3a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:e1100000-e1101fff
  *-network
       description: Ethernet interface
       product: Ethernet Connection I219-LM
       vendor: Intel Corporation
       physical id: 1f.6
       bus info: pci@0000:00:1f.6
       logical name: enp0s31f6
       version: 21
       serial: d4:81:d7:80:2e:8d
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=5.11.0-36-generic duplex=full firmware=0.13-3 ip=192.168.1.232 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:128 memory:e1300000-e131ffff

Codice: Seleziona tutto

claudio@claudio-Latitude-E7270:~$ dmesg | grep iwl
[    3.518979] iwlwifi 0000:01:00.0: Found debug destination: EXTERNAL_DRAM
[    3.518985] iwlwifi 0000:01:00.0: Found debug configuration: 0
[    3.519634] iwlwifi 0000:01:00.0: loaded firmware version 36.77d01142.0 8000C-36.ucode op_mode iwlmvm
[    3.628753] iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 8260, REV=0x204
[    3.636381] iwlwifi 0000:01:00.0: Applying debug destination EXTERNAL_DRAM
[    3.636836] iwlwifi 0000:01:00.0: Allocated 0x00400000 bytes for firmware monitor.
[    3.744536] iwlwifi 0000:01:00.0: base HW address: b8:08:cf:58:6a:52
[    3.821997] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    3.869333] iwlwifi 0000:01:00.0 wlp1s0: renamed from wlan0
Avatar utente
woddy68
Rampante Reduce
Rampante Reduce
Messaggi: 6939
Iscrizione: sabato 12 febbraio 2011, 14:23
Desktop: Kde Plasma5
Distribuzione: openSUSE Leap-Tumbleweed-Kubuntu 20
Sesso: Maschile

Re: Testando Live 20.04 wifi spento

Messaggio da woddy68 »

Permessa, non sono un genio del wifi...tuttavia questo
Hard blocked: yes
significa che il tuo wifi è spento via hardware, dovresti avere da qualche parte un tasto per attivarlo, il mio sul portatile è Fn+F3 ma dipende dal pc.
Desktop - Acer Aspire M5500 (AMD) - Notebook Acer Aspire E1 -522 (Amd)
-Ho sempre accettato caramelle dagli sconosciuti-
Ecco cosa succede quando...https://www.youtube.com/watch?v=iigtsYY ... ni7HzinVf8
Avatar utente
clango
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1083
Iscrizione: martedì 23 dicembre 2008, 20:38
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04.3 LTS
Sesso: Maschile
Località: Milano

Re: Testando Live 20.04 wifi spento

Messaggio da clango »

woddy68 ha scritto:
mercoledì 22 settembre 2021, 23:23
Permessa, non sono un genio del wifi...tuttavia questo
Hard blocked: yes
significa che il tuo wifi è spento via hardware, dovresti avere da qualche parte un tasto per attivarlo, il mio sul portatile è Fn+F3 ma dipende dal pc.
Ed infatti avevi ragione. Nel mio caso il tasto è Fn+F6! :birra: :birra: :birra:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 23364
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: Testando Live 20.04 wifi spento

Messaggio da magozurlinux »

clango ha scritto:
giovedì 23 settembre 2021, 8:13
woddy68 ha scritto:
mercoledì 22 settembre 2021, 23:23
Permessa, non sono un genio del wifi...tuttavia questo
Hard blocked: yes
significa che il tuo wifi è spento via hardware, dovresti avere da qualche parte un tasto per attivarlo, il mio sul portatile è Fn+F3 ma dipende dal pc.
Ed infatti avevi ragione. Nel mio caso il tasto è Fn+F6! :birra: :birra: :birra:
Perfetto! :birra:

Non capissco come mai il comando:

Codice: Seleziona tutto

sudo nmcli radio wifi on
non abbia attivato il wifi senza premere i tasti FN+F6 o F3.
Xubuntu 20.04 LTS amd64 :ciao:
Pike
Rampante Reduce
Rampante Reduce
Messaggi: 5460
Iscrizione: domenica 20 gennaio 2008, 1:13
Desktop: Kubuntu
Distribuzione: 20.04 x64
Contatti:

Re: [Risolto] Testando Live 20.04 wifi spento

Messaggio da Pike »

Nella mia piccola esperienza, non tutti i softbutton per Wireless e BT si comportano allo stesso modo.
Infatti era la sezione "hard blocked" ad essere attiva, ed era attiva per entrambi gli aggeggi.
Sono colui che fa cose che non servono...
Secondo Principio di Dilbert, di Scott Adams. "Si parte dalla certezza che siamo tutti idioti". Ed alcuni su questo mi ab-battono alla grande.
Come certificato dalla moderazione, incivile e maleducato. You have been warned.
Avatar utente
clango
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1083
Iscrizione: martedì 23 dicembre 2008, 20:38
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04.3 LTS
Sesso: Maschile
Località: Milano

Re: Testando Live 20.04 wifi spento

Messaggio da clango »

magozurlinux ha scritto:
giovedì 23 settembre 2021, 9:46
[
Non capissco come mai il comando:

Codice: Seleziona tutto

sudo nmcli radio wifi on
non abbia attivato il wifi senza premere i tasti FN+F6 o F3.
perchè l'ho copiato male io! :cry:

Codice: Seleziona tutto

claudio@claudio-Latitude-E7270:~$ nmcli radio

Grazie a tutti! Questa comunità di Ubuntu è davvero sempre straordinaria! :birra: :birra:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
Messaggi: 23364
Iscrizione: mercoledì 17 marzo 2010, 17:44
Desktop: Xubuntu
Distribuzione: Ubuntu 20.04 LTS x86_64
Località: Pisa

Re: [Risolto] Testando Live 20.04 wifi spento

Messaggio da magozurlinux »

Pike ha scritto:
giovedì 23 settembre 2021, 10:52
Nella mia piccola esperienza, non tutti i softbutton per Wireless e BT si comportano allo stesso modo.
Infatti era la sezione "hard blocked" ad essere attiva, ed era attiva per entrambi gli aggeggi.
Ciao.

Grazie Pike :birra:

________________________________________________
clango ha scritto:
giovedì 23 settembre 2021, 11:10
magozurlinux ha scritto:
giovedì 23 settembre 2021, 9:46
[
Non capissco come mai il comando:

Codice: Seleziona tutto

sudo nmcli radio wifi on
non abbia attivato il wifi senza premere i tasti FN+F6 o F3.
perchè l'ho copiato male io! :cry:

Codice: Seleziona tutto

claudio@claudio-Latitude-E7270:~$ nmcli radio

Grazie a tutti! Questa comunità di Ubuntu è davvero sempre straordinaria! :birra: :birra:
Va bene, importante che hai risolto.

:birra:
Xubuntu 20.04 LTS amd64 :ciao:
Scrivi risposta

Ritorna a “Driver e periferiche”

Chi c’è in linea

Visualizzano questa sezione: il24 e 11 ospiti