windows + kubuntu

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.
Scrivi risposta
mondom
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 297
Iscrizione: martedì 17 aprile 2007, 20:05

windows + kubuntu

Messaggio da mondom »

Salve a tutti
ho aggiornato (finalmente) il pc : ryzen7700x+32bg ram +1tb nvme + rx6700.
Ho installato windows 10 e volevo affiancargli kubuntu (già provato in live, col vecchio pc mi dava glitch grafici).
Ho selezionato la partizione manuale, creato una swap di 2Gb e una root di 250Gb, ma al riavvio non mi compare grub con le opzioni di lancio, ma parte windows in automatico. Sul precedente pc ho sempre utilizzato lo stesso sistema con Xubuntu e ubuntu e grub veniva installato automaticamente.
Credo che il problema abbia a che fare con la partizione EFI (della quale ammetto parecchia ignoranza), anche perchè al momento dell'installazione kubuntu mi avvertiva della mancanca di tale partizione.
cosa devo fare?
vi ringrazio anticipatamente
caturen
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 18073
Iscrizione: giovedì 8 aprile 2010, 18:41
Desktop: diversi
Distribuzione: debian

Re: windows + kubuntu

Messaggio da caturen »

dalla live posta una schermata di partition-manager ( o GPARTED) del tuo sistema
mondom
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 297
Iscrizione: martedì 17 aprile 2007, 20:05

Re: windows + kubuntu

Messaggio da mondom »

ecco lo screenshot
Allegati
Screenshot_20240613_132902.png
caturen
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 18073
Iscrizione: giovedì 8 aprile 2010, 18:41
Desktop: diversi
Distribuzione: debian

Re: windows + kubuntu

Messaggio da caturen »

la partizione uefi c'è quindi devi aver sbagliato a posizionare il grub
https://wiki.ubuntu-it.org/Amministrazi ... stino/Uefi
altrimenti senza fare niente dovrebbe bastare all'accensione del pc far partire l'uefi e tra le varie opzioni impostare quale sistema far partire all'avvio
mondom
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 297
Iscrizione: martedì 17 aprile 2007, 20:05

Re: windows + kubuntu

Messaggio da mondom »

Durante l'installazione non mi è stato chiesto di installare gruub da nessuna parte.
Come ti ho già detto ho solo preparato una partizione swap e una per il sistema operativo.
È chiaro che mi manca un passaggio, ma non so quale dato che come ti ho detto nelle precedenti installazioni mi bastavano questi passaggi per avere un gruub installato automaticamente.
Se mi dici come installare gruub o come farlo vedere in fase di avvio che non sarei grato
Ultima modifica di mondom il giovedì 13 giugno 2024, 15:57, modificato 1 volta in totale.
korda
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1823
Iscrizione: giovedì 24 dicembre 2020, 15:58

Re: windows + kubuntu

Messaggio da korda »

Per caso su Windows10 era già attivo BitLocker quando hai installato Kubuntu?
Io non sono Bagheera né Akela, io non frequento la Rupe.
Io sono Kaa: faccio ballare le scimmie alle Tane Fredde.
mondom
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 297
Iscrizione: martedì 17 aprile 2007, 20:05

Re: windows + kubuntu

Messaggio da mondom »

no, dopo una verifica su windows biltlocker risulta disattivato
caturen
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 18073
Iscrizione: giovedì 8 aprile 2010, 18:41
Desktop: diversi
Distribuzione: debian

Re: windows + kubuntu

Messaggio da caturen »

mondom ha scritto:
giovedì 13 giugno 2024, 15:56
Durante l'installazione non mi è stato chiesto di installare gruub da nessuna parte.
Come ti ho già detto ho solo preparato una partizione swap e una per il sistema operativo.
È chiaro che mi manca un passaggio, ma non so quale dato che come ti ho detto nelle precedenti installazioni mi bastavano questi passaggi per avere un gruub installato automaticamente.
Se mi dici come installare gruub o come farlo vedere in fase di avvio che non sarei grato
ma non leggi quello che scrivo?
mondom
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 297
Iscrizione: martedì 17 aprile 2007, 20:05

Re: windows + kubuntu

Messaggio da mondom »

si, ho letto, ma come ti ho detto io durante l'installazione non ho posizionato grub da nessuna parte.
E' quello che cercavo di capire come fare.
Da quello che ho capito devo posizionarlo all'interno della partizione fat32 creata in precedenza da windows, ma non l'ho mai fatto attraverso l'installer di kubuntu (o ubuntu ecc).
Avatar utente
woddy68
Rampante Reduce
Rampante Reduce
Messaggi: 8823
Iscrizione: sabato 12 febbraio 2011, 14:23
Desktop: Kde Plasma 6
Distribuzione: openSUSE Tumbleweed - KDE Neon
Sesso: Maschile

Re: windows + kubuntu

Messaggio da woddy68 »

Da quello che ho capito hai fatto il partizionamento manuale, nei sistemi uefi l'unica cosa che devi fare per il grub, è selezionare la partizione uefi e dargli il flag di montaggio, ad es. in pratica sulla partizione efi imposti / e il suo flag pre-impostato efi-boot.
Desktop - DELL Optiplex 7010 - Notebook HP 250
-Ho sempre accettato caramelle dagli sconosciuti-
mondom
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 297
Iscrizione: martedì 17 aprile 2007, 20:05

Re: windows + kubuntu

Messaggio da mondom »

intanto mi scuso per non aver specificato di aver proceduto con il partizionamento manuale.
ho fatto ripartire l'installer ed ho selezionato la partizione fat32 efi da 100MB con il tasto modifica.
A questo punto mi esce la finestra della foto 1 e 2 ma non vorrei fare danni.
Cosa devo mettere nel punto di mount e flag? (etichetta lascio in bianco?)
ringrazio per l'immensa pazienza
Allegati
resized_1.jpg
resized_2.jpg
caturen
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 18073
Iscrizione: giovedì 8 aprile 2010, 18:41
Desktop: diversi
Distribuzione: debian

Re: windows + kubuntu

Messaggio da caturen »

mondom ha scritto:
venerdì 14 giugno 2024, 7:52
si, ho letto, ma come ti ho detto io durante l'installazione non ho posizionato grub da nessuna parte.
E' quello che cercavo di capire come fare.
Da quello che ho capito devo posizionarlo all'interno della partizione fat32 creata in precedenza da windows, ma non l'ho mai fatto attraverso l'installer di kubuntu (o ubuntu ecc).
nel link c'era il modo di settare UEFI per sistemare la cosa oppure far partire uefi e da li selezionare il sistema da far partire. tu invece fai come ti pare . Che serve rifar partire l'installer di ubuntu? Vuol dire che passo la mano ad altri.
mondom
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 297
Iscrizione: martedì 17 aprile 2007, 20:05

Re: windows + kubuntu

Messaggio da mondom »

Allora premetto che ho estratto fisicamente il disco Nvme per evitare di fare danni.
Ho inserito un vecchio SSD da 120 GB e installato windows 10.
Ho seguito esattamente tutte le indicazioni del link che mi hai dato per ricostruire grub, ma il risultato è che parte solo Windows.
Ho anche scaricato una iso di Ubuntu, e in questa l' installer mi metteva in automatico il boot/efi nel windows boot manager fat32.
Anche in questo caso non mi compare il menu di grub ma parte solo Windows.
far partire uefi e da li selezionare il sistema da far partire.
questo sinceramente non sono riuscito a capirlo dal link che mi hai mandato. Mi spiace di averti sfiancato.
Se ci fosse qualcun altro che ha avuto lo stesso problema che magari ha risolto, accetto qualunque suggerimento tanto a questo punto è un disco di prova.
Grazie a tutti
caturen
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 18073
Iscrizione: giovedì 8 aprile 2010, 18:41
Desktop: diversi
Distribuzione: debian

Re: windows + kubuntu

Messaggio da caturen »

mondom
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 297
Iscrizione: martedì 17 aprile 2007, 20:05

Re: windows + kubuntu

Messaggio da mondom »

Un aggiornamento sulla situazione. Questa notte preso dal furore informatico ho provato a scaricare la ISO di Ubuntu ed installarla. L'installer è completamente diverso, io ho proceduto con l'installazione manuale creando la partizione di root e swap. Ho notato che per il boot loader chiede soltanto in quale disco deve essere installato. E infatti il tutto parte perfettamente con il buon grub che in fase di avvio mi chiede quale sistema voglio avviare. A questo punto non c'è dubbio che il problema risiede nel posizionamento del boot loader. Nel frattempo ho installato Ubuntu anche sul disco originale, ma perché nessuno dica che mi sono arreso ho lasciato 300 GB di spazio per un eventuale terza distribuzione di kubuntu... se mai riuscissi a venire a capo di questa problematica😁😁
Ringrazio comunque tutti quelli che mi hanno aiutato
korda
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1823
Iscrizione: giovedì 24 dicembre 2020, 15:58

Re: windows + kubuntu

Messaggio da korda »

mondom ha scritto:
domenica 16 giugno 2024, 8:29
Ho notato che per il boot loader chiede soltanto in quale disco deve essere installato.
Curioso... questa opzione c'è di sicuro almeno su Kubuntu 22.04 LTS. Scoprirò questa novità mancante sulla prossima LTS, se questo autunno non riuscissi a fare l'upgrade di release alla LTS successiva.
Io non sono Bagheera né Akela, io non frequento la Rupe.
Io sono Kaa: faccio ballare le scimmie alle Tane Fredde.
Scrivi risposta

Ritorna a “Installazione e aggiornamento del sistema operativo”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 4 ospiti