[RISOLTO] Aggiornamento non riuscito

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.
areudi
Prode Principiante
Messaggi: 4
Iscrizione: sabato 24 marzo 2012, 20:51

[RISOLTO] Aggiornamento non riuscito

Messaggio da areudi »

Salve a tutti,
sono nuovo del forum ed ho un problema con l'aggiornamento di Ubuntu 11.10.
Qualche giorno fa ho provato ad installare il gioco "Alien Arena"; purtroppo dopo averlo scaricato tramite "Software center" l'installazione si è bloccata e non è andata avanti.
Oggi ho provato a fare l'aggiornamento di Ubuntu, ma ho riscontrato il seguente errore:

" I seguenti pacchetti presentano dipendenze non soddisfatte:

alien-arena: Depends: libgcc1 (>= 1:4.1.1) ma 1:4.6.1-9ubuntu3 è installato
            Depends: alien-arena-data ma non è installato
"

Ho provato da terminale con il comando "sudo apt-get install -f", ma anche qui ho riscontrato un errore:


"Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti saranno inoltre installati:
 alien-arena-data
I seguenti pacchetti NUOVI saranno installati:
 alien-arena-data
0 aggiornati, 1 installati, 0 da rimuovere e 16 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 0 B/382 MB di archivi.
Dopo quest'operazione, verranno occupati 847 MB di spazio su disco.
Continuare [S/n]? s
(Lettura del database... 161669 file e directory attualmente installati.)
Estrazione di alien-arena-data (da .../alien-arena-data_7.51-2_all.deb)...
dpkg-deb (sottoprocesso): dati: errore interno di lettura di gzip: ": data error"
dpkg-deb: errore: il sottoprocesso ha restituito lo stato di errore 2
dpkg: errore nell'elaborare /var/cache/apt/archives/alien-arena-data_7.51-2_all.deb (--unpack):
il sottoprocesso dpkg-deb --fsys-tarfile ha restituito lo stato di errore 2
Si sono verificati degli errori nell'elaborazione:
/var/cache/apt/archives/alien-arena-data_7.51-2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Cosa posso fare?
Grazie, Armando.
Ultima modifica di areudi il domenica 25 marzo 2012, 17:09, modificato 1 volta in totale.
^alessio^
Rampante Reduce
Rampante Reduce
Messaggi: 5384
Iscrizione: giovedì 15 maggio 2008, 22:00
Sesso: Maschile
Località: como

Re: Aggiornamento non riuscito

Messaggio da ^alessio^ »

Ciao,dai nel terminale

Codice: Seleziona tutto

sudo apt-get clean
e dopo posta

Codice: Seleziona tutto

sudo apt-get update && sudo apt-get upgrade
 
areudi
Prode Principiante
Messaggi: 4
Iscrizione: sabato 24 marzo 2012, 20:51

Re: Aggiornamento non riuscito

Messaggio da areudi »

Ciao, grazie mille per la veloce risposta.
Ho provato a fare ciò che mi hai suggerito, ma dopo il comando "apt-get upgrade" ho avuto questa risposta:

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze     
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
alien-arena : Dipende: alien-arena-data ma non è installato
E: Dipendenze non trovate. Riprovare usando -f.


Provo il comando "apt-get -f install" come mi suggerisce ?
^alessio^
Rampante Reduce
Rampante Reduce
Messaggi: 5384
Iscrizione: giovedì 15 maggio 2008, 22:00
Sesso: Maschile
Località: como

Re: Aggiornamento non riuscito

Messaggio da ^alessio^ »

areudi ha scritto: Ciao, grazie mille per la veloce risposta.
Ho provato a fare ciò che mi hai suggerito, ma dopo il comando "apt-get upgrade" ho avuto questa risposta:

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
alien-arena : Dipende: alien-arena-data ma non è installato
E: Dipendenze non trovate. Riprovare usando -f.


Provo il comando "apt-get -f install" come mi suggerisce ?
si,e posta il risultato.
 
areudi
Prode Principiante
Messaggi: 4
Iscrizione: sabato 24 marzo 2012, 20:51

Re: Aggiornamento non riuscito

Messaggio da areudi »

Pare che abbia funzionato, grazie Alessio!!!
Ecco il risultato:

sudo apt-get -f install
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze     
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti saranno inoltre installati:
  alien-arena-data
I seguenti pacchetti NUOVI saranno installati:
  alien-arena-data
0 aggiornati, 1 installati, 0 da rimuovere e 16 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 382 MB di archivi.
Dopo quest'operazione, verranno occupati 847 MB di spazio su disco.
Continuare [S/n]? s
Scaricamento di:1 http://it.archive.ubuntu.com/ubuntu/ oneiric/multiverse alien-arena-data all 7.51-2 [382 MB]
Recuperati 382 MB in 7min 48s (815 kB/s)                                     
(Lettura del database... 161669 file e directory attualmente installati.)
Estrazione di alien-arena-data (da .../alien-arena-data_7.51-2_all.deb)...
Configurazione di alien-arena-data (7.51-2)...
Configurazione di alien-arena (7.51-3)...


Grazie ancora, ora si aggiorna perfettamente !!!
Avatar utente
hellojoker
Rampante Reduce
Rampante Reduce
Messaggi: 7740
Iscrizione: martedì 22 febbraio 2011, 20:37
Desktop: Gnome Shell
Distribuzione: Fedora|Win10

Re: Aggiornamento non riuscito

Messaggio da hellojoker »

si ma mettete risolto però
Scrivi risposta

Ritorna a “Installazione e aggiornamento del sistema operativo”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 7 ospiti