problemi con APT e DPKG

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.

Re: problemi con APT e DPKG

Messaggioda wilecoyote » mercoledì 17 maggio 2017, 17:12

:) Salve, i 'i915' sono i driver di alcune schede video Intel, forse un'inconsistenza nel pacchetti.

L'unica è aspettare, e sperare, che venga rilasciata una nuova versione corretta del pacchetto, magari tentando di rimediare col comando:

Codice: Seleziona tutto
sudo apt-get install -f


:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz 160 Gb HDD 1Gb Ram
ACER Extensa 5635Z 2,2 Ghz 320 Gb HDD 4 Gb Ram
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4911
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14.04LTS 16.04 LTS 64bit
Sesso: Maschile

Re: problemi con APT e DPKG

Messaggioda caturen » mercoledì 17 maggio 2017, 17:55

devi eliminare questi kernel e i relitivi headers
Codice: Seleziona tutto
Trovata immagine linux: /boot/vmlinuz-3.13.0-117-generic
Trovata immagine initrd: /boot/initrd.img-3.13.0-117-generic
Trovata immagine linux: /boot/vmlinuz-3.11.0-15-generic
Trovata immagine initrd: /boot/initrd.img-3.11.0-15-generic
e poi anche questo file
20auto-upgrades.ucf-dist
che si trova dentro
Codice: Seleziona tutto
/etc/apt/apt.conf.d/
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 13096
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: problemi con APT e DPKG

Messaggioda Jure Linux » mercoledì 17 maggio 2017, 21:32

caturen Immagine ha scritto:devi eliminare questi kernel e i relitivi headers
Codice: Seleziona tutto
Trovata immagine linux: /boot/vmlinuz-3.13.0-117-generic
Trovata immagine initrd: /boot/initrd.img-3.13.0-117-generic
Trovata immagine linux: /boot/vmlinuz-3.11.0-15-generic
Trovata immagine initrd: /boot/initrd.img-3.11.0-15-generic
e poi anche questo file
20auto-upgrades.ucf-dist
che si trova dentro
Codice: Seleziona tutto
/etc/apt/apt.conf.d/

Tutto chiaro fino qua. Inquadrati i kernel obsoleti, ci metto niente a cancellarli (sudo rm, se non erro). Ma 'i relativi' headers dove li scovo? Dove stanno e che nome hanno?
DELL ??? - Intel Core 2 Quad 2.40GHz x 4 - 4Gb RAM - Grafica: GeForce 210/PCIe/SSE2 - OS Ubuntu 16.04.2 64bit
ASUS X551CA - Intel Pentium CPU 2117U 1.80GHz × 2 - 4Gb RAM - Grafica: Intel Ivybridge Mobile - OS Ubuntu 16.04.2 64bit
Jure Linux
Prode Principiante
 
Messaggi: 27
Iscrizione: maggio 2017
Località: Trieste, Primorska
Desktop: ubuntu
Distribuzione: Ubuntu 16.04.2 LTS x86_64

Re: problemi con APT e DPKG

Messaggioda trekfan1 » mercoledì 17 maggio 2017, 21:36

Se hai installato synaptic devi usare synaptic (Gestore Pacchetti) per rimuoverli
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 15710
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Unity/Gnome Shell
Distribuzione: Ubuntu 17.04 e 17.10 (dev) 64 bit
Sesso: Maschile

Re: problemi con APT e DPKG

Messaggioda Jure Linux » mercoledì 17 maggio 2017, 22:50

trekfan1 Immagine ha scritto:Se hai installato synaptic devi usare synaptic (Gestore Pacchetti) per rimuoverli

Aha... Qualche giorno fa mi sono installato gmusicbrowser e mediadrug (non male), e ho bazzicato con itune (e relativo playonlinux) e spotify, che lassù qualcuno li maledica, sotto c'è gates. (Scrivo 'lassù' e intendo seti - lo dico a trekfan1: vedi Rotelli, gravità quantistica, gran bel testo di fisica). Vedo di aggiustare qualcosa con synaptic, poi vi so dire.
-----
Aggiorno per tekfan1: synaptic i suddetti files non li trova, se li ha messi lui non so da quale installazione li abbia pescati. Ho rimosso spotify, ma risultava presente solo il client con relativi addobbi e registri: i vecchi kernel sono sempre là. Che faccio, li elimino a mano?
DELL ??? - Intel Core 2 Quad 2.40GHz x 4 - 4Gb RAM - Grafica: GeForce 210/PCIe/SSE2 - OS Ubuntu 16.04.2 64bit
ASUS X551CA - Intel Pentium CPU 2117U 1.80GHz × 2 - 4Gb RAM - Grafica: Intel Ivybridge Mobile - OS Ubuntu 16.04.2 64bit
Jure Linux
Prode Principiante
 
Messaggi: 27
Iscrizione: maggio 2017
Località: Trieste, Primorska
Desktop: ubuntu
Distribuzione: Ubuntu 16.04.2 LTS x86_64

Re: problemi con APT e DPKG

Messaggioda Jure Linux » giovedì 18 maggio 2017, 1:00

Tagliata la testa al toro (vedi apocalypse now). Spazzati via i kernel obsoleti e il 20auto manualmente via terminale - rm .
Poi ho dato i comandi di riparzione e aggiornamento apt-get install, update e upgrade. Ora sembra tutto a posto.
A dirla tutta, mancano all'appello gli headers relativi che non sono riuscito a individuare: spero non diano problemi.
Ecco gli output_
Codice: Seleziona tutto
jure@jure-LT:~$ sudo rm /boot/vmlinuz-3.13.0-117-generic
jure@jure-LT:~$ sudo rm /boot/initrd.img-3.13.0-117-generic
jure@jure-LT:~$ sudo rm /boot/vmlinuz-3.11.0-15-generic
jure@jure-LT:~$ sudo rm /boot/initrd.img-3.11.0-15-generic
jure@jure-LT:~$ sudo rm /etc/apt/apt.conf.d/20auto-upgrades.ucf-dist

-------------

jure@jure-LT:~$ sudo apt-get install -f
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

-------------------

jure@jure-LT:~$ sudo apt-get update
Trovato:1 http://it.archive.ubuntu.com/ubuntu xenial InRelease
Scaricamento di:2 http://it.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]                 
Scaricamento di:3 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]                 
Scaricamento di:4 http://it.archive.ubuntu.com/ubuntu xenial-updates/main Sources [248 kB]
Scaricamento di:5 http://security.ubuntu.com/ubuntu xenial-security/main Sources [70,9 kB]
Scaricamento di:6 http://it.archive.ubuntu.com/ubuntu xenial-updates/universe Sources [154 kB]
Scaricamento di:7 http://security.ubuntu.com/ubuntu xenial-security/universe Sources [27,6 kB]
Scaricamento di:8 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages [267 kB]
Scaricamento di:9 http://it.archive.ubuntu.com/ubuntu xenial-updates/multiverse Sources [5.672 B]
Scaricamento di:10 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [540 kB]
Scaricamento di:11 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [254 kB]
Scaricamento di:12 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en [112 kB]
Scaricamento di:13 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [54,6 kB]
Scaricamento di:14 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [39,7 kB]   
Scaricamento di:15 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages [114 kB]
Scaricamento di:16 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages [101 kB]
Scaricamento di:17 http://it.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [524 kB]
Scaricamento di:18 http://security.ubuntu.com/ubuntu xenial-security/universe Translation-en [58,9 kB]
Scaricamento di:19 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [32,2 kB]
Scaricamento di:20 http://it.archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [218 kB]         
Scaricamento di:21 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [298 kB]
Scaricamento di:22 http://it.archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [193 kB]
Scaricamento di:23 http://it.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [467 kB]
Scaricamento di:24 http://it.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [452 kB]               
Scaricamento di:25 http://it.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [160 kB]       
Scaricamento di:26 http://it.archive.ubuntu.com/ubuntu xenial-updates/universe DEP-11 64x64 Icons [183 kB]         
Scaricamento di:27 http://it.archive.ubuntu.com/ubuntu xenial-updates/multiverse i386 Packages [8.000 B]           
Scaricamento di:28 http://it.archive.ubuntu.com/ubuntu xenial-updates/multiverse Translation-en [4.460 B]           
Scaricamento di:29 http://it.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [2.520 B]   
Recuperati 4.794 kB in 7s (624 kB/s)                                                                               
Lettura elenco dei pacchetti... Fatto

-------------------

jure@jure-LT:~$ sudo apt-get upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Calcolo dell'aggiornamento... Fatto
I seguenti pacchetti sono stati mantenuti alla versione attuale:
  linux-tools-virtual-hwe-16.04-edge
I seguenti pacchetti saranno aggiornati:
  bash chromium-codecs-ffmpeg-extra
2 aggiornati, 0 installati, 0 da rimuovere e 1 non aggiornati.
È necessario scaricare 1.581 kB di archivi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
Continuare? [S/n] s
Scaricamento di:1 http://it.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 chromium-codecs-ffmpeg-extra amd64 58.0.3029.110-0ubuntu0.16.04.1281 [999 kB]
Scaricamento di:2 http://security.ubuntu.com/ubuntu xenial-security/main amd64 bash amd64 4.3-14ubuntu1.2 [583 kB]
Scaricamento di:1 http://it.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 chromium-codecs-ffmpeg-extra amd64 58.0.3029.110-0ubuntu0.16.04.1281 [999 kB]
Recuperati 1.139 kB in 10s (109 kB/s)                                                                               
(Lettura del database... 235319 file e directory attualmente installati.)
Preparativi per estrarre .../bash_4.3-14ubuntu1.2_amd64.deb...
Estrazione di bash (4.3-14ubuntu1.2) su (4.3-14ubuntu1.1)...
Elaborazione dei trigger per install-info (6.1.0.dfsg.1-5)...
Elaborazione dei trigger per man-db (2.7.5-1)...
Configurazione di bash (4.3-14ubuntu1.2)...
update-alternatives: viene usato /usr/share/man/man7/bash-builtins.7.gz per fornire /usr/share/man/man7/builtins.7.gz (builtins.7.gz) in modalità automatica
(Lettura del database... 235319 file e directory attualmente installati.)
Preparativi per estrarre .../chromium-codecs-ffmpeg-extra_58.0.3029.110-0ubuntu0.16.04.1281_amd64.deb...
Estrazione di chromium-codecs-ffmpeg-extra (58.0.3029.110-0ubuntu0.16.04.1281) su (58.0.3029.96-0ubuntu0.16.04.1279)...
Configurazione di chromium-codecs-ffmpeg-extra (58.0.3029.110-0ubuntu0.16.04.1281)...
jure@jure-LT:~$


ciao cari, e grazie (hvala lepa). :birra:
DELL ??? - Intel Core 2 Quad 2.40GHz x 4 - 4Gb RAM - Grafica: GeForce 210/PCIe/SSE2 - OS Ubuntu 16.04.2 64bit
ASUS X551CA - Intel Pentium CPU 2117U 1.80GHz × 2 - 4Gb RAM - Grafica: Intel Ivybridge Mobile - OS Ubuntu 16.04.2 64bit
Jure Linux
Prode Principiante
 
Messaggi: 27
Iscrizione: maggio 2017
Località: Trieste, Primorska
Desktop: ubuntu
Distribuzione: Ubuntu 16.04.2 LTS x86_64

Re: problemi con APT e DPKG

Messaggioda trekfan1 » giovedì 18 maggio 2017, 6:47

In synaptic clicca su cerca e scrivi linux-headers e anche linux-image
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 15710
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Unity/Gnome Shell
Distribuzione: Ubuntu 17.04 e 17.10 (dev) 64 bit
Sesso: Maschile

Re: problemi con APT e DPKG

Messaggioda wilecoyote » giovedì 18 maggio 2017, 14:01

:) Salve, per trovare i pacchetti in oggetto, senza sbagliare la versione, dai questo comando:

Codice: Seleziona tutto
dpkg -l linux*3.13.0*


Ti mostrerà solo gli eventuali pacchetti installati, indicati all'inizio da 'ii', che poi potrai rimuovere.

:ciao: Ciao

P.S. a scanso di equivoci sul funziona non funziona, ti posto il risultato del mio Trusty riferito alla sua versione, 4.4.0, di kernel:

Codice: Seleziona tutto
wilecoyote@MonumentValley:~$ dpkg -l linux*4.4.0*
Voluto=U (non noto)/I (installato)/R (rimosso)/P (rimosso totale)/H (in attesa)
| Stato=Non/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(nessuno)/R (reinstallazione richiesta) (Stato,Err: maiuscolo=grave)
||/ Nome                 Versione        Architettura    Descrizione
+++-====================-===============-===============-=============================================
ii  linux-headers-4.4.0- 4.4.0-75.96~14. all             Header files related to Linux kernel version
ii  linux-headers-4.4.0- 4.4.0-75.96~14. amd64           Linux kernel headers for version 4.4.0 on 64
ii  linux-headers-4.4.0- 4.4.0-78.99~14. all             Header files related to Linux kernel version
ii  linux-headers-4.4.0- 4.4.0-78.99~14. amd64           Linux kernel headers for version 4.4.0 on 64
ii  linux-image-4.4.0-75 4.4.0-75.96~14. amd64           Linux kernel image for version 4.4.0 on 64 bi
ii  linux-image-4.4.0-78 4.4.0-78.99~14. amd64           Linux kernel image for version 4.4.0 on 64 bi
ii  linux-image-extra-4. 4.4.0-75.96~14. amd64           Linux kernel extra modules for version 4.4.0
ii  linux-image-extra-4. 4.4.0-78.99~14. amd64           Linux kernel extra modules for version 4.4.0
ACER Extensa 5230E 2,2 Ghz 160 Gb HDD 1Gb Ram
ACER Extensa 5635Z 2,2 Ghz 320 Gb HDD 4 Gb Ram
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4911
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14.04LTS 16.04 LTS 64bit
Sesso: Maschile

Re: problemi con APT e DPKG

Messaggioda Jure Linux » giovedì 18 maggio 2017, 21:13

Fatto, sia con synaptic che col terminale. Nessun superstite rilevato dopo la pulizia.
Ecco l'output

Codice: Seleziona tutto
jure@jure-LT:~$ dpkg -l linux*3.13.0*
dpkg-query: nessun pacchetto corrispondente a linux*3.13.0*
jure@jure-LT:~$ dpkg -l linux*4.8.0*
Voluto=U (non noto)/I (installato)/R (rimosso)/P (rimosso totale)/H (in attesa)
| Stato=Non/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(nessuno)/R (reinstallazione richiesta) (Stato,Err: maiuscolo=grave)
||/ Nome           Versione     Architettura Descrizione
+++-=========================-=================-=================-=======================================================
un  linux-headers-4.8.0-36-ge <nessuna>         <nessuna>         (nessuna descrizione disponibile)
ii  linux-headers-4.8.0-51    4.8.0-51.54~16.04 all               Header files related to Linux kernel version 4.8.0
ii  linux-headers-4.8.0-51-ge 4.8.0-51.54~16.04 amd64             Linux kernel headers for version 4.8.0 on 64 bit x86 SM
ii  linux-headers-4.8.0-52    4.8.0-52.55~16.04 all               Header files related to Linux kernel version 4.8.0
ii  linux-headers-4.8.0-52-ge 4.8.0-52.55~16.04 amd64             Linux kernel headers for version 4.8.0 on 64 bit x86 SM
rc  linux-image-4.8.0-36-gene 4.8.0-36.36~16.04 amd64             Linux kernel image for version 4.8.0 on 64 bit x86 SMP
ii  linux-image-4.8.0-51-gene 4.8.0-51.54~16.04 amd64             Linux kernel image for version 4.8.0 on 64 bit x86 SMP
ii  linux-image-4.8.0-52-gene 4.8.0-52.55~16.04 amd64             Linux kernel image for version 4.8.0 on 64 bit x86 SMP
rc  linux-image-extra-4.8.0-3 4.8.0-36.36~16.04 amd64             Linux kernel extra modules for version 4.8.0 on 64 bit
ii  linux-image-extra-4.8.0-5 4.8.0-51.54~16.04 amd64             Linux kernel extra modules for version 4.8.0 on 64 bit
ii  linux-image-extra-4.8.0-5 4.8.0-52.55~16.04 amd64             Linux kernel extra modules for version 4.8.0 on 64 bit
jure@jure-LT:~$

Che ne pensate della prima riga

Codice: Seleziona tutto
un  linux-headers-4.8.0-36-ge <nessuna>         <nessuna>         (nessuna descrizione disponibile)

e delle due marcate 'rc'?
DELL ??? - Intel Core 2 Quad 2.40GHz x 4 - 4Gb RAM - Grafica: GeForce 210/PCIe/SSE2 - OS Ubuntu 16.04.2 64bit
ASUS X551CA - Intel Pentium CPU 2117U 1.80GHz × 2 - 4Gb RAM - Grafica: Intel Ivybridge Mobile - OS Ubuntu 16.04.2 64bit
Jure Linux
Prode Principiante
 
Messaggi: 27
Iscrizione: maggio 2017
Località: Trieste, Primorska
Desktop: ubuntu
Distribuzione: Ubuntu 16.04.2 LTS x86_64

Re: problemi con APT e DPKG

Messaggioda wilecoyote » giovedì 18 maggio 2017, 22:04

:) Salve, penso che l'ansia ti obnubila la vista ;) .

Jure Linux ha scritto:
Codice: Seleziona tutto
jure@jure-LT:~$ dpkg -l linux*4.8.0*
Voluto=U (non noto)/I (installato)/R (rimosso)/P (rimosso totale)/H (in attesa)
| Stato=Non/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(nessuno)/R (reinstallazione richiesta) (Stato,Err: maiuscolo=grave)
||/ Nome           Versione     Architettura Descrizione
+++-=========


Quindi il 'un' indica non installato, il 'rc' rimosso e rimasti file configurazione (Conf-files).

Comunque rimuovili definitamente, hai già 2 kernel installati, le versioni 4.8.0-51 e 4.8.0-52, la 4.8.0-36 è ridondante per cui pulisci da anch'essa.

:ciao: Ciao.
ACER Extensa 5230E 2,2 Ghz 160 Gb HDD 1Gb Ram
ACER Extensa 5635Z 2,2 Ghz 320 Gb HDD 4 Gb Ram
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4911
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14.04LTS 16.04 LTS 64bit
Sesso: Maschile

Re: problemi con APT e DPKG

Messaggioda VitoDoc » giovedì 18 maggio 2017, 22:29

Per l'elenco dei kernel installati il comando da dare è questo
Codice: Seleziona tutto
dpkg --get-selections | grep linux-image


Per il kernel in uso è questo
Codice: Seleziona tutto
uname -r


Per rimuovere i kernel vecchi
Codice: Seleziona tutto
sudo apt-get purge linux-image-x.x.x-xx-generic


Da sostituire le "x" con il numero versione del kernel che si vuole rimuovere.
Avatar utente
VitoDoc
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1694
Iscrizione: maggio 2012
Desktop: plasma
Distribuzione: Kubuntu 16.04.2 LTS x86_64
Sesso: Maschile

Re: problemi con APT e DPKG

Messaggioda Jure Linux » giovedì 18 maggio 2017, 23:20

VitoDoc Immagine ha scritto:Per l'elenco dei kernel installati il comando da dare è questo
Codice: Seleziona tutto
dpkg --get-selections | grep linux-image

Per il kernel in uso è questo
Codice: Seleziona tutto
uname -r

Per rimuovere i kernel vecchi
Codice: Seleziona tutto
sudo apt-get purge linux-image-x.x.x-xx-generic

Da sostituire le "x" con il numero versione del kernel che si vuole rimuovere.

Grazie VitoDoc. Ripulito tutto, ho lasciato solo il 4.8.0-52. Ho appena riavviato per vedere se c'è qualche problema: tutto va secondo norma.
A wilecoyote non replico altrimenti ci azzuffiamo - prendere in giro un novellino non dà gloria. Ma le faccine ti salvano, apposta le hai messe, manigoldo.
Insomma grazie a tutti, come al solito. Gran bella compagnia, niente da dire :birra:
DELL ??? - Intel Core 2 Quad 2.40GHz x 4 - 4Gb RAM - Grafica: GeForce 210/PCIe/SSE2 - OS Ubuntu 16.04.2 64bit
ASUS X551CA - Intel Pentium CPU 2117U 1.80GHz × 2 - 4Gb RAM - Grafica: Intel Ivybridge Mobile - OS Ubuntu 16.04.2 64bit
Jure Linux
Prode Principiante
 
Messaggi: 27
Iscrizione: maggio 2017
Località: Trieste, Primorska
Desktop: ubuntu
Distribuzione: Ubuntu 16.04.2 LTS x86_64

Re: problemi con APT e DPKG

Messaggioda wilecoyote » venerdì 19 maggio 2017, 14:16

:) Salve,

Jure Linux ha scritto:A wilecoyote non replico altrimenti ci azzuffiamo - prendere in giro un novellino non dà gloria. Ma le faccine ti salvano, apposta le hai messe, manigoldo.


Delicatissimo... :lol:

Ad ogni buon conto è bene avere sempre 2 kernel installati, in questo modo se il kernel in uso per qualsivoglia ragione si corrompe usando il precedente puoi riavviare il sistema.

Appena ti verrà proposto un aggiornamento del kernel, non rimuovere l'attuale in uso, vedi nel mio output più sù che ne ho 2 installati.

:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz 160 Gb HDD 1Gb Ram
ACER Extensa 5635Z 2,2 Ghz 320 Gb HDD 4 Gb Ram
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4911
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14.04LTS 16.04 LTS 64bit
Sesso: Maschile

Re: problemi con APT e DPKG

Messaggioda Jure Linux » venerdì 19 maggio 2017, 17:33

wilecoyote Immagine ha scritto:Ad ogni buon conto è bene avere sempre 2 kernel installati, in questo modo se il kernel in uso per qualsivoglia ragione si corrompe usando il precedente puoi riavviare il sistema.
Appena ti verrà proposto un aggiornamento del kernel, non rimuovere l'attuale in uso, vedi nel mio output più sù che ne ho 2 installati.


Mhh... Dovevate dirmelo prima. Lezione capita :sisi:
DELL ??? - Intel Core 2 Quad 2.40GHz x 4 - 4Gb RAM - Grafica: GeForce 210/PCIe/SSE2 - OS Ubuntu 16.04.2 64bit
ASUS X551CA - Intel Pentium CPU 2117U 1.80GHz × 2 - 4Gb RAM - Grafica: Intel Ivybridge Mobile - OS Ubuntu 16.04.2 64bit
Jure Linux
Prode Principiante
 
Messaggi: 27
Iscrizione: maggio 2017
Località: Trieste, Primorska
Desktop: ubuntu
Distribuzione: Ubuntu 16.04.2 LTS x86_64

Re: problemi con APT e DPKG

Messaggioda Virgoss » lunedì 5 giugno 2017, 17:02

Salve a tutti, è passato un pò di tempo, vedo che alcuni pare abbiano risolto alcuni problemi, ma io sono rimasto al palo! :D
Per un po non ho usato il mio PC, comunque il guaio rimane....
Scarica gli aggiornamenti, ma non installa un tubo! :muro:

Codice: Seleziona tutto
Estrazione dei template dai pacchetti: 100%
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhtml-tagset-perl" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libical1a:amd64" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhttp-date-perl" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhtml-format-perl" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhttp-cookies-perl" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhud2:amd64" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhttp-daemon-perl" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhx509-5-heimdal:amd64" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhtml-tree-perl" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhogweed4:amd64" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhybris-common1" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhyphen0:amd64" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "fonts-tlwg-mono-ttf" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhtml-parser-perl" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "fonts-tlwg-loma-ttf" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhtml-form-perl" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libiw30:amd64" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhttp-message-perl" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhunspell-1.3-0:amd64" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhpmud0:amd64" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libieee1284-3:amd64" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "fonts-tlwg-loma" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "fonts-kacst" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libidn11:amd64" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libhttp-negotiate-perl" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: errore fatale non recuperabile, uscita:
 al file con l'elenco dei file del pacchetto "libhybris" manca un newline finale
E: Sub-process /usr/bin/dpkg returned an error code (2)
Installazione di un pacchetto non riuscita. Tentativo di ripristino:



Perchè????? :cry:
Virginio
Avatar utente
Virgoss
Prode Principiante
 
Messaggi: 173
Iscrizione: luglio 2007
Desktop: Ubuntu unity
Distribuzione: Ubuntu 16.04 x86_64 (Xenial)
Sesso: Maschile

Re: problemi con APT e DPKG

Messaggioda wilecoyote » lunedì 5 giugno 2017, 17:20

:) Salve, aspetta che ho appena ripassato la discussione, non posso ricordare tutto.

Noto ora nella tua firma riportato il Precise 12.04 LTS, se stai usando esso è fuori supporto quindi per funzionare prima devi aggiornare.

Se invece usi una release più recente supportata aggiorna la firma.

Di tutti i vari comandi postati se e quali hai provato ?

Hai ripulito dai ppa l'elenco repository ?

Hai provato l'aggiornamento dopo il repulisti ?

Codice: Seleziona tutto
sudo apt-get install -f
sudo apt-get update
sudo apt-get upgrade


Il 1° corregge gli eventuali errori, il 2° aggiorna la lista dei pacchetti, il 3° installa eventuali aggiornamenti.

:ciao: Ciao
ACER Extensa 5230E 2,2 Ghz 160 Gb HDD 1Gb Ram
ACER Extensa 5635Z 2,2 Ghz 320 Gb HDD 4 Gb Ram
Quando una Finestra chiusa incontra un Pinguino la Finestra chiusa è una Finestra aperta.
Avatar utente
wilecoyote
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4911
Iscrizione: agosto 2009
Località: Ceranesi - Ge
Desktop: Kubuntu Lubuntu
Distribuzione: 9.04 32bit 14.04LTS 16.04 LTS 64bit
Sesso: Maschile

Re: problemi con APT e DPKG

Messaggioda pachisapiu » lunedì 5 giugno 2017, 17:26

Posta il risultato di
Codice: Seleziona tutto
cat /etc/apt/sources.list && ls /etc/apt/sources.list.d/
Carbonara is my law
Avatar utente
pachisapiu
Prode Principiante
 
Messaggi: 175
Iscrizione: maggio 2017
Distribuzione: LinuxMint Filippa

Re: problemi con APT e DPKG

Messaggioda daigo » lunedì 5 giugno 2017, 17:41

Ubuntu 12.04 credo che abbia i repo chiusi, comunque in fondo all'outputtutti ti dice che nel pacchetto libhybris manca un'andata a capo (new linea finale) prova a editare il file
Codice: Seleziona tutto
sudo gedit /var/lib/dpkg/info/libhybris.list
e portati con il cursore in fondo all'ultima riga e poi dai un invio, in modo da avere un newline alla fine.

Fatto questo, salva il file e chiudi e prova
Codice: Seleziona tutto
sudo apt-get install -f

Codice: Seleziona tutto
sudo apt-get update && sudo apt-get upgrade


Sempre che siano ancora i repo attivi....magari si, boh
Avatar utente
daigo
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 18592
Iscrizione: maggio 2011

Re: problemi con APT e DPKG

Messaggioda pachisapiu » lunedì 5 giugno 2017, 17:50

@Daigo ma nel primo post della discussione si vede xenial
Carbonara is my law
Avatar utente
pachisapiu
Prode Principiante
 
Messaggi: 175
Iscrizione: maggio 2017
Distribuzione: LinuxMint Filippa

Re: problemi con APT e DPKG

Messaggioda daigo » lunedì 5 giugno 2017, 17:54

Ah perché non ho visto tutto ho visto gli ultimi con wilecoyote che parlava di precise...
Avatar utente
daigo
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 18592
Iscrizione: maggio 2011

PrecedenteSuccessiva

Torna a Installazione e aggiornamento del sistema operativo

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 8 ospiti