Pagina 1 di 2

[risolto]Errori nell'aggiornamento

MessaggioInviato: sabato 19 maggio 2018, 16:43
da MisterEma79
Buonasera , il mio ubuntu 18.04 da oggi mi da errore Brokencount e non posso aggiornare, ho seguito un pò di guida ma nulla.
Vi elenco risultati , sapete aiutarmi?
Codice: Seleziona tutto
emanuel@emanuel-desktop:~$ sudo apt-get update && sudo apt-get upgrade
Trovato:1 http://archive.canonical.com/ubuntu bionic InRelease
Trovato:2 http://archive.ubuntu.com/ubuntu bionic InRelease
Trovato:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Trovato:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Scaricamento di:5 http://archive.ubuntu.com/ubuntu bionic-security InRelease [83,2 kB]
Recuperati 83,2 kB in 1s (138 kB/s)                           
Lettura elenco dei pacchetti... Fatto
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt --fix-broken install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libsnmp30:i386 : Dipende: libperl5.26:i386 (>= 5.26.0~rc1) ma non è installato
E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).
emanuel@emanuel-desktop:~$     sudo rm  /var/lib/dpkg/lock
emanuel@emanuel-desktop:~$     sudo apt --fix-broken install
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  dkms libbsd0:i386 libgl1:i386 libglvnd0:i386 libglx0:i386 libnvidia-cfg1-390
  libnvidia-compute-390 libnvidia-compute-390:i386 libnvidia-decode-390
  libnvidia-decode-390:i386 libnvidia-encode-390 libnvidia-encode-390:i386
  libnvidia-fbc1-390 libnvidia-fbc1-390:i386 libnvidia-gl-390:i386
  libnvidia-ifr1-390 libnvidia-ifr1-390:i386 libwayland-client0:i386
  libwayland-server0:i386 libx11-6:i386 libxau6:i386 libxcb1:i386
  libxdmcp6:i386 libxext6:i386 libxnvctrl0 nvidia-compute-utils-390
  nvidia-dkms-390 nvidia-kernel-common-390 nvidia-kernel-source-390
  nvidia-prime nvidia-settings nvidia-utils-390 pkg-config
  screen-resolution-extra xserver-xorg-video-nvidia-390
Usare "sudo apt autoremove" per rimuoverli.
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  libperl5.26:i386
I seguenti pacchetti NUOVI saranno installati:
  libperl5.26:i386
0 aggiornati, 1 installati, 0 da rimuovere e 17 non aggiornati.
35 non completamente installati o rimossi.
È necessario scaricare 3.155 kB di archivi.
Dopo quest'operazione, verranno occupati 16,3 MB di spazio su disco.
Continuare? [S/n] S
Scaricamento di:1 http://archive.ubuntu.com/ubuntu bionic/main i386 libperl5.26 i386 5.26.1-6 [3.155 kB]
Recuperati 3.155 kB in 1s (4.913 kB/s)       
(Lettura del database... 151168 file e directory attualmente installati.)
Preparativi per estrarre .../libperl5.26_5.26.1-6_i386.deb...
Estrazione di libperl5.26:i386 (5.26.1-6)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libperl5.26_5.26.1-6_i386.deb (--unpack):
 tentata sovrascrittura di "/usr/share/doc/libperl5.26/changelog.Debian.gz" (condiviso), diverso da altre istanze del pacchetto libperl5.26:i386
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libperl5.26_5.26.1-6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
emanuel@emanuel-desktop:~$ sudo apt-get -f install
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  dkms libbsd0:i386 libgl1:i386 libglvnd0:i386 libglx0:i386 libnvidia-cfg1-390
  libnvidia-compute-390 libnvidia-compute-390:i386 libnvidia-decode-390
  libnvidia-decode-390:i386 libnvidia-encode-390 libnvidia-encode-390:i386
  libnvidia-fbc1-390 libnvidia-fbc1-390:i386 libnvidia-gl-390:i386
  libnvidia-ifr1-390 libnvidia-ifr1-390:i386 libwayland-client0:i386
  libwayland-server0:i386 libx11-6:i386 libxau6:i386 libxcb1:i386
  libxdmcp6:i386 libxext6:i386 libxnvctrl0 nvidia-compute-utils-390
  nvidia-dkms-390 nvidia-kernel-common-390 nvidia-kernel-source-390
  nvidia-prime nvidia-settings nvidia-utils-390 pkg-config
  screen-resolution-extra xserver-xorg-video-nvidia-390
Usare "sudo apt autoremove" per rimuoverli.
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  libperl5.26:i386
I seguenti pacchetti NUOVI saranno installati:
  libperl5.26:i386
0 aggiornati, 1 installati, 0 da rimuovere e 17 non aggiornati.
35 non completamente installati o rimossi.
È necessario scaricare 0 B/3.155 kB di archivi.
Dopo quest'operazione, verranno occupati 16,3 MB di spazio su disco.
Continuare? [S/n] S
(Lettura del database... 151168 file e directory attualmente installati.)
Preparativi per estrarre .../libperl5.26_5.26.1-6_i386.deb...
Estrazione di libperl5.26:i386 (5.26.1-6)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libperl5.26_5.26.1-6_i386.deb (--unpack):
 tentata sovrascrittura di "/usr/share/doc/libperl5.26/changelog.Debian.gz" (condiviso), diverso da altre istanze del pacchetto libperl5.26:i386
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libperl5.26_5.26.1-6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
emanuel@emanuel-desktop:~$ sudo apt-get clean
emanuel@emanuel-desktop:~$ sudo apt-get autoremove && sudo apt-get autoclean && sudo apt-get purge && sudo apt-get clean
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt --fix-broken install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libsnmp30:i386 : Dipende: libperl5.26:i386 (>= 5.26.0~rc1) ma non è installato
E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).
emanuel@emanuel-desktop:~$ sudo apt-get clean
emanuel@emanuel-desktop:~$ sudo apt-get update
Trovato:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Trovato:2 http://archive.canonical.com/ubuntu bionic InRelease               
Trovato:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease           
Trovato:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Scaricamento di:5 http://archive.ubuntu.com/ubuntu bionic-security InRelease [83,2 kB]
Recuperati 83,2 kB in 1s (123 kB/s)                           
Lettura elenco dei pacchetti... Fatto
emanuel@emanuel-desktop:~$ sudo apt-get upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt --fix-broken install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libsnmp30:i386 : Dipende: libperl5.26:i386 (>= 5.26.0~rc1) ma non è installato
E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).
emanuel@emanuel-desktop:~$

Re: rrori nell'aggiornamento

MessaggioInviato: sabato 19 maggio 2018, 17:13
da giulux
Prova con
Codice: Seleziona tutto
sudo dpkg -i --force-overwrite  /var/cache/apt/archives/libperl5.26_5.26.1-6_i386.deb
e poi riaggiorna e verifica se ci sono errori.

Re: rrori nell'aggiornamento

MessaggioInviato: sabato 19 maggio 2018, 19:06
da MisterEma79
Codice: Seleziona tutto
emanuel@emanuel-desktop:~$ sudo dpkg -i --force-overwrite  /archives/libperl5.26_5.26.1-6_i386.deb
dpkg: errore: cannot access archive '/archives/libperl5.26_5.26.1-6_i386.deb': File o directory non esistente

Re: Errori nell'aggiornamento

MessaggioInviato: sabato 19 maggio 2018, 19:23
da trekfan1
Il percorso giusto è /var/cache/apt/archives/

Re: Errori nell'aggiornamento

MessaggioInviato: sabato 19 maggio 2018, 19:29
da MisterEma79
Codice: Seleziona tutto
emanuel@emanuel-desktop:~$ sudo dpkg -i --force-overwrite /var/cache/apt/archives/libperl5.26_5.26.1-6_i386.deb
[sudo] password di emanuel:
dpkg: errore: cannot access archive '/var/cache/apt/archives/libperl5.26_5.26.1-6_i386.deb': File o directory non esistente

Re: Errori nell'aggiornamento

MessaggioInviato: sabato 19 maggio 2018, 19:32
da giulux
trekfan1 ha scritto:Il percorso giusto è /var/cache/apt/archives/
giusto, non so come mi è uscito il comando sbagliato, che correggo nel precedente post.

EDIT: vedo che non funge nemmeno così. Mi arrendo.

Re: Errori nell'aggiornamento

MessaggioInviato: sabato 19 maggio 2018, 19:59
da pachisapiu
Prova a dare
Codice: Seleziona tutto
sudo dpkg -P --force-all libsnmp30:i386
e dopo se non da errori
Codice: Seleziona tutto
sudo apt -f install

Re: Errori nell'aggiornamento

MessaggioInviato: domenica 20 maggio 2018, 9:15
da MisterEma79
Codice: Seleziona tutto
emanuel@emanuel-desktop:~$     sudo dpkg -P --force-all libsnmp30:i386
[sudo] password di emanuel:
dpkg: libsnmp30:i386: problemi con le dipendenze, ma viene rimosso comunque:
 libhpmud0:i386 dipende da libsnmp30 (>= 5.7.3+dfsg-1.8ubuntu3~dfsg).

(Lettura del database... 151167 file e directory attualmente installati.)
Rimozione di libsnmp30:i386 (5.7.3+dfsg-1.8ubuntu3)...
Elaborazione dei trigger per libc-bin (2.27-3ubuntu1)...
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/i386-linux-gnu_EGL.conf: No such file or directory
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/i386-linux-gnu_GL.conf: No such file or directory
emanuel@emanuel-desktop:~$     sudo apt -f install
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  dkms libbsd0:i386 libgl1:i386 libglvnd0:i386 libglx0:i386 libnvidia-cfg1-390
  libnvidia-compute-390 libnvidia-compute-390:i386 libnvidia-decode-390
  libnvidia-decode-390:i386 libnvidia-encode-390 libnvidia-encode-390:i386
  libnvidia-fbc1-390 libnvidia-fbc1-390:i386 libnvidia-gl-390:i386
  libnvidia-ifr1-390 libnvidia-ifr1-390:i386 libwayland-client0:i386
  libwayland-server0:i386 libx11-6:i386 libxau6:i386 libxcb1:i386
  libxdmcp6:i386 libxext6:i386 libxnvctrl0 nvidia-compute-utils-390
  nvidia-dkms-390 nvidia-kernel-common-390 nvidia-kernel-source-390
  nvidia-prime nvidia-settings nvidia-utils-390 pkg-config
  screen-resolution-extra xserver-xorg-video-nvidia-390
Usare "sudo apt autoremove" per rimuoverli.
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  libperl5.26:i386 libsnmp30:i386
I seguenti pacchetti NUOVI saranno installati:
  libperl5.26:i386 libsnmp30:i386
0 aggiornati, 2 installati, 0 da rimuovere e 17 non aggiornati.
34 non completamente installati o rimossi.
È necessario scaricare 944 kB/4.099 kB di archivi.
Dopo quest'operazione, verranno occupati 20,2 MB di spazio su disco.
Continuare? [S/n] S
Scaricamento di:1 http://archive.ubuntu.com/ubuntu bionic/main i386 libsnmp30 i386 5.7.3+dfsg-1.8ubuntu3 [944 kB]
Recuperati 944 kB in 1s (1.602 kB/s)   
(Lettura del database... 151156 file e directory attualmente installati.)
Preparativi per estrarre .../libperl5.26_5.26.1-6_i386.deb...
Estrazione di libperl5.26:i386 (5.26.1-6)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libperl5.26_5.26.1-6_i386.deb (--unpack):
 tentata sovrascrittura di "/usr/share/doc/libperl5.26/changelog.Debian.gz" (condiviso), diverso da altre istanze del pacchetto libperl5.26:i386
Selezionato il pacchetto libsnmp30:i386 non precedentemente selezionato.
Preparativi per estrarre .../libsnmp30_5.7.3+dfsg-1.8ubuntu3_i386.deb...
Estrazione di libsnmp30:i386 (5.7.3+dfsg-1.8ubuntu3)...
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libperl5.26_5.26.1-6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
emanuel@emanuel-desktop:~$

Re: Errori nell'aggiornamento

MessaggioInviato: domenica 20 maggio 2018, 9:56
da pachisapiu
posta
Codice: Seleziona tutto
cat /etc/apt/sources.list && ls /etc/apt/sources.list.d/

Re: Errori nell'aggiornamento

MessaggioInviato: domenica 20 maggio 2018, 18:44
da MisterEma79
Codice: Seleziona tutto
emanuel@emanuel-desktop:~$     cat /etc/apt/sources.list && ls /etc/apt/sources.list.d/
# deb cdrom:[Ubuntu 17.10 _Artful Aardvark_ - Release amd64 (20180105.1)]/ artful main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://archive.ubuntu.com/ubuntu bionic main restricted
# deb-src http://it.archive.ubuntu.com/ubuntu/ artful main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted
# deb-src http://it.archive.ubuntu.com/ubuntu/ artful-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu bionic universe
# deb-src http://it.archive.ubuntu.com/ubuntu/ artful universe
deb http://archive.ubuntu.com/ubuntu bionic-updates universe
# deb-src http://it.archive.ubuntu.com/ubuntu/ artful-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
# deb-src http://it.archive.ubuntu.com/ubuntu/ artful multiverse
# deb-src http://it.archive.ubuntu.com/ubuntu/ artful-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe
# deb-src http://it.archive.ubuntu.com/ubuntu/ artful-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu bionic partner
deb-src http://archive.canonical.com/ubuntu bionic partner

deb http://archive.ubuntu.com/ubuntu bionic-security main restricted
# deb-src http://security.ubuntu.com/ubuntu artful-security main restricted
deb http://archive.ubuntu.com/ubuntu bionic-security universe
# deb-src http://security.ubuntu.com/ubuntu artful-security universe
# deb-src http://security.ubuntu.com/ubuntu artful-security multiverse
lucid-bleed-ubuntu-ppa-artful.list
lucid-bleed-ubuntu-ppa-artful.list.distUpgrade
lucid-bleed-ubuntu-ppa-artful.list.save
emanuel@emanuel-desktop:~$

Re: Errori nell'aggiornamento

MessaggioInviato: domenica 20 maggio 2018, 18:59
da a323109
Codice: Seleziona tutto
lucid-bleed-ubuntu-ppa-artful.list
lucid-bleed-ubuntu-ppa-artful.list.distUpgrade
lucid-bleed-ubuntu-ppa-artful.list.save


devi commentare queste 3 righe facendole diventare cosi':

Codice: Seleziona tutto
#lucid-bleed-ubuntu-ppa-artful.list
#lucid-bleed-ubuntu-ppa-artful.list.distUpgrade
#lucid-bleed-ubuntu-ppa-artful.list.save

Re: Errori nell'aggiornamento

MessaggioInviato: domenica 20 maggio 2018, 19:17
da pachisapiu
a323109 Immagine ha scritto:
Codice: Seleziona tutto
lucid-bleed-ubuntu-ppa-artful.list
lucid-bleed-ubuntu-ppa-artful.list.distUpgrade
lucid-bleed-ubuntu-ppa-artful.list.save


devi commentare queste 3 righe facendole diventare cosi':

Codice: Seleziona tutto
#lucid-bleed-ubuntu-ppa-artful.list
#lucid-bleed-ubuntu-ppa-artful.list.distUpgrade
#lucid-bleed-ubuntu-ppa-artful.list.save

quelle non sono righe sono file

Re: Errori nell'aggiornamento

MessaggioInviato: domenica 20 maggio 2018, 19:20
da a323109
pachisapiu Immagine ha scritto:
a323109 Immagine ha scritto:
Codice: Seleziona tutto
lucid-bleed-ubuntu-ppa-artful.list
lucid-bleed-ubuntu-ppa-artful.list.distUpgrade
lucid-bleed-ubuntu-ppa-artful.list.save


devi commentare queste 3 righe facendole diventare cosi':

Codice: Seleziona tutto
#lucid-bleed-ubuntu-ppa-artful.list
#lucid-bleed-ubuntu-ppa-artful.list.distUpgrade
#lucid-bleed-ubuntu-ppa-artful.list.save

quelle non sono righe sono file


Oops! :shy:

Re: Errori nell'aggiornamento

MessaggioInviato: domenica 20 maggio 2018, 19:28
da trekfan1
@MisterEma79 posta l'output di
Codice: Seleziona tutto
cat /etc/apt/sources.list.d/lucid-bleed-ubuntu-ppa-artful.list

Re: Errori nell'aggiornamento

MessaggioInviato: lunedì 21 maggio 2018, 11:44
da MisterEma79
Codice: Seleziona tutto
emanuel@emanuel-desktop:~$     cat /etc/apt/sources.list.d/lucid-bleed-ubuntu-ppa-artful.list
# deb http://ppa.launchpad.net/lucid-bleed/ppa/ubuntu artful main
# deb-src http://ppa.launchpad.net/lucid-bleed/ppa/ubuntu artful main

Re: Errori nell'aggiornamento

MessaggioInviato: lunedì 21 maggio 2018, 12:57
da trekfan1
Rimuovi quel ppa, ha il supporto fino a natty... http://ppa.launchpad.net/lucid-bleed/ppa/ubuntu/dists/

Re: Errori nell'aggiornamento

MessaggioInviato: lunedì 21 maggio 2018, 13:59
da MisterEma79
ok come devo fare?

Re: Errori nell'aggiornamento

MessaggioInviato: lunedì 21 maggio 2018, 15:56
da giulux
Codice: Seleziona tutto
software-properties-gtk
vai alla scheda 'altro software' e togli la spunta a quel ppa (o rimuovilo del tutto, visto che non è mantenuto più dai tempi di natty).

Re: Errori nell'aggiornamento

MessaggioInviato: lunedì 21 maggio 2018, 16:03
da trekfan1
Oppure
Codice: Seleziona tutto
sudo rm /etc/apt/sources.list.d/lucid-bleed*

Re: Errori nell'aggiornamento[RISOLTO]

MessaggioInviato: mercoledì 23 maggio 2018, 10:17
da MisterEma79
grazie a tutti , risolto