Avvio ultralento

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.

Avvio ultralento

Messaggioda re_sasha » mercoledì 14 novembre 2018, 23:23

Buonasera,

non sono un mago di ubuntu ma ho l'avvio davvero lento.
Ho letto qualcosa in giro ma ci capisco zero così Vi dò qualche dato:

Codice: Seleziona tutto
systemd-analyze
Startup finished in 3.841s (kernel) + 1min 3.687s (userspace) = 1min 7.528s
graphical.target reached after 1min 3.679s in userspace


in allegato i risultati di analyzeblame.txt ; sudo blkd ; cat /etc/fstab

e qualche specifica del pc

Codice: Seleziona tutto
H/W path                 Device      Class          Description
===============================================================
                                     system         Latitude E4310
/0                                   bus            0T6M8G
/0/0                                 memory         64KiB BIOS
/0/4                                 processor      Intel(R) Core(TM) i5 CPU   
/0/4/5                               memory         32KiB L1 cache
/0/4/6                               memory         512KiB L2 cache
/0/4/7                               memory         3MiB L3 cache
/0/19                                memory         8GiB System Memory
/0/19/0                              memory         4GiB SODIMM DDR3 Synchronous
/0/19/1                              memory         4GiB SODIMM DDR3 Synchronous
/0/100                               bridge         Core Processor DRAM Controll
/0/100/2                             display        Core Processor Integrated Gr
/0/100/19                eno1        network        82577LM Gigabit Network Conn
/0/100/1a                            bus            5 Series/3400 Series Chipset
/0/100/1a/1              usb1        bus            EHCI Host Controller
/0/100/1a/1/1                        bus            Integrated Rate Matching Hub
/0/100/1a/1/1/4                      multimedia     Laptop_Integrated_Webcam_2M
/0/100/1b                            multimedia     5 Series/3400 Series Chipset
/0/100/1c                            bridge         5 Series/3400 Series Chipset
/0/100/1c.1                          bridge         5 Series/3400 Series Chipset
/0/100/1c.1/0            wlp2s0b1    network        BCM43224 802.11a/b/g/n
/0/100/1c.2                          bridge         5 Series/3400 Series Chipset
/0/100/1c.2/0                        generic        MMC/SD Host Controller
/0/100/1c.3                          bridge         5 Series/3400 Series Chipset
/0/100/1d                            bus            5 Series/3400 Series Chipset
/0/100/1d/1              usb2        bus            EHCI Host Controller
/0/100/1d/1/1                        bus            Integrated Rate Matching Hub
/0/100/1d/1/1/3          scsi6       storage        Elements 10A2
/0/100/1d/1/1/3/0.0.0    /dev/sdb    disk           1TB Elements 10A2
/0/100/1d/1/1/3/0.0.0/1  /dev/sdb1   volume         931GiB Windows NTFS volume


Sapreste darmi qualche consiglio?

Grazie mille.
Allegati
cat -etc-fstab.txt
(587 Byte) Scaricato 7 volte
sudo blkid.txt
(476 Byte) Scaricato 6 volte
analyzeblame.txt
(3.53 KiB) Scaricato 10 volte
re_sasha
Prode Principiante
 
Messaggi: 27
Iscrizione: novembre 2007

Re: Avvio ultralento

Messaggioda TuxInside18 » sabato 17 novembre 2018, 19:52

Ciao! Per velocizzare il tuo Ubuntu dovresti disinstallare o disabilitare un bel po' di programmi che ti rallentano l'avvio. È molto importante quest'azione perché può perfino dimezzare il tempo d'avvio del tuo PC! Il tuo tempo totale, da quanto leggo, è di un minuto e 8 secondi + 1m e 4s. Non è poi lunghissimo come tempo, certo, si può migliorare con qualche trucco :ciao:
"Quale sistema operativo usi? Linux!"Linux non è un sistema operativo!! GNU/Linux è un sistema operativo! Prima di sparare cavolate informati!!!
Avatar utente
TuxInside18
Prode Principiante
 
Messaggi: 104
Iscrizione: novembre 2018
Località: Roma
Desktop: GNOME shell 3.30.1
Distribuzione: Ubuntu 18.10 x86_64
Sesso: Maschile

Re: Avvio ultralento

Messaggioda a323109 » sabato 17 novembre 2018, 19:55

Codice: Seleziona tutto
matrix@linux:~$ systemd-analyze
Startup finished in 8.076s (kernel) + 2min 13.868s (userspace) = 2min 21.945s
graphical.target reached after 2min 13.835s in userspace
matrix@linux:~$


E' + veloce del mio :cry:
Avatar utente
a323109
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1037
Iscrizione: luglio 2013
Località: Area 51
Desktop: Openbox/LXDE
Distribuzione: Disco
Sesso: Maschile

Re: Avvio ultralento

Messaggioda TuxInside18 » sabato 17 novembre 2018, 19:56

Mi dispiace :lol: Comunque ti consiglio di fare la stessa cosa :ciao:
"Quale sistema operativo usi? Linux!"Linux non è un sistema operativo!! GNU/Linux è un sistema operativo! Prima di sparare cavolate informati!!!
Avatar utente
TuxInside18
Prode Principiante
 
Messaggi: 104
Iscrizione: novembre 2018
Località: Roma
Desktop: GNOME shell 3.30.1
Distribuzione: Ubuntu 18.10 x86_64
Sesso: Maschile

Re: Avvio ultralento

Messaggioda a323109 » domenica 18 novembre 2018, 10:31

TuxInside18 Immagine ha scritto:Mi dispiace :lol: Comunque ti consiglio di fare la stessa cosa :ciao:


Ormai non spengo nemmeno più. Ho capito che disconnetto internet altrimenti ci sono problemi, e sospendo. Lo schermo si spegne il disco si ferma, rimane solo il processore alimentato.

Riparte in 2 secondi.

Mentre l'ibernazione ho visto che non funziona tanto bene. Tanto che era più le volte che dovevo riavviare vanificando vantaggi dell'ibernazione.

Riavvio solo se serve per installare oppure aggiornamenti che lo richiedono.
Avatar utente
a323109
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1037
Iscrizione: luglio 2013
Località: Area 51
Desktop: Openbox/LXDE
Distribuzione: Disco
Sesso: Maschile

Re: Avvio ultralento

Messaggioda enziosavio » domenica 18 novembre 2018, 10:46

Io con un ssd ho questi risultati da 7,5 a 8,5 secondi per avviare :p
Nel tuo vedo un sacco di servizi che io non ho
Codice: Seleziona tutto
enziosavio@linux-area51:~> systemd-analyze && systemd-analyze blame
Startup finished in 3.139s (kernel) + 947ms (initrd) + 4.195s (userspace) = 8.282s
graphical.target reached after 4.179s in userspace
          1.308s postfix.service
           791ms firewalld.service
           768ms display-manager.service
           546ms systemd-fsck@dev-disk-by\x2duuid-4a79e528\x2d7bbb\x2d4357\x2dac42\x2dc6b1b4796448.service
           480ms systemd-logind.service
           418ms initrd-switch-root.service
           402ms ModemManager.service
           363ms dev-sda2.device
           311ms udisks2.service
           286ms archivio.mount
           240ms var.mount
           227ms chronyd.service
           218ms systemd-fsck@dev-disk-by\x2duuid-badbc6e3\x2dcd3d\x2d4ea7\x2db946\x2d7037dca2c4b1.service
           211ms kbdsettings.service
           211ms issue-generator.service
           210ms lm_sensors.service
           208ms upower.service
           206ms nscd.service
           202ms avahi-daemon.service
           182ms systemd-tmpfiles-setup.service
           142ms systemd-vconsole-setup.service
           132ms systemd-random-seed.service
           129ms tmp.mount
           128ms systemd-fsck@dev-disk-by\x2duuid-c7c3a57f\x2dc5e8\x2d4327\x2d8fdb\x2d9ab3e6720784.service
           121ms polkit.service
           111ms initrd-parse-etc.service
           106ms NetworkManager.service
           103ms systemd-journal-flush.service
            86ms accounts-daemon.service
            72ms auditd.service
            69ms systemd-udevd.service
            67ms user@1000.service
            64ms systemd-udev-trigger.service
            63ms mcelog.service
            43ms iscsi.service
            39ms dracut-cmdline.service
            32ms systemd-fsck@dev-disk-by\x2duuid-a9d3ce66\x2da5db\x2d4801\x2da86f\x2d000b90e1bca9.service
            32ms systemd-fsck@dev-disk-by\x2duuid-64bfcff2\x2da36c\x2d4f21\x2d98c7\x2d8fbeaf14b11b.service
            30ms initrd-cleanup.service
            24ms home.mount
            24ms systemd-journald.service
            22ms systemd-update-utmp.service
            22ms boot.mount
            21ms dev-mqueue.mount
            19ms rtkit-daemon.service
            19ms dev-hugepages.mount
            18ms systemd-modules-load.service
Rivestì la corazza come gigante , cinse l'armatura di guerra e impegnò battaglia difendendo il campo con la spada
Avatar utente
enziosavio
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2386
Iscrizione: novembre 2010
Desktop: Plasma
Distribuzione: 64bit
Sesso: Maschile

Re: Avvio ultralento

Messaggioda TuxInside18 » domenica 18 novembre 2018, 16:21

a323109 Immagine ha scritto:
TuxInside18 Immagine ha scritto:Mi dispiace :lol: Comunque ti consiglio di fare la stessa cosa :ciao:


Ormai non spengo nemmeno più. Ho capito che disconnetto internet altrimenti ci sono problemi, e sospendo. Lo schermo si spegne il disco si ferma, rimane solo il processore alimentato.

Riparte in 2 secondi.

Mentre l'ibernazione ho visto che non funziona tanto bene. Tanto che era più le volte che dovevo riavviare vanificando vantaggi dell'ibernazione.

Riavvio solo se serve per installare oppure aggiornamenti che lo richiedono.

Ma hai mai provato ad ibernare? Così non devi riavviare niente :ciao:
"Quale sistema operativo usi? Linux!"Linux non è un sistema operativo!! GNU/Linux è un sistema operativo! Prima di sparare cavolate informati!!!
Avatar utente
TuxInside18
Prode Principiante
 
Messaggi: 104
Iscrizione: novembre 2018
Località: Roma
Desktop: GNOME shell 3.30.1
Distribuzione: Ubuntu 18.10 x86_64
Sesso: Maschile

Re: Avvio ultralento

Messaggioda a323109 » domenica 18 novembre 2018, 19:17

Si

Solo che dopo ibernato non funziona più un tubo e non ho voglia di stare a diventarci matto così riavvio.
Avatar utente
a323109
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1037
Iscrizione: luglio 2013
Località: Area 51
Desktop: Openbox/LXDE
Distribuzione: Disco
Sesso: Maschile

Re: Avvio ultralento

Messaggioda TuxInside18 » martedì 20 novembre 2018, 17:16

Allora fa come ti ho consigliato e poi dimmi se va più veloce :ciao:
"Quale sistema operativo usi? Linux!"Linux non è un sistema operativo!! GNU/Linux è un sistema operativo! Prima di sparare cavolate informati!!!
Avatar utente
TuxInside18
Prode Principiante
 
Messaggi: 104
Iscrizione: novembre 2018
Località: Roma
Desktop: GNOME shell 3.30.1
Distribuzione: Ubuntu 18.10 x86_64
Sesso: Maschile

Re: Avvio ultralento

Messaggioda re_sasha » martedì 20 novembre 2018, 23:21

Se può essere utile ho migliorato i tempi editando il file grub
Codice: Seleziona tutto
sudo gedit /etc/default/grub
impostando questi parametri
Codice: Seleziona tutto
GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""


In questo modo non carica la schermata grafica di caricamento Ubuntu e si è velocizzato... se guardate la parte grafica direi niente male...
Codice: Seleziona tutto
Startup finished in 5.666s (kernel) + 59.255s (userspace) = 1min 4.922s
graphical.target reached after 59.232s in userspace


Voi direte che il tempo è simile ma cronometro alla mano è molto migliorato.

A questo punto non rimane che migliorare il kernel e la domanda è solo disinstallando programmi è possibile toglierli dal caricamento moduli del kernel? Se un programma lo uso poco (es. teamviewer e in kernel lo trovo, posso disabilitarlo? e se sì, quando mi servirà riesco a lanciare il programma dall'elenco software senza problemi?

Grazie per l'aiuto!
re_sasha
Prode Principiante
 
Messaggi: 27
Iscrizione: novembre 2007


Torna a Installazione e aggiornamento del sistema operativo

Chi c’è in linea

Visualizzano questa sezione: LinoPersona e 8 ospiti