[risolto] errore con upgrade python3

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.

[risolto] errore con upgrade python3

Messaggioda duns » giovedì 29 novembre 2018, 16:31

Ho questi errori dando il comando sudo apt upgrade
Codice: Seleziona tutto
error running python rtupdate hook hplip-data
dpkg: errore nell'elaborare il pacchetto python3 (--configure):
 installed python3 package post-installation script subprocess returned error exit status 4
dpkg: problemi con le dipendenze impediscono la configurazione di python3-update-manager:
 python3-update-manager dipende da python3:any (>= 3.3.2-2~); tuttavia:
  Il pacchetto python3 non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto python3-update-manager (--configure):
 problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di ubuntu-release-upgrader-core:
 ubuntu-release-upgrader-core dipende da python3:any (>= 3.2~); tuttavia:
  Il pacchetto python3 non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto ubuntu-release-upgrader-core (--configure):
 problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di virtualbox:
 virtualbox dipende da python3 (<< 3.7); tuttavia:
  Il pacchetto python3 non è ancora configurato.
 virtualbox dipende da python3 (>= 3.6~); tuttavia:
  Il pacchetto python3 non è ancora configurato.
 virtualbox dipendSegnalazione apport non scritta poiché il messaggio di errore indica la presenza di un fallimento precedente.
                                       Segnalazione apport non scritta poiché il messaggio di errore indica la presenza di un fallimento precedente.
                                                            Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
                                                            Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
                                                            Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
                                                            e da python3:any (>= 3.3.2-2~); tuttavia:
  Il pacchetto python3 non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto virtualbox (--configure):
 problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di ubuntu-release-upgrader-qt:
 ubuntu-release-upgrader-qt dipende da ubuntu-release-upgrader-core (= 1:18.04.29); tuttavia:
  Il pacchetto ubuntu-release-upgrader-core non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto ubuntu-release-upgrader-qt (--configure):
 problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di python3-gdbm:amd64:
 python3-gdbm:amd64 dipende da python3 (>= 3.6.6-1~); tuttavia:
  Il pacchetto python3 non è ancora configurato.
 python3-gdbm:amd64 dipende da python3 (<< 3.8); tuttavia:
  Il pacchetto python3 non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto python3-gdbm:amd64 (--configure):
 problemSegnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
        Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
        Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
        i con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di python3-lib2to3:
 python3-lib2to3 dipende da python3 (>= 3.6.6-1~); tuttavia:
  Il pacchetto python3 non è ancora configurato.
 python3-lib2to3 dipende da python3 (<< 3.8); tuttavia:
  Il pacchetto python3 non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto python3-lib2to3 (--configure):
 problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di python3-distutils:
 python3-distutils dipende da python3 (>= 3.6.6-1~); tuttavia:
  Il pacchetto python3 non è ancora configurato.
 python3-distutils dipende da python3 (<< 3.8); tuttavia:
  Il pacchetto python3 non è ancora configurato.
 python3-distutils dipende da python3-lib2to3 (>= 3.6.4); tuttavia:
  Il pacchetto python3-lib2to3 non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto python3-distutils (--configure):
 problemi con le dipendeSegnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
                        nze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di python3-distupgrade:
 python3-distupgrade dipende da python3:any (>= 3.3.2-2~); tuttavia:
  Il pacchetto python3 non è ancora configurato.
 python3-distupgrade dipende da python3-update-manager (>= 1:0.196.2~); tuttavia:
  Il pacchetto python3-update-manager non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto python3-distupgrade (--configure):
 problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di virtualbox-qt:
 virtualbox-qt dipende da virtualbox (= 5.2.18-dfsg-2~ubuntu18.04.1); tuttavia:
  Il pacchetto virtualbox non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto virtualbox-qt (--configure):
 problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di update-manager-core:
 update-manager-core dipende da python3:any (>= 3.2~); tuttavia:
  Il pacchetto python3 non è ancora configurato.
 update-manager-core dipende da python3-update-manager (= 1:18.04.11.7); tuttavia:
  Il pacchetto python3-update-manager non è ancora configurato.
 update-manager-core dipende da ubuntu-release-upgrader-core (>= 1:18.04.9); tuttavia:
  Il pacchetto ubuntu-release-upgrader-core non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto update-manager-core (--configure):
 problemi con le dipendenze - lasciato non configurato
Segnalazione apport non scritta poiché è stato raggiunto il valore massimo di MaxReports
Si sono verificati degli errori nell'elaborazione:
 python3
 python3-update-manager
 ubuntu-release-upgrader-core
 virtualbox
 ubuntu-release-upgrader-qt
 python3-gdbm:amd64
 python3-lib2to3
 python3-distutils
 python3-distupgrade
 virtualbox-qt
 update-manager-core
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ho provato con
Codice: Seleziona tutto
sudo apt-get install --reinstall python3

ma non ha risolto.

Il computer funziona del resto correttamente.
Grazie
Duns
Ultima modifica di duns il giovedì 29 novembre 2018, 19:53, modificato 1 volta in totale.
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 286
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile

Re: errore con upgrade python3

Messaggioda caturen » giovedì 29 novembre 2018, 16:37

Codice: Seleziona tutto
sudo apt -f install
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15141
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: errore con upgrade python3

Messaggioda pachisapiu » giovedì 29 novembre 2018, 16:41

Prima
Codice: Seleziona tutto
sudo apt -y install --reinstall hplip hplip-data

e poi
Codice: Seleziona tutto
sudo apt -y install --reinstall python3


https://bugs.launchpad.net/ubuntu/+sour ... ug/1779237
pachisapiu
 

Re: errore con upgrade python3

Messaggioda duns » giovedì 29 novembre 2018, 19:53

Non ha avuto successo
Codice: Seleziona tutto
sudo apt -f install

Mentre ha avuto successo risolutivo
Codice: Seleziona tutto
sudo apt -y install --reinstall hplip hplip-data
e
Codice: Seleziona tutto
sudo apt -y install --reinstall python3
.
Grazie mille! :birra:
Viva Linux
duns
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 286
Iscrizione: febbraio 2006
Desktop: KDE plasma5
Distribuzione: Kubuntu 18.04
Sesso: Maschile

Re: [risolto] errore con upgrade python3

Messaggioda aleandro » giovedì 29 novembre 2018, 22:34

Stesso problema e ho risolto con:

sudo apt -y install --reinstall hplip hplip-data

Era da due giorni che cercavo risposta sul web. Grazie per aver dato la soluzione.
Avatar utente
aleandro
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1343
Iscrizione: agosto 2006


Torna a Installazione e aggiornamento del sistema operativo

Chi c’è in linea

Visualizzano questa sezione: Nejiro e 5 ospiti