Pagina 2 di 4

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: sabato 5 gennaio 2019, 11:34
da Piragora
Ciao wil, premetto che in "Altro Software ho lasciato la spunta solo su "Partner di Canonical ( codice sorgente). C'è nell'elenco anche la voce "Partner di Canonical ma non ha la dizione "Codice sorgente":
Ci sono nell'elenco "altro software 2 ppa se può interessare:

Disabilitato durante l'avanzamento a bionic bionic
http://ppa.launchpad.net/moka/daily/ubuntu

e

http://ppa.launchpad.net/moka/daily/ubuntu xenial main (codice sorgente)

Il secondo comando "sudo rm /var/lib/dpkg/info/libnvidia-gl-390* " da quanto segue. Qualcosa non viene rimosso...:

Codice: Seleziona tutto

rm: impossibile rimuovere '/var/lib/dpkg/info/libnvidia-gl-390*': File o directory non esistente
Il terzo comando "sudo dpkg --configure -a" da:

Codice: Seleziona tutto

Elaborazione dei trigger per libc-bin (2.27-3ubuntu1)...
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf: No such file or directory
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf: No such file or directory
Il comando "sudo apt install --reinstall libnvidia-gl-390" da:

Codice: Seleziona tutto

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  libdbusmenu-gtk4 libhdb9-heimdal libkadm5clnt7-heimdal libkadm5srv8-heimdal
  libkafs0-heimdal libllvm6.0 libotp0-heimdal libqt4-designer libqt4-help
  libqt4-scripttools libqt4-svg libqt4-test libqtassistantclient4
  libsl0-heimdal python-apt python-aptdaemon python-aptdaemon.gtk3widgets
  python-attr python-automat python-click python-colorama python-constantly
  python-cups python-debian python-defer python-dirspec python-httplib2
  python-hyperlink python-incremental python-openssl python-piston-mini-client
  python-pyasn1 python-qt4 python-qt4-dbus python-serial python-sip
  python-twisted-bin python-xapian python-zope.interface
  python3-piston-mini-client software-center-aptdaemon-plugins
Usare "sudo apt autoremove" per rimuoverli.
I seguenti pacchetti NUOVI saranno installati:
  libnvidia-gl-390
0 aggiornati, 1 installati, 0 da rimuovere e 1 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 0 B/14,9 MB di archivi.
Dopo quest'operazione, verranno occupati 73,6 MB di spazio su disco.
(Lettura del database... 219764 file e directory attualmente installati.)
Preparativi per estrarre .../libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb...
deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340
dpkg-divert: errore: corrispondenza errata sul pacchetto
  nel rimuovere "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 da libnvidia-gl-390"
  trovato "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340"
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb (--unpack):
 new libnvidia-gl-390:i386 package pre-installation script subprocess returned error exit status 2
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
E l'ultimo comando da:

Codice: Seleziona tutto

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt --fix-broken install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libnvidia-ifr1-390 : Dipende: libnvidia-gl-390 ma non è installato
 nvidia-driver-390 : Dipende: libnvidia-gl-390 (= 390.77-0ubuntu0.18.04.1) ma non è installato
E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).
Non credo sia ancora risolta...... Grazie..... :muro:

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: sabato 5 gennaio 2019, 14:34
da wilecoyote
Immagine Salve, c'è un altro paio di pacchetti da eliminare, provvediamo modificando il comando:

Codice: Seleziona tutto

sudo rm -r /var/lib/apt/lists/* -vf
sudo rm /var/lib/dpkg/info/*nvidia*390*
sudo dpkg --configure -a
sudo apt update
sudo apt install --reinstall libnvidia-gl-390
sudo apt upgrade
Immagine Ciao

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: sabato 5 gennaio 2019, 14:53
da Piragora
Ciao, posto gli esiti dei comandi che mi sembra diano esito negativo:

Il comando "sudo dpkg --configure -a" da:

Codice: Seleziona tutto

Elaborazione dei trigger per libc-bin (2.27-3ubuntu1)...
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf: No such file or directory
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf: No such file or directory
Il comando "sudo apt install --reinstall libnvidia-gl-390" da:

Codice: Seleziona tutto

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  libdbusmenu-gtk4 libhdb9-heimdal libkadm5clnt7-heimdal libkadm5srv8-heimdal
  libkafs0-heimdal libllvm6.0 libotp0-heimdal libqt4-designer libqt4-help
  libqt4-scripttools libqt4-svg libqt4-test libqtassistantclient4
  libsl0-heimdal python-apt python-aptdaemon python-aptdaemon.gtk3widgets
  python-attr python-automat python-click python-colorama python-constantly
  python-cups python-debian python-defer python-dirspec python-httplib2
  python-hyperlink python-incremental python-openssl python-piston-mini-client
  python-pyasn1 python-qt4 python-qt4-dbus python-serial python-sip
  python-twisted-bin python-xapian python-zope.interface
  python3-piston-mini-client software-center-aptdaemon-plugins
Usare "sudo apt autoremove" per rimuoverli.
I seguenti pacchetti NUOVI saranno installati:
  libnvidia-gl-390
0 aggiornati, 1 installati, 0 da rimuovere e 1 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 0 B/14,9 MB di archivi.
Dopo quest'operazione, verranno occupati 73,6 MB di spazio su disco.
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-kernel-source-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-driver-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-fbc1-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-encode-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-utils-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-compute-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-dkms-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-kernel-common-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-cfg1-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "xserver-xorg-video-nvidia-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-decode-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-compute-utils-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-common-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
(Lettura del database... 219445 file e directory attualmente installati.)
Preparativi per estrarre .../libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb...
deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340
dpkg-divert: errore: corrispondenza errata sul pacchetto
  nel rimuovere "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 da libnvidia-gl-390"
  trovato "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340"
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb (--unpack):
 new libnvidia-gl-390:i386 package pre-installation script subprocess returned error exit status 2
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Infine "sudo apt upgrade" da:

Codice: Seleziona tutto

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt --fix-broken install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libnvidia-ifr1-390 : Dipende: libnvidia-gl-390 ma non è installato
 nvidia-driver-390 : Dipende: libnvidia-gl-390 (= 390.77-0ubuntu0.18.04.1) ma non è installato
E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).
Pare ci sia ancora della porcheria dentro.... Grazie 1000 per la tua disponibilità... :ciao:

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: sabato 5 gennaio 2019, 15:02
da wilecoyote
Immagine Salve, segui il suggerimento:

Codice: Seleziona tutto

sudo apt --fix-broken install
Immagine Ciao

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: sabato 5 gennaio 2019, 18:39
da Piragora
Ciao Wil.. permane pur sempre l'errore... Grazie

Codice: Seleziona tutto

Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  libdbusmenu-gtk4 libhdb9-heimdal libkadm5clnt7-heimdal libkadm5srv8-heimdal
  libkafs0-heimdal libllvm6.0 libotp0-heimdal libqt4-designer libqt4-help
  libqt4-scripttools libqt4-svg libqt4-test libqtassistantclient4
  libsl0-heimdal python-apt python-aptdaemon python-aptdaemon.gtk3widgets
  python-attr python-automat python-click python-colorama python-constantly
  python-cups python-debian python-defer python-dirspec python-httplib2
  python-hyperlink python-incremental python-openssl python-piston-mini-client
  python-pyasn1 python-qt4 python-qt4-dbus python-serial python-sip
  python-twisted-bin python-xapian python-zope.interface
  python3-piston-mini-client software-center-aptdaemon-plugins
Usare "sudo apt autoremove" per rimuoverli.
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  libnvidia-gl-390
I seguenti pacchetti NUOVI saranno installati:
  libnvidia-gl-390
0 aggiornati, 1 installati, 0 da rimuovere e 1 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 0 B/14,9 MB di archivi.
Dopo quest'operazione, verranno occupati 73,6 MB di spazio su disco.
Continuare? [S/n] s
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-kernel-source-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-driver-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-fbc1-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-encode-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-utils-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-compute-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-dkms-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-kernel-common-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-cfg1-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "xserver-xorg-video-nvidia-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-decode-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-compute-utils-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-common-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
(Lettura del database... 219445 file e directory attualmente installati.)
Preparativi per estrarre .../libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb...
deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340
dpkg-divert: errore: corrispondenza errata sul pacchetto
  nel rimuovere "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 da libnvidia-gl-390"
  trovato "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340"
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb (--unpack):
 new libnvidia-gl-390:i386 package pre-installation script subprocess returned error exit status 2
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: domenica 6 gennaio 2019, 14:21
da wilecoyote
Immagine Salve, vediamo di capire quali pacchetti 'nvidia' hai installato:

Codice: Seleziona tutto

dpkg -l *nvidia*
Per la deviazione bloccata prova così:

Codice: Seleziona tutto

sudo dpkg-divert --remove /usr/lib/i386-linux-gnu/libGL.so.1.distrib
Immagine Ciao

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: domenica 6 gennaio 2019, 18:45
da Piragora
sudo -l *nvidia* da:

Codice: Seleziona tutto

Voluto=U (non noto)/I (installato)/R (rimosso)/P (rimosso totale)/H (in attesa)
| Stato=Non/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(nessuno)/R (reinstallazione richiesta) (Stato,Err: maiuscolo=grave)
||/ Nome           Versione     Architettura Descrizione
+++-==============-============-============-=================================
ii  bumblebee-nvid 3.2.1-17     i386         NVIDIA Optimus support using the 
un  libgl1-nvidia- <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  libgldispatch0 <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ii  libnvidia-cfg1 390.77-0ubun i386         NVIDIA binary OpenGL/GLX configur
un  libnvidia-cfg1 <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  libnvidia-comm <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ii  libnvidia-comm 390.77-0ubun all          Shared files used by the NVIDIA l
ii  libnvidia-comp 390.77-0ubun i386         NVIDIA libcompute package
un  libnvidia-deco <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ii  libnvidia-deco 390.77-0ubun i386         NVIDIA Video Decoding runtime lib
un  libnvidia-enco <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ii  libnvidia-enco 390.77-0ubun i386         NVENC Video Encoding runtime libr
un  libnvidia-fbc1 <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ii  libnvidia-fbc1 390.77-0ubun i386         NVIDIA OpenGL-based Framebuffer C
in  libnvidia-gl-3 <nessuna>    i386         (nessuna descrizione disponibile)
un  libnvidia-ifr1 <nessuna>    <nessuna>    (nessuna descrizione disponibile)
pU  libnvidia-ifr1 390.77-0ubun i386         NVIDIA OpenGL-based Inband Frame 
un  nvidia         <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-304     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-304-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-310     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-310-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-313     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-313-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-319     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-319-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-325     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-325-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-331     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-331-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-334     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-334-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-337     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-337-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ic  nvidia-340     340.96-0ubun i386         NVIDIA binary driver - version 34
un  nvidia-340-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-343     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-343-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-346     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-346-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-349     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-349-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-352     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-352-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-355     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-355-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-358     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-358-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ii  nvidia-361     367.57-0ubun i386         Transitional package for nvidia-3
un  nvidia-361-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-364     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-364-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ii  nvidia-367     375.82-0ubun i386         Transitional package for nvidia-3
un  nvidia-367-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ii  nvidia-375     384.130-0ubu i386         Transitional package for nvidia-3
un  nvidia-375-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-378     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-378-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-381     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-381-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ii  nvidia-384     390.77-0ubun i386         Transitional package for nvidia-d
un  nvidia-384-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-387     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-387-upd <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-390     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-common  <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ii  nvidia-compute 390.77-0ubun i386         NVIDIA compute utilities
un  nvidia-current <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-current <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ii  nvidia-dkms-39 390.77-0ubun i386         NVIDIA DKMS package
un  nvidia-dkms-ke <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-driver  <nessuna>    <nessuna>    (nessuna descrizione disponibile)
pi  nvidia-driver- 390.77-0ubun i386         NVIDIA driver metapackage
un  nvidia-driver- <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-driver- <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-driver- <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-experim <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-kernel- <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ii  nvidia-kernel- 390.77-0ubun i386         Shared files used with the kernel
un  nvidia-kernel- <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-kernel- <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ii  nvidia-kernel- 390.77-0ubun i386         NVIDIA kernel source package
un  nvidia-legacy- <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-legacy- <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-legacy- <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-legacy- <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-legacy- <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-libopen <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-opencl- <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-opencl- <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-persist <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ii  nvidia-prime   0.8.8.2      all          Tools to enable NVIDIA's Prime
ii  nvidia-setting 390.77-0ubun i386         Tool for configuring the NVIDIA g
un  nvidia-setting <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-smi     <nessuna>    <nessuna>    (nessuna descrizione disponibile)
un  nvidia-utils   <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ii  nvidia-utils-3 390.77-0ubun i386         NVIDIA driver support binaries
un  nvidia-vdpau-d <nessuna>    <nessuna>    (nessuna descrizione disponibile)
ii  xserver-xorg-v 390.77-0ubun i386         NVIDIA binary Xorg driver

Il comando "sudo dpkg-divert --remove /usr/lib/i386-linux-gnu/libGL.so.1.distrib" da:

Codice: Seleziona tutto

Nessuna deviazione "qualsiasi deviazione di /usr/lib/i386-linux-gnu/libGL.so.1.distrib", nessuna rimossa.
Grazie...

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: domenica 6 gennaio 2019, 21:26
da wilecoyote
Immagine Salve, alcuni pacchetti male installati, comincia col rimuovere questo:

Codice: Seleziona tutto

sudo dpkg --remove nvidia-340
Immagine Ciao

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: lunedì 7 gennaio 2019, 10:28
da Piragora
Ciao, ecco sotto l'esito del comando che mi hai datao. Grazie sempre per la tua/vostra disponibilità

Codice: Seleziona tutto

dpkg: attenzione: viene ignorata la richiesta di rimuovere nvidia-340, solo i file
di configurazione sono presenti nel sistema: usare --purge per rimuoverli

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: lunedì 7 gennaio 2019, 13:29
da Piragora
Aggiungo anche quanto sotto se serve.. Facendo aggiornamento non lo fa fare e esce quanto di seguito:

Codice: Seleziona tutto

Verificare se sono in uso repository di terze parti. Qualora così fosse, disabilitarli, poiché questi sono talvolta causa di problemi.
Inoltre eseguire il seguente comando in un terminale: apt-get install -f
Transaction failed: Il sistema di pacchetti è danneggiato
 I seguenti pacchetti presentano dipendenze non soddisfatte:

libnvidia-ifr1-390: Depends: libnvidia-gl-390 ma non è installato
nvidia-driver-390: Depends: libnvidia-gl-390 (= 390.77-0ubuntu0.18.04.1) ma non è installato
                   Depends: nvidia-dkms-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
                   Depends: nvidia-kernel-source-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
                   Depends: libnvidia-compute-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
                   Depends: nvidia-compute-utils-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
                   Depends: libnvidia-decode-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
                   Depends: libnvidia-encode-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
                   Depends: nvidia-utils-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
                   Depends: xserver-xorg-video-nvidia-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
                   Depends: libnvidia-cfg1-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
                   Depends: libnvidia-ifr1-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato
                   Depends: libnvidia-fbc1-390 (= 390.77-0ubuntu0.18.04.1) ma 390.77-0ubuntu0.18.04.1 è installato

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: lunedì 7 gennaio 2019, 14:35
da wilecoyote
Immagine Salve, modifichiamo come da richiesta il comando:

Codice: Seleziona tutto

sudo dpkg --purge nvidia-340
E veniamo all'osso duro, cambiamo strada, il pacchetto scaricalo cliccando qui http://it.archive.ubuntu.com/ubuntu/poo ... _amd64.deb , e salvalo nella tua "Home".

Lancia il terminale e dai i seguenti comandi:

Codice: Seleziona tutto

cd ~/Scaricati
sudo dpkg --force-configure-any -i libnvidia-gl-390*amd64.deb
sudo apt install --fix-broken
Il 1° comando ti sposta nella directory ove salvato, se lo salvi in un'altra directory invece di Scaricati cambiane il nome, il 2° installa il pacchetto mancante, il 3° corregge eventuali errori.

Immagine Ciao

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: lunedì 7 gennaio 2019, 16:28
da Piragora
Il primo comando "sudo dpkg --purge nvidia-340" da:

Codice: Seleziona tutto

dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-kernel-source-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-driver-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-fbc1-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-encode-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-utils-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-compute-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-dkms-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-kernel-common-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-cfg1-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "xserver-xorg-video-nvidia-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-decode-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-compute-utils-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-common-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
(Lettura del database... 219444 file e directory attualmente installati.)
Eliminazione dei file di configurazione di nvidia-340 (340.96-0ubuntu3)...
userdel: user nvidia-persistenced is currently used by process 1152
update-initramfs: deferring update (trigger activated)
Elaborazione dei trigger per initramfs-tools (0.130ubuntu3.6)...
update-initramfs: Generating /boot/initrd.img-4.15.0-43-generic
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf: No such file or directory
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf: No such file or directory
Il comando"sudo dpkg --force-configure-any -i libnvidia-gl-390*amd64.deb" da l'errore di seguito:

Codice: Seleziona tutto

dpkg: errore nell'elaborare l'archivio libnvidia-gl-390_390.77-0ubuntu0.18.04.1_amd64.deb (--install):
 l'architettura del pacchetto (amd64) non corrisponde a quella del sistema (i386)
Si sono verificati degli errori nell'elaborazione:
 libnvidia-gl-390_390.77-0ubuntu0.18.04.1_amd64.deb
L'ultimo comando "sudo apt install --fix-broken" l'ho dato ma penso non servisse proseguire visti i precedenti...

Codice: Seleziona tutto

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  libdbusmenu-gtk4 libhdb9-heimdal libkadm5clnt7-heimdal libkadm5srv8-heimdal
  libkafs0-heimdal libllvm6.0 libotp0-heimdal libqt4-designer libqt4-help
  libqt4-scripttools libqt4-svg libqt4-test libqtassistantclient4
  libsl0-heimdal python-apt python-aptdaemon python-aptdaemon.gtk3widgets
  python-attr python-automat python-click python-colorama python-constantly
  python-cups python-debian python-defer python-dirspec python-httplib2
  python-hyperlink python-incremental python-openssl python-piston-mini-client
  python-pyasn1 python-qt4 python-qt4-dbus python-serial python-sip
  python-twisted-bin python-xapian python-zope.interface
  python3-piston-mini-client software-center-aptdaemon-plugins
Usare "sudo apt autoremove" per rimuoverli.
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  libnvidia-gl-390
I seguenti pacchetti NUOVI saranno installati:
  libnvidia-gl-390
0 aggiornati, 1 installati, 0 da rimuovere e 1 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 0 B/14,9 MB di archivi.
Dopo quest'operazione, verranno occupati 73,6 MB di spazio su disco.
Continuare? [S/n] s
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-kernel-source-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-driver-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-fbc1-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-encode-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-utils-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-compute-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-dkms-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-kernel-common-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-cfg1-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "xserver-xorg-video-nvidia-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-decode-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-compute-utils-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-common-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
(Lettura del database... 219443 file e directory attualmente installati.)
Preparativi per estrarre .../libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb...
deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340
dpkg-divert: errore: corrispondenza errata sul pacchetto
  nel rimuovere "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 da libnvidia-gl-390"
  trovato "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340"
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb (--unpack):
 new libnvidia-gl-390:i386 package pre-installation script subprocess returned error exit status 2
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
:muro: Ciao :ciao:

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: lunedì 7 gennaio 2019, 16:42
da wilecoyote
Immagine Salve, intanto i file di troppo sono stati rimossi.

Per quello da installare se l'architettura è a 32 bit come riporta, leggendo questo in rosso mi faccio tante domande…
/etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf
Rifai con la versione a 32 bit, la scarichi da qui http://it.archive.ubuntu.com/ubuntu/poo ... 1_i386.deb

E poi dai i comandi di prima.

Immagine Ciao

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: lunedì 7 gennaio 2019, 17:44
da Piragora
Ciao, pare che il comando " sudo dpkg --force-configure-any -i libnvidia-gl-390*amd64.deb" dia ancora u nerrore....

Codice: Seleziona tutto

dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-kernel-source-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-driver-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-fbc1-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-encode-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-utils-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-compute-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-dkms-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-kernel-common-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-cfg1-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "xserver-xorg-video-nvidia-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-decode-390:i386" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "nvidia-compute-utils-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "libnvidia-common-390" mancante, il pacchetto viene considerato senza alcun file attualmente installato
(Lettura del database... 219443 file e directory attualmente installati.)
Preparativi per estrarre libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb...
deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340
dpkg-divert: errore: corrispondenza errata sul pacchetto
  nel rimuovere "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 da libnvidia-gl-390"
  trovato "deviazione di /usr/lib/i386-linux-gnu/libGL.so.1 in /usr/lib/i386-linux-gnu/libGL.so.1.distrib da nvidia-340"
dpkg: errore nell'elaborare l'archivio libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb (--install):
 new libnvidia-gl-390:i386 package pre-installation script subprocess returned error exit status 2
Elaborazione dei trigger per libc-bin (2.27-3ubuntu1)...
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf: No such file or directory
/sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf: No such file or directory
Si sono verificati degli errori nell'elaborazione:
 libnvidia-gl-390_390.77-0ubuntu0.18.04.1_i386.deb

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: lunedì 7 gennaio 2019, 17:47
da Piragora
Che occorra fare anche un "purge" sul 390?-- Grazie 1000

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: martedì 8 gennaio 2019, 14:52
da wilecoyote
Immagine Salve,

Codice: Seleziona tutto

sudo rm /var/lib/dpkg/info/*nvidia*
 sudo dpkg --configure -a
 sudo apt update
 sudo apt install --reinstall nvidia-driver-390
 sudo apt upgrade
Il 1° rimuove le informazioni dei pacchetti oggetto, il 2° riconfigura il sistema pacchetti, il 3° aggiorna la lista pacchetti, il 4° forza il reinstallo, il 5° installa eventuali aggiornamenti.

Immagine Ciao

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: martedì 8 gennaio 2019, 15:36
da Piragora
Ciao, la prima istruzione che mi hai dato da:

Codice: Seleziona tutto

rm: impossibile rimuovere '/var/lib/dpkg/info/*nvidia*': File o directory non esistente
La seconsa istruzione "sudo dpkg --configure -a" l'ho lanciata e non ha dato esiti da postare;

La terza istruzione "sudo apt update" ha dato:

Codice: Seleziona tutto

Trovato:1 http://it.archive.ubuntu.com/ubuntu bionic InRelease
Scaricamento di:2 http://it.archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]
Ignorato:3 http://archive.canonical.com/ubuntu trusty InRelease                
Trovato:4 http://archive.canonical.com/ubuntu trusty Release                   
Scaricamento di:5 http://it.archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]
Scaricamento di:6 http://it.archive.ubuntu.com/ubuntu bionic-security InRelease [83,2 kB]
Scaricamento di:7 http://it.archive.ubuntu.com/ubuntu bionic-proposed InRelease [242 kB]
Scaricamento di:8 http://it.archive.ubuntu.com/ubuntu bionic-updates/universe Sources [121 kB]
Scaricamento di:10 http://it.archive.ubuntu.com/ubuntu bionic-updates/main Sources [226 kB]
Scaricamento di:11 http://it.archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages [414 kB]
Scaricamento di:12 http://it.archive.ubuntu.com/ubuntu bionic-updates/main Translation-en [178 kB]
Scaricamento di:13 http://it.archive.ubuntu.com/ubuntu bionic-updates/main i386 DEP-11 Metadata [261 kB]
Scaricamento di:14 http://it.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 48x48 Icons [58,2 kB]
Scaricamento di:15 http://it.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [111 kB]
Scaricamento di:16 http://it.archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages [698 kB]
Scaricamento di:17 http://it.archive.ubuntu.com/ubuntu bionic-updates/universe Translation-en [172 kB]
Scaricamento di:18 http://it.archive.ubuntu.com/ubuntu bionic-updates/universe i386 DEP-11 Metadata [200 kB]
Scaricamento di:19 http://it.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 48x48 Icons [183 kB]
Scaricamento di:20 http://it.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 64x64 Icons [343 kB]
Scaricamento di:21 http://it.archive.ubuntu.com/ubuntu bionic-updates/multiverse i386 DEP-11 Metadata [2.464 B]
Scaricamento di:22 http://it.archive.ubuntu.com/ubuntu bionic-backports/universe i386 DEP-11 Metadata [5.812 B]
Scaricamento di:23 http://it.archive.ubuntu.com/ubuntu bionic-security/universe Sources [28,6 kB]
Scaricamento di:24 http://it.archive.ubuntu.com/ubuntu bionic-security/main i386 DEP-11 Metadata [204 B]
Scaricamento di:25 http://it.archive.ubuntu.com/ubuntu bionic-security/universe i386 Packages [107 kB]
Scaricamento di:26 http://it.archive.ubuntu.com/ubuntu bionic-security/universe i386 DEP-11 Metadata [14,9 kB]
Scaricamento di:27 http://it.archive.ubuntu.com/ubuntu bionic-security/universe DEP-11 64x64 Icons [39,7 kB]
Scaricamento di:28 http://it.archive.ubuntu.com/ubuntu bionic-proposed/main i386 Packages [46,0 kB]
Scaricamento di:29 http://it.archive.ubuntu.com/ubuntu bionic-proposed/main Translation-en [26,6 kB]
Scaricamento di:30 http://it.archive.ubuntu.com/ubuntu bionic-proposed/main i386 DEP-11 Metadata [28,4 kB]
Scaricamento di:31 http://it.archive.ubuntu.com/ubuntu bionic-proposed/main DEP-11 48x48 Icons [4.581 B]
Scaricamento di:32 http://it.archive.ubuntu.com/ubuntu bionic-proposed/main DEP-11 64x64 Icons [7.303 B]
Scaricamento di:33 http://it.archive.ubuntu.com/ubuntu bionic-proposed/universe i386 Packages [21,1 kB]
Scaricamento di:34 http://it.archive.ubuntu.com/ubuntu bionic-proposed/universe Translation-en [13,5 kB]
Scaricamento di:35 http://it.archive.ubuntu.com/ubuntu bionic-proposed/universe i386 DEP-11 Metadata [110 kB]
Scaricamento di:36 http://it.archive.ubuntu.com/ubuntu bionic-proposed/universe DEP-11 48x48 Icons [108 kB]
Scaricamento di:37 http://it.archive.ubuntu.com/ubuntu bionic-proposed/universe DEP-11 64x64 Icons [162 kB]
Recuperati 4.179 kB in 4s (1.081 kB/s)                           
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
4 pacchetti possono essere aggiornati: eseguire "apt list --upgradable" per vederli.
La terza istruzione "sudo apt install --reinstall nvidia-driver-390" da:

Codice: Seleziona tutto

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt --fix-broken install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libnvidia-ifr1-390 : Dipende: libnvidia-gl-390 ma non sta per essere installato
 nvidia-driver-390 : Dipende: libnvidia-gl-390 (= 390.77-0ubuntu0.18.04.1) ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).
L'ultima istruzione "sudo apt upgrade" ha dato:

Codice: Seleziona tutto

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt --fix-broken install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libnvidia-ifr1-390 : Dipende: libnvidia-gl-390 ma non è installato
 nvidia-driver-390 : Dipende: libnvidia-gl-390 (= 390.77-0ubuntu0.18.04.1) ma non è installato
E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).
Qualcosa non va ancora a quanto pare...

Grazie.... ciao

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: martedì 8 gennaio 2019, 16:15
da wilecoyote
Immagine Salve, capito è cocciuto, cambiamo strada.

Apri il terminale e dai i seguente comando:

Codice: Seleziona tutto

mkdir nvidial
Adesso scarica direttamente i seguenti pacchetti da questi link libnvidia-cfg1-390, libnvidia-common-390, libnvidia-compute-390, libnvidia-decode-390, libnvidia-encode-390, libnvidia-fbc1-390, libnvidia-gl-390, libnvidia-ifr1-390, nvidia-compute-utils-390, nvidia-dkms-390, nvidia-driver-390, nvidia-kernel-source-390, nvidia-utils-390, xserver-xorg-video-nvidia-390, salvandoli nella directory 'nvidia' che hai creato.

Adesso dai nel terminale i seguenti comandi:

Codice: Seleziona tutto

cd ~/nvidia
sudo dpkg --force-configure-any -i *.i386.deb
sudo apt --fix-broken install
Il 1° ti sposta nella directory creata, il 2° installa di brutto, il 3° dovrebbe sistemare gli errori eventuali.

Immagine Ciao

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: martedì 8 gennaio 2019, 16:38
da Piragora
Ciao, al secondo passaggio "" mi da un errore come sotto...:

Codice: Seleziona tutto

dpkg: errore: cannot access archive '*.i386.deb': File o directory non esistente
La directory l'ha creata in Home, con "cd ~/nvidia" me la apre, strano!... Grazie....

Re: Problema: sistema di pacchetti danneggiato nvidia 390

Inviato: martedì 8 gennaio 2019, 16:43
da wilecoyote
Immagine Salve, prova il comando così:

Codice: Seleziona tutto

sudo dpkg --force-configure-any -i *_i386.deb
Immagine Ciao