[Risolto] No EFI partition was found !

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.
Jhonnydvd
Prode Principiante
Messaggi: 15
Iscrizione: martedì 13 gennaio 2015, 22:50

[Risolto] No EFI partition was found !

Messaggio da Jhonnydvd » mercoledì 19 giugno 2019, 13:06

Sto installando ubuntu e nella procedura di installazione prima di tutto non mi trova altro sistema operativo (sto installando affianco a windows 10). allora selezione l'opzione altro e dopo aver creato le partizioni per swap e root cliccando su installa ora mi dice

No EFI partition was found

E' rischioso continuare la pratica di installazione? se si come posso risolvere questo problema ?
Grazie per l'aiuto
Ultima modifica di Jhonnydvd il giovedì 20 giugno 2019, 9:32, modificato 1 volta in totale.

Avatar utente
willy54
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4629
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: No EFI partition was found !

Messaggio da willy54 » mercoledì 19 giugno 2019, 13:43

Per poterti aiutare devi fornire le caratteristiche del tuo pc o da Informazioni di sistema di windows o avviando una live e pubblicare

Codice: Seleziona tutto

inxi -Fz
probabilmente da installare con

Codice: Seleziona tutto

sudo apt install inxi
dopoo avere atttivato la 2 casella nella App Software ed aggiornamenti .
Probabilmente o il pc non supporta il 64 Bit oppure è datato e non supporta Uefi.
Utile anche vedere una immagine di Gestione disco di Windoows o da live

Codice: Seleziona tutto

sudo parted -l
i listati del terminale vanno postati con copia ed incolla tra i tag code ottenuti con il tasto Codice come da immagine
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio (provvisorio)
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10

Jhonnydvd
Prode Principiante
Messaggi: 15
Iscrizione: martedì 13 gennaio 2015, 22:50

Re: No EFI partition was found !

Messaggio da Jhonnydvd » mercoledì 19 giugno 2019, 15:15

willy54 [url=https://forum.ubuntu-it.org/viewtopic.php?p=5139386#p5139386][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Per poterti aiutare devi fornire le caratteristiche del tuo pc o da Informazioni di sistema di windows o avviando una live e pubblicare

Codice: Seleziona tutto

inxi -Fz
probabilmente da installare con

Codice: Seleziona tutto

sudo apt install inxi
dopoo avere atttivato la 2 casella nella App Software ed aggiornamenti .
Probabilmente o il pc non supporta il 64 Bit oppure è datato e non supporta Uefi.
Utile anche vedere una immagine di Gestione disco di Windoows o da live

Codice: Seleziona tutto

sudo parted -l
i listati del terminale vanno postati con copia ed incolla tra i tag code ottenuti con il tasto Codice come da immagine

Questo è sono le informazioni ottenute sulla partizione

Codice: Seleziona tutto

Model: ATA Samsung SSD 850 (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type      File system     Flags
 1      1049kB  525MB  524MB   primary   ntfs            boot
 2      525MB   207GB  207GB   primary   ntfs
 4      207GB   249GB  41.9GB  extended
 5      207GB   208GB  537MB   logical   linux-swap(v1)
 6      208GB   249GB  41.4GB  logical   ext4
 3      249GB   250GB  902MB   primary   ntfs            diag


Model: SKYMEDI USB Drive (scsi)
Disk /dev/sdb: 4008MB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  4008MB  4007MB  fat32        Microsoft Basic Data  msftdata

il comando

Codice: Seleziona tutto

 inxi -Fz
mi restituisce questo quando provo a installarlo.

Codice: Seleziona tutto

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package inxi
Come posso vedere se supporta Uefi o meno ?

Avatar utente
willy54
Imperturbabile Insigne
Imperturbabile Insigne
Messaggi: 4629
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: No EFI partition was found !

Messaggio da willy54 » mercoledì 19 giugno 2019, 16:09

Le informazioni ricevute da parted -l sono abbastanza chiare il tuo hdd è partizionato MsDos con quel partizionamento non puoi installare in modalità Uefi , se il tuo sistema supporta Uefi lo vedremo quando pubblicherai inxi -Fz ma qualora uefi fosse supportato dovrai reinstallare sia Windows che linux/x se vuoi avere il pc configurato in Uefi mode.
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio (provvisorio)
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10

Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7346
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome - (19.04 Cinnamon)
Distribuzione: 18.04-19.10-20.04 (NO UEFI)
Località: Ancona

Re: No EFI partition was found !

Messaggio da et4beta » mercoledì 19 giugno 2019, 16:32

Oppure, molto più semplicemente, lasci da parte l'UEFI e prepari il supporto avviabile con la .iso di Linux in modalità msdos e in tale modalità installi Ubuntu sul PC.
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.

Jhonnydvd
Prode Principiante
Messaggi: 15
Iscrizione: martedì 13 gennaio 2015, 22:50

Re: [Risolto] No EFI partition was found !

Messaggio da Jhonnydvd » giovedì 20 giugno 2019, 9:33

Grazie mille. Ho preparato il supporto con la .iso in modalità msdos. Tutto funziona correttamente ora.

Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7346
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome - (19.04 Cinnamon)
Distribuzione: 18.04-19.10-20.04 (NO UEFI)
Località: Ancona

Re: [Risolto] No EFI partition was found !

Messaggio da et4beta » domenica 16 febbraio 2020, 21:55

:birra:
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.

Scrivi risposta

Ritorna a “Installazione e aggiornamento del sistema operativo”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 10 ospiti