[Risolto] Problema con GRUB

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.
Scrivi risposta
Bosshot
Prode Principiante
Messaggi: 3
Iscrizione: mercoledì 18 settembre 2019, 23:20
Desktop: Gnome
Distribuzione: Ubuntu 19.04

[Risolto] Problema con GRUB

Messaggio da Bosshot » mercoledì 18 settembre 2019, 23:32

Buonasera,
premetto che non sono un utente per niente esperto, anzi, ma ho la necessità di iniziare ad usare Ubuntu per motivi di studio. In pratica negli scorsi giorni ho installato Ubuntu in una partizione da 100 GB creata su un PC con Windows 10 come main OS. Volevo impostare GRUB come opzione primaria di boot, il che è molto semplice dal BIOS, ma qui viene il problema: in pratica dal GRUB non riesco a fare il boot di Windows. Tra le altre cose GRUB rileva che la versione installata di Windows è la 7 e non la 10, presumo che anche questa cosa faccia parte del problema. Se ci fosse qualcuno che sapesse come risolvere mi eviterebbe di dover entrare nel BIOS ad ogni avvio :D . Grazie mille in anticipo :D .
Ultima modifica di Bosshot il lunedì 23 settembre 2019, 17:01, modificato 2 volte in totale.

Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 5227
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: PROBLEMA CON GRUB

Messaggio da willy54 » mercoledì 18 settembre 2019, 23:41

Benvenuto sul Forum
Se il tuo windows 10 è un aggiornamento di win 7 è una cosa normale che grub riconosca win 7 e non win 10.
Il problema si risolve facendo una installazione pulità di windows 10 e verrà poi riconosciuto Windows 10.
Per gli altri problemi devi dare più notizie sia del pc , del partizionamento e se si tratti di una installazione uefi o csm/legacy
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio (provvisorio)
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10

Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 21026
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 20.04 e 20.10 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: PROBLEMA CON GRUB

Messaggio da trekfan1 » giovedì 19 settembre 2019, 5:10

Benvenuto, 100Gb per Ubuntu sono troppi, bastano 30GB, inoltre modifica il titolo del primo post togliendo il tutto maiuscolo che equivale ad urlare, grazie

Inoltre sulla 19.04 non c'è Unity (a meno di installarlo specificatamente) ma Gnome

Bosshot
Prode Principiante
Messaggi: 3
Iscrizione: mercoledì 18 settembre 2019, 23:20
Desktop: Gnome
Distribuzione: Ubuntu 19.04

Re: Problema con GRUB

Messaggio da Bosshot » sabato 21 settembre 2019, 11:39

Buongiorno,
Purtroppo non sono riuscito a mettere in atto alcuni test a causa di vari impegni, nei prossimi giorni penso che eliminerò Ubuntu per creare una partizione più piccola, magari da 50 GB, e vedere se la reinstallazione da zero mette a posto i problemi ed intanto cerco di informarmi bene su come avviene l'installazione. Per ora vi ringrazio 😁

Avatar utente
woddy68
Rampante Reduce
Rampante Reduce
Messaggi: 5375
Iscrizione: sabato 12 febbraio 2011, 14:23
Desktop: Kde Plasma5
Distribuzione: openSUSE Leap-Tumbleweed-Kubuntu 20
Sesso: Maschile

Re: Problema con GRUB

Messaggio da woddy68 » sabato 21 settembre 2019, 14:54

Si però calcola che la dimensione della partizione può essere un problema, ma solo quando è piccola, per cui se non hai problemi di spazio, lasciala pure a 100 Gb, non è certo un problema, anzi !
100Gb per Ubuntu sono troppi, bastano 30GB
...e qual'è il problema ?
Desktop - Acer Aspire M5500 (AMD) - Notebook Acer Aspire E1 -522 (Amd)
Voglio trovare la mia strada per il paradiso - Perché ho scontato la mia pena all'inferno
Non avevo un bell'aspetto ma mi sentivo proprio bene 😬

Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 21026
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 20.04 e 20.10 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Problema con GRUB

Messaggio da trekfan1 » sabato 21 settembre 2019, 16:00

Forse lo spazio sprecato? Cmq è una mia opinione personale...

Avatar utente
woddy68
Rampante Reduce
Rampante Reduce
Messaggi: 5375
Iscrizione: sabato 12 febbraio 2011, 14:23
Desktop: Kde Plasma5
Distribuzione: openSUSE Leap-Tumbleweed-Kubuntu 20
Sesso: Maschile

Re: Problema con GRUB

Messaggio da woddy68 » sabato 21 settembre 2019, 16:24

Dipende da come un utente utilizza il sistema e cosa ci installa, se ha la /home separata oppure no... credo lui abbia fatto un unica partizione in quanto è l'impostazione predefinita di Ubuntu, se utilizza la /home per i dati è probabile che non sia sprecato, se invece utilizza una partizione dati condivisa con Windows è un'altro discorso. Poi se installa tanti giochi, questi occupano molto spazio...insomma per come la vedo io solo lui può sapere quanto dovrebbe essere grande.
Desktop - Acer Aspire M5500 (AMD) - Notebook Acer Aspire E1 -522 (Amd)
Voglio trovare la mia strada per il paradiso - Perché ho scontato la mia pena all'inferno
Non avevo un bell'aspetto ma mi sentivo proprio bene 😬

Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 5227
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: Problema con GRUB

Messaggio da willy54 » sabato 21 settembre 2019, 17:24

In considerazione che si parla di un dual boot i 50gb sarebbero utili come partizione condivisa, visto che windows mal tollera che si entri nella sua partizione con un SO alieno. Condivido quanto detto da trekfan1
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio (provvisorio)
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10

Zombie17

Re: Problema con GRUB

Messaggio da Zombie17 » sabato 21 settembre 2019, 22:10

Ciao, fai quello che devi fare per far partire Ubuntu perchè non ho capito se questo ti funziona bene o meno, poi posta gli output di

Codice: Seleziona tutto

ls /boot
cat /boot/grub/grub.cfg
cat /etc/default/grub
ls /sys/firmware/efi
sudo parted -l

Codice: Seleziona tutto

od --address-radix=n --format=u1 /sys/firmware/efi/efivars/SecureBoot-

Quando arrivi a "SecureBoot-" premi il tasto tab e la stringa si autocompleterà, a quel punto puoi lanciare con invio e postare l'output.
Poi dato che leggo "tra le altre cose" presumo ci siano problemi anche nell'avvio di Ubuntu, se cosi non fosse, i passaggi da qui in avanti saltali.

Lancia

Codice: Seleziona tutto

sudo nano /etc/default/grub
Al parametro GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Cancella quiet splash e sostituiscili con text per ottenere:

Codice: Seleziona tutto

GRUB_CMDLINE_LINUX_DEFAULT="text"
Lancia nuovamente

Codice: Seleziona tutto

cat /etc/default/grub
E posta ancora l'output, per accertarci che non sia stato modificato altro per errore.

Dopodichè lancia:

Codice: Seleziona tutto

sudo update-grub
Spegni il pc e avvia Ubuntu in maniera da farlo bloccare, nei listati che compariranno al posto delle solite schermate di avvio guarda esattente dove si blocca e posta una foto, poi ritenta l'avvio altre 3/4 volte sempre facendolo bloccare, vedi se si blocca al medesimo punto o in fasi diverse e dacci il responso.

Vediamo se si riesce a trovare qualcosa su cui lavorare.

Buon lavoro.

P.S.

Quando avrò il pc a portata di mano editerò per inserire i tag code

P.S. 2

Vista la quarantena lascio una n.d.r. a margine meno articolata dato che ritengo i contenuti degni di nota.

Si può accedere al file system di Windows da sistemi Linux e al contrario al file system dei sistemi linux da Windows in modo rapido e semplice senza problemi di sorta, basta documentarsi a tal riguardo.
Ultima modifica di Zombie17 il domenica 22 settembre 2019, 20:41, modificato 1 volta in totale.

Bosshot
Prode Principiante
Messaggi: 3
Iscrizione: mercoledì 18 settembre 2019, 23:20
Desktop: Gnome
Distribuzione: Ubuntu 19.04

Re: Problema con GRUB

Messaggio da Bosshot » domenica 22 settembre 2019, 17:13

Buongiorno, allora ci sono importanti novità 😅. Può sembrare strano ma ho risolto il problema installando rEFInd, dopo aver fatto ciò che avete scritto 😅. Vi ringrazio comunque per l'aiuto, buona giornata 😁

Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 21026
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 20.04 e 20.10 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Problema con GRUB

Messaggio da trekfan1 » domenica 22 settembre 2019, 18:48

Allora metti [Risolto] all'inizio del titolo del primo post cliccando su Modifica ed evitando di scriverlo tutto maiuscolo

Scrivi risposta

Ritorna a “Installazione e aggiornamento del sistema operativo”

Chi c’è in linea

Visualizzano questa sezione: Baidu [Spider], Google [Bot] e 6 ospiti