Aiuto installazione pacchetti

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.
Scrivi risposta
EdmondDantes
Prode Principiante
Messaggi: 42
Iscrizione: lunedì 20 ottobre 2014, 13:07

Aiuto installazione pacchetti

Messaggio da EdmondDantes » lunedì 10 febbraio 2020, 11:04

Buongiorno, sto provando ad installare la libreria: ``libboost-all-dev''.

Eseguendo il comando:

Codice: Seleziona tutto

sudo apt-get install libboost-all-dev
Ottengo il seguente messaggio:

Codice: Seleziona tutto

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 libboost-all-dev : Dipende: libboost-date-time-dev ma non sta per essere installato
                    Dipende: libboost-log-dev ma non sta per essere installato
                    Dipende: libboost-mpi-dev ma non sta per essere installato
                    Dipende: libboost-mpi-python-dev ma non sta per essere installato
                    Dipende: libboost-thread-dev ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.
Dal momento che spesso incorro in questo errore, potreste darmi indicazioni su come risolverlo?

Attualmente sto usando:

Codice: Seleziona tutto

No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 18.04.3 LTS
Release:	18.04
Codename:	bionic

Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 20653
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Aiuto installazione pacchetti

Messaggio da trekfan1 » lunedì 10 febbraio 2020, 11:55

Dilemmi è per problemi terra-terra, leggi la descrizione delle sezioni prima di postare, sposto in Installazione

Avatar utente
Stealth
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 16519
Iscrizione: martedì 31 gennaio 2006, 22:55
Desktop: Gnome
Distribuzione: Ubuntu 18.04 LTS

Re: Aiuto installazione pacchetti

Messaggio da Stealth » lunedì 10 febbraio 2020, 12:02

Ho controllato in ubuntu packages e i pacchetti che il tuo sistema non trova sono tutti presenti, e tutti in universe. L'unica cosa che posso suggerire è di verificare in "software e aggiornamenti" se la casella universe (seconda dall'alto) ha il segno di spunta
ciao

caturen
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 15729
Iscrizione: giovedì 8 aprile 2010, 18:41
Desktop: diversi
Distribuzione: debian sid

Re: Aiuto installazione pacchetti

Messaggio da caturen » lunedì 10 febbraio 2020, 12:35

Codice: Seleziona tutto

sudo apt  -f install
e posta cosa ti restituisce il terminale

EdmondDantes
Prode Principiante
Messaggi: 42
Iscrizione: lunedì 20 ottobre 2014, 13:07

Re: Aiuto installazione pacchetti

Messaggio da EdmondDantes » martedì 11 febbraio 2020, 10:11

trekfan1 ha scritto:
lunedì 10 febbraio 2020, 11:55
Dilemmi è per problemi terra-terra, leggi la descrizione delle sezioni prima di postare, sposto in Installazione
Scusa per la leggerezza.
caturen ha scritto:
lunedì 10 febbraio 2020, 12:35

Codice: Seleziona tutto

sudo apt  -f install
e posta cosa ti restituisce il terminale
Ciao, eccoti l'output:

Codice: Seleziona tutto

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  libboost-chrono1.55.0 libboost-serialization1.55.0 libboost-system1.55.0
  libboost-thread1.55.0 libode1 libompl9 pkg-config
Usare "sudo apt autoremove" per rimuoverli.
0 aggiornati, 0 installati, 0 da rimuovere e 2 non aggiornati.
Ultima modifica di EdmondDantes il martedì 11 febbraio 2020, 14:05, modificato 1 volta in totale.

freengin
Prode Principiante
Messaggi: 22
Iscrizione: lunedì 18 marzo 2019, 11:19

Re: Aiuto installazione pacchetti

Messaggio da freengin » martedì 11 febbraio 2020, 11:38

sembrerebbe che tu abbia fatto pasticci con le sorgenti software , tipo attivato i proposed o altro ...
posta

Codice: Seleziona tutto

cat -n /etc/apt/sources.list && ls /etc/apt/sources.list.d/

Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 20653
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Aiuto installazione pacchetti

Messaggio da trekfan1 » martedì 11 febbraio 2020, 11:51

Per l'output usa i tag CODE (tasto </> dell'editor completo) e non i tag quote, grazie :)

caturen
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 15729
Iscrizione: giovedì 8 aprile 2010, 18:41
Desktop: diversi
Distribuzione: debian sid

Re: Aiuto installazione pacchetti

Messaggio da caturen » martedì 11 febbraio 2020, 13:20

posta

Codice: Seleziona tutto

sudo apt autoremove --purge
e poi

Codice: Seleziona tutto

sudo apt upgrade

EdmondDantes
Prode Principiante
Messaggi: 42
Iscrizione: lunedì 20 ottobre 2014, 13:07

Re: Aiuto installazione pacchetti

Messaggio da EdmondDantes » martedì 11 febbraio 2020, 14:06

freengin ha scritto:
martedì 11 febbraio 2020, 11:38
sembrerebbe che tu abbia fatto pasticci con le sorgenti software , tipo attivato i proposed o altro ...
posta

Codice: Seleziona tutto

cat -n /etc/apt/sources.list && ls /etc/apt/sources.list.d/
Ecco l'output:

Codice: Seleziona tutto

     1	deb http://old-releases.ubuntu.com/ubuntu/ utopic main restricted
     2	deb-src http://old-releases.ubuntu.com/ubuntu/ utopic main restricted
     3	deb http://old-releases.ubuntu.com/ubuntu/ utopic-updates main restricted
     4	deb-src http://old-releases.ubuntu.com/ubuntu/ utopic-updates main restricted
     5	deb http://old-releases.ubuntu.com/ubuntu/ utopic universe multiverse
     6	deb-src http://old-releases.ubuntu.com/ubuntu/ utopic universe multiverse
     7	deb http://old-releases.ubuntu.com/ubuntu utopic-security main restricted
     8	deb-src http://old-releases.ubuntu.com/ubuntu utopic-security main restricted
     9	deb http://old-releases.ubuntu.com/ubuntu/ utopic-backports main restricted universe multiverse
skype-stable.list  sublime-text.list

EdmondDantes
Prode Principiante
Messaggi: 42
Iscrizione: lunedì 20 ottobre 2014, 13:07

Re: Aiuto installazione pacchetti

Messaggio da EdmondDantes » martedì 11 febbraio 2020, 14:08

caturen ha scritto:
martedì 11 febbraio 2020, 13:20
posta

Codice: Seleziona tutto

sudo apt autoremove --purge
e poi

Codice: Seleziona tutto

sudo apt upgrade
Primo comando:

Codice: Seleziona tutto

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno RIMOSSI:
  libboost-chrono1.55.0* libboost-serialization1.55.0* libboost-system1.55.0* libboost-thread1.55.0* libode1*
  libompl9* pkg-config*
0 aggiornati, 0 installati, 7 da rimuovere e 2 non aggiornati.
Dopo quest'operazione, verranno liberati 5.960 kB di spazio su disco.
Continuare? [S/n] S
(Lettura del database... 348928 file e directory attualmente installati.)
Rimozione di libompl9 (0.14.2+dfsg-1)...
Rimozione di libboost-chrono1.55.0:amd64 (1.55.0+dfsg-1ubuntu3)...
Rimozione di libboost-serialization1.55.0:amd64 (1.55.0+dfsg-1ubuntu3)...
Rimozione di libboost-thread1.55.0:amd64 (1.55.0+dfsg-1ubuntu3)...
Rimozione di libboost-system1.55.0:amd64 (1.55.0+dfsg-1ubuntu3)...
Rimozione di libode1 (2:0.11.1-4.1)...
Rimozione di pkg-config (0.28-1ubuntu1)...
Elaborazione dei trigger per man-db (2.8.3-2ubuntu0.1)...
Elaborazione dei trigger per libc-bin (2.27-3ubuntu1)...
(Lettura del database... 348883 file e directory attualmente installati.)
Eliminazione dei file di configurazione di libboost-serialization1.55.0:amd64 (1.55.0+dfsg-1ubuntu3)...
Eliminazione dei file di configurazione di libboost-system1.55.0:amd64 (1.55.0+dfsg-1ubuntu3)...
Eliminazione dei file di configurazione di libompl9 (0.14.2+dfsg-1)...
Eliminazione dei file di configurazione di libboost-thread1.55.0:amd64 (1.55.0+dfsg-1ubuntu3)...
Eliminazione dei file di configurazione di libboost-chrono1.55.0:amd64 (1.55.0+dfsg-1ubuntu3)...
Eliminazione dei file di configurazione di libode1 (2:0.11.1-4.1)...
Secondo comando:

Codice: Seleziona tutto

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Calcolo dell'aggiornamento... Fatto
I seguenti pacchetti saranno aggiornati:
  bison libbison-dev
2 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
È necessario scaricare 595 kB di archivi.
Dopo quest'operazione, verranno occupati 124 kB di spazio su disco.
Continuare? [S/n] s
Scaricamento di:1 http://old-releases.ubuntu.com/ubuntu utopic/main amd64 bison amd64 2:3.0.2.dfsg-2 [257 kB]
Scaricamento di:2 http://old-releases.ubuntu.com/ubuntu utopic/main amd64 libbison-dev amd64 2:3.0.2.dfsg-2 [338 kB]
Recuperati 595 kB in 0s (1.366 kB/s)  
(Lettura del database... 348884 file e directory attualmente installati.)
Preparativi per estrarre .../bison_2%3a3.0.2.dfsg-2_amd64.deb...
Estrazione di bison (2:3.0.2.dfsg-2) su (2:2.7.1.dfsg-1)...
Preparativi per estrarre .../libbison-dev_2%3a3.0.2.dfsg-2_amd64.deb...
Estrazione di libbison-dev:amd64 (2:3.0.2.dfsg-2) su (2:2.7.1.dfsg-1)...
Configurazione di libbison-dev:amd64 (2:3.0.2.dfsg-2)...
Configurazione di bison (2:3.0.2.dfsg-2)...
Elaborazione dei trigger per man-db (2.8.3-2ubuntu0.1)...
Intanto ringrazio tutti per le risposte.

Ho provato ad installare anche l'ubuntu software manager ma incorro in un errore simile (cambiano solo i pacchetti).

freengin
Prode Principiante
Messaggi: 22
Iscrizione: lunedì 18 marzo 2019, 11:19

Re: Aiuto installazione pacchetti

Messaggio da freengin » mercoledì 12 febbraio 2020, 10:51

Qualcosa di sicuro hai combinato dal momento che dici di usare la 18.04 ma nel sources.list hai i repo della 14.10 (che è fuori supporto da anni)

/Repository/SourcesList

caturen
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 15729
Iscrizione: giovedì 8 aprile 2010, 18:41
Desktop: diversi
Distribuzione: debian sid

Re: Aiuto installazione pacchetti

Messaggio da caturen » mercoledì 12 febbraio 2020, 11:28

Qualcosa di sicuro hai combinato dal momento che dici di usare la 18.04 ma nel sources.list hai i repo della 14.10 (che è fuori supporto da anni)
infatti :sisi:
1) dai

Codice: Seleziona tutto

sudo -H nautilus
ed limina tutto quello che trovi dentro /etc/apt/sources.list.d
2) dai

Codice: Seleziona tutto

sudo -H gedit /etc/apt/sources.list
ed elimina tutto quello che trovi nel file e copia/incolla questo

Codice: Seleziona tutto

 deb http://it.archive.ubuntu.com/ubuntu/ bionic main universe restricted multiverse
#deb-src http://it.archive.ubuntu.com/ubuntu/ bionic main universe restricted multiverse

deb http://security.ubuntu.com/ubuntu bionic-security main universe restricted multiverse
#deb-src http://security.ubuntu.com/ubuntu bionic-security main universe restricted multiverse

deb http://it.archive.ubuntu.com/ubuntu/ bionic-updates main universe restricted multiverse
#deb-src http://it.archive.ubuntu.com/ubuntu/ bionic-updates main universe restricted multiverse
deb http://archive.canonical.com/ubuntu bionic partner
#deb-src http://archive.canonical.com/ubuntu bionic partner
#deb http://it.archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
deb http://it.archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
deb-src http://it.archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
#deb-src http://it.archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
e salva il file

infine posta

Codice: Seleziona tutto

sudo apt update && sudo apt upgrade
Ultima modifica di caturen il mercoledì 12 febbraio 2020, 12:50, modificato 2 volte in totale.

Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
Messaggi: 20653
Iscrizione: domenica 21 maggio 2006, 10:51
Desktop: Gnome
Distribuzione: Ubuntu 19.10 e 20.04 (dev) 64 bit
Sesso: Maschile
Località: Formigine (MO) | Accecante Asceta

Re: Aiuto installazione pacchetti

Messaggio da trekfan1 » mercoledì 12 febbraio 2020, 11:33

@caturen hai sbagliato i tag per il sources.list :D

caturen
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 15729
Iscrizione: giovedì 8 aprile 2010, 18:41
Desktop: diversi
Distribuzione: debian sid

Re: Aiuto installazione pacchetti

Messaggio da caturen » mercoledì 12 febbraio 2020, 12:50

sostituiti

Scrivi risposta

Ritorna a “Installazione e aggiornamento del sistema operativo”

Chi c’è in linea

Visualizzano questa sezione: corradoventu, pikomarco e 22 ospiti